aptosid.com

Hardware - fglrx doesn't work

orinoco - 28.03.2011, 18:06
Post subject: fglrx doesn't work
Hello,

today I tried to install fglrx for my onboard HD4290 chip. Unfortunatly the driver failed to load.

In /var/log/Xorg.0.log I found messages like

      Code:
[    28.620] (EE) fglrx(0): ACPI: DRM connection failed

      Code:
[    32.019] (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
[    32.019] (WW) fglrx(0): ***********************************************************
[    32.019] (WW) fglrx(0): * DRI initialization failed                               *
[    32.019] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[    32.019] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
[    32.019] (WW) fglrx(0): ***********************************************************

      Code:
[    32.019] (EE) fglrx(0): Failed to map FB memory


Any ideas to solve this?
towo - 28.03.2011, 18:21
Post subject:
      Quote:
kernel module (fglrx.ko) may be missing or incompatible

      Code:
lsmod | grep fglrx

sayes what?
orinoco - 28.03.2011, 19:29
Post subject:
      towo wrote:
      Quote:
kernel module (fglrx.ko) may be missing or incompatible

      Code:
lsmod | grep fglrx

sayes what?


Nothing.

I installed via
      Code:
# apt-get -V install fglrx-driver
# aticonfig --initial


I also ignored the additional packages mentioned by apt-get. My mistake?
towo - 28.03.2011, 19:38
Post subject:
Without the fglrx-kernelmodule no fglrx for X, should be clear.
fglrx kernelmodule will not build against the aptosid-kernel without patching.
orinoco - 28.03.2011, 20:00
Post subject:
Is there a patch?

I installed fglrx-module-dkms and did some more investigations and found in /var/lib/dkms/fglrx/11-2/build/make.log:
      Code:
/var/lib/dkms/fglrx/11-2/build/firegl_public.c:119:28: fatal error: linux/smp_lock.h: file or directory not found

towo - 28.03.2011, 20:02
Post subject:
http://aptosid.com/index.php?name=PNphp ... amp;t=1038
orinoco - 28.03.2011, 21:44
Post subject:
Thank you towo. You moved me into the right direction.

For the other users who may have the same problem, can find a way how it works for me at the moment: http://aptosid.com/index.php?name=PNphpBB2&file=viewtopic&t=1038

Not brilliant, but better than nothing.

One question left: Why have I lost my desktop-effects? (Compositing is disabled by KDE)
oschi - 29.03.2011, 04:52
Post subject:
had the same problem some time ago

try adding OpenGLIsUnsafe=false in kwinrc, after that everything worked fine for me

if your capable of reading german see http://forum.ubuntuusers.de/topic/arbei ... st-2653773

(mgraesslin is the guy who writes the code, so he knows what to do)

greetings
peter
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits