aptosid.com

User Scripts & Dragons - KDE SC 4.6.1 just now hit http://qt-kde.debian.net/

devil - 02.04.2011, 11:40
Post subject: KDE SC 4.6.1 just now hit http://qt-kde.debian.net/
as topic says. please go read http://qt-kde.debian.net/ before upgrading and watch what apt wants to remove.
here it ditches 7 packages:
      Code:
kde-icons-oxygen kdelibs5 kdepimlibs5 kdiff3 libakonadiprivate1 libkexiv2-7 libkonq5a
kde(pim)libs5 are gone, the rest should be reinstallable. your list may differ slightly, but no essential things should be removed.

greetz
devil
blackhole - 02.04.2011, 11:49
Post subject: RE: KDE SC 4.6.1 just now hit http://qt-kde.debian.net/
ktorrent will be removed. However it is possible to reinstall it from experimental:

apt-get install ktorrent libsolidcontrol4 libsolidcontrolifaces4 -t experimental

(Using apt-get -t experimental-snapshots dist-upgrade

will remove only kdelibs5 and ktorrent)
se7en - 02.04.2011, 12:08
Post subject: RE: KDE SC 4.6.1 just now hit http://qt-kde.debian.net/
The following packages will be REMOVED:
libakonadiprivate1 libkonq5a
BelaLugosi - 02.04.2011, 12:37
Post subject: RE: KDE SC 4.6.1 just now hit http://qt-kde.debian.net/
A lot of stuf wants to be removed here...
      Code:
The following packages will be REMOVED:                                                                                                     
  akonadi-kde-resource-googledata akregator aptosid-art-kde aptosid-art-kde-keres aptosid-art-ksplash-keres aptosid-settings-kde             
  backintime-kde blogilo digikam kaddressbook kde-icons-oxygen kde-window-manager kdebase-workspace kdebase-workspace-bin kdelibs5           
  kdepasswd kdepim-groupware kdepim-kresources kdepim-runtime kdepim-wizards kdepimlibs5-dev kding kgpg kipi-plugins kmail konq-plugins     
  konqueror kontact konversation kopete korganizer kscreensaver libakonadi-contact4 libakonadi-kmime4 libkdepim4 libkopete4                 
  libmailtransport4 libmessagelist4 libssl-dev plasma-dataengines-workspace plasma-desktop plasma-netbook plasma-runners-addons             
  plasma-scriptengine-python plasma-widget-eventlist plasma-widgets-workspace python-dev python-kde4 python-kde4-dev python-qt4-dev         
  python-sip-dev python2.6-dev python2.7-dev system-config-printer-kde

yossarian - 02.04.2011, 12:56
Post subject: RE: KDE SC 4.6.1 just now hit http://qt-kde.debian.net/
You can try:
      Code:
# apt-get -t experimental-snapshots dist-upgrade

BelaLugosi - 02.04.2011, 13:19
Post subject: RE: KDE SC 4.6.1 just now hit http://qt-kde.debian.net/
Thanks, but i solved it by installing kdebase-workspace from experimental-snapshots and it pulled almost everything with it.
DeepDayze - 02.04.2011, 13:23
Post subject:
These packages will be removed here:

      Code:

...
The following packages will be REMOVED:
  kappfinder kde-icons-oxygen kde4-minimal kdelibs5 kdepimlibs5 kdessh kode kpilot akonadiprivate1

clubex - 02.04.2011, 19:21
Post subject:
apt-get -t experimental-snapshots dist-upgrade

did it for me. No problems so far.
merlyn - 03.04.2011, 01:57
Post subject:
      Code:
apt-get -t experimental-snapshots dist-upgrade

Worked without a hitch for me also.

I prefer the "old" system settings layout however as the "groupings" were more 'sensible' to my way of thinking.

Point in case there are now two or three (if you have kde-config-gtk-style installed) places to customise the appearance of your "desktop" & "applications"

Also the new monochrome icons while nice introduce visual inconsistancies to the system tray (the tooltip icons don't follow suit).

Not to mention the use of a pair of scissors to 'represent' the klipboard. Scissors = cut in my book and thus does not represent the full functionality of the the klipboard.

Cheers.
blackhole - 03.04.2011, 10:44
Post subject:
Can you all check akonadi? Please hit button "test" on akonadi configuration. Do you have some errors?
arwa - 03.04.2011, 19:36
Post subject:
I have now upgraded to KDE4.6.1 from KDE4.4.5. I had to download about "1 dot 21 jigabytes" (with all these dbg packages that I have installed). Everything went smooth. Only kappfinder and one akonadi-library was removed.

The dist-upgrade just asked when installing the new kdm if it should install the new kdmrc. I alowed it to make sure, everything fits together.

The only kde package that is held back is kdepim-runtime-dbg. If I try to install it, the package kdepim-dbg would be removed. This seems not correct somehow!?

When starting kdm it asked me to choose annother session type, because "kde" does not exist anymore?! I did choose the "KDE plasma workspace" IIRC and KDE did start fine.

My first impression: WOW how fast it is! I currently am using the nouveau driver with my GeForce 6200 card. Moving a window with the whole content displayed was _very_ slow before. Now it moves like when just displaying the window border while moving. Also konqueror is much faster. Really cool.

@blackhole:
akonadi "Test..." gives me several error logs. The mysql server log has a problem "
      Quote:
110403 21:30:10 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
110403 21:30:10 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
110403 21:30:10 [Note] /usr/sbin/mysqld: ready for connections.

And the akonadi control error log has 22 errors of the type 'void AgentManager::readPluginInfos(const QDir&) Duplicated agent identifier "akonadi_vcard_resource" from file "/usr/share/akonadi/agents/vcardresource.desktop"' with different agent identifiers like "akonadi_mbox_resource", "akonadi_kcal_resource" and so on.

As I do not yet use akonadi I do not know how problematic this is.
arwa - 03.04.2011, 20:42
Post subject:
One problem I had was that Ctrl+Alt+v did not open the klipper menu anymore. The hotkey is no longer configured in klipper but in the systray settings. There was this hotkey correctly defined. I had to remove and redefine it. Now it works again.
DeepDayze - 03.04.2011, 21:50
Post subject:
maybe the akonadi databases need rebuilding due to the upgrade? Think there was an article on it with some fixes/workarounds when issues with akonadi databases occurred on an older KDE4 release.
blackhole - 03.04.2011, 23:51
Post subject:
Yes, I have tried rebuilding deleting the akonadi directories in /home/user/.local/share and /home/user/.config.
(I was lucky that I had a backup of agenda and contacts...)

There are some error messages like this one:
      Quote:


void AgentManager::readPluginInfos(const QDir&) Duplicated agent identifier "akonadi_birthdays_resource" from file "/usr/share/akonadi/agents/birthdaysresource.desktop"


It seems to me that calendar is a real akonadi resource but addressbook is not. Maybe the switch to akonadi is not completed?
DeepDayze - 04.04.2011, 00:05
Post subject:
      blackhole wrote:
Yes, I have tried rebuilding deleting the akonadi directories in /home/user/.local/share and /home/user/.config.
(I was lucky that I had a backup of agenda and contacts...)

There are some error messages like this one:
      Quote:


void AgentManager::readPluginInfos(const QDir&) Duplicated agent identifier "akonadi_birthdays_resource" from file "/usr/share/akonadi/agents/birthdaysresource.desktop"


It seems to me that calendar is a real akonadi resource but addressbook is not. Maybe the switch to akonadi is not completed?


Maybe someone who knows akonadi can chime in
detaos - 04.04.2011, 00:52
Post subject:
the only thing i know about akondi is that its generally better left disabled Wink
DeepDayze - 04.04.2011, 02:17
Post subject:
Can't find how to disable it though
DeepDayze - 04.04.2011, 02:41
Post subject:
Also I find digikam does not work as it crashes on startup and the digikam in experimental is broken
arwa - 04.04.2011, 06:02
Post subject:
      DeepDayze wrote:
maybe the akonadi databases need rebuilding due to the upgrade?

Rebuilding this means to loose all the akonadi data. This is the reason why I am still sceptical and not yet using it.
devil - 04.04.2011, 06:56
Post subject:
nepomuk can be disabled, akonadi cant. at least i would not know how. it is so heavily weaved into kdepim that it cant do without. the goes even more for the upcoming kde2. i have no probs with either nepomuk or akonadi at the moment.

greetz
devil
merlyn - 04.04.2011, 08:40
Post subject:
While on the topic of akonadi, has anybody had any experience with the googledata resource?

Is it reliable enough for syncing google contacts / calender with 'Kontact'?

Or is it better left alone for now?

Cheers.
arwa - 04.04.2011, 09:03
Post subject:
What happens when you execute "akonadictl stop". Will this state be remembered at the next KDE login?
spacepenguin - 04.04.2011, 14:03
Post subject:
d-u wants to remove these packages:
libakonadiprivate1 (libraries for the Akonadi PIM storage service)
libknotificationitem-1-1 (library for new way of handling system tray)
Aren't those two needed?

Furthermore libsmokekde4-2 and libsmokeplasma2 are to be removed...
arwa - 04.04.2011, 14:37
Post subject:
As long as no applications, tools or system packages (etc.) are removed you can say that libraries can be removed without any drawbacks. So I think you can let these packages go (I am 99% sure).
DeepDayze - 04.04.2011, 14:39
Post subject:
      arwa wrote:
As long as no applications, tools or system packages (etc.) are removed you can say that libraries can be removed without any drawbacks. So I think you can let these packages go (I am 99% sure).


Some libs are being replaced by newer incompatible versions so apt's kicking the old ones.
yossarian - 04.04.2011, 15:50
Post subject:
      DeepDayze wrote:
Also I find digikam does not work as it crashes on startup and the digikam in experimental is broken


I just removed marble-plugins. Digikam 1.8 works fine now.
DeepDayze - 04.04.2011, 15:56
Post subject:
      yossarian wrote:
      DeepDayze wrote:
Also I find digikam does not work as it crashes on startup and the digikam in experimental is broken


I just removed marble-plugins. Digikam 1.8 works fine now.


Found that out too as I had a machine without marble-plugins installed and digikam 1.2 works without the plugin.
BelaLugosi - 04.04.2011, 16:11
Post subject:
@merlyn

Since the upgrade to KDE 4.6.1 there are problems using akonadi and google-calendars/contacts. But there is also a solution --> Bug #264861 @ bugs.kde.org (site down atm). Works here.
DeepDayze - 04.04.2011, 16:34
Post subject:
      arwa wrote:
What happens when you execute "akonadictl stop". Will this state be remembered at the next KDE login?


No, at each login akonadi restarts
blackhole - 04.04.2011, 17:05
Post subject:
Digikam is not working here, after removing marble-plugins
DeepDayze - 04.04.2011, 17:12
Post subject:
      blackhole wrote:
Digikam is not working here, after removing marble-plugins


On my thinkpad digikam 1.2 from sid starts and I don't have marble-plugins installed while on my desktop it crashes...haven't checked if I had marble plugins installed there.

Maybe move the digikam config files aside (don't delete just rename) to see if it is a bad setting that causes it to crash?

Also did you PURGE marble-plugins? I think digikam picks up the config file that's left behind if that package isn't purged. Purging the plugins package removes that config file.
devil - 04.04.2011, 19:12
Post subject:
digikam depends on libmarblewidget10, which is broken at the moment.
i think, this has to do with unbuildable kdebindings due to python breakage.

greetz
devil
blackhole - 04.04.2011, 21:57
Post subject:
Compiled and installed libgcal0 and akonadi-googledata from source. Now sync with gmail is working perfect (contacts and calendar).
DeepDayze - 05.04.2011, 00:23
Post subject:
Another thing I discovered is that you may need to install upower package if you want powerdevil to work properly on 4.6. Without this package, some systems may not display any power profiles nor allow sleep or hibernate to work.
devil - 05.04.2011, 05:21
Post subject:
upower got installed here on all machines with the upgrade to 4.6.1

greetz
devil
merlyn - 05.04.2011, 09:41
Post subject:
      BelaLugosi wrote:
@merlyn

Since the upgrade to KDE 4.6.1 there are problems using akonadi and google-calendars/contacts. But there is also a solution --> Bug #264861 @ bugs.kde.org (site down atm). Works here.


Thanks for the tip.

I haven't actually used the akonadi google-data resource before.

But given the information you provided a link to will definitely give it a try.

Cheers.
dexterus - 05.04.2011, 15:27
Post subject:
ok, upgraded. kappfinder and libakonadiprivate1 were removed and everything runs smoothly... more/less...

thing is, i have this usbhid (a remote control) device and since the upgrade it requires starting hald manually in order for it to work (which wasn't the case previously). so, is this udev related, or is there some package installing/additional configuring that should be done? or maybe i've missed something here in the forums/manual? also, if anyone can point me out to some readings on how to add hald properly to init.d scripts, it'll be highly appreciated. Smile

oh, and a small quirk i noticed since the upgrade... the "close tab" button in konsole became inactive (greyed out).
DeepDayze - 05.04.2011, 15:52
Post subject:
      dexterus wrote:
ok, upgraded. kappfinder and libakonadiprivate1 were removed and everything runs smoothly... more/less...

thing is, i have this usbhid (a remote control) device and since the upgrade it requires starting hald manually in order for it to work (which wasn't the case previously). so, is this udev related, or is there some package installing/additional configuring that should be done? or maybe i've missed something here in the forums/manual? also, if anyone can point me out to some readings on how to add hald properly to init.d scripts, it'll be highly appreciated. Smile

oh, and a small quirk i noticed since the upgrade... the "close tab" button in konsole became inactive (greyed out).

Hal is being deprecated and many of the hal rules have been removed so its necessary to start it manually for any legacy HID devices. Hopefully a future update will make your device work with udev.


You can still close tabs by going to File>Close Tab. Yes it's an annoying quirk not having Close Tab button greyed out so hope it gets fixed soon

      devil wrote:
upower got installed here on all machines with the upgrade to 4.6.1

greetz
devil


For some reason upower didn't get installed on my desktop system. Installed it manually and sleep works again on the desktop
dexterus - 05.04.2011, 16:47
Post subject:
      DeepDayze wrote:

Hal is being deprecated and many of the hal rules have been removed so its necessary to start it manually for any legacy HID devices. Hopefully a future update will make your device work with udev.


yeah, i read about hal being deprecated and udev taking over. so, i guess i'll have to take your advice and wait. Smile

      DeepDayze wrote:

You can still close tabs by going to File>Close Tab. Yes it's an annoying quirk not having Close Tab button greyed out so hope it gets fixed soon


hehe, yep, i was aware of the 'workaround', just wanted to make sure it wasn't only me.

thanks for the quick reply!
cheers!
arwa - 05.04.2011, 18:24
Post subject:
I do not have the open/close tab icons enabled, because I usually close a shell by pressing "ctrl+d". AFAIK only if a program does not quit correctly you might need another way.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits