aptosid.com

User Scripts & Dragons - kde 4.6.2

se7en - 26.04.2011, 17:04
Post subject: kde 4.6.2
looks like kde 4.6.2. is just being uploaded to experimental-snapshots
dibl - 26.04.2011, 18:14
Post subject:
Nice -- desktop effects working once again on my netbook (Intel Mobile 945GME).
blackhole - 26.04.2011, 19:05
Post subject:
Now is out here! Downloading almost 300 packages.

PS. No problems upgrade perfect.
clubex - 26.04.2011, 20:11
Post subject:
No problems apart from losing the title bar of windows and dialogues but a reboot fixed that. I also selected No when asked to update kmrc configuration.
merlyn - 26.04.2011, 20:47
Post subject:
No problems with the d-u here.

In fact a minor glitch I noticed with the panel under 4.6.1 is now fixed.

Cheers.
ShakaZ - 27.04.2011, 01:53
Post subject:
Doesn't work here. Dist-upgrade tells me I have the latest packages already, although this is kde 4.4.5 from june last year.
      Code:
apt-get -t experimental install kde-plasma-desktop kde-window-manager kdebase-workspace kdebase-apps kdebase-bin kdebase-data kdebase-runtime kdebase-runtime-data kdebase-workspace-bin kdebase-workspace-data kdebase-workspace-dev kdebase-workspace-kgreet-plugins kdegraphics-libs-data kdelibs-bin kdelibs-data kdelibs4c2a kdelibs5-data kdelibs5-dev kdelibs5-plugins kdepasswd kdepim-runtime kdepimlibs-kio-plugins kdesudo libakonadi-kde4 libkde3support4 libkdecorations4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 polkit-kde-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
kdelibs-bin is already the newest version.
kdelibs5-data is already the newest version.
kdelibs5-dev is already the newest version.
...

Experimental repository is enabled, though apt-cache policy doesn't show any candidates for kde in experimental.

Edit : Ok found the topic about http://qt-kde.debian.net
Would have expected to have something in experimental though.
DeepDayze - 27.04.2011, 01:56
Post subject:
I have it on x86_64...so far so good

EDIT: my font selections got screwed...reset them and a reboot fixed it.
se7en - 27.04.2011, 01:58
Post subject:
you need

      Code:
#kde
deb http://qt-kde.debian.net/debian experimental-snapshots main
deb-src http://qt-kde.debian.net/debian experimental-snapshots main


enabled in your /etc/apt/sources.list/
ShakaZ - 27.04.2011, 03:51
Post subject:
Feels quite sluggish after upgrading from 4.4.5.
System Load tab of System Monitor takes almost 1s to display the graphs when switching from another tab, + some visual artefacts sometimes when switching to the other tabs.
Blurry text in the task manager.
Some colours messed up in the theme I'm using, like blue tooltips.
Haven't found a cool new feature yet to balance that, but I'm sure that will come.

I put priority of that repo to 991 in /etc/apt/preferences.d/ so will be upgraded automatically with a d-u. First time I do this so I hope I chose the right number.
blackhole - 27.04.2011, 07:56
Post subject:
you don't need the number or the preferences section. It will upgrade automatically.
devil - 27.04.2011, 08:24
Post subject:
      Quote:
It will upgrade automatically.

this goes for minor upgrades, like the one yesterday. it does not neccessarily work for upgrades like from 4.5.x to 4.6.x
those should be done by: apt-get -t experimental-snapshots dist-upgrade
true is that preferences are obsolete.

greetz
devil
ShakaZ - 27.04.2011, 12:13
Post subject:
Good to know. Is there anything else providing the functionality of preferences or does apt just automatically use the same repositories a package was installed from?
finotti - 27.04.2011, 12:27
Post subject:
[quote="devil"]
      Quote:

true is that preferences are obsolete.


How about pinning? Should it also be done in a different way?

Thanks,

Luis
belze - 27.04.2011, 12:57
Post subject:
gone good!
MoDaX - 27.04.2011, 13:05
Post subject:
      ShakaZ wrote:
Good to know. Is there anything else providing the functionality of preferences or does apt just automatically use the same repositories a package was installed from?


      Code:

apt (0.8.5) unstable; urgency=low

... snip ..
   [ David Kalnischkies ]
   * apt-pkg/policy.cc:
     - support 100-pinning in Release file with ButAutomaticUpgrades
       as requested by the backports crew (Closes: #596097)

... snip ...

 -- Michael Vogt <mvo>  Fri, 17 Sep 2010 22:05:06 +0200


qt-kde.debian.net experimental-snapshots repository has "ButAutomaticUpgrades: yes" set in the Release file hence its priority defaults to 100. This means that newer packages are installed/upgraded from it unless currently installed version has a higher priority (e.g. you have the version from unstable installed (prio 500)). Debian experimental defaults to prio 1.

That's the reason you need to use -t experimental-snapshots (equivalent of bumping repositority priority to 900 via pinning) to upgrade packages from unstable which experimental-snapshots provides newer versions for.
Ilinsekt - 27.04.2011, 18:33
Post subject:
Just installed it, a few minor problems with the plasma theme I use, but installation went flawlessly. Just one thing though: Nepomuk doesn't seem to be working. The filter panel in Dolphin is completely greyed out, when I go to systemsettings->desktopsearch it says "The Nepomuk installation is not complete. No Nepomuk settings can be provided". The service section shows the nepomuk service is running, an apt-cache search for nepomuk and a reinstallation of libnepomuk4, libnepomukquery4a and libnepomukutils4 yielded no results, neither did a reboot.
DeepDayze - 27.04.2011, 19:12
Post subject:
      Ilinsekt wrote:
Just installed it, a few minor problems with the plasma theme I use, but installation went flawlessly. Just one thing though: Nepomuk doesn't seem to be working. The filter panel in Dolphin is completely greyed out, when I go to systemsettings->desktopsearch it says "The Nepomuk installation is not complete. No Nepomuk settings can be provided". The service section shows the nepomuk service is running, an apt-cache search for nepomuk and a reinstallation of libnepomuk4, libnepomukquery4a and libnepomukutils4 yielded no results, neither did a reboot.


To get nepomuk working you'll need to install the virtuoso-minimal package. I had that same problem and a google search and digging thru the nepomuk code turned that up
Ilinsekt - 27.04.2011, 19:25
Post subject:
Thanks, that worked.
DeepDayze - 27.04.2011, 19:39
Post subject:
      Ilinsekt wrote:
Thanks, that worked.


virtuoso-minimal should be a dependency...otherwise people couldn't get desktop search working
slam - 27.04.2011, 19:47
Post subject:
Desktop search is not a basic need for everyone, but an option. Therefore it is not a dependency, but "just" recommended. In Aptosid, recommended packages are not installed by default, instead we leave the decision to the user.
Greetings,
Chris
DeepDayze - 27.04.2011, 19:54
Post subject:
      slam wrote:
Desktop search is not a basic need for everyone, but an option. Therefore it is not a dependency, but "just" recommended. In Aptosid, recommended packages are not installed by default, instead we leave the decision to the user.
Greetings,
Chris


makes sense slam...maybe to be more accurate, an optional dependency
devil - 27.04.2011, 20:25
Post subject:
it does not make sense. nepomuk/strigi can be disabled in a second. on the other hand it takes users way much longer to find, what is missing.

greetz
devil
slam - 27.04.2011, 20:56
Post subject:
      devil wrote:
it does not make sense. nepomuk/strigi can be disabled in a second. on the other hand it takes users way much longer to find, what is missing.

greetz
devil
Well, the Aptosid approach is to ship the essentials, and leave other decisions to the users. Other distributions might have different policies.
Greetings,
Chris
devil - 27.04.2011, 21:33
Post subject:
essentials with kde-full?
if the approach is, to make such things unnesseccarily hard for the user, i consider it wrong.
why should user search for this for a span of his lifetime, if it can be included (and deactivated by default)

greetz
devil
dibl - 27.04.2011, 23:10
Post subject:
Whether desktop search is installed, or not, in the shipped aptosid distribution, it would only take one or two sentences in the manual to instruct users how to implement the opposite configuration. I would be happy to write the English instruction -- it's not a complicated instruction.
se7en - 28.04.2011, 00:30
Post subject:
I do agree with devil. It takes a while till you understand why you can enable desktop search but it is not working.
I might be wrong but I can not remember that there was a warning what package was missing. All I remember is that it is more trouble to activate than in most other distribution.
It would only take a package which would be no trouble on the full.iso or like dibl said some INFORMATION somewhere. Smile
domicius - 28.04.2011, 01:46
Post subject:
I actually have the Filter pane greyed out as well, but Nepomuk seems to be working fine here (enabled with status "Nepomuk system is active"). And virtuoso-minimal is already installed. Am I missing something? (is it relevant that I don't have Strigi enabled?)

BTW, if it were up to me, I'd put virtuoso-minimal as dependency.
DeepDayze - 28.04.2011, 02:02
Post subject:
      domicius wrote:
I actually have the Filter pane greyed out as well, but Nepomuk seems to be working fine here (enabled with status "Nepomuk system is active"). And virtuoso-minimal is already installed. Am I missing something? (is it relevant that I don't have Strigi enabled?)

BTW, if it were up to me, I'd put virtuoso-minimal as dependency.


I believe you need to enable "Semantic Desktop" in Systemsettings Under Desktop Search in Workspace Appearance and Settings in order to activate the filter settings
slam - 28.04.2011, 05:19
Post subject:
      dibl wrote:
Whether desktop search is installed, or not, in the shipped aptosid distribution, it would only take one or two sentences in the manual to instruct users how to implement the opposite configuration. I would be happy to write the English instruction -- it's not a complicated instruction.
Thanks! Please start in our Wiki, or directly get into contact with our docu team in the #aptosid-docs IRC channel.
Greetings,
Chris
Ilinsekt - 28.04.2011, 06:28
Post subject:
@domicius: You have to let strigi index a few directories to get this enabled.
DeepDayze - 28.04.2011, 13:54
Post subject:
      Ilinsekt wrote:
@domicius: You have to let strigi index a few directories to get this enabled.


If you want to use Strigi, it's suggested you let it only index your home folder to save resources. Trying to index your whole system's a waste of resources
arwa - 28.04.2011, 18:51
Post subject:
FYI: KDE4.6.2 seems to enter experimental.
devil - 28.04.2011, 19:17
Post subject:
installing from experimental does not make much sense:
for one its mostly identical with the one on qt-kde.debian.net,
secondly, 4.6.3 will probably surface on qt-kde.debian.net.
as for the reason, why 4.6.2-1 was pushed to experimental, my guess is, it was a testcase to see how it would pass NEW.
a dist-upgrade from qt-kde.debian.net is a lot easier than from experimental (as dist-upgrades from there are a total no-go.

greetz
devil
belze - 28.04.2011, 23:19
Post subject:
at least it a step forward to sid...isn't it?
DeepDayze - 28.04.2011, 23:25
Post subject:
      belze wrote:
at least it a step forward to sid...isn't it?


If it made it to experimental, most likely if no issues and the packages are accepted then we should see KDE 4.6.2 officially arrive to sid soon
devil - 28.04.2011, 23:38
Post subject:
i would rather put my money on 4.6.3 or 4.7

greetz
devil
DeepDayze - 29.04.2011, 00:14
Post subject:
      devil wrote:
i would rather put my money on 4.6.3 or 4.7

greetz
devil


Think 4.6.3 is due out any day now with 4.7 arriving by summer
bluewater - 30.04.2011, 12:44
Post subject: nepomuk and strigi in manual now as an extra
@dibl

Don

Thanks for the patch, it is now in svn and online for all langs:

http://manual.aptosid.com/en/wm-dm-en.htm

It will be another few days before it enters the aptosid repo.

Regards
Trevor
domicius - 02.05.2011, 08:38
Post subject:
      DeepDayze wrote:
I believe you need to enable "Semantic Desktop" in Systemsettings Under Desktop Search in Workspace Appearance and Settings in order to activate the filter settings

I already had Semantic Desktop activated and with that, Filter panel is simply not functional.

      Ilinsekt wrote:
@domicius: You have to let strigi index a few directories to get this enabled.

Thanks! That's the key! Wink

      DeepDayze wrote:
If you want to use Strigi, it's suggested you let it only index your home folder to save resources. Trying to index your whole system's a waste of resources

I agree. It's just too bad this filtering feature in Dolphin depends on the directory being indexed by Strigi.
blackhole - 04.05.2011, 09:51
Post subject:
Today, with qt-debian enabled, a simulation of dist-upgrade will download kde packages from experimental.

Is this right? Maybe I must disable experimental in sources?

In any case I am waiting for the problems about perl.
devil - 04.05.2011, 10:42
Post subject:
and the packages are?

greetz
devil
blackhole - 04.05.2011, 11:30
Post subject:
a lot:


      Quote:
akonadi-backend-mysql akonadi-server akonadiconsole akregator alsa-base alsa-utils apt-conf-aptosid
aptosid-archive-keyring aptosid-art-kde aptosid-art-kde-geras aptosid-art-kdm-geras aptosid-art-ksplash-geras
aptosid-art-wallpaper aptosid-art-wallpaper-geras aptosid-irc aptosid-manual-common aptosid-manual-en aptosid-scripts
aptosid-settings-kde ark avahi-daemon binutils blinken blogilo bomber bovo cantor ceni configure-cups cpp cpp-4.5
cuneiform cuneiform-common cvs debconf debconf-i18n debconf-utils debhelper dictionaries-common distro-defaults
dmakms dolphin dragonplayer elinks-lite exif exim4-base exim4-daemon-light filelight fll-iso2usb freespacenotifier
g++ g++-4.5 gcc gcc-4.5 gcc-4.5-base gcc-4.6-base gfxboot-theme-aptosid gfxboot-themes-aptosid-2010-02-keres-core
granatier gtk2-engines-qtcurve guile-1.8-libs gwenview imagemagick infobash install-usb-gui irssi iso-codes
jack-keyboard juk k3b k3b-data k9copy kaddressbook kaffeine kalarm kalgebra kalzium kalzium-data kamera kanagram
kapman katomic kbattleship kblackbox kblocks kbounce kbreakout kbruch kcalc kcharselect kcolorchooser kde-config-cddb
kde-config-cron kde-config-phonon-xine kde-full kde-plasma-desktop kde-plasma-netbook kde-window-manager kdeadmin
kdeartwork kdeartwork-emoticons kdeartwork-style kdeartwork-theme-icon kdeartwork-theme-window kdebase-apps
kdebase-bin kdebase-data kdebase-runtime kdebase-runtime-data kdebase-workspace kdebase-workspace-bin
kdebase-workspace-data kdebase-workspace-kgreet-plugins kdeedu kdeedu-kvtml-data kdegames kdegames-card-data
kdegames-mahjongg-data kdegraphics kdegraphics-libs-data kdelibs-bin kdelibs5-data kdelibs5-dev kdelibs5-plugins
kdemultimedia kdemultimedia-kio-plugins kdenetwork kdenlive kdenlive-data kdepasswd kdepim kdepim-groupware
kdepim-kresources kdepim-runtime kdepim-strigi-plugins kdepim-wizards kdepimlibs-kio-plugins kdepimlibs5-dev
kdeplasma-addons kdeutils kdewallpapers kdf kdiamond kdm kdoctools kernel-remover kexec-tools kfind kfloppy
kfourinline kgamma kgeography kgeography-data kget kgoldrunner kgpg khangman khelpcenter4 kig kigo killbots
kinfocenter kiriki kiten kjots kjumpingcube kleopatra klettres klettres-data klickety klines klipper kmahjongg kmail
kmines kmix kmplot knetwalk knode knotes kolf kollision kolourpaint4 konqueror konquest konsole konsolekalendar
kontact kopete korganizer kpat kppp krdc kremotecontrol kreversi krfb kruler ksame kscd kscreensaver kshisen ksirk
ksnapshot kspaceduel ksquares kstars kstars-data ksudoku ksysguard ksysguardd ksystemlog ktimer ktimetracker ktorrent
ktorrent-data ktouch ktron ktuberling kturtle kubrick kuser kwalletmanager kwordquiz kwrite lib32gcc1 lib32stdc++6
libaa1 libakonadi-calendar4 libakonadi-contact4 libakonadi-dev libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4
libakonadi-kmime4 libakonadiprotocolinternals1 libapt-pkg-perl libaudio2 libavahi-client3 libavahi-common-data
libavahi-common3 libavahi-core7 libavahi-glib1 libbfb0 libbit-vector-perl libbluray0 libc-bin libc-dev-bin libc6
libc6-dev libc6-i386 libcddb2 libcurses-perl libdate-calc-perl libdb4.7 libdb4.8 libdbi-perl libdigest-sha1-perl
libegl1-mesa libgcc1 libgeoip1 libgfortran3 libgl1-mesa-dri libgl1-mesa-glx libglib-perl libglu1-mesa libgomp1
libgpgme++2 libgpgme11 libgphoto2-2 libgphoto2-port0 libgpod4-nogtk libgraphicsmagick++3 libgraphicsmagick3
libgstreamer0.10-0 libhtml-parser-perl libieee1284-3 libio-pty-perl libk3b6 libk3b6-extracodecs libkabc4
libkastencontrollers4 libkastencore4 libkastengui4 libkatepartinterfaces4 libkblog4 libkcal4 libkcalcore4
libkcalutils4 libkcddb4 libkcmutils4 libkde3support4 libkdecorations4 libkdecore5 libkdeedu-data libkdeeduui4
libkdegames5a libkdepim4 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkeduvocdocument4 libkemoticons4
libkephal4abi1 libkexiv2-9 libkfile4 libkggzgames4 libkggzmod4 libkggznet4 libkholidays4 libkhtml5 libkidletime4
libkimap4 libkimproxy4 libkio5 libkipi8 libkiten4 libkjsapi4 libkjsembed4 libkldap4 libkleo4 libkmahjongglib4
libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common
libkonq5-templates libkonq5abi1 libkonqsidebarplugin4a libkontactinterface4 libkopete4 libkparts4 libkpgp4
libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4
libksane0 libkscreensaver5 libksgrd4 libksieve4 libksignalplotter4 libktexteditor4 libktnef4 libktorrent-l10n
libktorrent3 libkunitconversion4 libkutils4 libkwineffects1abi1 libkworkspace4 libkxmlrpcclient4 liblcms1
libldap-2.4-2 libldap2-dev liblocale-gettext-perl libmagick++3 libmagickcore3 libmagickwand3 libmailtransport4
libmailutils2 libmarblewidget11 libmessagecore4 libmessagelist4 libmicroblog4 libmimelib4 libmlt++3 libmlt-data
libmlt4 libmozjs2d libmpfr4 libmtp8 libmulticobex1 libnepomuk4 libnepomukquery4a libnepomukutils4 libnet-dns-perl
libobexftp0 liboktetacore4 liboktetagui4 liboktetakastencontrollers4 liboktetakastencore4 liboktetakastengui4
libokularcore1 liborc-0.4-0 libpam-modules libpam-runtime libpam0g libpcap0.8 libpixman-1-0 libpixman-1-dev
libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi1 libplasmagenericshell4 libpolkit-qt-1-1
libproc-processtable-perl libprocesscore4abi1 libprocessui4a libqgpgme1 libqt3-mt libqt4-assistant libqt4-core
libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-gui libqt4-help libqt4-network libqt4-opengl
libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg
libqt4-test libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libquadmath0 libreoffice
libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-help-it libreoffice-impress
libreoffice-java-common libreoffice-kde libreoffice-l10n-it libreoffice-math libreoffice-pdfimport
libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-style-oxygen libreoffice-writer libscience4
libsolid4 libsolidcontrol4abi1 libsolidcontrolifaces4abi1 libstdc++6 libstdc++6-4.5-dev libsvga1 libsvn1
libsyndication4 libtaskmanager4abi1 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libthreadweaver4
libweather-ion6 libwebkit-1.0-2 libwebkit-1.0-common libwpd-0.9-9 libwxbase2.8-0 libwxbase2.8-dev libwxgtk2.8-0
libwxgtk2.8-dev libxfixes3 libxml-parser-perl libxmu6 libxmuu1 linux-sound-base locales lskat luckybackup
luckybackup-data mailutils marble marble-data marble-plugins melt mencoder mesa-common-dev **removed** mplayerthumbs
nuvola-icon-theme okteta okular oxygen-icon-theme palapeli palapeli-data parley parley-data perl perl-base
perl-modules pkg-kde-tools plasma-containments-addons plasma-dataengines-addons plasma-dataengines-workspace
plasma-desktop plasma-desktopthemes-artwork plasma-netbook plasma-runners-addons plasma-scriptengine-googlegadgets
plasma-scriptengine-javascript plasma-scriptengine-python plasma-scriptengine-ruby plasma-scriptengine-superkaramba
plasma-scriptengine-webkit plasma-scriptengines plasma-wallpapers-addons plasma-widget-folderview
plasma-widget-lancelot plasma-widgets-addons plasma-widgets-workspace python-cups python-django python-obexftp
python-uno qjackctl qt4-qmake rocs smb4k **removed** squashfs-tools step subversion sun-java6-bin sun-java6-jre
sun-java6-plugin sweeper system-config-printer-kde systemsettings ttf-lyx ttf-opensymbol udev-config-aptosid
uno-libs3 ure wx2.8-headers x11-utils x11proto-xext-dev xdg-browser-launcher xserver-common xserver-xorg-core
xserver-xorg-dev xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-vmmouse
xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati
xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128
xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition
xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-savage xserver-xorg-video-siliconmotion
xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xulrunner-1.9.1
585 upgraded, 8 newly installed, 19 to remove and 10 not upgraded.

devil - 04.05.2011, 11:44
Post subject:
well, 4.6.2-1 has moved into experimental some days ago. so, if the versions of the new √ľackages are 4.6.2-1, its not really worth the hassle, as the packages differ only very minimal. besides that, 4.6.3 will be first reeleased to the kde-qt repo.
as to why a dist-upgrade involves experimentalm, there is (besides you having an insane pinning) only one explanation (been there, done that, got the t-shirt):
      Code:
apt-get -t experimental dist-upgrade

instead of:
      Code:
apt-get -t experimental-snapshots dist-upgrade


greeetz
devil
blackhole - 04.05.2011, 11:45
Post subject:
Now I know the reason: kde 4.6.2 has been removed from http://qt-kde.debian.net/

      Quote:
KDE SC 4.6.x packages will be removed from this repository once their newer versions enter official Debian archive (either experimental or unstable). The repository itself will continue to exist though it will be empty most of the time.

blackhole - 04.05.2011, 11:59
Post subject:
devil,
I have never and I will never dist-upgrade against experimental! And no pinning of experimental!

What I have is only experimental enabled in apt sources (and qt-kde).
The packages versions are different. For example kdebase is 4.6.2-0r3 now and 4.6.2-2 in experimental.

I have tried this:
1) Disable experimental in apt
2) apt-get clean
3) apt-get update
3)dist-upgrade

But the packages are always there for upgrade....


ERRATA CORRIGE:
I have checked now and there is un upgrade to 4.6.2-1 in experimental-snapshots. The reason of the problem is probably that for some time experimental-snapshots was empty, because it was upgrading to a new version
devil - 04.05.2011, 13:18
Post subject:
that might have been the problem. i didnt follow the repo after istalling 4.6.2-0r2 initialy

greetz
devil
DeepDayze - 04.05.2011, 14:11
Post subject:
There's now updated KDE 4.6.2 packages in qt-kde repo
ShakaZ - 08.05.2011, 02:12
Post subject:
I've just dist-upgraded the whole system including this kde release.
I reported earlier that kde 4.6.2 felt very sluggish when I first installed it.
Since today's d-u however my system is blazing fast again. I don't recall KDE 4 running that fast since the first time it got pushed onto sid users.
I don't know what caused this sudden responsiveness (kde, xorg,...) but it feels good. Hope it will stay like that Cool
merlyn - 08.05.2011, 03:57
Post subject:
      ShakaZ wrote:
I've just dist-upgraded the whole system including this kde release.
I reported earlier that kde 4.6.2 felt very sluggish when I first installed it.
Since today's d-u however my system is blazing fast again. I don't recall KDE 4 running that fast since the first time it got pushed onto sid users.
I don't know what caused this sudden responsiveness (kde, xorg,...) but it feels good. Hope it will stay like that Cool


Same here with regard to improved responsiveness since the most recent dist-upgrade, (approx 15 minutes ago at time of posting).

The only 'odd' thing is that I get some 'remnants' on the screen if I move the mouse/cursor just after launching an app.

Cheers.
wofritz - 08.05.2011, 07:49
Post subject:
      Quote:
The only 'odd' thing is that I get some 'remnants' on the screen if I move the mouse/cursor just after launching an app.


Ah! So I'm not alone. I am running this graphics board
      Code:
01:00.0 VGA compatible controller: ATI Technologies Inc R300 NF [Radeon 9600 TX] (prog-if 00 [VGA controller])

Regards,
wolfgang
blackhole - 08.05.2011, 11:40
Post subject:
Just now experimental-snapshots is empty. Same problem as before. A tentative apt-get dist-upgrade will have this as output:

      Quote:

Get:1 http://ftp.cz.debian.org/debian/ experimental/main kget amd64 4:4.6.3-0exp1 [2,075 kB]
Get:2 http://ftp.cz.debian.org/debian/ experimental/main libkopete4 amd64 4:4.6.3-0exp1 [465 kB]
Get:3 http://ftp.cz.debian.org/debian/ experimental/main kopete amd64 4:4.6.3-0exp1 [7,973 kB]
Get:4 http://ftp.cz.debian.org/debian/ experimental/main krdc amd64 4:4.6.3-0exp1 [542 kB]
Get:5 http://ftp.cz.debian.org/debian/ experimental/main krfb amd64 4:4.6.3-0exp1 [484 kB]
Get:6 http://ftp.cz.debian.org/debian/ experimental/main kdenetwork all 4:4.6.3-0exp1 [16.5 kB]
Get:7 http://ftp.cz.debian.org/debian/ experimental/main kppp amd64 4:4.6.3-0exp1 [672 kB]


So it seems that 4.6.3 is going to experimental. Not sure what will happen to the packages in experimental-snapshots.
They will upload 4.6.3?
Better wait...

PS
It seems that without pinning experimental-snapshots and with enabled experimental in debian sources a normal dist-upgrade will download packages from experimental in this case.
A bug or what?
ShakaZ - 08.05.2011, 13:05
Post subject:
      wofritz wrote:
      Quote:
The only 'odd' thing is that I get some 'remnants' on the screen if I move the mouse/cursor just after launching an app.


Ah! So I'm not alone. I am running this graphics board
      Code:
01:00.0 VGA compatible controller: ATI Technologies Inc R300 NF [Radeon 9600 TX] (prog-if 00 [VGA controller])

Regards,
wolfgang


No remnants here, using an Nvidia G105M with latest non-free driver.

I do however have an issue with kget. Getting files of Stunt Rally game from https://code.google.com/p/vdrift-ogre/downloads/list
I click the links in iceweasel then choose to download them through Flashgot which sends the link to Kget. The first file is ok, but the next ones take at least 2 minutes to show up in Kget, one at a time.
Even weirder on of the files showed up in Kget with the name of another one which hadn't showed up yet.
arwa - 08.05.2011, 18:58
Post subject:
      blackhole wrote:
Just now experimental-snapshots is empty
....
So it seems that 4.6.3 is going to experimental. Not sure what will happen to the packages in experimental-snapshots.
They will upload 4.6.3?


I do not understand what your problem is?

1) experimental-snapshots is not empty. Just click and check here: http://qt-kde.debian.net/debian

2) If you have problems with experimental, deactivate it in your sources.list. You do not need it usually. After deactivating do another "apt-get update" and then "apt-get dist-upgrade". On one PC this did upgrade to KDE4.6 fine. On another this did not work and I had to specify "apt-get dist-upgrade -t experimental-snapshots". Both ways should lead you to a system with KDE4.6.2. Also some packages from 4.6.3 show up today on experimental-snapshots.
DeepDayze - 08.05.2011, 23:17
Post subject:
      arwa wrote:
      blackhole wrote:
Just now experimental-snapshots is empty
....
So it seems that 4.6.3 is going to experimental. Not sure what will happen to the packages in experimental-snapshots.
They will upload 4.6.3?


I do not understand what your problem is?

1) experimental-snapshots is not empty. Just click and check here: http://qt-kde.debian.net/debian

2) If you have problems with experimental, deactivate it in your sources.list. You do not need it usually. After deactivating do another "apt-get update" and then "apt-get dist-upgrade". On one PC this did upgrade to KDE4.6 fine. On another this did not work and I had to specify "apt-get dist-upgrade -t experimental-snapshots". Both ways should lead you to a system with KDE4.6.2. Also some packages from 4.6.3 show up today on experimental-snapshots.



Yes I noticed some 4.6.3 packages starting to come in on E-S, so most likely 4.6.3 is going to be in both places. My guess is that Debian is waiting for 4.7 before the newest KDE hits sid.
devil - 23.05.2011, 11:28
Post subject:
http://steveire.wordpress.com/2011/05/1 ... m-4-6-rc1/

greetz
devil
DeepDayze - 23.05.2011, 14:21
Post subject:
      devil wrote:
http://steveire.wordpress.com/2011/05/15/kde-pim-4-6-rc1/

greetz
devil


So I can guess that kdepim's what's holding up the new KDE from being moved to Sid. With the showstopper bugs fixed then it should be any day now.
Lanzi - 23.05.2011, 23:30
Post subject:
The last sentence sounds to me more like we will have to wait until june2 or later...
devil - 24.05.2011, 06:43
Post subject:
it might even appear today in experimental or the kde-qt repo.

greetz
devil[/b]
Lanzi - 24.05.2011, 06:58
Post subject:
Keep fingers crossed Smile
I really like KDE 4.4... but a change is welcome Smile
devil - 24.05.2011, 09:12
Post subject:
i was only speaking of kdepim 4.6 ,the rest of 4.6 has been in experimental and qt-kde repo for some time.

greetz
devil
Lanzi - 24.05.2011, 13:06
Post subject:
Sure. I know. But I remeber that digicam was not working with the qt-kde repo - and I am waiting for KDE in SID.
DeepDayze - 24.05.2011, 13:23
Post subject:
      Lanzi wrote:
Sure. I know. But I remeber that digicam was not working with the qt-kde repo - and I am waiting for KDE in SID.


Same here - Digikam in Sid is broken with KDE 4.6.2 and the Digikam 1.9 in experimental works for me...why try it out?
devil - 25.05.2011, 22:03
Post subject:
kde 4.6 will move to sid tomorrow. please take care when upgrading

greetz
devil
DeepDayze - 26.05.2011, 00:15
Post subject:
      devil wrote:
kde 4.6 will move to sid tomorrow. please take care when upgrading

greetz
devil


Will the packages be compatible with the ones from experimental-snapshots or will we have to remove them?
devil - 26.05.2011, 05:46
Post subject:
i am sure there will b e an upgrade path.

greetz
devil
DeepDayze - 27.05.2011, 01:09
Post subject:
      devil wrote:
i am sure there will b e an upgrade path.

greetz
devil


Looks like KDE 4.6.3 is in the pipeline now as many KDE packages are in incoming right now so looks like the next sync we'll be getting them
yossarian - 27.05.2011, 09:11
Post subject:
http://lists.debian.org/debian-kde/2011/05/msg00034.html
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits