aptosid.com

Upgrade Warnings - libcrush1 & librados1 safe to let go

detaos - 07.10.2011, 03:53
Post subject: libcrush1 & librados1 safe to let go
Today's d-u wants to remove libcrush1 & librados1. They are safe to let go.

Enjoy.
sunu - 08.10.2011, 09:38
Post subject: RE: libcrush1 & librados1 safe to let go
librados1 is being replaced by librados2 so essentially it isn't removed. But I don't see libcrush2 or something.

Also it wants to remove libpulse-browse0
hefee - 08.10.2011, 10:04
Post subject: RE: libcrush1 & librados1 safe to let go
libpulse-browse0 is ok see http://www.freedesktop.org/wiki/Softwar ... /Notes/1.0
sunu - 09.10.2011, 10:35
Post subject: RE: libcrush1 & librados1 safe to let go
And for libcrush: http://packages.debian.org/changelogs/p ... /changelog
      Quote:

Add new binary packages, gceph, gceph-dbg and obsync . The libcrush ones removed.

spacepenguin - 09.10.2011, 17:12
Post subject: RE: libcrush1 & librados1 safe to let go
So I have to install librados2 manually? And gceph and obsync replace libcrush1? What is ceph used for? It is installed on my system but I don't know why. The description "distributed storage and file system" doesn't really help (me)...
piper - 09.10.2011, 19:15
Post subject: RE: libcrush1 & librados1 safe to let go
Might help

http://en.wikipedia.org/wiki/Ceph

      Code:
apt-cache depends ceph
ceph
  Depends: libc6
  Depends: libcrypto++9
  Depends: libedit2
  Depends: libgcc1
  Depends: libgoogle-perftools0
  Depends: libstdc++6
 |Depends: hdparm
  Depends: sdparm
  Depends: binutils
  Recommends: ceph-client-tools
  Recommends: ceph-fuse
  Recommends: libceph1
  Recommends: librados2
  Recommends: librbd1
  Recommends: btrfs-tools
  Recommends: gceph

spacepenguin - 10.10.2011, 04:59
Post subject: RE: libcrush1 & librados1 safe to let go
Thanks piper. And what is the other way round to find out which packages depend on a certain package? If I e.g. want to know which other packages except ceph need librados2?
finotti - 10.10.2011, 10:09
Post subject: RE: libcrush1 & librados1 safe to let go
I think it is this:

      Code:

$ apt-cache rdepends ceph
ceph
Reverse Depends:
  gceph
  ceph-fuse
  ceph-dbg
  ceph-client-tools


("man apt-cache" might help.)

HTH,

Luis
spacepenguin - 10.10.2011, 14:49
Post subject: RE: libcrush1 & librados1 safe to let go
Yes, that's it, tanks finotti. So qemu needs librados too, ok.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits