aptosid.com

Upgrade Warnings - [SOLVED] Errors with some GTK/GUI apps.

gutterslob - 31.03.2012, 17:35
Post subject: [SOLVED] Errors with some GTK/GUI apps.
Not necessarily an Aptosid issue, but I'd like some advice on this.

A friend's comp which runs Aptosid ran into some problems today. It seems some GUI apps don't work anymore.

For example, when you double-click on a zip or rar file, it's usually supposed to launch file-riller (which I installed for him), but now nothing happens. Launching it manually with "file-roller <name_of_file> via terminal gives:
      Code:
(file-roller:3901): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
3901 trace trap (core dumped)  file-roller <name_of_file>


Strangely, Xarchiver seems to work without issue.

Another example would be Comix (an app that extracts and displays). Launching in terminal gives:
      Code:
Traceback (most recent call last):
  File "/usr/bin/comix", line 151, in <module>
    run()
  File "/usr/bin/comix", line 123, in run
    icons.load_icons()
  File "/usr/share/comix/src/icons.py", line 48, in load_icons
    '16x16/comix.png'))
glib.GError: Couldn't recognize the image file format for file '/usr/share/comix/images/16x16/comix.png'


Doubling clicking on images (jpg or png) gives a "couldn't recognize image file format for file" error box, and running ristreto in terminal gives:
      Code:
(ristretto:3529): GdkPixbuf-CRITICAL **: gdk_pixbuf_saturate_and_pixelate: assertion `GDK_IS_PIXBUF (src)' failed


His file manager and browser, both included with Aptosid Xfce (Iceweasel and Thunar), seem to work without issues. Can't replicate on my own Debian box since I run standard Debian Sid with some Aptosid stuff added and don't use his particular apps.

Any clue on what the errors relate to? Seems to have something to do with the system no longer being able to recognize some image formats. Possibly even Pixbuf of Gconf related?

Cheers.

Edit:
Oh, it seems GDM can't be launched with the stock Aptosid artwork. Some message about not being able to locate some .png or something and it launches with a different look. Again, I can't replicate this on my Debian box since I don't use GDM.
piper - 31.03.2012, 17:49
Post subject: RE: Errors with some GTK/GUI apps.
Like to see
      Code:
apt-cache policy libglib2.0-0

and
      Code:
apt-cache policy gsettings-desktop-schemas

gutterslob - 31.03.2012, 17:54
Post subject: RE: Errors with some GTK/GUI apps.
libglib2.0-0
      Code:

libglib2.0-0:
  Installed: 2.32.0-3
  Candidate: 2.32.0-3
  Version table:
 *** 2.32.0-3 0
        500 http://ftp.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status


gsettings-desktop-schemas
      Code:

gsettings-desktop-schemas:
  Installed: 3.2.0-2
  Candidate: 3.2.0-2
  Version table:
 *** 3.2.0-2 0
        500 http://ftp.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

piper - 31.03.2012, 18:07
Post subject: RE: Errors with some GTK/GUI apps.
Maybe try apt-get install --reinstall both

Perhaps have a look at google GLib-GIO-ERROR **: No GSettings schemas are installed on the system


Mar 25, 2011 this one is old http://bugs.debian.org/619627
gutterslob - 31.03.2012, 18:36
Post subject: RE: Errors with some GTK/GUI apps.
Reinstalling gsettings-desktop-schemas fixed the issue. Still unsure what caused this in the first place, but everything seems to be running fine now. I'll note this down for future troubleshooting.

Much thanks, Piper. =)
DeepDayze - 01.04.2012, 15:21
Post subject: RE: Errors with some GTK/GUI apps.
Sounds like a possibility the schema configs got corrupted along the way and great that reinstalling the package fixed it for you. Its a good idea to try reinstalling the package that causes an issue and if that fixes it then post it up in case some people run into the same issue as you.
gutterslob - 01.04.2012, 21:06
Post subject: RE: Errors with some GTK/GUI apps.
I think I found the cause. It seems related to the broken ncurses-term & suckless-tools combo.
Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665877

If you've got these 2 packages installed, the current "bug" stops certain processes when you dist-upgrade. My friend encountered a problem again last night when he downloaded a new kernel. Seems the DU didn't create a initrd.img for the new kernel or something (resulting in panic upon reboot with newly installed kernel). Reinstalling/running gsettings-desktop-schemas again fixed issues and generated the initrd.img without hiccups.

I got him to put ncurses-term on hold till suckless-tools gets fixed and the two are once again able to copulate in harmony.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits