aptosid.com

User Scripts & Dragons - [solved]no kdm log-in screen after reversing to nouveau

Spaceferret - 24.04.2012, 13:01
Post subject: [solved]no kdm log-in screen after reversing to nouveau
After getting annoyed with the latest nvidia driver performance problems I reinstalled nouveau following aptosid tutorial, removed all nvidia files and purged xorg.conf. Now every time I start my machine after normal boot messages I'm presented with tty log-in prompt, not the kdm log-in window.If I log-in as root, switch to init 3 and then init 5 && exit I get the log-in window. If I log-in as user from the tty I have weird permission restrictions on all removable storage (any SD card or flash drive) . Quite annoying,even more than nvidia Sad
piper - 27.04.2012, 07:31
Post subject: RE: no kdm log-in screen after reversing to nouveau
Did you do
      Code:
apt-get install --reinstall xserver-xorg-core xserver-xorg-video-nouveau
and reboot
Spaceferret - 28.04.2012, 00:15
Post subject: RE: no kdm log-in screen after reversing to nouveau
@piper : yes, I followed the link posted in Manual. I checked the log files and that's what I get
      Code:
X.Org X Server 1.11.4
Release Date: 2012-01-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 i686 Debian
Current Operating System: Linux eternity 3.3-3.slh.2-aptosid-686 #1 SMP PREEMPT Wed Apr 25 01:27:53 UTC 2012 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.3-3.slh.2-aptosid-686 root=UUID=07667c61-7712-473b-bfaa-a1db282c5497 ro vga=791
Build Date: 05 March 2012  04:16:09AM
xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi>)
Current version of pixman: 0.24.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 26 21:40:52 2012
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "nv" (module does not exist, 0)
(EE) NOUVEAU(0): failed to set mode: Invalid argument
Fatal server error:
failed to create screen resources

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1)


Then I get log-in prompt, were I log-in as root, go to init 3, after that 'service kdm start' and I get my log-in screen
towo - 28.04.2012, 10:36
Post subject: RE: no kdm log-in screen after reversing to nouveau
remove
vga=791
from your kernel command line!
Spaceferret - 28.04.2012, 17:37
Post subject: RE: no kdm log-in screen after reversing to nouveau
Thank you towo, your input is always the most valuable, I removed that line first thing after purging nvidia
etc/default/grub
      Code:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""


and /boot/grub/grub.cfg
      Code:
menuentry 'Debian GNU/Linux, with Linux 3.3-4.slh.1-aptosid-686' --class debian --class gnu-linux --class gnu --class os {
   insmod gzio
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos3)'
   search --no-floppy --fs-uuid --set=root 07667c61-7712-473b-bfaa-a1db282c5497
   echo   'Loading Linux 3.3-4.slh.1-aptosid-686 ...'
   linux   /boot/vmlinuz-3.3-4.slh.1-aptosid-686 root=UUID=07667c61-7712-473b-bfaa-a1db282c5497 ro 
   echo   'Loading initial ramdisk ...'
   initrd   /boot/initrd.img-3.3-4.slh.1-aptosid-686


And I'm not the only one
http://www.digipedia.pl/usenet/thread/12076/1534/
Spaceferret - 03.05.2012, 06:08
Post subject: RE: no kdm log-in screen after reversing to nouveau
Latest update - installed NVIDIA 302.7 Beta , everything works perfect, nouveau no more Very Happy
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits