aptosid.com

Upgrade Warnings - KDE 4.8.4 is coming to sid

Friday - 09.06.2012, 21:37
Post subject: KDE 4.8.4 is coming to sid
Afte a long time, is the newest KDE 4.8.4 uploading into sid now!
      Code:
Package update (upgrade) will be charged ... Ready
The following packages will be upgraded (upgrade):
  base-files elinks-lite kde-plasma-desktop kde-wallpapers-default kdegraphics-libs-data librdf0 libsasl2-2 libsasl2-modules oxygen-icon-theme rsyslog ssl-cert
11 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
It must be downloaded 63.0 MB of archives.
After this operation, 25,4 MB disk space will be used in addition.
Do you want to continue [Y / n]?
Get: 1 http://ftp.nl.debian.org/debian/ unstable / main base-files i386 6:10 [69.6 kB]
Get 2 http://ftp.nl.debian.org/debian/ unstable / main libsasl2-modules-i386 2.1.25.dfsg1 4 + b1 [112 kB]
Get 3 http://ftp.nl.debian.org/debian/ unstable / main libsasl2-2-4 i386 2.1.25.dfsg1 + b1 [119 kB]
Get: 4 http://ftp.nl.debian.org/debian/ unstable / main rsyslog i386 5.8.11-1 + b1 [551 kB]
Get 5 http://ftp.nl.debian.org/debian/ unstable / main kde-plasma-desktop-i386 5:76 [11.4 kB]
Get: 6 http://ftp.nl.debian.org/debian/ unstable / main kde-wallpapers-all default 4:4.8.4-1 [31.7 MB]
Get: 7 http://ftp.nl.debian.org/debian/ unstable / main kdegraphics-libs-data all 4:4.8.4 +5.76 [11.2 kB]
Get: 8 http://ftp.nl.debian.org/debian/ unstable / main librdf0 i386 1.0.15-1 + b1 [131 kB]
Get: 9 http://ftp.nl.debian.org/debian/ unstable / main oxygen-icon-theme all 4:4.8.4-1 [29.8 MB]
Get 10 http://ftp.nl.debian.org/debian/ unstable / main ssl-cert 1.0.29-all [15.6 kB]
Get: 11 http://ftp.nl.debian.org/debian/ unstable / main elinks-lite-i386 0.12 ~ pre5-8 [431 kB]
It was 63.0 MB in 1 min 35 s taken (658 kB / s).
Download is complete, only download mode active
aptosidbox root @ :/ home / # friday


Be careful and keep cool! Very Happy

Regards
Friday
slh - 09.06.2012, 21:49
Post subject: RE: KDE 4.8.4 is coming to sid
As usual it is suggested to wait 2-3 days for the uploads to finish, in order to avoid partial upgrades, which might not work perfectly. This is especially true for i386 systems (because the upload arch is amd64, so the buildds need some time to build the i386 counterparts).
slaughterer - 10.06.2012, 15:26
Post subject: RE: KDE 4.8.4 is coming to sid
Just D-U!Everythink Ok.....
slh - 10.06.2012, 16:05
Post subject: RE: KDE 4.8.4 is coming to sid
Upgrading at this point in time might work, but it's still too early to give all clear (important parts of the KDE packages are only in the upcoming mirror sync, for the uploading architecture, and even then some parts are still missing). While it might not eat the cat - that's mostly by mere luck, a little patience is still a virtue (especially for arch != amd64).
DeepDayze - 10.06.2012, 22:45
Post subject: Re: RE: KDE 4.8.4 is coming to sid
      slh wrote:
Upgrading at this point in time might work, but it's still too early to give all clear (important parts of the KDE packages are only in the upcoming mirror sync, for the uploading architecture, and even then some parts are still missing). While it might not eat the cat - that's mostly by mere luck, a little patience is still a virtue (especially for arch != amd64).


true, if anything wants to be removed then everything is not all there yet
Mte90 - 12.06.2012, 14:20
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
python-kde4,ark,gwenview,kcalc,kcolorchooser,kde-config-cron,kdegraphics-thumbnailers are not updated and also more package...
but i wait it :-p
finotti - 14.06.2012, 10:28
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
Is it already safe? (All to be removed seem to be replaced for me.) Any reports?

Thanks,

Luis
Ilinsekt - 14.06.2012, 14:25
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
I du'd yesterday on an i686 system without major problems, so it's probably safe to say that a d-u now will not eat your kittens. However, there is a _very_ annoying bug in the new Dolphin, see https://bugs.kde.org/show_bug.cgi?id=298577
slh - 14.06.2012, 15:45
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
The KDE 4.8.4 upload is not complete yet, but the parts already uploaded appear to cooperate with the existing parts from 4.7.4 (which is not a given and doesn't necessarily work in all corner cases). As such I still wouldn't recommend it, even though it appears to be fine in practice (this time).
kenyee - 16.06.2012, 14:02
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
dum question, but how can we tell if the 4.8.4 upload is done so we don't have to keep pestering you to ask if it's ready yet? Smile
mz - 16.06.2012, 14:29
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
Not sure if this is related, but my d-u removed akonadi-backend-mysql and installed akonadi-backend-sqlite but akonadiserver still looked for mysql and failed to start. Reinstalling akonadi-backend-mysql fixed the problem.

If there is a way to tell akonadiserver to switch to sqlite, I would like to know it.
slh - 16.06.2012, 16:17
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
Not related, but an issue caused by the mysql-*-5.1 --> mysql-*-5.5 transition.

To switch akonadi from mysql to sqlite, warning this loses all data stored in the akonadi databases!
      Code:
# apt-get install akonadi-backend-sqlite
# apt-get remove --purge akonadi-backend-mysql akonadi-backend-postgresql

$ rm -rf ~/.local/share/akonadi ~/.config/akonadi/* ~/.kde/share/config/akonadi-firstrunrc
$ printf "%s\n%s\n" '[%General]' 'Driver=QSQLITE3' > ~/.config/akonadi/akonadiserverrc
Don't run this while being logged into KDE, but rather as the intended user from cli (needs to be done for each user you want to switch).
hy - 20.06.2012, 10:38
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
Is it secure now to d-u?
slh - 20.06.2012, 11:27
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
It can be considered safe, but as before, kdeutils and kdesdk are still missing - so this transition isn't technically finished, yet.
hy - 20.06.2012, 20:53
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
ok thanks. I'll be patient.
vinur - 20.06.2012, 23:54
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
hy, Take this for what it is worth, but I have been cautiously and carefully upgrading once a day since two days from when these KDE changes started.. I did an upgrade around June 12th and although at first I was noticing many missing elements the system was surviving OK... (Maybe lucky) as of a few days ago it is running pretty good and although it is still in cautionary use... I am not experiencing any issues that would cause serious concern. In fact I like it, many issues resolved.
like the ugly font smearing on the internet is gone now... Screen saver with switching pictures is still buggy though.
RE: https://bugs.kde.org/show_bug.cgi?id=293874.
There are differences and some caution is called for but I feel comfortable with the upgrades and at this point I will continue (while carefully reading here first of course)
KDE version 2.0 Using KDE Development Platform 4.8.3 (4.8.3)

michael@Eyland-1:~$ infobash -v3
Host/Kernel/OS "Eyland-1" running Linux 3.4-3.slh.1-aptosid-amd64 x86_64 [ aptosid 2011-03 Πόνος - kde-lite - (201112312100) ]
CPU Info 8x AMD FX-8120 Eight-Core 2048 KB cache flags( sse3 ht nx lm svm ) clocked at [ 1400.000 MHz ]
Videocard NVIDIA G86 [GeForce 8500 GT] X.Org 1.12.1.902 [ 1920x1080@60.0hz ]
Network cards D-Link System Inc DGE-560T PCI Express Gigabit
Processes 163 | Uptime 16:17 | Memory 812.5/7974.0MB | HDD ST32000641AS,WDC WD6000HLHX-0 Size 2600GB (52%used) | GLX Renderer Gallium 0.4 on NV86 | GLX Version Yes | Client Shell | Infobash v3.45
michael@Eyland-1:~$
slh - 22.06.2012, 20:51
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
I think it's safe to call the KDE 4.8.4 upload complete now (yes, some very peripheral packages haven't been uploaded yet, but those don't have a big potential for breakage anymore - if installed in the first place). Make sure to do a full dist-upgrade, before installing/ upgrading individual KDE packages, as doing so might result in packages getting removed or not working properly among the rest of KDE.
Barlafuss - 24.06.2012, 08:27
Post subject: RE: Re: RE: KDE 4.8.4 is coming to sid
done dist-upgrade today, but kde still saying "4.8.3" .
Why? Is it normal?

      Code:
infobash -v3
Host/Kernel/OS  "Obelix" running Linux 3.4-3.slh.1-aptosid-amd64 x86_64 [ aptosid 2011-02 Ἡμέρα - kde-lite - (201107131633) ]
CPU Info        4x Intel Core i5-2400 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 1600.000 MHz ]
Videocard       NVIDIA GF108 [GeForce GT 440]  X.Org 1.12.1.902  [ 1280x1024@60.0hz ]
Network cards   Realtek RTL8111/8168B PCI Express Gigabit

pumrel - 27.06.2012, 18:12
Post subject:
      Code:
Následující balíky budou ODSTRANĚNY:
  aptosid-art-kde aptosid-art-kde-imera aptosid-art-kdm-imera aptosid-art-ksplash-imera aptosid-settings-kde digikam kde-plasma-desktop kde-window-manager kde-workspace kde-workspace-bin
  kdeplasma-addons kdm kipi-plugins libplasmagenericshell4 plasma-dataengines-workspace plasma-desktop plasma-widgets-addons plasma-widgets-workspace


These are going to be removed. Why? Did I do something wrong?

I don't understand why they need to be removed as there are new versions.
      Code:
kdm:
  Instalovaná verze: 4:4.8.3-1
  Kandidát:          4:4.8.3-1
  Vypíchnutý balík: (nenalezeno)
  Tabulka verzí:
     4:4.8.4-2 500
        500 http://ftp.cz.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.cz.debian.org/debian/ wheezy/main amd64 Packages
 *** 4:4.8.3-1 500
        100 /var/lib/dpkg/status
     4:4.4.5-7+squeeze1 500
        500 http://ftp.cz.debian.org/debian/ squeeze/main amd64 Packages

slh - 27.06.2012, 18:39
Post subject:
That shouldn't happen, but you can try to avoid the problem (make sure that you don't hold back any packages!) by:
      Code:
apt-get update
apt-get install aptosid-art-kde aptosid-art-kde-imera aptosid-art-kdm-imera aptosid-art-ksplash-imera aptosid-settings-kde digikam kde-plasma-desktop kde-window-manager kde-workspace kde-workspace-bin kdm plasma-dataengines-workspace plasma-desktop plasma-widgets-addons plasma-widgets-workspace
That will at least help to pinpoint the actual reason, if not already solve it.

You really shouldn't have squeeze (==stable) in your sources.list.
pumrel - 27.06.2012, 21:13
Post subject:
      Code:
root@desktop-aptosid:/home/petr# LANG=en_US apt-get install --simulate  aptosid-art-kde aptosid-art-kde-imera aptosid-art-kdm-imera aptosid-art-ksplash-imera aptosid-settings-kde digikam kde-plasma-desktop kde-window-manager kde-workspace kde-workspace-bin kdm plasma-dataengines-workspace plasma-desktop plasma-widgets-addons plasma-widgets-workspace
Reading package lists... Done
Building dependency tree       
Reading state information... Done
aptosid-art-kde-imera is already the newest version.
aptosid-art-kdm-imera is already the newest version.
aptosid-art-ksplash-imera is already the newest version.
aptosid-settings-kde is already the newest version.
aptosid-art-kde is already the newest version.
kde-workspace-bin is already the newest version.
kde-workspace-bin set to manually installed.
kde-plasma-desktop is already the newest version.
kde-window-manager is already the newest version.
kde-workspace is already the newest version.
kde-workspace set to manually installed.
plasma-widgets-addons is already the newest version.
plasma-widgets-workspace is already the newest version.
plasma-dataengines-workspace is already the newest version.
plasma-desktop is already the newest version.
kdm is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 digikam : Depends: libkipi8 (>= 4:4.8.4) but 4:4.7.4-1 is to be installed
           Depends: libmarblewidget13 (>= 4:4.8.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@desktop-aptosid:/home/petr# dpkg --get-selections | grep hold
mac                                             hold


Sad Not working.
The mac package is my own dummy package that should be harmless.

It keeps saying that all those packages are up to date Evil or Very Mad
slh - 27.06.2012, 21:38
Post subject:
well, iterate further - add libkipi8 and libmarblewidget13 to your install line; digikam installs fine over here.
pumrel - 03.07.2012, 21:48
Post subject:
Now I know why it didn't work like it should have.
I had experimental added in one of my source lists and as is described in the howto for the experimental repo I had also a specific preferences file with pinned packages. When I deleted it with the line for the repository there was no problem anymore.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits