aptosid.com

Software - [solved]dist-upgrade error

apogarte - 04.07.2012, 13:32
Post subject: [solved]dist-upgrade error
hi
i've just finished to du on a system relatively old (last du was beginning of year) and process ended with an error concerning 4.8 kde version
      Quote:


...errors during execution :
/var/cache/apt/archives/konqueror_4%3a4.8.4-1_i386.deb (--unpack)

sub process /usr/bin/dpkg returned an error (1)



after trying to do an "apt-get -f install" wich gave no results

before d-u, system was using kde 4.4.6.5-1 ...

untill now i can still start kde but

-A connexion error message shows up :

"warning cannot open consolekit session : unable to open session : the permission of the setuid helper is not correct"

-After checking the "ok" in message box, the desktop loads but very slowly, and i can see kde version is 4.8.4

-There is no internet connection, and using ceni gives an error :
      Quote:
/sbin/ifup: failed to open statefile /run/network/ifstate: no such file or directory
W: up eth0 failed due to error at /usr/bin/Ceni line 1482


then i mkdir /var/run/network as root, run ceni again, and i have networking ok till next reboot...

is it anyway to correct this ?

thanks for your suggestions,

apog
DonKult - 04.07.2012, 23:01
Post subject: RE: dist-upgrade error
You haven't copied the full error message from dpkg, but i presume it is the following bug in the konqueror packaging: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679789

Anyway, usually these bugs are quickly fixed, yet, this one is marked as pending but not yet uploaded. So you can do by hand what APT and dpkg can't work out (as the information is missing). Or, just wait for the upload …

      Code:
apt-get update
dpkg --configure --pending
dpkg --force-depends --remove kdebase-data
apt-get install --fix-broken
apt-get dist-upgrade

ngong - 08.07.2012, 09:34
Post subject: RE: dist-upgrade error
I can confirm the problem with ceni:

If I boot up in a terminal as root (because an fsck failed) there is no initial eth0 connection. Using ceni led to the same failure as reported by apogarte. At my site it seems not to be related to the bug reported by DonKult.

However the workaround to manually create /run/network works fine.
slh - 08.07.2012, 11:15
Post subject: RE: dist-upgrade error
As part of the /run/ transition, ifupdown moved its state files to /run/. The upgrade process should work fine, but before the actual transition, there was an accidental upload to Debian, which was buggy in that regard. If you were affected by these broken packages, the 'recent' upgrades might have been confused. This should be the correct location, /etc/network/run being a symlink to /run/network
      Code:
$ ls -ld /etc/network/run
lrwxrwxrwx 1 root root 12 Jun 14  2011 /etc/network/run -> /run/network
if yours differs, you'll need to correct it
      Code:
rm -rf /etc/network/run
ln -fs /run/network /etc/network/run
reboot

Ceni is technically not part of this problem, as it just provides a configuration frontend to ifupdown - as long as the configuration is correct, actually making (and keeping up) the network connection is ifupdown's task.
apogarte - 09.07.2012, 09:13
Post subject: Re: RE: dist-upgrade error
      DonKult wrote:
You haven't copied the full error message from dpkg, but i presume it is the following bug in the konqueror packaging: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679789

Anyway, usually these bugs are quickly fixed, yet, this one is marked as pending but not yet uploaded. So you can do by hand what APT and dpkg can't work out (as the information is missing). Or, just wait for the upload …

      Code:
apt-get update
dpkg --configure --pending
dpkg --force-depends --remove kdebase-data
apt-get install --fix-broken
apt-get dist-upgrade


thanks DonKult i'm going to try this. not copied full message since it was in french... so translating to english could be a little unclear ...

also thank you slh for your answer i've done the correction you mentionned, there was effectively no symlink, i have to reboot now will edit later on...

EDIT : OK, everything seems to be fine by now, done the corrections by hand as DonKult suggested, they are applied and dist-upgrade gives no more errors, network runs fine. Thanks for your help !

Very Happy Razz Wink

apog
prp5627 - 10.07.2012, 02:29
Post subject:
Hi!
First cd / var / cache / apt / archives /
Within the directory dpkg-i - force-overwrite konqueror_4%3a4.8.4-1_i386.deb
After apt-get-f install.
Done the above mentioned use the Ctrl + Alt + F2.
Now again dist-upgrade.
I hope this helps.
DonKult - 13.07.2012, 17:58
Post subject:
for the record, prp5627 method works, too, of course, but i prefer to avoid forcing dpkg to do something if there is a way to do it cleanly - even if the clean way is a bit longer. After all, these checks are there for a reason: They are a (thin) protection layer. Probably you can do it without protection and you will be fine, but once in a while no protection will result in a delivery of a new set of problems nine-months later (and just as in the talkshows on TV nobody knows anymore what they have done (with whom) nine-months before…).
roli - 08.08.2012, 16:46
Post subject: Re: [solved]dist-upgrade error
For the records II
      apogarte wrote:
"warning cannot open consolekit session : unable to open session : the permission of the setuid helper is not correct"

On my system this was fixed by
      Code:
dpkg --configure -a

apogarte - 10.08.2012, 11:51
Post subject: Re: [solved]dist-upgrade error
      roli wrote:
For the records II
      apogarte wrote:
"warning cannot open consolekit session : unable to open session : the permission of the setuid helper is not correct"

On my system this was fixed by
      Code:
dpkg --configure -a


thanks again

apog
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits