aptosid.com

Software - [SOLVED] sound stopped after last upgrade

clive - 23.10.2012, 15:52
Post subject: [SOLVED] sound stopped after last upgrade
I upgraded yesterday morning since when sound has stopped working.

dmesg output looks OK
as does lsmod output

The kernel was upgraded to 3.6-3.slh.1-aptosid-686 but the previous kernel now doesn't play sound either (3.6-2.slh.4)

I'm at a bit of a loss as to how to debug this and would be grateful if someone could give me a couple of things to try.

Thanks
piper - 23.10.2012, 18:23
Post subject: RE: Sound stopped after last upgrade
How are your settings in kmix ? Anything muted ?
clive - 23.10.2012, 19:06
Post subject: RE: Sound stopped after last upgrade
I'm using XFCE and the alsamixer/sound settings seem to be fine

Thanks for the thought. Is there anywhere else the sound could be muted?
towo - 24.10.2012, 06:06
Post subject: RE: Sound stopped after last upgrade
cat /proc/asound/cards

And for checking volume-settings, use alsamixer instead of the graphical tools.
clive - 24.10.2012, 06:31
Post subject: RE: Sound stopped after last upgrade
:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfebfc000 irq 46


//edit by DonKult: removed double posts so that the thread can continue naturally - and yes, this SMTP error goes on my nerves, too, and is quiet confusing.
towo - 24.10.2012, 10:06
Post subject: RE: Sound stopped after last upgrade
Your Card is up and running.
So have you checked the mixer settings with alsamixer?
Do you have maybe pulseaudio installed?

dpkg -l | grep pulseaudio
clive - 24.10.2012, 21:18
Post subject: RE: Sound stopped after last upgrade
Yes it is, as is aumix:


ii gstreamer0.10-pulseaudio:i386 0.10.31-3 i386 GStreamer plugin for PulseAudio
ii pulseaudio 2.0-6 i386 PulseAudio sound server
ii aumix 2.9.1-2 i386 Simple text-based mixer control program
ii aumix-common 2.9.1-2 all Simple text-based mixer control program (common files)

Should I remove them?
towo - 25.10.2012, 05:23
Post subject: RE: Sound stopped after last upgrade
apt-get purge pulseaudio
clive - 25.10.2012, 08:03
Post subject: RE: Sound stopped after last upgrade
SOLVED - Thanks, that did it Smile
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits