aptosid.com

Upgrade Warnings - (solved) hang during boot at 5s mark - udev issue?

browe - 30.06.2013, 14:44
Post subject: (solved) hang during boot at 5s mark - udev issue?
After recent d-u system hangs for about 60s at the 5s mark. Let me know if more info is required. Might be a video driver issue or a setting I'm not aware of. Any suggestions to speed boot are appreciated.

Here's infobash and dmesg:

http://pastebin.ca/2412908
browe - 30.06.2013, 15:06
Post subject: RE: hang during boot at 5s mark - udev issue?
Removing oss-compat fixed things... went from a 82s boot back to a 25s boot.
piper - 30.06.2013, 17:23
Post subject: RE: hang during boot at 5s mark - udev issue?
oss-compat seems to be causing a lot of problems for people these days
DeepDayze - 02.07.2013, 16:02
Post subject: Re: RE: hang during boot at 5s mark - udev issue?
      piper wrote:
oss-compat seems to be causing a lot of problems for people these days


Yes its broken, and it isn't really necessary except for old apps and soundcards
spock - 03.07.2013, 09:56
Post subject: Re: RE: hang during boot at 5s mark - udev issue?
      DeepDayze wrote:
      piper wrote:
oss-compat seems to be causing a lot of problems for people these days


Yes its broken, and it isn't really necessary except for old apps and soundcards


One of those programs which depends on oss-compat is an olde ASCII graphics demo called bb, which I didn't know I had installed, so I ran it before removing oss-compat. It rocks! Cool If you'd enjoy being transported back to a Golden Age of computing for 10 minutes, it's well worth installing bb (and oss-compat) just to watch once, before purging both again to avoid problems with your aptosid install. I guess this software is so old that it might never get fixed. Shame Sad

Exclamation WARNING: I'm not an aptosid Team Member and this is not advice to be followed unless you promise not to forget to remove oss-compat again (using apt-get purge oss-compat) immediately (before rebooting), as it might break your system. Exclamation
DonKult - 03.07.2013, 18:55
Post subject: Re: RE: hang during boot at 5s mark - udev issue?
      spock wrote:
… One of those programs which depends on oss-compat is an olde ASCII graphics demo called bb, which … rocks! Cool If you'd enjoy being transported back to a Golden Age of computing for 10 minutes, it's well worth installing bb …

bb was the reason why oss-compat was installed on one of my (old) machines. Its cool, I love it Smile

I guess the fixable point here is that oss-compat neads to be fixed to do what it is supposed to do without silly waiting. It did it for years, I assume it will do it again after bug #660803 is fixed …


Some mediaplayer have a 'aa' or 'caca' video-output available btw. I haven't found a video I would like to watch this way though. These picture-videos are not as well designed as the ascii-video bb is Wink
browe - 05.07.2013, 21:11
Post subject: RE: Re: RE: hang during boot at 5s mark - udev issue?
Sometimes it takes breakage like this to discover old cruft on the system. I'm sure that most users of aptosid like to keep a clean system free of unnecessary programs like this. Whenever I do an upgrade I keep an eye on what's being updated and investigate anything that looks like it's not required.... as well as any associated libs.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits