aptosid.com

Software - update-flashplugin-nonfree --install doesn't work

alexk - 04.06.2016, 17:47
Post subject: update-flashplugin-nonfree --install doesn't work
"update-flashplugin-nonfree --install" hasn't been able to retrieve the latest 11.2.202.621 version of the plugin for me. I had to retrieve it from https://get.adobe.com/flashplayer/otherversions/ and install it manually. "update-flashplugin-nonfree --status" had been reporting the more recent 621 version available, but it wouldn't install:
      Code:
update-flashplugin-nonfree --status         
Flash Player version installed on this system  : 11.2.202.616
Flash Player version available on upstream site: 11.2.202.621
flash-mozilla.so - auto mode
  link best version is /usr/lib/flashplugin-nonfree/libflashplayer.so
  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
  link flash-mozilla.so is /usr/lib/mozilla/plugins/flash-mozilla.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
/usr/lib/gnash/libgnashplugin.so - priority 10
/usr/lib/lightspark/liblightsparkplugin.so - priority 0

# update-flashplugin-nonfree --verbose --install   
options :  --verbose --install --
temporary directory: /tmp/flashplugin-nonfree.FEwpY50uYM
importing public key ...
selected action = --install
installed version = 11.2.202.616
upstream version = 11.2.202.621
wgetoptions= -nd -P .   -v --progress=dot:default
downloading http://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.11.2.202.621.sha512.amd64.pgp.asc ...
URL transformed to HTTPS due to an HSTS policy
--2016-06-04 13:25:30--  https://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.11.2.202.621.sha512.amd64.pgp.asc
Resolving people.debian.org (people.debian.org)... 5.153.231.30, 2001:41c8:1000:21::21:30
Connecting to people.debian.org (people.debian.org)|5.153.231.30|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-06-04 13:25:31 ERROR 404: Not Found.

wget failed to download http://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.11.2.202.621.sha512.amd64.pgp.asc
downloading http://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp10.sha512.amd64.pgp.asc ...
URL transformed to HTTPS due to an HSTS policy
--2016-06-04 13:25:31--  https://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp10.sha512.amd64.pgp.asc
Resolving people.debian.org (people.debian.org)... 5.153.231.30, 2001:41c8:1000:21::21:30
Connecting to people.debian.org (people.debian.org)|5.153.231.30|:443... connected.                                           
HTTP request sent, awaiting response... 200 OK                                                                               
Length: 1250 (1.2K) [text/plain]                                                                                             
Saving to: ‘./fp10.sha512.amd64.pgp.asc’                                                                                     
                                                                                                                             
     0K .                                                     100% 29.0M=0s                                                   
                                                                                                                             
2016-06-04 13:25:31 (29.0 MB/s) - ‘./fp10.sha512.amd64.pgp.asc’ saved [1250/1250]                                             
                                                                                                                             
verifying PGP fp10.sha512.amd64.pgp.asc ...                                                                                   
copying /var/cache/flashplugin-nonfree/install_flash_player_11_linux.x86_64.tar.gz ...                                       
verifying checksum install_flash_player_11_linux.x86_64.tar.gz ...                                                           
wgetoptions= -nd -P .   -v --progress=dot:default  -O /tmp/flashplugin-nonfree.FEwpY50uYM/install_flash_player_11_linux.x86_64.tar.gz                                                                                                                       
downloading https://fpdownload.adobe.com/get/flashplayer/pdc/11.2.202.616/install_flash_player_11_linux.x86_64.tar.gz ...     
verifying checksum install_flash_player_11_linux.x86_64.tar.gz ...                                                           
unpacking install_flash_player_11_linux.x86_64.tar.gz ...                                                                     
verifying checksum contents of install_flash_player_11_linux.x86_64.tar.gz ...
moving libflashplayer.so to /usr/lib/flashplugin-nonfree ...
setting permissions and ownership of /usr/lib/flashplugin-nonfree/libflashplayer.so ...
Flash Player version: 11.2.202.616
moving install_flash_player_11_linux.x86_64.tar.gz to /var/cache/flashplugin-nonfree ...
flash-mozilla.so - auto mode
  link best version is /usr/lib/flashplugin-nonfree/libflashplayer.so
  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
  link flash-mozilla.so is /usr/lib/mozilla/plugins/flash-mozilla.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
/usr/lib/gnash/libgnashplugin.so - priority 10
/usr/lib/lightspark/liblightsparkplugin.so - priority 0
calling update-alternatives ...
flash-mozilla.so - auto mode
  link best version is /usr/lib/flashplugin-nonfree/libflashplayer.so
  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
  link flash-mozilla.so is /usr/lib/mozilla/plugins/flash-mozilla.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
/usr/lib/gnash/libgnashplugin.so - priority 10
/usr/lib/lightspark/liblightsparkplugin.so - priority 0
removing /usr/bin/flash-player-properties
removing /usr/share/applications/flash-player-properties.desktop
removing /usr/share/icons/hicolor/16x16/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/22x22/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/24x24/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png
removing /usr/share/icons/hicolor/48x48/apps/flash-player-properties.png
removing /usr/share/pixmaps/flash-player-properties.png
installing /usr/bin/flash-player-properties
installing /usr/share/applications/flash-player-properties.desktop
installing /usr/share/icons/hicolor/16x16/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/22x22/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/24x24/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png
installing /usr/share/icons/hicolor/48x48/apps/flash-player-properties.png
installing /usr/share/pixmaps/flash-player-properties.png
end of action --install
cleaning up temporary directory /tmp/flashplugin-nonfree.FEwpY50uYM ...
end of update-flashplugin-nonfree

slh - 05.06.2016, 19:45
Post subject: RE: update-flashplugin-nonfree --install doesn
Disclaimer, I've never used flashplugin-nonfree myself and don't really want to dive into the topic either, but, as far as I understand the situation:

The flashplugin-nonfree downloader package requests a package signature from its maintainer in order to verify and secure the download (trying to avoid man in the middle attacks). For this to work, the maintainer actually has to provide the signature for each supported flashplugin version. Quite obviously this hasn't happened for 11.2.202.621 yet, so the download is rejected as unverified.

In other words, each new version needs explicit manual interaction (a signature) from the flashplugin-nonfree maintainer, if he/ she hasn't gotten to it yet (work, vacation, travelling, hospital/ illness, bored, run-over-by-a-bus, yada, yada) it's just not available for assisted updating via flashplugin-nonfree.
Luis_P - 10.06.2016, 18:48
Post subject:
Now you can get the version 11.2.202.621 through update-flashplugin-nonfree --install. The issue has been solved.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits