aptosid.com

Upgrade Warnings - Cannot log into KDE after DU

arwa - 20.10.2010, 15:34
Post subject: Cannot log into KDE after DU
Hello,

I did a dist-upgrade of a remote machine and wanted to log into KDE4 remotely via x11vnc and krdc on kdm. I did this several times on former dist-upgrades already and it usually works fine.

Now kdm starts up and I can connect the remote Xorg via vnc. When logging in on the remote kdm I see the switch to the splash-screen graphics but before the first icon appears, the vnc-connection shuts down. I think kdm jumps back to the login prompt.

I did check the log files on the remote system and all I found was:
~/.xsession-errors
      Code:
Xsession: X session started for arwa at Mi 20. Okt 17:13:20 CEST 2010
startkde: Starting up...
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_klauncher.so
kdeinit4: (klauncher /usr/lib/kde4/libexec/klauncher) Pipe closed unexpectedlykdeinit4: Pipe closed unexpectedly: No such file or directory
No protocol specified
kdeinit4: Can not connect to the X Server.
kdeinit4: Might not terminate at end of session.
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
kdeinit4: (kded4 /usr/bin/kded4) Pipe closed unexpectedlykdeinit4: Pipe closed unexpectedly: No such file or directory
kdeinit4: preparing to launch /usr/lib/kde4/libkdeinit/libkdeinit4_kcminit_startup.so
kdeinit4: (kcminit_startup /usr/bin/kcminit_startup) Pipe closed unexpectedlykdeinit4: Pipe closed unexpectedly: No such file or directory
kdeinit4: Communication error with launcher. Exiting!


In the /var/log/kdm.log there is only a warning at startup of kdm:
      Code:
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.23-dsa-ia32 i686 Debian
Current Operating System: Linux cinzano 2.6.35-7.slh.5-aptosid-686 #1 SMP PREEMPT Wed Oct 20 03:27:00 UT
C 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-7.slh.5-aptosid-686 root=UUID=147c0386-9736-472e-a368-6f837e3c4092 ro quiet vga=791 quiet
Build Date: 10 October 2010  11:57:07AM
xorg-server 2:1.7.7-8 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 20 17:13:23 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
SELinux: Disabled on system, not enabling in X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'


The Xorg.0.log does not show any warnings or errors.

When trying to start X remotely without kdm by "startx -- :1" I just get the message "X: user not authorized to run the X server, aborting.". As I never did this remotely, I am not sure if this is a problem or just a misconfiguration of ssh or something.

As I do not know if this is a special issue with the remote stuff or if the problem might happen on local machines, too, this report is just a warning and maybe not a real error report.

arwa
arwa - 20.10.2010, 15:45
Post subject: RE: Cannot log into KDE after DU
Ok, after many tries with init 3 && init 5 and logging in with broken connections I gave this a last chance and tried it again. Guess what, everything was fine!? I do not understand it, but I could log in now. Hmmm. So I mark this as solved, ok? Seems to be a special case.
gangsta - 21.10.2010, 12:41
Post subject: RE: Cannot log into KDE after DU
This is very strange. I logged into KDE with new kernel only the fifth time Shocked And now it is ok.
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits