aptosid.com

Hardware - wifi problem

beppe_rm - 27.01.2011, 22:14
Post subject: wifi problem
hi friends,

my wifi connection works with usb antenna, because of the internal one is broken;
well, wifi network works well, I tested it with another laptop, but my connection usually falls every about 20 minutes; could you suggest why? do I have to edit something?
many thanks

beppe
devil - 28.01.2011, 12:08
Post subject: RE: wifi problem
hi friend,
my car is broken. it runs on diesel. any help?

greetz
devil
ToZ - 28.01.2011, 13:09
Post subject: RE: wifi problem
@beppe_rm, you will need to provide more information for someone to be able to assist. You can start with:

- make/model of wireless card
- result of 'infobash -v3'
- contents of /etc/network/interfaces file
- any relevant content from the command 'dmesg'
beppe_rm - 31.01.2011, 22:39
Post subject: RE: wifi problem
thanks ToZ.

- make/model of wireless card
digicom
8E4442
usb wave 300c

- result of 'infobash -v3'
oot@laptop-giulia:/home/peppino# infobash -v3
Host/Kernel/OS "laptop-giulia" running Linux 2.6.37-0.slh.14-aptosid-686 i686 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]
CPU Info (1) AMD Turion 64 X2 Mobile TL-50 256 KB cache flags( sse3 ht nx lm svm ) clocked at [ 1600.000 MHz ]
(2) AMD Turion 64 X2 Mobile TL-50 256 KB cache flags( sse3 ht nx lm svm ) clocked at [ 1600.000 MHz ]
Videocard nVidia C51 [GeForce Go 6100] [ ]
Network cards nVidia MCP51
Ralink 802.11 n WLAN
Processes 129 | Uptime 4min | Memory 330.1/945.6MB | HDD ST9120822AS Size 120GB (72%used) | Client Shell | Infobash v3.34
root@laptop-giulia:/home/peppino#

- contents of /etc/network/interfaces file
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
# The loopback network interface
auto lo
iface lo inet loopback
allow-hotplug eth0
iface eth0 inet dhcp
allow-hotplug wlan1
iface wlan1 inet dhcp
wpa-psk *************
wpa-ssid Hogwarts

- any relevant content from the command 'dmesg'. this is the end:
[ 17.889012] eth0: no link during initialization.
[ 17.889821] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 18.072487] NET: Registered protocol family 17
[ 19.147483] Bluetooth: Core ver 2.15
[ 19.147516] NET: Registered protocol family 31
[ 19.147519] Bluetooth: HCI device and connection manager initialized
[ 19.147523] Bluetooth: HCI socket layer initialized
[ 19.229885] Bluetooth: L2CAP ver 2.15
[ 19.229890] Bluetooth: L2CAP socket layer initialized
[ 19.332239] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 19.332244] Bluetooth: BNEP filters: protocol multicast
[ 19.573860] lp: driver loaded but no devices found
[ 19.643914] Bluetooth: RFCOMM TTY layer initialized
[ 19.643921] Bluetooth: RFCOMM socket layer initialized
[ 19.643924] Bluetooth: RFCOMM ver 1.11
[ 19.647285] Bluetooth: SCO (Voice Link) ver 0.6
[ 19.647289] Bluetooth: SCO socket layer initialized
[ 19.728312] ppdev: user-space parallel port driver
[ 19.905431] wlan1: authenticate with 00:14:c1:39:aa:15 (try 1)
[ 19.907946] wlan1: authenticated
[ 19.912932] wlan1: associate with 00:14:c1:39:aa:15 (try 1)
[ 19.915312] wlan1: RX AssocResp from 00:14:c1:39:aa:15 (capab=0x411 status=0 aid=1)
[ 19.915315] wlan1: associated
[ 19.923843] ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 20.249687] padlock: VIA PadLock not detected.
[ 22.724058] powernow-k8: Found 1 AMD Turion(tm) 64 X2 Mobile Technology TL-50 (2 cpu cores) (version 2.20.00)
[ 22.724104] powernow-k8: 0 : fid 0x8 (1600 MHz), vid 0x13
[ 22.724108] powernow-k8: 1 : fid 0x0 (800 MHz), vid 0x1e
[ 23.501052] Clocksource tsc unstable (delta = -246511857 ns)
[ 30.450051] wlan1: no IPv6 routers present
[ 176.676274] start_kdeinit (2314): /proc/2316/oom_adj is deprecated, please use /proc/2316/oom_score_adj instead.
[ 184.374012] CE: hpet increased min_delta_ns to 11520 nsec
[ 829.180628] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
root@laptop-giulia:/home/peppino#

(sorry, which is the command to restart wifi without reastarting computer?)
slh - 31.01.2011, 22:44
Post subject: RE: wifi problem
http://sidux.com/index.php?name=PNphpBB2&file=viewtopic&t=20817
beppe_rm - 02.02.2011, 17:11
Post subject: RE: wifi problem
thanks slh.
mmhhhh .....sorry, what I have to do with "rt2870.bin"?
belze - 02.02.2011, 19:41
Post subject: RE: wifi problem
rt2870sta with recent kernels works quite well, just blacklist rt2800usb and others.
slh - 02.02.2011, 23:38
Post subject: RE: wifi problem
We support rt2800pci/ rt2800usb, no staging or vendor drivers, which in case of rt2860sta/ rt2870sta are utterly broken.
pinguin - 03.02.2011, 22:09
Post subject: Re: RE: wifi problem
      slh wrote:
We support rt2800pci/ rt2800usb, no staging or vendor drivers, which in case of rt2860sta/ rt2870sta are utterly broken.

apologize me, slh, but what it means?
aptosid kernel > 2.6.33 and rt3090 can't work together, because of this issue
http://www.aptosid.com/index.php?name=P ... highlight=
so, please slh, give support also to rt2860sta, it could be broken but it's the only workaround, seen that also rt2800pci seems to have a bug https://dev.openwrt.org/browser/branche ... ?rev=23107
lefaroth - 03.05.2011, 22:39
Post subject:
just in case someone needs this desperately..

1) the 'sta' drivers were removed after 2.6.35 kernel
2) rt2x00usb totally sucks at my alpha usb n wifi card
3) the driver from the ralink site cannot compile with 2.6.37 and up kernel versions due to 2 changes:
usb_buffer_alloc() was renamed to usb_alloc_coherent()
usb_buffer_free() was renamed to usb_free_coherent()

so these have to change for a successful compilation at the following 2 files:

include/os/rt_linux.h and os/linux/rt_usb_util.c

after making the following changes, the driver would compile successfully Smile

you can follow one of the many guides to install the sta drivers for example:

http://www.cyberciti.biz/tips/linux-ins ... apter.html

or similar ones
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits