aptosid.com

User Scripts & Dragons - KDE SC 4.6 (UNOFFICIAL & UNSUPPORTED!!!)

BlueJayofEvil - 15.09.2010, 19:18
Post subject: KDE SC 4.6 (UNOFFICIAL & UNSUPPORTED!!!)
Update: I made a few minor tweaks to this guide to (hopefully) avoid some confusion. This guide works for KDE SC 4.6 (and should for any future KDE developments hosted in the repo it uses.) I tried this on a fresh install (and completely dist-upgraded.)

This is an unofficial, unsupported how-to for those who wish to try KDE SC 4.6.x on their systems. Do not try this unless you know what you are doing!
This how-to uses a third-party repo found at http://qt-kde.debian.net



Step 1
Add these lines to a .list file in /etc/apt/sources.list.d/
(e.g. /etc/apt/sources.list.d/kde.list)
      Code:
deb http://qt-kde.debian.net/debian experimental-snapshots main
deb-src http://qt-kde.debian.net/debian experimental-snapshots main


Step 2
      Code:
apt-get update

and then
      Code:
apt-get install pkg-kde-archive-keyring

then
      Code:
apt-get update


Step 3
Create or edit the /etc/apt/preferences file and add the following entries:
      Code:
Package: *
Pin: release a=unstable
Pin-Priority: 900

Package: *
Pin: release o=qt-kde,a=experimental-snapshots
Pin-Priority: 901


Step 4
Change to runlevel 3
      Code:
init 3

and then log in as root.

Step 5
      Code:
apt-get dist-upgrade

Check the list of packages to be installed, upgraded, and/or removed. If you agree with what it wants to do, confirm the upgrade.

Step 6
Either reboot or go back to runlevel 5.
You should now have KDE SC 4.6.x on your system.
DeepDayze - 16.09.2010, 01:06
Post subject: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)
Good write up for all who want to play with KDE SC 4.5.1

I have it installed and so far no major issues and it's pretty decent
belze - 16.09.2010, 11:48
Post subject: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)
2 days with it and my cat is still alive!
DeepDayze - 16.09.2010, 16:51
Post subject: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)
      belze wrote:
2 days with it and my cat is still alive!


That's good to hear Smile
Lanzi - 16.09.2010, 17:20
Post subject: RE: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)
What about digikam and Gwenvies. Are theese upgraded as well? in Sid is still digicam 1.2
devil - 16.09.2010, 17:58
Post subject: RE: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)
digicam is, no idea on gwenview.
the cat sits on the notebook with 4.5, so i cant check now Smile

greetz
devil
dexterus - 17.09.2010, 00:02
Post subject: RE: Re: RE: KDE SC 4.5 (UNOFFICIAL & UNSUPPORTED!!!)
Here's what I get:
      Code:

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  aptosid-art-kde aptosid-art-kde-keres aptosid-art-ksplash-keres
  aptosid-settings-kde kappfinder kde-minimal kde-window-manager 
  kdebase-workspace kdebase-workspace-bin libkephal4 libkonq5
  libplasmaclock4a libprocesscore4a libsolidcontrol4 libsolidcontrolifaces4
  libtaskmanager4a plasma-desktop plasma-widget-adjustableclock
  sidux-art-kde sidux-art-kde-moros sidux-art-ksplash-moros
  sidux-settings-kde
The following NEW packages will be installed:
  akonadi-backend-mysql docbook-xml freespacenotifier libcln6
  libdbusmenu-qt2 libkatepartinterfaces4 libkcmutils4 libkemoticons4
  libkephal4a libkidletime4 libkonq5a libkprintutils4 libplasmaclock4b
  libprocesscore4b libqalculate5 libsolidcontrol4a libsolidcontrolifaces4a
  libtaskmanager4b sgml-base sgml-data xml-core
The following packages will be upgraded:
  akonadi-server ark dolphin gwenview kate kcalc
  kdebase-apps kdebase-bin kdebase-data kdebase-runtime
  kdebase-runtime-data kdebase-workspace-data
  kdebase-workspace-kgreet-plugins kdegraphics-libs-data
  kdelibs-bin kdelibs5 kdelibs5-data kdelibs5-dev kdelibs5-plugins
  kdepasswd kdepimlibs-kio-plugins kdepimlibs5 kdm kdoctools kfind
  khelpcenter4 klipper konqueror konqueror-nsplugins konsole kppp
  ksnapshot ksysguard ksysguardd ktorrent kwrite libakonadi-contact4
  libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadiprivate1 libgpgme++2 libkabc4 libkblog4 libkcal4
  libkde3support4 libkdecorations4 libkdecore5 libkdesu5 libkdeui5
  libkdewebkit5 libkdnssd4 libkfile4 libkholidays4 libkhtml5 libkimap4
  libkimproxy4 libkio5 libkipi7 libkjsapi4 libkjsembed4 libkldap4
  libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkonq5-templates libkonqsidebarplugin4a
  libkontactinterface4 libkparts4 libkpimidentities4 libkpimtextedit4
  libkpimutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4 libksane0
  libkscreensaver5 libksgrd4 libksignalplotter4 libktexteditor4 libktnef4
  libkunitconversion4 libkutils4 libkwineffects1a libkworkspace4
  libkxmlrpcclient4 libmailtransport4 libmicroblog4 libnepomuk4
  libnepomukquery4a libokularcore1 libplasma-geolocation-interface4
  libplasma3 libplasmagenericshell4 libprocessui4a libqgpgme1 libsolid4
  libsyndication4 libthreadweaver4 libweather-ion4a okular
  oxygen-icon-theme plasma-dataengines-workspace
  plasma-desktopthemes-artwork plasma-scriptengine-javascript
  plasma-widget-folderview plasma-widgets-workspace systemsettings
113 upgraded, 21 newly installed, 22 to remove and 0 not upgraded.

Something tells me it would be not a good idea to proceed. Am I right? Thanks in advance. Smile
dibl - 17.09.2010, 11:26
Post subject:
Here's what I saw:

      Code:
root@sidbox:/home/dibl# apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  kappfinder libkephal4 libkonq5 libplasmaclock4a libprocesscore4a libsolidcontrol4 libsolidcontrolifaces4 libtaskmanager4a
The following NEW packages will be installed:
  akonadi-backend-mysql freespacenotifier libcln6 libdbusmenu-qt2 libkatepartinterfaces4 libkcmutils4 libkdewebkit5 libkemoticons4
  libkephal4a libkidletime4 libkonq5a libkprintutils4 libplasmaclock4b libprocesscore4b libqalculate5 libsolidcontrol4a
  libsolidcontrolifaces4a libtaskmanager4b
The following packages will be upgraded:
  akonadi-server ark dolphin foomatic-db-engine foomatic-filters foomatic-filters-ppds gwenview kate kcalc kde-window-manager
  kdebase-apps kdebase-bin kdebase-data kdebase-runtime kdebase-runtime-data kdebase-workspace kdebase-workspace-bin
  kdebase-workspace-data kdebase-workspace-kgreet-plugins kdegraphics-libs-data kdegraphics-strigi-plugins kdelibs-bin kdelibs5
  kdelibs5-data kdelibs5-plugins kdenetwork-filesharing kdepasswd kdepimlibs-kio-plugins kdepimlibs5 kdm kdoctools kfind
  khelpcenter4 kinfocenter klipper konqueror konsole kppp ksnapshot ksysguard ksysguardd ksystemlog kwrite libakonadi-kabc4
  libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libakonadiprivate1 libgpgme++2 libkabc4 libkblog4 libkcal4 libkdcraw8
  libkde3support4 libkdecorations4 libkdecore5 libkdesu5 libkdeui5 libkdnssd4 libkexiv2-8 libkfile4 libkholidays4 libkhtml5
  libkimap4 libkimproxy4 libkio5 libkipi7 libkjsapi4 libkjsembed4 libkldap4 libkmediaplayer4 libkmime4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq5-templates libkonqsidebarplugin4a libkparts4 libkpimidentities4
  libkpimtextedit4 libkpimutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4 libksane0 libkscreensaver5 libksgrd4
  libksignalplotter4 libktexteditor4 libktnef4 libkunitconversion4 libkutils4 libkwineffects1a libkworkspace4 libkxmlrpcclient4
  libmailtransport4 libmicroblog4 libnepomuk4 libnepomukquery4a libokularcore1 libplasma-geolocation-interface4 libplasma3
  libplasmagenericshell4 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libprocessui4a libqgpgme1 libsolid4
  libsyndication4 libthreadweaver4 libweather-ion4a okteta okular okular-extra-backends oxygen-icon-theme
  plasma-dataengines-workspace plasma-desktop plasma-desktopthemes-artwork plasma-scriptengine-javascript plasma-widget-folderview
  plasma-widgets-workspace policykit-1 systemsettings                                                                               
126 upgraded, 18 newly installed, 8 to remove and 0 not upgraded.                                                                   
Need to get 145MB of archives.                                                                                                       
After this operation, 44.0MB disk space will be freed.                                                                               
Do you want to continue [Y/n]


It seems to have installed with no issues. Desktop settings all remain untouched, compiz and conky work as expected, very nice!

Thanks BlueJayofEvil!
DeepDayze - 17.09.2010, 15:37
Post subject:
kappfinder has been removed from KDE 4.5.x according to upstream as I inquired about it, and the other packages that were removed were replaced with new versions.
d.v.e. - 18.09.2010, 15:33
Post subject:
Upgrade done , all good Very Happy
merlyn - 18.09.2010, 23:30
Post subject:
I've installed this on my desktop system but will hold off installing it on my laptop for now.

Reasons so far being, (I've yet to spend a good deal of time with it).

1. Not so keen on the new layout of system settings, it's a little disjointed and cluttered to my way of thinking, the 4.4.x layout is a lot cleaner imho.

2. Not a big fan of the monochrome systray icons, the new 'info' icon is barely visible (except the highlights) on dark themes, scissors for klipper, ( = "cut" in my book).

2a. as the monochrome icons apply only to system/hardware 'utilities' and the tooltips still display the 'old colourful icons', (to date) it introduces visual inconsistencies.

Obviously the above points are purely subjective, (based on personal tastes), and other folks will be happy with the changes.

Other than that I'm happy with 4.5.x, and the upgrade path went smoothly.
devil - 18.09.2010, 23:37
Post subject:
i would be happy with all monochrome icons and look forward for the other sections to follow.
i heard you can get the colourful ones back though, but didnt bother myself.

greetz
devil
kap4lin - 19.09.2010, 02:43
Post subject:
Anyone who upgraded to 4.5.1 with nvidia card and using the binary drivers? Any issues there?
ghstryder - 19.09.2010, 03:57
Post subject:
      kap4lin wrote:
Anyone who upgraded to 4.5.1 with nvidia card and using the binary drivers? Any issues there?


7150M and current binary driver. No issues here.
DeepDayze - 19.09.2010, 04:34
Post subject:
No issues here with latest nVidia binary driver as well
dibl - 19.09.2010, 13:29
Post subject:
I see no graphics-related issues on my platform with Nvidia driver 260.19.04, but I noticed the power management settings do not recognize my CPU correctly (-11, -12, and -15 kernels). System-settings > power management > capabilities shows Number of CPUs = 0, and no mention of frequency scaling. But the other items (DPMS support, ConsoleKit, and Status) have green checkmarks.

On boot, my CPU comes up at half speed. In the terminal I issue
      Code:
service cpufreqd start
and I get full speed, but no scaling.

Is there a better way to invoke frequency scaling?

      Code:
dibl@sidbox:~$ infobash -v3
Host/Kernel/OS  "sidbox" running Linux 2.6.35-4.slh.15-aptosid-amd64 x86_64 [ sidux 2009-03 Μώμος - kde-lite - (200911110039) ]
CPU Info        (1) Intel Core2 X6800 @ 4096 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2926.000 MHz ]
                (2) Intel Core2 X6800 @ 4096 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2926.000 MHz ]
Videocard       nVidia GT200 [GeForce GTX 260]  X.Org 1.7.7  [ 1600x1200@50.0hz ]
Network cards   Intel 82573L Gigabit
Processes 159 | Uptime 21min | Memory 591.8/3964.8MB | HDD WDC WD1002FBYS-0,WDC WD7500AAKS-0,WDC WD1500AHFD-0 Size 1900GB (47%used) | GLX Renderer GeForce GTX 260/PCI/SSE2 | GLX Version 3.3.0 NVIDIA 260.19.04 | Client Shell | Infobash v3.34

Lanzi - 19.09.2010, 14:45
Post subject:
@BlueJayofEvilOffline

Is this a typo:

      Quote:
Package: *
Pin: release o=qt-kde,a=experimental-snapshots
Pin-Priority: 101


With "Pin-Priority: 101" nothing happes. It should maybe be 1001?
kap4lin - 19.09.2010, 15:07
Post subject:
@ ghstryder, DeepDayze: Good to know. Do you use the sid 195.36.xx or the experimental 256.xx drivers? Do you or anyone have a dual monitor setup?
DeepDayze - 19.09.2010, 15:12
Post subject:
I been using the 260.xx beta drivers as installed by a 3rd party script we know well. Don't have a dual monitor setup atm.
Lanzi - 19.09.2010, 16:22
Post subject:
@Devil
      Quote:

digicam is, no idea on gwenview.


No it is not. I made a testinstall, and it is still in Version 1.2.
The Problem is, taht it does not play mov files (imediate crash of Digicam) of my Canon DSLR. The rest of the Digicamfilms is divided in two parts, the upper normal, the donside green.

So, is there any chance to get digicam 1.4?
ghstryder - 19.09.2010, 17:04
Post subject:
      kap4lin wrote:
@ ghstryder, DeepDayze: Good to know. Do you use the sid 195.36.xx or the experimental 256.xx drivers? Do you or anyone have a dual monitor setup?


I'm using the 195.36.xx drivers installed using the directions supplied in the aptomanual. I don't use dual monitors, but I did test it with a large CRT monitor attached and it worked just fine.
merlyn - 19.09.2010, 20:12
Post subject:
      devil wrote:
i would be happy with all monochrome icons and look forward for the other sections to follow.
i heard you can get the colourful ones back though, but didnt bother myself.

greetz
devil


I wouldn't mind if all the icons were monochrome either, my main bugbear with this is consistency.

However as the tooltip icons do not follow the changes made with the introduction of monochrome icons, the implementation seems rushed and incomplete.

Also given what has been posted on the KDE forums though I don't think this is going to happen. The push behind the monochrome icons is to differentiate between 'system space' or plasma & 'user space' or applications.

Perhaps that same reasoning is behind the new 'System settings' layout.

Frankly, I found the previous layout more streamlined, and the grouping logical.

Not in keeping with the usual standard of polish and 'elegance' that I've become accustomed to with KDE.

Restoring the colourful icons, requires a little bit of mucking around, and would need to be done each time the associated packages are updated. Thus a pain in the posterior.

Getting back to the monochrome icons thought.

1. Portions of the new notification icon tends to blend in with both light and dark backgrounds, making it less visible.

2. The use of 'scissors' to represent the clipboard (klipper), seems a poor choice as scissors are associated with the "cut" function in word processing applications and many (gui based) text editors. The clipboard's functionality is not 'limited' to just 'cutting'

3. The new device icon resembles the "USB" symbol, thus suggesting that USB devices are only detected, what of Firewire, Optical drives, Card Readers etc.

Each of these points raise usability issues imo.

Overall I don't believe that the new iconset has been well thought out, and it's introduction premature.
Lanzi - 19.09.2010, 21:45
Post subject:
You know what really bugs me on KDE 4.5?

In Krusader, copying a lot of files for backup-reasons, you could until now decide between "overwirte file" and "overwrite all". Now there is a checkbox "apply to all" and then you click overwrite. Its (another) click more (like for such a lot of applications in KDE4), but also you have to find a really small field, instead of a switch before.
This is really annoying clicking twice!
spacepenguin - 26.09.2010, 16:19
Post subject:
Lanzi, that is not only krusader, same in dolphin. I agree, a button is better than a switch. How about a bugs.kde.org wishlist entry?

BTW: My KDE SC 4.5.1 was relatively slow and unstable, especially dolphin that crashed a lot times a day. I have now dared to install the dbus and libdbus-1-3 packages from experimental (own risk) and dolphin is more responsive and a lot more stable. Improves KDE 4.5.1 feeling a lot. http://randomguy3.wordpress.com/2010/06 ... ng-issues/

Nvidia: I keep on using the 195.36.xx drivers as long as possible because kuickshow doesn't work anymore with the 26x driver (displays only garbage).
DeepDayze - 26.09.2010, 18:40
Post subject:
      spacepenguin wrote:
Lanzi, that is not only krusader, same in dolphin. I agree, a button is better than a switch. How about a bugs.kde.org wishlist entry?

BTW: My KDE SC 4.5.1 was relatively slow and unstable, especially dolphin that crashed a lot times a day. I have now dared to install the dbus and libdbus-1-3 packages from experimental (own risk) and dolphin is more responsive and a lot more stable. Improves KDE 4.5.1 feeling a lot. http://randomguy3.wordpress.com/2010/06 ... ng-issues/

Nvidia: I keep on using the 195.36.xx drivers as long as possible because kuickshow doesn't work anymore with the 26x driver (displays only garbage).


As I been also troubled by the dolphin issues in KDE SC 4.5.1 I shall try installing those dbus/libdbus packages myself. Thanks for the tip!

EDIT: I installed the experimental dbus packages on both KDE 4.4.5 and KDE 4.5.1 and dolphin seemed a lot smoother and more stable. Will try copying/moving files around in dolphin to see what happens..hopefully no lockups/crashes

UPDATE!

No crash or lockups in Dolphin with these experimental dbus packages. Getting them is highly recommended if you want to install KDE SC 4.5.x but these packages DO work for KDE 4.4.5 as I also tested them with this KDE version too.
polycarp - 27.09.2010, 12:53
Post subject:
I have dual monitors. No problems with 4.5.1 repo so far with clone/absolute positioning; I haven't tried side/top alignment.
iotaka - 06.10.2010, 15:27
Post subject:
      spacepenguin wrote:

BTW: My KDE SC 4.5.1 was relatively slow and unstable, especially dolphin that crashed a lot times a day. I have now dared to install the dbus and libdbus-1-3 packages from experimental (own risk) and dolphin is more responsive and a lot more stable. Improves KDE 4.5.1 feeling a lot. http://randomguy3.wordpress.com/2010/06 ... ng-issues/


After a

      Code:
aptitude -t experimental install libdbus-1-3


also for me kde 4.5.1 become stable. I suggest to add this step in the first post.
Lanzi - 06.10.2010, 17:50
Post subject:
@Spacepenguin - I did this last week. Lets see what happens.
Mte90 - 08.10.2010, 20:12
Post subject:
but kde 4.5.2?
BelaLugosi - 08.10.2010, 20:57
Post subject:
      Mte90 wrote:
but kde 4.5.2?

pardon, what are you trying to ask?
merlyn - 08.10.2010, 23:11
Post subject:
      Lanzi wrote:
You know what really bugs me on KDE 4.5?

In Krusader, copying a lot of files for backup-reasons, you could until now decide between "overwirte file" and "overwrite all". Now there is a checkbox "apply to all" and then you click overwrite. Its (another) click more (like for such a lot of applications in KDE4), but also you have to find a really small field, instead of a switch before.
This is really annoying clicking twice!


It's interesting to see things go this way, i.e. additional clicks.

I was of the impression that one of the design principles for KDE 4.x was to lessen the number of clicks required to perform a given task where possible.

I mentioned this briefly in an earlier post but the change in layout of the System settings tool, to me is indicative of this apparent change in thinking.
merlyn - 08.10.2010, 23:12
Post subject:
      spacepenguin wrote:
BTW: My KDE SC 4.5.1 was relatively slow and unstable, especially dolphin that crashed a lot times a day. I have now dared to install the dbus and libdbus-1-3 packages from experimental (own risk) and dolphin is more responsive and a lot more stable. Improves KDE 4.5.1 feeling a lot. http://randomguy3.wordpress.com/2010/06 ... ng-issues/


Groovy, I'll give it a try.

Thanks for posting the tip.

As an aside, does anyone know of an updated plasma-widget-quickaccess .deb. The one provided from Xadra's repo doesn't like 4.5.1

Cheers.
spacepenguin - 09.10.2010, 15:24
Post subject: quickaccess widget
      merlyn wrote:
As an aside, does anyone know of an updated plasma-widget-quickaccess .deb. The one provided from Xadra's repo doesn't like 4.5.1


I have patched the sources so that it works with 4.5.1 - could provide my quickndirty checkinstall deb...

http://www.materialordner.de/Vh2j1UlUWu ... YRk2V.html - stays there for 48 hours and max. 25 downloads.

Or you could modify the sources by yourself and compile them.

http://launchpadlibrarian.net/55388877/ ... ess.h.diff
http://launchpadlibrarian.net/55388819/ ... s.cpp.diff

I took a look at the altered trash widget and used the same method that was applied to its sources and was somehow surprised to see it actually work (I don't understand anything from those sources and coding). Now I only need someone to make something official out of it - nobody seems to maintain that widget anymore?

BTW: What happend to Xadras? Not active anymore in these fields?
merlyn - 10.10.2010, 00:05
Post subject: Re: quickaccess widget
      spacepenguin wrote:
I have patched the sources so that it works with 4.5.1 - could provide my quickndirty checkinstall deb...


Cheers, thanks for that.

      spacepenguin wrote:
Or you could modify the sources by yourself and compile them.

http://launchpadlibrarian.net/55388877/ ... ess.h.diff
http://launchpadlibrarian.net/55388819/ ... s.cpp.diff

I took a look at the altered trash widget and used the same method that was applied to its sources and was somehow surprised to see it actually work (I don't understand anything from those sources and coding). Now I only need someone to make something official out of it - nobody seems to maintain that widget anymore?


Unfortunately this is a little out of my skill set. My coding abilities, or lack thereof are limited to little used and rudimentary html/php.

Also from the listings for this plasmoid on KDE-look.org there has been no maintenance activity for some time, even the "maintenance fork".
belze - 17.10.2010, 22:41
Post subject: RE: Re: quickaccess widget
i'm downloading 4.5.2 from experimental snapshot right now.
devil - 18.10.2010, 04:39
Post subject: RE: Re: quickaccess widget
are you sure?
topic on #debian-kde still advertises 4.5.1.
could it be that its just kdelibs thats updated?
will check later.

greetz
devil
iotaka - 18.10.2010, 07:52
Post subject: Re: RE: Re: quickaccess widget
      devil wrote:
are you sure?
topic on #debian-kde still advertises 4.5.1.
could it be that its just kdelibs thats updated?
will check later.

greetz
devil


I just installed 4.5.2, the topic is not updated.
monkeynuts - 18.10.2010, 12:51
Post subject: RE: Re: RE: Re: quickaccess widget
4.5.2 is not in the normal Debian repos.
      Code:
kdebase-bin:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages

libkio5:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages

kdebase-bin:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

kdebase-runtime:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

dolphin:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages

konqueror:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

kdebase-data:
  Installed: 4:4.4.5-1
  Candidate: 4:4.4.5-1
  Version table:
 *** 4:4.4.5-1 0
        500 http://mirrors.kernel.org/debian/ sid/main i386 Packages



Also some package may have higher version numbers without the entire set of KDE packages being that version.
For example:
apt-cache policy korganizer
korganizer:
Installed: (none)
Candidate: 4:4.4.6-1
Version table:
4:4.4.6-1 0
500 http://mirrors.kernel.org/debian/ sid/main i386 Packages

kdepim:
Installed: (none)
Candidate: 4:4.4.6-1
Version table:
4:4.4.6-1 0
500 http://mirrors.kernel.org/debian/ sid/main i386 Packages

Also QT package versions do not reflect KDE package versions.
devil - 18.10.2010, 12:57
Post subject: RE: Re: RE: Re: quickaccess widget
4.5.2 will not be in normal debian repos, neither will probably be 4.6.x
as debian is in deep freeze, noone cares much for 4.5.x, as it will not be in Squeeze.
people rather fix bugs in 4.4.x to make it perfect for Squeeze.

greetz
devil
dibl - 18.10.2010, 13:03
Post subject:
As said by belze, the updated packages are in the experimental-snapshots repo:


      Code:
root@sidbox:/home/don# apt-cache policy dolphin
dolphin:
  Installed: 4:4.5.1-0r2
  Candidate: 4:4.5.1-0r2
  Version table:
 *** 4:4.5.1-0r2 0
        101 http://qt-kde.debian.net/debian/ experimental-snapshots/main amd64 Packages
        100 /var/lib/dpkg/status
     4:4.4.5-1 0
        500 http://ftp.us.debian.org/debian/ unstable/main amd64 Packages


"About KDE" does say 4.5.2.
devil - 18.10.2010, 13:09
Post subject:
yes, but it was just a partial update, and i doubt there will be more.

greetz
devil
Mte90 - 18.10.2010, 15:22
Post subject:
      BelaLugosi wrote:
      Mte90 wrote:
but kde 4.5.2?

pardon, what are you trying to ask?

i ask if in the repos qt-kde.debian receive the kde 4.5.2.
kris99 - 18.10.2010, 16:11
Post subject:
      Mte90 wrote:
i ask if in the repos qt-kde.debian receive the kde 4.5.2.


Yes they do but only partial:

      Code:
ii  kdelibs-bin                                 4:4.5.2-0r1                  core executables for KDE Applications
ii  kdelibs5                                    4:4.5.2-0r1                  transitional package for the KDE Development Platform libraries
ii  kdelibs5-data                               4:4.5.2-0r1                  core shared data for all KDE Applications
ii  kdelibs5-plugins                            4:4.5.2-0r1                  core plugins for KDE Applications
ii  kdoctools                                   4:4.5.2-0r1                  various tools for accessing application documentation
ii  libkatepartinterfaces4                      4:4.5.2-0r1                  the kate part library
ii  libkcmutils4                                4:4.5.2-0r1                  utility classes for using KCM modules
ii  libkde3support4                             4:4.5.2-0r1                  the KDE 3 Support Library for the KDE 4 Platform
ii  libkdecore5                                 4:4.5.2-0r1                  the KDE Platform Core Library
ii  libkdesu5                                   4:4.5.2-0r1                  the Console-mode Authentication Library for the KDE Platform
ii  libkdeui5                                   4:4.5.2-0r1                  the KDE Platform User Interface Library
ii  libkdewebkit5                               4:4.5.2-0r1                  the KDE WebKit Library
ii  libkdnssd4                                  4:4.5.2-0r1                  the DNS-SD Protocol Library for the KDE Platform
ii  libkemoticons4                              4:4.5.2-0r1                  utility classes to deal with emoticon themes
ii  libkfile4                                   4:4.5.2-0r1                  the File Selection Dialog Library for KDE Platform
ii  libkhtml5                                   4:4.5.2-0r1                  the KHTML Web Content Rendering Engine
ii  libkidletime4                               4:4.5.2-0r1                  library to provide information about idle time
ii  libkimproxy4                                4:4.5.2-0r1                  the Instant Messaging Interface Library for the KDE Platform
ii  libkio5                                     4:4.5.2-0r1                  the Network-enabled File Management Library for the KDE Platform
ii  libkjsapi4                                  4:4.5.2-0r1                  the KJS API Library for the KDE Development Platform
ii  libkjsembed4                                4:4.5.2-0r1                  library for binding JavaScript objects to QObjects
ii  libkmediaplayer4                            4:4.5.2-0r1                  the KMediaPlayer Interface for the KDE Platform
ii  libknewstuff2-4                             4:4.5.2-0r1                  the "Get Hot New Stuff" v2 Library for the KDE Platform
ii  libknewstuff3-4                             4:4.5.2-0r1                  the "Get Hot New Stuff" v3 Library for the KDE Platform
ii  libknotifyconfig4                           4:4.5.2-0r1                  library for configuring KDE Notifications
ii  libkntlm4                                   4:4.5.2-0r1                  the NTLM Authentication Library for the KDE Platform
ii  libkparts4                                  4:4.5.2-0r1                  the Framework for the KDE Platform Graphical Components
ii  libkprintutils4                             4:4.5.2-0r1                  utility classes to deal with printing
ii  libkpty4                                    4:4.5.2-0r1                  the Pseudo Terminal Library for the KDE Platform
ii  libkrosscore4                               4:4.5.2-0r1                  the Kross Core Library
ii  libkrossui4                                 4:4.5.2-0r1                  the Kross UI Library
ii  libktexteditor4                             4:4.5.2-0r1                  the KTextEditor interfaces for the KDE Platform
ii  libkunitconversion4                         4:4.5.2-0r1                  the Unit Conversion library for the KDE Platform
ii  libkutils4                                  4:4.5.2-0r1                  dummy transitional library
ii  libnepomuk4                                 4:4.5.2-0r1                  the Nepomuk Meta Data Library
ii  libnepomukquery4a                           4:4.5.2-0r1                  the Nepomuk Query Library for the KDE Platform
ii  libplasma3                                  4:4.5.2-0r1                  the Plasma Library for the KDE Platform
ii  libsolid4                                   4:4.5.2-0r1                  Solid Library for KDE Platform
ii  libthreadweaver4                            4:4.5.2-0r1                  the ThreadWeaver Library for the KDE Platform

belze - 19.10.2010, 08:13
Post subject: Re: RE: Re: RE: Re: quickaccess widget
      monkeynuts wrote:
4.5.2 is not in the normal Debian repos.

sure, indeed this thread is about kde 4.5 unofficial repo, and was talking about that repo, not the official debian sid.
Anyway, not such a great upgrade from the end-user point of view...
DeepDayze - 19.10.2010, 16:00
Post subject: RE: Re: RE: Re: RE: Re: quickaccess widget
Yes the kde 4.5.2 packages are not all there yet..will wait to see if anymore get uploaded before testing
spacepenguin - 02.11.2010, 16:25
Post subject: Re: quickaccess widget
      merlyn wrote:
      spacepenguin wrote:
I have patched the sources so that it works with 4.5.1 - could provide my quickndirty checkinstall deb...


Cheers, thanks for that.


I have uploaded the patched sources to kde-look.org since obviously nobody seems to care: http://kde-look.org/content/show.php?content=134442

The checkinstall deb is now here, use at your own risk: http://spacepenguin.de/download/aptosid ... 2_i386.deb
spacepenguin - 05.11.2010, 11:37
Post subject: RE: Re: quickaccess widget
Does anyone also have the problem that konqueror temporarily freezes after downloads (culprit nepomuk?) with 4.5.1 & 4.5.2 libs? https://bugs.kde.org/show_bug.cgi?id=254373
iotaka - 22.11.2010, 13:25
Post subject:
Today I find the 4.5.3-0r1 in the semi official repo.
blackhole - 22.11.2010, 15:21
Post subject:
Yes but only partial.
spacepenguin - 23.11.2010, 05:55
Post subject:
4.5.2 also was only partial...
dibl - 23.11.2010, 15:54
Post subject:
This newest Dolphin is a little crashy on both of my aptosid systems - anyone else noticed it?
blackhole - 23.11.2010, 16:39
Post subject:
Kinfo hardware information summary is always showing version 4.5.1, so some key components of 4.5.3 are missing.
devil - 23.11.2010, 19:47
Post subject:
dolphin has not crashed on me yet with 4.5.3

greetz
devil
HeSaid - 23.11.2010, 20:46
Post subject:
No crashes here, either.
--
Neal
dibl - 24.11.2010, 01:49
Post subject:
Possibly the dolphin crashes are due to a 2-disk btrfs filesystem that I have set up for experimental purposes. I'll post back if I can prove anything useful.
iotaka - 24.11.2010, 09:38
Post subject:
There is a new version libdbus in experimental.
      Code:
apt-get install libdbus-1-3 -t experimental

I evidence this because without the libdbus from experimental kde 4.5.x was unstable for me.
dibl - 25.11.2010, 01:35
Post subject:
      iotaka wrote:


There is a new version libdbus in experimental.



I installed it this morning (12 hours ago) on both my desktop systems, and have been beating on Dolphin all day -- moving and deleting DVD iso images, making new directories, etc. etc. I have not had one crash yet. I think maybe this has fixed it -- thanks iotaka!
DeepDayze - 30.11.2010, 00:20
Post subject:
      dibl wrote:
      iotaka wrote:


There is a new version libdbus in experimental.



I installed it this morning (12 hours ago) on both my desktop systems, and have been beating on Dolphin all day -- moving and deleting DVD iso images, making new directories, etc. etc. I have not had one crash yet. I think maybe this has fixed it -- thanks iotaka!


I have been using this libdbus package for a while now and it indeed works for both KDE 4.4.5 and 4.5.x. Been slinging files big and small around in dolphin and no crash at all, compared to using the libdbus in Sid. Even copying files to USB sticks and burning CD's been a piece of cake
snvv - 03.12.2010, 17:54
Post subject:
In a newly installed aptosid in a VM the command
      Quote:
apt-get -t experimental-snapshots full-upgrade


Instead I uprated the system with
      Quote:
apt-get -t experimental-snapshots dist-upgrade


I can't see any problem till now.

It would be OK to upgrade my everyday PC with dist-upgrade?
devil - 03.12.2010, 18:18
Post subject:
sure. i do. never used full-upgrade.

greetz
devil
ibgb - 03.12.2010, 18:35
Post subject:
Isn't full-upgrade an aptitude only command?
(it sure isn't referenced in man apt-get and it confuses apt-get if you use it as an argument)
devil - 03.12.2010, 20:42
Post subject:
it is. http://qt-kde.debian.net recommends aptitude, as those guys all use it.
you can just use apt-get and dist-upgeade instead.

greetz
devil
arwa - 04.12.2010, 09:42
Post subject:
full-upgrade for in aptitude what dist-upgrade is for apt-get. So when using apt-get (which is the recommended tool in aptosid) dist-upgrade is right.
muchan - 04.12.2010, 12:36
Post subject:
full-upgrade is a command of aptitude. apt-get has dist-upgrade. see "man apt-get"
snvv - 09.12.2010, 21:23
Post subject:
The qt-kde.debian.net is empty now. Therefore the packages should have been moved to experimental.

sid is moving again Smile
kris99 - 10.12.2010, 12:12
Post subject:
      snvv wrote:
The qt-kde.debian.net is empty now. Therefore the packages should have been moved to experimental.

sid is moving again Smile


Question Question Question

No change since 26-Nov-2010. The files are still there.
slam - 10.12.2010, 12:41
Post subject:
      kris99 wrote:
No change since 26-Nov-2010. The files are still there.
Correct, and they have not been uploaded to Debian experimental - so, the entire post is a misinformation.
Greetings,
Chris
snvv - 10.12.2010, 13:34
Post subject:
Sorry about this.
I tried to upgrade an other machine but the apt-get was empty.
arwa - 10.12.2010, 20:53
Post subject:
Hello,

I have found a crash in the KDE4.5.x installation: When switching to the desktop-grid effect (Ctrl+FCool and returning from it very fast via Esc, kwin did crash. I could reproduce it multiple times. Sometimes it requires many tries, but it crashes from time to time.

A bug report for this already exists (sorry, I do not have the number at hand) and it is marked fixed. The fix will be in KDE 4.6, but may be backported to the November 4.5.x version. Maybe this already is fixed with installing qt4.7.1.

Qt4.7.1 is in experimental. Did someone try to install it together with KDE 4.5.x? Does it work fine, maybe better than 4.6? Is there a howto somewhere to install it? (The most simple way might be to manually collect all installed qt4.6 packages and upgrade them?)

Thanks,
arwa
arwa - 10.12.2010, 20:54
Post subject:
Oops, Strg+F8 together with the bracket generates a smilie Cool
arwa - 12.12.2010, 16:42
Post subject:
Ok, I did read one comment incorrectly. The bug is not fixed in qt4.7.1 but in KDE4.6 and 4.5.4.
https://bugs.kde.org/show_bug.cgi?id=244813

But anyway: I tried to install the experimental qt4.7.1. So far nearly everything seems to work. But with qt4.7.1 there exists the bug that a digikam process keeps running after exiting digikam. So better do not try qt4.7.1 yet.
Mte90 - 15.02.2011, 17:35
Post subject:
i have a problem when i try to compile a program because i need kdelisb5-dev but when i try to install i get this:
      Code:

root@aptosidbox:/home/mte90/Desktop# apt-get install kdelibs5-dev
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
kdelibs5-dev è già alla versione più recente.
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kdelibs5-dev : Dipende: libkde3support4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdecore5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdeui5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkio5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkpty4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdesu5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkjsapi4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkjsembed4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkntlm4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libsolid4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkfile4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libknewstuff2-4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libknewstuff3-4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkparts4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkutils4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libthreadweaver4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkhtml5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkimproxy4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkmediaplayer4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libktexteditor4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libknotifyconfig4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdnssd4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkrosscore4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkrossui4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libnepomuk4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libnepomukquery4a (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libplasma3 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkunitconversion4 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: libkdewebkit5 (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: kdoctools (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
                Dipende: kdelibs-bin (= 4:4.4.5-3) ma la versione 4:4.5.3-0r1 sta per essere installata
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

i use kde 4.5 of this repo.
Any Ideas?
arwa - 15.02.2011, 17:53
Post subject:
What does "apt-cache policy kdelibs5-dev" tell you?

If I understand the output correctly, you want to install the 4.5.x version of this dev package, but all other KDE-packages are 4.4.5? Do you have KDE 4.4 or 4.5 installed?
devil - 15.02.2011, 18:53
Post subject:
btw: LANG=C apt-get install kdelibs5-dev will produce an english output.

greetz
devil
Mte90 - 15.02.2011, 19:46
Post subject:
      Code:

mte90@aptosidbox:~/Desktop/Websecurify 0.8$ LANG=C apt-cache policy kdelibs5-dev
kdelibs5-dev:
  Installed: (none)
  Candidate: 4:4.4.5-3
  Version table:
     4:4.5.3-0r1 0
        100 http://qt-kde.debian.net/debian/ experimental-snapshots/main amd64 Packages
     4:4.4.5-3 0
        500 http://ftp.it.debian.org/debian/ sid/main amd64 Packages


      Code:
root@aptosidbox:/home/mte90/.local/share/Trash/files/Websecurify 0.8# LANG=C apt-get install kdelibs5-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdelibs5-dev : Depends: libkde3support4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdecore5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdeui5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkio5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkpty4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdesu5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkjsapi4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkjsembed4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkntlm4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libsolid4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkfile4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libknewstuff2-4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libknewstuff3-4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkparts4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkutils4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libthreadweaver4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkhtml5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkimproxy4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkmediaplayer4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libktexteditor4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libknotifyconfig4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdnssd4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkrosscore4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkrossui4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libnepomuk4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libnepomukquery4a (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libplasma3 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkunitconversion4 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: libkdewebkit5 (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: kdoctools (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
                Depends: kdelibs-bin (= 4:4.4.5-3) but 4:4.5.3-0r1 is to be installed
E: Broken packages

I have the kde 4.5 on my system but i need the package kdelibs5-dev for compile software but isn't installable.
slh - 15.02.2011, 19:50
Post subject:
I guess you found one of the reason why we can't support random stuff from experimental or 3rd party repositories - especially for such fragile dependency chains as KDE. Yes, debian-qt-kde knows what they're doing, but they also need to stop at some point - and that's where stuff falls over the edge and breaks.

--
/been there, done that, got the t-shirt.
muchan - 15.02.2011, 23:13
Post subject:
my guess, is you have some pinning in /etc/apt/preferences...

And another guess is, that this is the very case, that
# apt-get install kdelibs5-dev/sid
will do the right things, thanks to the DonKult's update of apt?
arwa - 16.02.2011, 08:25
Post subject:
Ok, it seems that version 4.4 wants to be installed by default. You could try tp specify the version that matches your KDE version, like

apt-get install kdelibs5-dev/4.5.3-0r1

or

apt-get -t 4.5.3-0r1 kdelibs5-dev

usually you give the name of the repository behind "-t", but I do not know what to specify here in case of this semi-official KDE-repository.
ibgb - 16.02.2011, 08:51
Post subject:
      arwa wrote:
usually you give the name of the repository behind "-t", but I do not know what to specify here in case of this semi-official KDE-repository.


It's as simple as taking the repo name right from the sources.list line.

e.g

the line in sources.list is
      Code:
deb http://qt-kde.debian.net/debian experimental-snapshots main

so
      Code:
apt-get install foo -t experimental-snapshots

Mte90 - 16.02.2011, 15:36
Post subject:
Thanks with this command i have resolved:
      Code:
apt-get -t experimental-snapshots install kdelibs5-dev

I don't think that i needed to specify repo but thanks!
All times are GMT - 12 Hours
Powered by PNphpBB2 © 2003-2010 The Zafenio Group
Credits