Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
arwaOffline
Post subject: init 3 does not stop kdm  PostPosted: 10.07.2011, 10:14



Joined: 2010-09-11
Posts: 183

Status: Offline
Hello,

on a fresh installation of aptosid 2011-01, upgraded to the current state, "init 3" does not stop kdm as I saw.

The following Symlink does exist, but I am not sure if insserv (or whatever) takes notice of it:
      Code:
ls -l /etc/rc3.d/S05kdm
lrwxrwxrwx 1 root root 13 25. Jun 10:58 /etc/rc3.d/S05kdm -> ../init.d/kdm


What could I check to make it work correctly?

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 10.07.2011, 10:28



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
S = start, not stop
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 10.07.2011, 10:39



Joined: 2010-09-11
Posts: 183

Status: Offline
Oops, it seems to be too early for me this sunday.

Ok, there is no stop script in rc3.d, only in rc0.d, rc1.d and rc6.d. Shouldn't be one in rc3.d, too?

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 10.07.2011, 10:51
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
Try
      Code:
apt-get install --reinstall distro-defaults

and try again (init 3)
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 10.07.2011, 14:43



Joined: 2010-09-11
Posts: 183

Status: Offline
@piper: I have tried this now, but it does not change anything.

"init 3" keeps kdm started.
If I stop it manually and after this do an "init 5" again, kdm is not started automatically. I have to start it manually, too.

I now tried an "update-rc.d kdm defaults", but this seems not change anything, too:
      Code:
root@flupp:~# ls -l /etc/rc?.d/K*kdm*
lrwxrwxrwx 1 root root 13 24. Jun 19:48 /etc/rc0.d/K01kdm -> ../init.d/kdm
lrwxrwxrwx 1 root root 13 24. Jun 19:48 /etc/rc1.d/K01kdm -> ../init.d/kdm
lrwxrwxrwx 1 root root 13 24. Jun 19:48 /etc/rc6.d/K01kdm -> ../init.d/kdm
root@flupp:~# update-rc.d kdm defaults
update-rc.d: using dependency based boot sequencing
insserv: warning: current start runlevel(s) (2 3 4 5) of script `kdm' overwrites defaults (5).
insserv: warning: current stop runlevel(s) (0 1 6) of script `kdm' overwrites defaults (0 1 2 3 4 6).
root@flupp:~#
root@flupp:~# ls -l /etc/rc?.d/K*kdm*
lrwxrwxrwx 1 root root 13 24. Jun 19:48 /etc/rc0.d/K01kdm -> ../init.d/kdm
lrwxrwxrwx 1 root root 13 24. Jun 19:48 /etc/rc1.d/K01kdm -> ../init.d/kdm
lrwxrwxrwx 1 root root 13 24. Jun 19:48 /etc/rc6.d/K01kdm -> ../init.d/kdm
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 10.07.2011, 15:15
Team Member


Joined: 2010-08-26
Posts: 249

Status: Offline
"update-rc.d kdm defaults" is expected to do what you saw and is not what you want.

"update-rc.d kdm start 05 5 . stop 01 0 1 2 3 4 6 ." should get you back into normal shape I think (given you seemed to have kdm starting at sequence number 05 initially).
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 11.07.2011, 06:31



Joined: 2010-09-11
Posts: 183

Status: Offline
Thanks, bfree. I now see the /etc/insserv/overrides/kdm file with the new settings.

But am I the only one with this issue? As it seems I had the packages defaults, every aptosid user should have the wrong behaviour as long he does not fix it manually?!
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 11.07.2011, 09:33
Team Member


Joined: 2010-08-26
Posts: 249

Status: Offline
Perhaps you ran "update-rc.d kdm defaults" in the past? Other then that I can't (sanely) guess how this happened to you but it certainly doesn't seem to be a common problem.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 11.07.2011, 11:18



Joined: 2010-09-11
Posts: 183

Status: Offline
I am quite shure that I did not execute an "update-rc.d kdm defaults" in the last two weeks after setting up the PC before the one I have posted above.
 
 View user's profile Send private message  
Reply with quote Back to top
seagullOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 12.07.2011, 07:21



Joined: 2010-09-11
Posts: 38

Status: Offline
You are not the only one with this issue. I found it on 3 machines during d-u.
 
 View user's profile Send private message  
Reply with quote Back to top
sx9Offline
Post subject: RE: init 3 does not stop kdm  PostPosted: 14.07.2011, 22:30



Joined: 2010-09-12
Posts: 219
Location: Wiesbaden,Germany
Status: Offline
I had this problem a time ago, too, but I already did the update-rc.d before which has fixed it for me.
KDM has been upgraded a time ago, maybe it has started the update-rc.d kdm default command as a postinst script.

_________________
My new self-made computer:
Intel Core i7-2600k
ASUS Maximus IV Gene-Z (Mainboard)
2x4GB DDR3 RAM
ATI Radeon HD 6770
OCZ Vertex 3 60GB (SSD)
Western Digital Caviar Green WD20EARX 2TB (HDD)
...
aptosid x86_64
 
 View user's profile Send private message Send e-mail Yahoo Messenger  
Reply with quote Back to top
broweOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 15.07.2011, 00:48



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
I just had a look at the overrides file and noticed hal is still listed there. I require hal-cups-utils so this is ok for my system, but others who have completely removed hal may wish to edit this file.

      Code:

root@siduxbox64a:/etc/insserv/overrides# cat kdm
### BEGIN INIT INFO
# Provides:          kdm
# Required-Start:    $local_fs $remote_fs
# Required-Stop:     $local_fs $remote_fs
# Should-Start:      console-screen kbd acpid dbus hal krb5-kdc
# Should-Stop:       console-screen kbd
# Default-Start:     5
# Default-Stop:      0 1 2 3 4 6
# Short-Description: X display manager for KDE
# Description:       KDM manages a collection of X servers, which may be on the local host or remote machines.
### END INIT INFO
# Managed by the distro-defaults package.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 15.07.2011, 06:22



Joined: 2010-09-11
Posts: 183

Status: Offline
I did purge hal yesterday, but kdm still is starting up fine! Why?
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: init 3 does not stop kdm  PostPosted: 03.09.2011, 17:28



Joined: 2010-09-11
Posts: 183

Status: Offline
I now have fixed the behaviour of kdm like described by bfree here: http://aptosid.com/index.php?name=PNphp ... 1528#11528

      Code:

update-rc.d kdm remove
update-rc.d kdm defaults
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio