Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
apogarteOffline
14 Post subject: [closed]usb key install : no network, ceni not working  PostPosted: 18.07.2011, 20:44



Joined: 2011-01-25
Posts: 83

Status: Offline
hi

sorry to come again with trouble...

I freshly installed new aptosid-2011-02-imera-xfce-i386-201107131632.iso on a stick using this procedure :

first, i downloaded the iso from a working aptosid up to date
installation, then i used the "install aptosid to usb" menu entry, choosing the right stick with my langage option AND persist.

everything went fine, i rebooted, persist seems to work but i cannot get the network functionning. i usually do not need nothing to get it to work (wired), this time i get a strange error with ceni :

eth0 failed due to error at /usr/bin/ceni line 1482
/sbin/ifup: failed to open statefile /etc/network/run/ifstate: Input/output error

a little later, i tried on an other pc (laptop) with a
wifi D-link key (wich i use everyday with other distros and with aptosid), after installing the firmware (i always have it somewhere) via dpkg. wifi is detected, but after entering the wpa key i get something similar :

wlan0 ailed due to error at /usr/bin/ceni line 1482
/sbin/ifup: failed to open statefile /etc/network/run/ifstate: Input/output error

so i wonder wether i did a mistake somewhere wich makes some files unreadable/unwritable ?

thanks to whom might suggest something ?

apoG


Last edited by apogarte on 16.08.2011, 10:01; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
SuperdigiOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 21.07.2011, 06:41



Joined: 2011-04-16
Posts: 39

Status: Offline
Perhaps the same problem here: I wanted to install Sidux 2011-02 from DVD on my new Computer with Gigabyte GA-Z68MA-D2H-B3 Motherboard. In the live mode the network adapter is missing.
 
 View user's profile Send private message  
Reply with quote Back to top
dptOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 21.07.2011, 13:51



Joined: 2010-09-11
Posts: 281
Location: New Delhi
Status: Offline
It is called aptosid now, no longer sidux.
As earlier, all characters lower-case.

dpt

_________________
In a lunatic asylum, everyone thinks that he is the doctor.
 
 View user's profile Send private message AIM Address  
Reply with quote Back to top
SuperdigiOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 21.07.2011, 13:54



Joined: 2011-04-16
Posts: 39

Status: Offline
Thank you dpt. Your post is very helpful.
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 21.07.2011, 18:44



Joined: 2011-01-25
Posts: 83

Status: Offline
hello to all

thanks for correcting misspelling
how about this network prob? any clever remark ?

apoG
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 21.07.2011, 19:14
Team Member


Joined: 2010-08-26
Posts: 247

Status: Offline
Everyone grow up please.

As to the problem, you can try and debug it a little (probably starting with what does "ls -l /etc/network/run" say) or just wait for someone to have a bit of time to check it out.

For the record (and to replicate the situation easier), is your usb stick using a vfat filesystem and hence persistence in a file, or is it using an ext filesystem?
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 21.07.2011, 19:30



Joined: 2011-01-25
Posts: 83

Status: Offline
hi bfree, sorry i was just kidding...

my usb stick is formated with ext2 (2partitions) wich was doing good in some other experiments (#!, extlinux, handwritten extlinux.cfg)

i never encountered this network trouble before

i will try to find more as soon as i have a working aptosid live stick in my hand !

as a mater of fact i thought the trouble might come from the installation i did via the usb-installer script, so after reading your topic on "booting aptosid", i experimented the extlinux way and this leaded me into problems...

(message at boot time from extlinux : "unknown keyword in configuration file, could not find kernel image : linux", i've started a new thread for this forgive me if i do too many requests)

(this is why i cannot investigate network prob further i will look for a spare stick and try again)

thanks to you ,

apoG
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: usb key install : no network, ceni not working  PostPosted: 22.07.2011, 05:59
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
It's been a while since I messed with a stick, if I rememeber correctly I had problems with 2 partitions, but, like I said, its been a while

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: Re: RE: usb key install : no network, ceni not working  PostPosted: 22.07.2011, 12:41



Joined: 2011-01-25
Posts: 83

Status: Offline
hi

      piper wrote:
It's been a while since I messed with a stick, if I rememeber correctly I had problems with 2 partitions, but, like I said, its been a while


well never had trouble using 2 partitions (not fat don't use that only ext2 and even unetbootin handles ext2 if extlinux is installed too bad with aptosid it is not working...)

i am into sticks (!) since a while, sometimes it's easy sometimes not, well it seem lots of people still burn cds
well i don't : for me, sticks is the future of cds/dvds and the future is : now...

as far as my point of vue is valid, i think very few experience is done with that and it's a pitty, because as a result it is still unclear how to use the (usb) sticks even with a state of the art distro...

apoG
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: Re: RE: usb key install : no network, ceni not working  PostPosted: 22.07.2011, 13:59
Team Member


Joined: 2010-08-26
Posts: 247

Status: Offline
After checking out extlinux as per the other thread, I went on and used the usb installer to resetup the first partition on the stick using it (and hence grub, fromiso).

Networking worked as expected.

So something is funny here. The only networking oddity I can think of is that it's possible sometimes your ethernet may not come up automatically depending on the timing of when the various boot scripts are run, but in that case running ceni (or probably just ifup eth0) should work fine. Superdigi, perhaps this is what was catching you out?

I really don't have a clue what the problem is here and can't reproduce it. If you can then please at least show the output of "ls -l /etc/network" and "ls -l /etc/network/run/".

I've a suspicion though that something was funny with the stick and or/partitioning and that after following the ideas in the other thread this issue will be gone.
 
 View user's profile Send private message  
Reply with quote Back to top
apogarteOffline
Post subject: Re: RE: Re: RE: usb key install : no network, ceni not worki  PostPosted: 16.08.2011, 10:00



Joined: 2011-01-25
Posts: 83

Status: Offline
      bfree wrote:
After checking out extlinux as per the other thread, I went on and used the usb installer to resetup the first partition on the stick using it (and hence grub, fromiso).

Networking worked as expected.

So something is funny here. The only networking oddity I can think of is that it's possible sometimes your ethernet may not come up automatically depending on the timing of when the various boot scripts are run, but in that case running ceni (or probably just ifup eth0) should work fine. Superdigi, perhaps this is what was catching you out?

I really don't have a clue what the problem is here and can't reproduce it. If you can then please at least show the output of "ls -l /etc/network" and "ls -l /etc/network/run/".

I've a suspicion though that something was funny with the stick and or/partitioning and that after following the ideas in the other thread this issue will be gone.


myself unable to reproduce it since i changed my methods for installing on a stick so i thank you all for helping and stop
wandering about around this ... network prob

must mention here the extlinux way now works perfectly to get a live stick with several partitions, i've been completing description in the other topic

thanks to all for help
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio