Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
towoOnline!
Post subject: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:19



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Online!
No, you are not wrong.
The nvidia blob has no official support for xserver 1.11.
You can get nvidia running, if you start X with the option "ignoreABI", but on my system, i had many graphical problems with the beta driver.
 
 View user's profile Send private message  
Reply with quote Back to top
johnlittle001Offline
Post subject: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:23



Joined: 2010-09-12
Posts: 15
Location: Miami, Florida USA
Status: Offline
I'm one of the morons who despite seeing the warning about the packages to be removed went ahead anyway and did the dist-upgrade.

I've got an intel graphics card but but when I boot up I can't get to the graphical log-in screen. I did another D-U a few minutes ago but still no luck. Do I need to simply wait and try an another D-U later or do I need to affirmatively install some missing package?
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:24



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Online!
You need at least xserver-xorg-video-intel and xserver-xorg-input-evdev.
If they are not installable, you have to wait.
 
 View user's profile Send private message  
Reply with quote Back to top
johnlittle001Offline
Post subject: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:40



Joined: 2010-09-12
Posts: 15
Location: Miami, Florida USA
Status: Offline
      towo wrote:
You need at least xserver-xorg-video-intel and xserver-xorg-input-evdev.

Thanks. One of the two (xserver-xorg-input-evdev) was missing so I installed it. Unfortunately it didn't solve the problem. I'm hoping I don't have to re-install aptosid. Until I find a solution I'm using a Mepis installation on another partition.
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject: RE: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:41



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Online!
Without /var/log/Xorg.0.log, no one can give you any hint.
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:47



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
      johnlittle001 wrote:


I've got an intel graphics card but but when I boot up I can't get to the graphical log-in screen. I did another D-U a few minutes ago but still no luck.


Check and be sure you have the xserver-xorg package installed -- I found it was missing and causing the problem.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
johnlittle001Offline
Post subject: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 12:59



Joined: 2010-09-12
Posts: 15
Location: Miami, Florida USA
Status: Offline
      dibl wrote:
Check and be sure you have the xserver-xorg package installed -- I found it was missing and causing the problem.

That did the trick!!! Thank you for your prompt response (and thanks also to Towo)
 
 View user's profile Send private message  
Reply with quote Back to top
kris99Offline
Post subject: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 17:58



Joined: 2010-09-11
Posts: 21

Status: Offline
      ghstryder wrote:
      clubex wrote:
None of the proprietry nvida drivers work with 1.11 version (including beta 285.03). God knows when it will be fixed.
      Code:
$ infobash -v3
Host/Kernel/OS  "P690" running Linux 3.0-3.slh.4-aptosid-amd64 x86_64 [ sidux 2010-01 Ύπνος - kde-full
Videocard   nVidia NV45 [GeForce 6800 GTO]  X.Org 1.11.0  [ 1600x1200@50.0hz ]
GLX Renderer GeForce 6800 XT/PCI/SSE2 | GLX Version 2.1.2 NVIDIA 285.03 | Client Shell | Infobash v3.37

This only works if you have added the parameter '-ignoreABI' to the line 'ServerCmd=/usr/bin/X' in '/etc/kde4/kdm/kdmrc'

Kris
 
 View user's profile Send private message  
Reply with quote Back to top
AMDx64BTOffline
Post subject: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 29.08.2011, 23:58



Joined: 2011-05-16
Posts: 5

Status: Offline
I have updated xorg and now it doesn't work nvidia propietary drivers.

How I can downgrade the xserver-xorg packages?
 
 View user's profile Send private message  
Reply with quote Back to top
elboy71Offline
Post subject: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 30.08.2011, 00:43



Joined: 2011-05-17
Posts: 25

Status: Offline
Thanks towo!!! Installed xserver-xorg-video-ati and xserver-xorg-input-evdev and voila!!! It did the trick. Sorry for being such a MORON... I'm not worthy!!!
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 30.08.2011, 02:01
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      AMDx64BT wrote:
I have updated xorg and now it doesn't work nvidia propietary drivers.

How I can downgrade the xserver-xorg packages?


You don't want to downgrade xorg !

Please read this carefully !!

http://aptosid.com/index.php?module=wik ... g=GoNvidia

until nvidia is fixed

any problems going back to nouveau let us know.

I borked one box on purpose to see if any problems with this, I had no problems (64 bit)

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
vinurOffline
Post subject: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 30.08.2011, 04:26



Joined: 2010-09-11
Posts: 60
Location: Lake Oswego
Status: Offline
I was going to D-U this evening as I just got Google Earth up again from the last D-U which made it go away.
I have made it a habit to read every warning... I learned that some time ago.
Since I have nVidia secret sauce and compiled the application that builds the google-earth-stable_current_amd64.deb to my local machine, it is not so difficult to bring it back if I temporarily bork it. Quite the learning experience to do this I think.
Anyway I saw this warning and I think I will just cool my heels a little and wait. aptosid is very habit forming and I too have a compulsion to upgrade all of the time.
At least I am very current today and everything is working at this time... so I will just wait and enjoy the patience that many falls and mistakes have taught me, caution as well.
michael@eyland:~$ infobash -v3
Host/Kernel/OS "eyland" running Linux 3.0-3.slh.2-aptosid-amd64 x86_64 [ aptosid 2011-01 Γῆρας - kde-lite - (201102051540) ]
CPU Info 4x AMD Phenom II X4 955 512 KB cache flags( sse3 ht nx lm svm ) clocked at [ 3214.733 MHz ]
Videocard nVidia G96 [GeForce 9400 GT] X.Org 1.10.4 [ 1920x1080@50.0hz ]
Network cards D-Link System Inc DGE-560T PCI Express Gigabit
Processes 134 | Uptime 49min | Memory 726.9/8005.8MB | HDD ST3500418AS,ST32000641AS Size 2500GB (4%used) | GLX Renderer GeForce 9400 GT/PCI/SSE2 | GLX Version 3.3.0 NVIDIA 280.13 | Client Shell | Infobash v3.37

I really like aptosid, especially after helping a friend with Kubuntu which is just a little weird and pretty limited.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
kris99Offline
Post subject: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 30.08.2011, 08:02



Joined: 2010-09-11
Posts: 21

Status: Offline
      AMDx64BT wrote:
I have updated xorg and now it doesn't work nvidia propietary drivers.

How I can downgrade the xserver-xorg packages?

Don't downgrade just add "-ignoreABI" as parameter for startx (have a look at my first post in this thread) . It's running fine on several machines.

kris
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject: RE: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 30.08.2011, 09:16



Joined: 2010-09-13
Posts: 499
Location: Pößneck / Thüringen
Status: Online!
This will never work, if the user is using debian packages.
The nvidia-packages are not installable, if xserver 1.11 is installed.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: Re: RE: Re: RE: xorg-server 2:1.11.0-1  PostPosted: 30.08.2011, 10:11
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      kris99 wrote:
      AMDx64BT wrote:
I have updated xorg and now it doesn't work nvidia propietary drivers.

How I can downgrade the xserver-xorg packages?

Don't downgrade just add "-ignoreABI" as parameter for startx (have a look at my first post in this thread) . It's running fine on several machines.

kris


This didn't work on one of my 3 nvidia boxes, didn't bother with the others and it wasn't my intention to get it working at the time.

I was testing to make sure people using "the blob" (me) can revert back to nouveau without a hitch and wait for a fix from nvidia (debian package)

xorg-video-abi-10 was the dependency problem I was having and -ignoreABI did nothing, now I did not do extensive testing with this as of yet, but maybe will later after work.

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio