Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
etorixOffline
6 Post subject: nvidia-kernel-source 280.13-2 + X.Org 1.11.0  PostPosted: 30.08.2011, 17:17
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
this wont start X without editing in '/etc/kde4/kdm/kdmrc, like

      Code:
ServerCmd=/usr/bin/X -ignoreABI


When it DOES start X, its GLITCHY

i cant reccomend it

EDIT: tested, seems ok with all default Sid drivers/Xorg

not 100% perfect but seems all working acceptably


Last edited by etorix on 25.09.2011, 07:38; edited 3 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: nvidia-kernel-source 280.13-2 + X.Org 1.11.0  PostPosted: 30.08.2011, 21:18
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
Is it glitchy with the patched kdmrc?

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
amdgoonOffline
Post subject:   PostPosted: 30.08.2011, 23:27



Joined: 2010-09-11
Posts: 3
Location: Brandon Manitoba
Status: Offline
Thanks etorix. Hit this today on a new install + d-u. Saw that ignoreABI message in the output, but had no idea of where to put the option.

Install is with the xfce4 aptosid 2011-02 disk. I'll have to look for a gdm3rc file I presume.
 
 View user's profile Send private message  
Reply with quote Back to top
etorixOffline
Post subject:   PostPosted: 31.08.2011, 01:41
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
this is NOT a viable solution

switching to the Nouveau driver is a far better option for nVidia card users

see http://aptosid.com/index.php?module=wik ... g=GoNvidia
 
 View user's profile Send private message  
Reply with quote Back to top
jacmoeOffline
Post subject:   PostPosted: 31.08.2011, 04:40



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
Dont be ridiculous. That driver is not an alternative. What a crap reply.
I guess we just have to wait a bit longer.
(Wrote this using Links!)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
jacmoeOffline
Post subject:   PostPosted: 31.08.2011, 05:01



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
      Quote:
As most people with Nvidia cards are probably not aware of, the new free and open source driver Nouveau is already enabled in Aptosid kernels, and does work well for most cards and use cases (3D support still experimental, though). So, it's time to finally get rid of the closed source and non DSFG distributable packages, along with potentially problematic 3rd party repositories.


If this is the official policy of the Aptosid team I guess there is something fundamental that you've misunderstood.

The problem is that I need 3D support.

Since most Aptosid users are fairly advanced users, don't give us that crap.
We are using the proprietary nVidia driver for a reason.

Thanks. Wink
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
etorixOffline
Post subject:   PostPosted: 31.08.2011, 05:20
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
jacmoe: moderate your tone please, you are patently misreading

im a member of Dev team + i use 3d nVidia AND Nouveau both for different puposes

if you have lost 3D its thru NOT READING what Apt plainly said it was going to do

REMOVE STUFF


Last edited by etorix on 31.08.2011, 05:33; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 31.08.2011, 05:30
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
      jacmoe wrote:
      Quote:
As most people with Nvidia cards are probably not aware of, the new free and open source driver Nouveau is already enabled in Aptosid kernels, and does work well for most cards and use cases (3D support still experimental, though). So, it's time to finally get rid of the closed source and non DSFG distributable packages, along with potentially problematic 3rd party repositories.


If this is the official policy of the Aptosid team I guess there is something fundamental that you've misunderstood.

The problem is that I need 3D support.

Since most Aptosid users are fairly advanced users, don't give us that crap.
We are using the proprietary nVidia driver for a reason.

Thanks. Wink
Yes, this is our official policy. However, your quote is incomplete:
      Quote:
The Aptosid development team recommends and fully supports the removal of the nv driver and installation/usage of the nouveau driver (and of course vesa). Only for those actually needing the full 3D features of the proprietary driver, we always have and will provide help in our manuals, forums and IRC channel.

Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
jacmoeOffline
Post subject:   PostPosted: 31.08.2011, 05:34



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
1) Apt did not say it was going to remove anything.

2) Telling people to install the Nouveau is not really a valid answer to people having lost the nVidia driver.

3) I am mainly frustrated at myself for not checking the Aptosid forum prior to my DU. Even if apt didn't say it was going to remove anything. But I am also frustrated at hearing that Nouveau is the answer:
      Quote:
switching to the Npuveau driver is a far better option for nVidia card users


So, I think I'll just wait it out.
I didn't screw anything as apt did not remove anything. I just have no X. Wink

Yeah, I'll moderate myself. Smile
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
etorixOffline
Post subject:   PostPosted: 31.08.2011, 05:42
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
      Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  nvidia-glx xserver-xorg-video-nvidia
 
 View user's profile Send private message  
Reply with quote Back to top
jacmoeOffline
Post subject:   PostPosted: 31.08.2011, 05:58



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
I waited until apt told me that it wasn't going to be removed.
      Quote:
One added, nothing to remove and a lot of upgraded packages.

nvidia-glx and xserver-xorg-video-nvidia was among the packages to upgrade.
Too bad I didn't pipe the output to a file as proof. Smile
But the bottom line is that it's broken even if it's upgraded.
It will probably fix itself.

Sorry for having brought forth insults and vitriolic remarks, btw.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
SordonOffline
Post subject:   PostPosted: 31.08.2011, 06:59



Joined: 2010-09-13
Posts: 55

Status: Offline
      jacmoe wrote:
Too bad I didn't pipe the output to a file as proof. Smile
Simply look in /var/log/apt/history.log

And by the way I'm now a nouveau user and can not complain at all (e.g. desktop effect, games and GoogleEarth work without problems).

Best Regards,
Sordon
 
 View user's profile Send private message  
Reply with quote Back to top
jacmoeOffline
Post subject:   PostPosted: 31.08.2011, 07:53



Joined: 2011-04-13
Posts: 40
Location: Denmark
Status: Offline
      Sordon wrote:
      jacmoe wrote:
Too bad I didn't pipe the output to a file as proof. Smile
Simply look in /var/log/apt/history.log

Thanks for the tip! Smile

      Sordon wrote:
And by the way I'm now a nouveau user and can not complain at all (e.g. desktop effect, games and GoogleEarth work without problems).

I am a graphics programmer..
I will check it out only as a last resort (read: if I can't have X in my aptosid box for more than 14 days). Wink
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 31.08.2011, 08:49



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
Imortant notice:
http://www.nvnews.net/vbulletin/showpos ... ostcount=4
 
 View user's profile Send private message  
Reply with quote Back to top
Barcelona_debOffline
Post subject:   PostPosted: 31.08.2011, 10:43



Joined: 2011-08-31
Posts: 2

Status: Offline
      etorix wrote:
this is NOT a viable solution

switching to the Npuveau driver is a far better option for nVidia card users

see http://aptosid.com/index.php?module=wik ... g=GoNvidia


I don' t usually play modern 3D games, so for now this solution is good for me until propietary driver is fixed. Thank you very much for your help Smile
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio