Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hyOffline
Post subject: RE: Printer not Working  PostPosted: 11.08.2011, 12:28



Joined: 2010-09-14
Posts: 160
Location: Costa Teguise
Status: Offline
Actually I do not have a parallell port. The printer is not a usb-printer.

system-config-printer-udev was not installed here. Installing it didn't change anything.

Thanks slh for trying.
 
 View user's profile Send private message  
Reply with quote Back to top
kelmoOffline
Post subject: Re: RE: Printer not Working  PostPosted: 13.08.2011, 00:38



Joined: 2010-09-21
Posts: 15

Status: Offline
      hy wrote:
Actually I do not have a parallell port. The printer is not a usb-printer.


Whoa, this is confusing. How IS the printer connected?

      hy wrote:

system-config-printer-udev was not installed here. Installing it didn't change anything.

Thanks slh for trying.


He didn't ask you to try and install system-config-printer-udev, but rather remove it (if present) and attempt conventional configuration via CUPS web configuration interface.
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject: RE: Re: RE: Printer not Working  PostPosted: 13.08.2011, 06:15



Joined: 2010-09-14
Posts: 160
Location: Costa Teguise
Status: Offline
The printer is connected with a cable that has a USB stick on one side and a parallell outlet on the other.

I understood what slh meant. But as far as nothing seemed to help I tried it. Because configuring the printer with CUPS web config interface didn't work - neither before nor after installing the tool.
 
 View user's profile Send private message  
Reply with quote Back to top
yamanekoOffline
Post subject:   PostPosted: 15.08.2011, 17:43



Joined: 2010-09-12
Posts: 9
Location: Weil am Rhein
Status: Offline
Hi @all,

can confirm hy's and phen's observations.

Printer (HP LaserJet 6MP) working with W7 (brrrrr) and old kernel (< 3.0),
not working on 3.01, does not find printer (cups via localhost:631)

Cheers Yamaneko

PS 64 bit
      Code:
Host/Kernel/OS  "Kuddel" running Linux 3.0-1.slh.7-aptosid-amd64 x86_64 [ sidux 2009-02 Αιθήρ - kde-lite - (200907141521) ]
CPU Info        2x AMD Athlon 64 X2 Dual Core 5600+ 512 KB cache flags( sse3 ht nx lm svm ) clocked at [ 2900.000 MHz ]
Videocard       ATI Radeon HD 3200 Graphics  X.Org 1.10.3  [ 1280x1024@60.0hz ]
Network cards   Realtek RTL8111/8168B PCI Express Gigabit
Processes 121 | Uptime 12min | Memory 534.4/5479.8MB | HDD SAMSUNG HD642JJ,SAMSUNG HD642JJ Size 1280GB (25%used) | GLX Renderer Gallium 0.4 on AMD RS780 | GLX Version Yes | Client Shell | Infobash v3.37
 
 View user's profile Send private message  
Reply with quote Back to top
slaughtererOffline
Post subject:   PostPosted: 15.08.2011, 18:52



Joined: 2010-09-11
Posts: 31
Location: Athens
Status: Offline
My box is laptop x64 aptosid installed. Printer work's fine (Hp officejet Pro) connected via usb!
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 16.08.2011, 01:00



Joined: 2010-08-25
Posts: 731

Status: Offline
I had a chance to test a USB (real USB 2.0, no adaptor) printer today (not a fair comparison, as the printer has native postscript 3 support), setting it up manually (http://localhost:631, system-config-printer-udev was not installed) and printing using the auto-detected PPD didn't expose any problems (the system was fully updated and is usually configured to use to network printers). While I didn't have much time to test corner cases or do proper debugging, everything appeared to work fine,
 
 View user's profile Send private message  
Reply with quote Back to top
yamanekoOffline
Post subject:   PostPosted: 16.08.2011, 15:58



Joined: 2010-09-12
Posts: 9
Location: Weil am Rhein
Status: Offline
Thanks, slh, for looking into it.

I tend to believe that the real issue is the adapter (usb--> parallel).
It's recognised
      Code:
Bus 004 Device 002: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port
but that's it.

Previously the printer behind the adapter was recognised (like W7 does). Not anymore, unfortunately.

I fully understand that my printer is legacy from the last millenium, not state of the art. I would hate to throw away a working printer, though...

Cheers,

Yamaneko
 
 View user's profile Send private message  
Reply with quote Back to top
saxxonianOffline
Post subject: RE: Printer not Working  PostPosted: 23.08.2011, 14:40



Joined: 2010-09-11
Posts: 28
Location: Brasov, Romania
Status: Offline
Just to add, I'm hit too. HP Laserjet 2100M via Parallel/USB cable. Worked for many years, but not any more. It's not recognized via localhost:631, or else.
Am waiting patiently, any suggestions welcome.
[edit] Printer and cable work on a Mac Powerbook.
[edit2} networked HP multi works too


Last edited by saxxonian on 24.08.2011, 14:10; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
phenOffline
Post subject: RE: Printer not Working  PostPosted: 23.08.2011, 18:40



Joined: 2010-09-11
Posts: 27

Status: Offline
Yep, I really hope this will be fixed at some point, and that this working was not a feature been removed now. Still though I am somewhat optimistic, excited about any cups-related files being updated in DUs.

However, only thing left to do for me these days is, to simply use Windows.
=S
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject: RE: Printer not Working  PostPosted: 30.08.2011, 01:25



Joined: 2010-09-12
Posts: 152
Location: Canada
Status: Offline
I have problems with an hp printer too... see this other thread:

http://aptosid.com/index.php?name=PNphp ... =9842#9842

I also tried switching daemons with no different result:

root@siduxbox64a:/# apt-get install system-config-printer-udev
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
python-cupshelpers
The following packages will be REMOVED:
hal-cups-utils
The following NEW packages will be installed:
python-cupshelpers system-config-printer-udev
0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 116 kB of archives.
After this operation, 274 kB of additional disk space will be used.
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject: RE: Printer not Working  PostPosted: 30.08.2011, 08:06



Joined: 2010-09-11
Posts: 183

Status: Offline
As "hal" is obsolete, it is ok to let this package be removed.
 
 View user's profile Send private message  
Reply with quote Back to top
kb0haeOffline
Post subject: RE: Printer not Working  PostPosted: 30.08.2011, 08:23



Joined: 2010-09-12
Posts: 50

Status: Offline
Hi Guys. I am not having a problem right now, but in the past I have. My printer is an HP Deskjet 970cxi connected via USB. On a couple of past D-Us, the printer driver was changed to one that did not allow duplex printing. I had to change drivers using http://localhost:631). to one that allows duplex printing.
 
 View user's profile Send private message  
Reply with quote Back to top
ghstryderOffline
Post subject: RE: Printer not Working  PostPosted: 30.08.2011, 16:22



Joined: 2010-09-12
Posts: 94
Location: Detroit
Status: Offline
I'm glad to know I didn't lose my mind. Some short time ago, I had to change the drivers on both of my printers. Both of them are working just fine right now. I have a USB connected HP PSC1209 All in One, and a network connected HP Laserjet 2100M.

Edit: both of these were set up using localhost:631
 
 View user's profile Send private message  
Reply with quote Back to top
saxxonianOffline
Post subject: RE: Printer not Working  PostPosted: 01.09.2011, 16:15



Joined: 2010-09-11
Posts: 28
Location: Brasov, Romania
Status: Offline
so, is my above mentioned problem then, one of USB-parallel adapter not being "transparent" anymore to CUPS? what should I look into?
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: Printer not Working  PostPosted: 01.09.2011, 17:55
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
I deleted my old printer setup and created a new one. All problems were gone.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio