Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
arwaOffline
Post subject: opera wants to upgrade to same version?  PostPosted: 22.09.2011, 06:55



Joined: 2010-09-11
Posts: 183

Status: Offline
Hello,

I have included the opera.com repository to install the opera browser.
deb http://deb.opera.com/opera/ sid non-free

No I wonder that the opera package wants to be updated, but to the same version as already installed!? Why does this happen?

      Code:

# apt-cache policy opera
opera:
  Installed: 11.51.1087
  Candidate: 11.51.1087
  Version table:
     11.51.1087 0
        500 http://deb.opera.com/opera/ sid/non-free amd64 Packages
 *** 11.51.1087 0
        100 /var/lib/dpkg/status

apt-get -duV -o Debug::pkgProblemResolver=yes dist-upgrade
...
   opera (11.51.1087 => 11.51.1087)
...

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: opera wants to upgrade to same version?  PostPosted: 22.09.2011, 07:49
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
11.51 is the latest version

Where is it telling you that it wants to be upgraded ?

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: opera wants to upgrade to same version?  PostPosted: 22.09.2011, 08:12
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
While the versions have the same version number apt detects them as different and prefers to download and install the version coming from a repository over the locally installed one.

This is to help with rebuilds of packages with the same version number - it's discouraged, but not too uncommon.

That they are different is concluded from different dependencies and similar stuff. I can tell you what exactly is the bugger if you post the the output of 'apt-cache show opera -a'. So, until further notice, this is a feature, not a bug.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 22.09.2011, 09:08



Joined: 2010-09-11
Posts: 183

Status: Offline
@piper: apt-get dist-upgrade tells me (see the code block in my first post)

@DonKult: This is the output of the apt-cache show command:
      Code:

# apt-cache show opera -a
Package: opera
Version: 11.51.1087
Architecture: i386
Depends: libc6 (>= 2.3.2), libc6 (>= 2.3.6-6~), libfontconfig1 (>= 2.5.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.16.6), libgstreamer-plugins-base0.10-0 (>= 0.10.16), libgstreamer0.10-0 (>= 0.10.15), libice6 (>= 1:1.0.0), libsm6, libstdc++6 (>= 4.1.1), libx11-6, libxext6, libxml2 (>= 2.6.27), libxrender1, libxt6, zlib1g (>= 1:1.1.4), gstreamer0.10-plugins-good, debconf (>= 0.5) | debconf-2.0, ttf-liberation | ttf-mscorefonts-installer
Recommends: flashplugin-nonfree, cups-client
Provides: www-browser, mail-reader, imap-client, news-reader
Installed-Size: 34646
Maintainer: Opera Packaging Team <packager@opera.com>
Bugs: https://bugs.opera.com/wizard/
Homepage: http://www.opera.com/browser/
Priority: optional
Section: non-free/web
Filename: pool/non-free/o/opera/opera_11.51.1087_i386.deb
Size: 11074552
MD5sum: 775c64c1f223fb3854d8fc6c4972c6fa
Description: Fast and secure web browser and Internet suite
 Opera is a small, fast, customizable, powerful and user-friendly web
 browser, as well as an Internet suite, including an email client, an IRC
 client, web developer tools (Opera Dragonfly), and a personal web server
 (Opera Unite).

Package: opera
Status: install ok installed
Priority: optional
Section: non-free/web
Installed-Size: 34646
Maintainer: Opera Packaging Team <packager@opera.com>
Bugs: https://bugs.opera.com/wizard/
Architecture: i386
Version: 11.51.1087
Provides: www-browser, mail-reader, imap-client, news-reader
Depends: libc6 (>= 2.3.2), libc6 (>= 2.3.6-6~), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.24.0), libgstreamer-plugins-base0.10-0 (>= 0.10.16), libgstreamer0.10-0 (>= 0.10.15), libice6 (>= 1:1.0.0), libsm6, libstdc++6 (>= 4.1.1), libx11-6, libxext6, libxml2 (>= 2.6.27), libxrender1, libxt6, zlib1g (>= 1:1.1.4), gstreamer0.10-plugins-good, debconf (>= 0.5) | debconf-2.0, ttf-liberation | ttf-mscorefonts-installer
Recommends: flashplugin-nonfree, cups-client
Conffiles:
 /etc/operaprefs_default.ini 9d8c0cb15a7240a7fd0e32e995a9d022 obsolete
 /etc/operaprefs_fixed.ini 2b02c2dd0c8a5a750aa8f42ee0505444 obsolete
Description: Fast and secure web browser and Internet suite
 Opera is a small, fast, customizable, powerful and user-friendly web
 browser, as well as an Internet suite, including an email client, an IRC
 client, web developer tools (Opera Dragonfly), and a personal web server
 (Opera Unite).
Homepage: http://www.opera.com/browser/
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject:   PostPosted: 22.09.2011, 13:24
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
Thanks, as i guessed: Your installed version depends on libglib2.0-0 >= 2.24.0 while the one currently online depends on libglib2.0-0 >= 2.16.6

Opera Company properly decided that it would be a good idea to decrease the version-constrants to allow users with older debian versions (aka debian oldstable) to install the opera package.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 22.09.2011, 13:59



Joined: 2010-09-11
Posts: 183

Status: Offline
Thanks, DonKult, interesting to learn this.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 22.09.2011, 18:52
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
Sorry arwa

I did not see this using a cell phone and in a hurry

apt-get -duV -o Debug::pkgProblemResolver=yes dist-upgrade Embarassed

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio