Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LatOffline
Post subject: Wireless disconnects after resume from stand-by  PostPosted: 01.10.2011, 19:29



Joined: 2010-09-19
Posts: 167

Status: Offline
Every time I open the lid of my laptop the desktop appears as always and the wireless led starts blinking and I get a notification that it is connected to my access point
      Code:
[60369.566638] Restarting tasks ... done.
[60369.579213] video LNXVIDEO:00: Restoring backlight state
[60372.042546] EXT4-fs (sda8): re-mounted. Opts: errors=remount-ro,barrier=0,commit=0
[60372.048622] EXT4-fs (sda6): re-mounted. Opts: commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=0,commit=600,commit=0,commit=0,commit=0,commit=0,commit=0


but once I use the wireless connection, it disconnects by itself. It disconnects even with a simple ping command
      Code:
[60422.280053] wlan0: deauthenticated from 00:16:b6:dd:ee:gg (Reason: 7)
[60422.299127] cfg80211: Calling CRDA to update world regulatory domain
[60422.601249] cfg80211: World regulatory domain updated:
[60422.601252] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[60422.601256] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[60422.601259] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[60422.601263] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[60422.601266] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[60422.601269] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[60422.601635] cfg80211: Calling CRDA for country: US
[60422.609205] cfg80211: Regulatory domain changed to country: US
[60422.609209] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[60422.609213] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[60422.609216] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[60422.609219] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[60422.609222] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[60422.609225] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[60422.609228] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[60422.784449] ADDRCONF(NETDEV_UP): wlan0: link is not ready
I have two options to connect again. Either wait for half a minute to a whole minute to connect itself, or open a terminal and use `wpa_client reassociate` (as root, or user)
      Code:

[60444.090798] wlan0: authenticate with 00:16:b6:dd:ee:gg (try 1)
[60444.092800] wlan0: authenticated
[60444.092883] wlan0: associate with 00:16:b6:dd:ee:gg (try 1)
[60444.095391] wlan0: RX AssocResp from 00:16:b6:dd:ee:gg (capab=0x411 status=0 aid=3)
[60444.095400] wlan0: associated
[60444.097557] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: Wireless disconnects after resume from stand-by  PostPosted: 01.10.2011, 19:33



Joined: 2010-09-19
Posts: 167

Status: Offline
      Code:
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port [8086:27a1] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 3 [8086:27d4] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 4 [8086:27d6] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 02)
00:1f.2 SATA controller [0106]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller [8086:27c5] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 02)
01:00.0 VGA compatible controller [0300]: nVidia Corporation G72M [GeForce Go 7200] [10de:01d6] (rev a1)
05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
08:08.0 Ethernet controller [0200]: Intel Corporation PRO/100 VE Network Connection [8086:1092] (rev 02)
08:09.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832]
08:09.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
08:09.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 0a)
08:09.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 05


      Code:
auto lo
iface lo inet loopback

allow-hotplug wlan0
iface wlan0 inet manual
        wpa-driver wext
        wpa-roam /etc/wpa_supplicant/wpa-roam.conf

iface default inet dhcp

iface home inet static
        address 192.168.1.xxx
        broadcast 192.168.1.255
        # opendns
        dns-nameservers 75.75.75.75 192.168.1.1 208.67.222.222 8.8.8.8
        dns-search hsd1.va.comcast.net
        gateway 192.168.1.1
        netmask 255.255.255.0
        network 192.168.1.0

iface homedhcp inet dhcp
 dns-nameserver 75.75.75.75 192.168.1.1 208.67.222.222 8.8.8.8

iface outside  inet dhcp


      Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        key_mgmt=NONE
}

network={
        ssid="linksys_SES"
        bssid=00:16:b6:xx:xx:xx
        psk="xxx"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        priority=850
        disabled=0
        id_str="home"
}

network={
        ssid="linksys_SES"
        bssid=00:16:b6:xx:xx:xx
        psk="xxx"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        priority=925
        disabled=0
        id_str="homedhcp"
}

network={
        ssid=""
        scan_ssid=1
        key_mgmt=NONE
        auth_alg=OPEN
        priority=5
        disabled=0
        id_str="outside"
}

network={
        ssid="610n24"
        bssid=68:7f:74:xx:xx:xx
        psk="ddddd"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP WEP104 WEP40
        priority=800
        disabled=0
}
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: Wireless disconnects after resume from stand-by  PostPosted: 11.10.2011, 00:59



Joined: 2010-09-19
Posts: 167

Status: Offline
A temporary fix is to run wpa_cli reconfigure or wpa_cli reassociate as soon the laptop resume, so I made a debian package with the below file:
      Code:
#!/bin/bash
# Lat
# /etc/pm/sleep.d/80wpa_reassociate_fix
# This script belongs to wpareassociate-resume package
# resume - This is a workaround to make the wireless to reassociate with
# the router everytime it resumes from sleep
# bad hack

case "$1" in
        hibernate|suspend|suspend_hybrid)
                ;;
        thaw|resume)
                testp="$( ping -c2 -w 2 8.8.8.8 1>/dev/null ; echo $? )"
                if [[ "${testp}" == "1" ]] ; then
                  #/sbin/wpa_cli  reassociate
                  /sbin/wpa_cli reconfigure
                fi
                ;;
        *) exit 1
                ;;
esac

exit 0
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio