Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
šumskiOffline
Post subject:   PostPosted: 02.10.2011, 09:42



Joined: 2011-09-30
Posts: 11
Location: Zagreb, Croatia
Status: Offline
Are you building master or 4.7.x ? Master kdelibs are frozen for 1~1/2 month - KDE devs are currently working on frameworks (what will be KDE 5.0) - there are new repos: nepomuk core are activities - for kde-workspace master you will need libkactivities , for 4.7.x everething should be supplied with kdelibs 4.7.x.

Post the entire cmake log so we can see what's missing
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 02.10.2011, 10:40



Joined: 2010-09-11
Posts: 183

Status: Offline
I am trying to build master currently. Here is the cmake configure logfile for kde-workspace. http://paste.pocoo.org/show/485943/

If master is not really compilable atm, I could try to switch to 4.7.x instead.

Thanks,
arwa
 
 View user's profile Send private message  
Reply with quote Back to top
šumskiOffline
Post subject:   PostPosted: 02.10.2011, 10:51



Joined: 2011-09-30
Posts: 11
Location: Zagreb, Croatia
Status: Offline
CMake Error at CMakeLists.txt:20 (find_package):
Could not find module FindKActivities.cmake or a configuration file for
package KActivities.

You will nedd libkactivities for kde-workspace master. Don't know if kdesrc-build can build them
 
 View user's profile Send private message  
Reply with quote Back to top
šumskiOffline
Post subject:   PostPosted: 02.10.2011, 11:04



Joined: 2011-09-30
Posts: 11
Location: Zagreb, Croatia
Status: Offline
https://projects.kde.org/projects/extra ... ample#L240
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 02.10.2011, 11:57



Joined: 2010-09-11
Posts: 183

Status: Offline
Yes, kactivities might be the problem. But as quoted in my first comment this does not build because of the unknown 'Agent'. Perhaps the problem is, that nepomuk might be taken from my sid-installation first?

-- Found Nepomuk: /usr/lib/libnepomuk.so;/home/foo/kde/lib/libsoprano.so

I will check out the example configuration. Thanks so far.

arwa
 
 View user's profile Send private message  
Reply with quote Back to top
šumskiOffline
Post subject:   PostPosted: 02.10.2011, 12:44



Joined: 2011-09-30
Posts: 11
Location: Zagreb, Croatia
Status: Offline
Yeah, both nepomuk and s-d-o are from packaged sources - try adding nepomuk-core before kactivities:

use-modules akonadi kdepimlibs nepomuk-core kactivities kde-workspace
 
 View user's profile Send private message  
Reply with quote Back to top
šumskiOffline
Post subject:   PostPosted: 02.10.2011, 12:52



Joined: 2011-09-30
Posts: 11
Location: Zagreb, Croatia
Status: Offline
Well, if there is someone interested , here are the packages:
https://spideroak.com/share/ON2W243LNE/ ... format=zip

-dev packages:
https://spideroak.com/share/ON2W243LNE/ ... format=zip

-dbg packages:
https://spideroak.com/share/ON2W243LNE/ ... format=zip

Built everything except kde-edu and kde-bindings
Unfortunately (not for me Smile ) - packages are built without pulseaudio support, v1.0 is not recognized by KDE.
Also, packages are built with shared-desktop-ontologies from experimental.
What i changed from debian/* - built soprano against raptor2 not raptor1 (as suggested by Nepomuk/Soprano dev S. Truegg), and built kde-workspace against libgl - not GLES (GLES only works for free drivers, not proprietary NVIDIA and fglrx)
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 02.10.2011, 16:44



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
adding pulse 1.0 support should be mentioned in a bug report
 
 View user's profile Send private message  
Reply with quote Back to top
arwaOffline
Post subject:   PostPosted: 02.10.2011, 16:59



Joined: 2010-09-11
Posts: 183

Status: Offline
Man, this is complicated. Thanks, šumski. I added the nepomuk-core. This required the ontologies that are configured in your linked example configuration for kdebuild-src. With this nepomuk-core can be configured, but it does not compile:
      Code:

[ 79%] [ 80%] Building CXX object services/backupsync/service/CMakeFiles/nepomukbackupsync.dir/backup
syncservice.o
Building CXX object services/backupsync/gui/CMakeFiles/nepomukbackup.dir/backupwizardpages.cpp.o
Linking CXX shared module ../../lib/nepomukfileindexer.so
/usr/bin/ld: cannot find -lnepomukdatamanagement
collect2: ld returned 1 exit status
make[2]: *** [lib/nepomukfileindexer.so] Error 1
make[1]: *** [services/fileindexer/CMakeFiles/nepomukfileindexer.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 80%] Building CXX object services/backupsync/gui/CMakeFiles/nepomukbackup.dir/backupwizard.cpp.o

Well, I have got no idea what the nepomukdatamanagement is and where it should come from. Some googling and searching the kde projects web page gave no info on this.
 
 View user's profile Send private message  
Reply with quote Back to top
šumskiOffline
Post subject:   PostPosted: 02.10.2011, 17:31



Joined: 2011-09-30
Posts: 11
Location: Zagreb, Croatia
Status: Offline
Nepomukdatamanagement is in kde-runtime Very Happy
I suggest you to check kde-forums for possible answers-

@DeepDayze
Will do that
https://bugs.gentoo.org/show_bug.cgi?id=384693
 
 View user's profile Send private message  
Reply with quote Back to top
Mte90Offline
Post subject:   PostPosted: 31.10.2011, 13:47



Joined: 2010-09-14
Posts: 51
Location: Rieti
Status: Offline
news?

_________________
I'm an italian Aptosid user!!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
detaosOffline
Post subject:   PostPosted: 31.10.2011, 20:43
Team Member


Joined: 2010-08-26
Posts: 166
Location: floating in the ether
Status: Offline
it's not ready yet Wink

_________________
#aptosid-art ftw!
(what would cleary do?)
 
 View user's profile Send private message Send e-mail Visit poster's website  
Reply with quote Back to top
belzeOffline
Post subject:   PostPosted: 04.11.2011, 18:58



Joined: 2010-09-13
Posts: 100

Status: Offline
i am really looking forward to have it in debian! i try new version on my arch box and kde 4.7 (kdepim 4.7) has a very useful feature: google calendar sync! Even multiple calendars! I just can't understand why any packager write a single line blog post with the following text: "we are working on it, we have some problem with $problem1, stay tuned"...it is not hard to do. I just can't understand all that silence...just a little bit more of communication will not hurt!
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject:   PostPosted: 04.11.2011, 20:37



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
I have tested KDE 4.7.2 in Sabayon 7 (a Gentoo based distro) and it looks good but downside still has some stability bugs on nepomuk/akonadi but its being worked on from what I been reading on the forums
 
 View user's profile Send private message  
Reply with quote Back to top
hefeeOffline
Post subject:   PostPosted: 04.11.2011, 21:38



Joined: 2010-09-14
Posts: 26

Status: Offline
I met the core developer treug, btw. a very nice guy, of nepomuk and he is really on the way to a zero bug nepomuk. See his blog http://trueg.wordpress.com/2011/11/02/k ... y-release/

The akonadi is a complitly diffrent field:) The kdepim people are now happy to have released the akonadi based kontact suite - it like the kde 4.0 release - Now many bugs are filed against the akonadi... It'll take time to get rock soild Smile
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio