Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: strange printing problem  PostPosted: 31.10.2011, 00:26



Joined: 2010-09-12
Posts: 318

Status: Offline
Dear all.

I have a really strange printing problem.

I can printing almost anything fine, but LaTeX generated PDFs or DVIs are printed "shifted up". (The top is cut off and there is a large empty margin at the bottom.) The files preview just fine in okular or acroread. Converting to PS does not change the problem. (The PS shows just fine with gv too.)

I don't have to generate the PDF myself. For instance, the file http://cran.r-project.org/doc/manuals/R-intro.pdf (which seems to be generated by LaTeX) has the problem. (While www.irs.gov/pub/irs-pdf/fw4.pdf prints correctly. So, it is not a PDF problem.)

I am not sure when the problem started, but it was recently, like last month or so. (I could print LaTeX files perfectly before.)

Does any one have any idea of what the problem could be?

Some info on my system:

      Code:

root@debian[/home/finotti]# infobash -v3
Host/Kernel/OS  "debian" running Linux 3.0-7.slh.1-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]
CPU Info        2x Intel Core2 Duo E8400 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2999.578 MHz ]
Videocard       nVidia G86 [GeForce 8500 GT]  X.Org 1.11.1.901  [ 1280x1024@50.0hz ]
Network cards   nVidia MCP55
                nVidia MCP55
Processes 178 | Uptime 11:27 | Memory 3085.9/8005.4MB | HDD WDC WD1500ADFD-0,ST31000528AS,WDC WD1001FALS-0,WDC WD10EALS-00Z Size 3150GB (42%used) | GLX Renderer GeForce 8500 GT/PCI/SSE2 | GLX Version 3.3.0 NVIDIA 275.28 | Client Shell | Infobash v3.37


Printer:
      Code:

Description:   HP LaserJet 3055
Location:   Luis's Office
Driver:   HP LaserJet 3055, hpcups 3.11.5 (color, 2-sided printing)
Connection:   socket://192.168.2.140
Defaults:   job-sheets=none, none media=na_letter_8.5x11in sides=one-sided


Thanks,

Luis

P.S.: I am not sure why the first url tag is not working...

Edit: fixed url tag. (Thanks, CaesarTjalbo.)


Last edited by finotti on 31.10.2011, 19:14; edited 2 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
CaesarTjalboOffline
Post subject: Re: strange printing problem  PostPosted: 31.10.2011, 18:54



Joined: 2010-09-13
Posts: 95
Location: Enschede
Status: Offline
"Works fine here (R)" (I printed a few pages from Okular)

      finotti wrote:
P.S.: I am not sure why the first url tag is not working...
perhaps because the forum software checks for a www or http.
[url]cran.r-project.org/doc/manuals/R-intro.pdf[/url]
http://cran.r-project.org/doc/manuals/R-intro.pdf
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: strange printing problem  PostPosted: 31.10.2011, 19:21



Joined: 2010-09-12
Posts: 318

Status: Offline
      CaesarTjalbo wrote:
"Works fine here (R)" (I printed a few pages from Okular)


I greatly appreciate you checking. May I ask what printer/driver did you use?

I just checked, and my laptop, also running up to date aptosid, prints fine at work (with a different HP printer):

      Code:

Description:   HP LaserJet Professional P1606dn
Location:   Office
Driver:   HP LaserJet Professional p1606dn hpijs, 3.11.7, requires proprietary plugin (color, 2-sided printing)
Connection:   hp:/usb/HP_LaserJet_Professional_P1606dn?serial=000000000QQ0CE82SI1c
Defaults:   job-sheets=none, none media=na_letter_8.5x11in sides=one-sided


(And thanks for the comment on the url tag also.)

So, it seems like the driver for my home printer is messing things up somehow...

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
kb0haeOffline
Post subject: RE: Re: strange printing problem  PostPosted: 01.11.2011, 01:49



Joined: 2010-09-12
Posts: 50

Status: Offline
Hi. My HP printer has several drivers listed. A couple of times after a d-u, the driver that I had selected had been changed. This caused double-sided printing not to work until I changed the driver back. If there is more than 1 driver listed for your printe, try them all.

How do PDF files generated by other programs print?
 
 View user's profile Send private message  
Reply with quote Back to top
CaesarTjalboOffline
Post subject: Re: strange printing problem  PostPosted: 01.11.2011, 19:17



Joined: 2010-09-13
Posts: 95
Location: Enschede
Status: Offline
      finotti wrote:
what printer/driver did you use?
Brother DCP-6690CW, proprietary drivers.

      finotti wrote:
So, it seems like the driver for my home printer is messing things up somehow...
Reasonable conclusion, especially if different programs show the same thing (i.e. it's not just Okular). Perhaps comb through the settings in the print-dialog and Cups once more?

(what did you use to generate the printer info output?)
 
 View user's profile Send private message  
Reply with quote Back to top
clubexOffline
Post subject: RE: Re: strange printing problem  PostPosted: 02.11.2011, 10:56



Joined: 2010-09-11
Posts: 98

Status: Offline
In my experience with Brother printers, when errors occur, it always seems necessary to completely purge and reinstall the driver. I can't say whether this is also necessary with other makes of printer but I don't suppose it can do any harm and is worth a try. .
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: Re: strange printing problem  PostPosted: 02.11.2011, 13:26



Joined: 2010-09-12
Posts: 318

Status: Offline
Thanks for all the comments. I will try to remove and add the printer again, as suggested, and see if there are other drivers to try. (I used CUPS to get the printer info: http://localhost:631/printers/name_of_the_printer.)

PDFs generated by other programs seem to work fine. (Like the IRS form from the original post.) It just seems so odd the only PDFs (and DVIs) generated by LaTeX print badly, while the viewers have no problem with it...

I will report back after I try the suggestions, but thanks all for the input.

Best,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio