Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
mheyesOffline
15 Post subject: [SOLVED] Transition to perl 5.14  PostPosted: 13.11.2011, 14:52



Joined: 2011-02-10
Posts: 40

Status: Offline
In case you don't subscribe to debian-devel, be aware of the upcoming transition to perl 5.14:

From: Dominic Hargreaves <dom>
Subject: Upcoming perl 5.14 transition
Date: November 13, 2011 8:59:19 AM EST
To: debian-devel@lists.debian.org
Cc: debian-release@lists.debian.org, debian-perl@lists.debian.org

As per #637809, I plan to upload perl 5.14 to unstable soon (maybe today,
depending on how some last bits of testing go). Like last time, this
will mean that a large number (~ 470) of packages will need to be binNMUed
by the release team. I'm sure they would appreciate uploads for these
packages being avoided once the rebuilds start, so that the transition
isn't interrupted, so I hope that this heads-up is useful. If this is
likely to cause any serious problems for anyone, let me know ASAP.
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: Transition to perl 5.14  PostPosted: 13.11.2011, 15:46



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
Sounds like fun...sid's about to get a little temperamental again soon Smile
 
 View user's profile Send private message  
Reply with quote Back to top
gutterslobOffline
Post subject: RE: Transition to perl 5.14  PostPosted: 13.11.2011, 16:21



Joined: 2010-12-25
Posts: 42
Location: Wandering
Status: Offline
Oh boy ... here we go again.
Last time there was a major Perl upgrade, my urxvt broke >_<
 
 View user's profile Send private message  
Reply with quote Back to top
barbasla
Post subject: upgrade want to remove ceni and other 59 packages  PostPosted: 13.11.2011, 22:52



Joined: 2011-01-27
Posts: 41

What is happening?
Thank you.
Hello.

Very Happy

The following packages will be REMOVED:
apt-show-versions aspell ceni clamtk debconf-i18n dictionaries-common dmakms hplip hplip-cups hyphen-de hyphen-en-us hyphen-it icoutils irssi kscreensaver-xsavers libapt-pkg-perl libbit-vector-perl libcairo-perl
libcurses-perl libcurses-ui-perl libdate-calc-perl libexpect-perl libglib-perl libgtk2-perl libhpmud0 libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl libhttp-message-perl libhttp-negotiate-perl
libio-pty-perl libio-socket-ssl-perl liblocale-gettext-perl liblwp-protocol-https-perl libnet-dns-perl libnet-ssleay-perl libpango-perl libperl5.12 libproc-processtable-perl libpurple0 libsane-hpaio libsnmp15
libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libwww-perl module-assistant myspell-de-de myspell-en-us myspell-it openoffice.org-hyphenation-de
openoffice.org-hyphenation-en-us openoffice.org-hyphenation-it qutecom siduxcc siduxcc-common speakup-source xscreensaver-data-extra xscreensaver-screensaver-bsod
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: upgrade want to remove ceni and other 59 packages  PostPosted: 13.11.2011, 23:05



Joined: 2010-08-25
Posts: 689

Status: Offline
It's also called perl transition, just wait a day, or two, for it to go through.
 
 View user's profile Send private message  
Reply with quote Back to top
gutterslobOffline
Post subject: RE: Transition to perl 5.14  PostPosted: 14.11.2011, 00:12



Joined: 2010-12-25
Posts: 42
Location: Wandering
Status: Offline
Yup, it's started..... as expected, d-u want's to remove stuff I need so I'll hold off for now.

      Code:
[Mon 11/11/14 08:10 SGT][pts/1][i686/linux-gnu/3.1-1.slh.1-aptosid-686][4.3.12]
<geezer>
zsh/2 1494 % su
Password:
root@sid:/home/geezer# apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  abiword aspell ceni debconf-i18n dictionaries-common elinks hpijs hpijs-ppds hplip-cups irssi irssi-scripts libabiword-2.8 libabiword-2.9 libaudio-scrobbler-perl libcurses-perl libcurses-ui-perl libdbi-perl libenchant1c2a
  libexpect-perl libhpmud0 libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl libhttp-message-perl libhttp-negotiate-perl libio-pty-perl libio-socket-ssl-perl liblocale-gettext-perl liblwp-protocol-https-perl libnet-ssleay-perl
  libperl5.12 libsane-hpaio libsexy2 libsnmp15 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libwebkitgtk-3.0-0 libwww-perl libxml-parser-perl module-assistant myspell-de-de myspell-en-us
  rxvt-unicode-256color weechat-plugins weechat-scripts zenity
The following NEW packages will be installed:
  libclass-isa-perl libswitch-perl linux-headers-3.1-1.slh.2-aptosid-686 linux-image-3.1-1.slh.2-aptosid-686
The following packages will be upgraded:
  linux-headers-2.6-aptosid-686 linux-headers-aptosid-686 linux-image-2.6-aptosid-686 linux-image-aptosid-686 perl perl-base perl-modules
7 upgraded, 4 newly installed, 48 to remove and 0 not upgraded.
Need to get 35.3 MB of archives.
After this operation, 4,744 kB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.
 
 View user's profile Send private message  
Reply with quote Back to top
DeepDayzeOffline
Post subject: RE: Transition to perl 5.14  PostPosted: 14.11.2011, 00:16



Joined: 2010-09-11
Posts: 616
Location: USA
Status: Offline
And I'm sure there will be other transitions planned that will make Sid quite fun Very Happy
 
 View user's profile Send private message  
Reply with quote Back to top
elboy71Offline
Post subject: DU wants to remove KDE essentials  PostPosted: 14.11.2011, 05:29



Joined: 2011-05-17
Posts: 23

Status: Offline
After last DU attempt:

      Code:
The following packages will be REMOVED:
  akregator amarok aptosid-art-kde aptosid-art-kde-imera aptosid-art-kdm-imera aptosid-art-ksplash-imera aptosid-irc aptosid-settings-kde ark aspell basket
  bluedevil ceni debsums dictionaries-common digikam dolphin gwenview hpijs hpijs-ppds hplip hplip-cups hplip-gui hyphen-de hyphen-en-us icoutils irssi k3b k9copy
  kate kbattleship kcalc kcharselect kde-plasma-desktop kde-window-manager kdeadmin kdebase-apps kdebase-bin kdebase-runtime kdebase-workspace
  kdebase-workspace-bin kdelibs5-plugins kdelirc kdemultimedia-kio-plugins kdenlive kdepasswd kdepim-groupware kdepim-kresources kdepim-runtime kdepim-wizards kdf
  kdm kfind kget kgpg khelpcenter4 kipi-plugins klipper kmahjongg kmail kmix kmymoney knemo koffice-libs konq-plugins konqueror konsole konversation kopete kpat
  kppp krdc kremotecontrol kreversi krita krusader ksnapshot ksysguard ksystemlog ktorrent kuser kwalletmanager kwrite libaudio-xmmsclient-perl libcurses-perl
  libcurses-ui-perl libenchant1c2a libexpect-perl libfile-fnmatch-perl libhpmud0 libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl libhttp-message-perl
  libhttp-negotiate-perl libio-pty-perl libio-socket-ssl-perl libkdepim4 libkopete4 liblwp-protocol-https-perl libmessagelist4 libnet-ssleay-perl libperl5.12
  libreoffice-kde libsane-hpaio libsnmp15 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libwebkitgtk-3.0-0 libwww-perl
  module-assistant myspell-de-de myspell-en-us mythes-de mythes-en-us okular plasma-dataengines-workspace plasma-desktop plasma-widgets-workspace playonlinux
  rekonq skanlite systemsettings yakuake zenity
The following NEW packages will be installed:
  libclass-isa-perl linux-headers-3.1-1.slh.2-aptosid-amd64 linux-image-3.1-1.slh.2-aptosid-amd64 weechat-core weechat-curses
The following packages will be upgraded:
  aptosid-manual-common aptosid-manual-de aptosid-manual-en cups cups-bsd cups-client cups-common cups-ppdc gconf2 gconf2-common gparted grub-common
  grub-efi-amd64-bin grub-pc grub-pc-bin grub2-common gzip kmymoney-common libcups2 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libgconf2-4
  libgtk2.0-0 libgtk2.0-common libmlt++3 libmlt-data libmlt4 libroar-compat1 libroar1 linux-headers-aptosid-amd64 linux-image-aptosid-amd64 melt memtest86+ perl
  perl-base perl-modules sudo tar
41 upgraded, 5 newly installed, 127 to remove and 0 not upgraded.
Need to get 87.6 MB of archives.
After this operation, 288 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
root@aptosidbox:/home/oscar#
Maybe we have to wait a little bit more...
 
 View user's profile Send private message  
Reply with quote Back to top
allywilsonOffline
Post subject: RE: DU wants to remove KDE essentials  PostPosted: 14.11.2011, 06:46



Joined: 2011-11-14
Posts: 1

Status: Offline
Stupidly, I missed that...

So now I'm on LXDE again.
 
 View user's profile Send private message  
Reply with quote Back to top
oddballOffline
Post subject: RE: upgrade want to remove ceni and other 59 packages  PostPosted: 14.11.2011, 09:56



Joined: 2010-09-11
Posts: 107
Location: Skåne, Sweden
Status: Offline
I think this and similar should be in a d-u warning on the front side
 
 View user's profile Send private message  
Reply with quote Back to top
drbOffline
Post subject: aptosid-art-kde error  PostPosted: 14.11.2011, 10:19



Joined: 2010-09-11
Posts: 96

Status: Offline
      Code:
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 aptosid-art-kde : Depends: aptosid-art-kde-ponos but it is not going to be installed or
                            aptosid-art-kde-theme
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


Got this today
 
 View user's profile Send private message  
Reply with quote Back to top
SpaceferretOffline
Post subject: RE: aptosid-art-kde error  PostPosted: 14.11.2011, 12:53



Joined: 2010-09-13
Posts: 97

Status: Offline
Confirm, same thing here
 
 View user's profile Send private message  
Reply with quote Back to top
belzeOffline
Post subject: RE: DU wants to remove KDE essentials  PostPosted: 14.11.2011, 13:27



Joined: 2010-09-13
Posts: 100

Status: Offline
same here. do someone know whar is the package causing this situation?
 
 View user's profile Send private message  
Reply with quote Back to top
SordonOffline
Post subject: RE: DU wants to remove KDE essentials  PostPosted: 14.11.2011, 14:23



Joined: 2010-09-13
Posts: 54

Status: Offline
It is the transition to perl 5.14
 
 View user's profile Send private message  
Reply with quote Back to top
redsidOffline
Post subject:   PostPosted: 14.11.2011, 15:56



Joined: 2011-02-08
Posts: 32
Location: Lake Otsego
Status: Offline
I see it's panic time again! People that don't understand in spite of apt-get screaming at them.
People that haven't learned how to put pkg's on hold. Other than the 3 Perl pkg's, my computers are
up to date. Sure, I could wait, but I wanted a particular pkg update.
I'm going to keep saying it folks; a lot of you should try a non-volatile distribution! Or are you
closet masochists?
Am I expecting too much?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio