Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
RitaG.Offline
Post subject: [solved] slow d/l speed  PostPosted: 27.11.2011, 19:54



Joined: 2010-09-18
Posts: 44

Status: Offline
3.1-2.slh.3-aptosid-amd64 KDE

the download speed i'm getting with aptosid is 1/3 the d/l speed of the other operating system (other partition) on same computer.

how do i correct this?


Last edited by RitaG. on 11.12.2011, 15:04; edited 3 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: slow d/l speed  PostPosted: 27.11.2011, 20:12
Team Member


Joined: 2010-08-26
Posts: 255

Status: Offline
What network card/chip are you using ("infobash -v 3" should help though don't forget to say if you are using wired or wireless)?

If it is wireless can/have you tried hooking up a wire temporarily to narrow down the problem and if you did was that the same speed or back to "normal"?

Finally saying what sort of speeds you are talking about might also help people figure out what it could be.
 
 View user's profile Send private message  
Reply with quote Back to top
RitaG.Offline
Post subject: RE: slow d/l speed  PostPosted: 28.11.2011, 00:21



Joined: 2010-09-18
Posts: 44

Status: Offline
Marvell Yukon Optima 88E8059 [PCIe Gigabit with AVB]

wired

just tested: 9.03Mbps d/l
other system: 34.99Mbps d/l
 
 View user's profile Send private message  
Reply with quote Back to top
RitaG.Offline
Post subject: RE: slow d/l speed  PostPosted: 29.11.2011, 17:14



Joined: 2010-09-18
Posts: 44

Status: Offline
nobody huh?

guess i'll just re-install.
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: slow d/l speed  PostPosted: 29.11.2011, 19:45



Joined: 2010-10-01
Posts: 185
Location: Bay state
Status: Offline
Looks the same as issue reported here. Controller stuck at 10 Mb/s speed. You can check with:
      Code:
dmesg | grep -i duplex
ethtool eth0

To get it to full speed:
      Code:
ethtool -s eth0 advertise 0x008

Replace "eth0" with whatever the network interface name is.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
RitaG.Offline
Post subject: RE: slow d/l speed  PostPosted: 30.11.2011, 00:08



Joined: 2010-09-18
Posts: 44

Status: Offline
thank you alexk.

you saved me from re-installing.

you're the 'sweetie of the day'!
 
 View user's profile Send private message  
Reply with quote Back to top
RitaG.Offline
Post subject: RE: slow d/l speed  PostPosted: 01.12.2011, 00:07



Joined: 2010-09-18
Posts: 44

Status: Offline
only 1 problem..

whenever i restart aptosid, i have to run those 2 commands again in order to get normal d/l speed.

any way to make it permanent?
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: slow d/l speed  PostPosted: 01.12.2011, 03:17



Joined: 2010-10-01
Posts: 185
Location: Bay state
Status: Offline
You should only need the ethtool command. AFAIK you could put in into /etc/rc.local to make it run at each boot.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
RitaG.Offline
Post subject: Re: RE: slow d/l speed  PostPosted: 11.12.2011, 15:03



Joined: 2010-09-18
Posts: 44

Status: Offline
      alexk wrote:
you could put in into /etc/rc.local to make it run at each boot.

thank you alexk, that worked nicely!
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio