Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
CarnophageOffline
Post subject: [FIXED] lxdm-binary uses 100% cpu  PostPosted: 31.03.2012, 19:06



Joined: 2010-09-12
Posts: 59

Status: Offline
Anyone else uses lxdm from the http://w3you.com/debian/ repository?
Today I got back home after 2 weeks away and after dist-upgrade lxdm-binary uses the whole core right from the start.

The list of updated packages is unfortunately quiet big:
http://wklej.org/hash/85d69304f1/

tail /var/log/lxdm.log:
      Code:
X.Org X Server 1.11.4
Release Date: 2012-01-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-1-amd64 x86_64 Debian
Current Operating System: Linux deska 3.2-11.slh.2-aptosid-amd64 #1 SMP PREEMPT Thu Mar 15 01:33:53 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2-11.slh.2-aptosid-amd64 root=UUID=b0202d6d-8854-4b48-9563-671f7d1018a8 ro quiet
Build Date: 04 March 2012  11:42:13PM
xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.24.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 31 20:53:30 2012
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "nv" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
resize called 1280 800
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
** Message: add 0x23254a0

** Message: prepare greeter on :0

** Message: start greeter on :0


(lxdm-greeter-gtk:2825): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(lxdm-greeter-gtk:2825): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
resize called 1280 800
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slamOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 01.04.2012, 07:38
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Sorry, can not reproduce the problem here.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
CarnophageOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 01.04.2012, 09:56



Joined: 2010-09-12
Posts: 59

Status: Offline
I found some bugr eports @launchpad:
https://bugs.launchpad.net/ubuntu/+sour ... bug/901407
https://bugs.launchpad.net/ubuntu/+sour ... bug/922363
But I can't really connect them to my situation.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slamOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 01.04.2012, 11:00
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
While Upstream, the Ubuntu packager and me have synced our code base and patches used, Ubuntu bug reports are not relevant for us in Debian/Aptosid.
Please try to completely dist-upgrade today, and check if the problem persists.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
CarnophageOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 01.04.2012, 11:13



Joined: 2010-09-12
Posts: 59

Status: Offline
Yeah I know that they are not relevant for Aptosid, but I just wanted to look if anyone elase was having similar problems.

Unfortunately it does.

      Code:
Host/Kernel/OS  "deska" running Linux 3.3-0.slh.6-aptosid-amd64 x86_64 [ sidux 2009-04 Μόρος - xfce - (200912310312) ]
CPU Info        2x Intel Core2 Duo T6600 @ 2048 KB cache flags( sse3 ht nx lm ) clocked at [ 2200.000 MHz ]
Videocard       NVIDIA G96 [GeForce 9600M GS]  X.Org 1.11.4  [ 1280x800@60.0hz ]
Network cards   Broadcom NetLink BCM5906M Fast PCI Express
                Intel PRO/Wireless 5100 AGN [Shiloh]
Processes 130 | Uptime 1:10 | Memory 503.7/3927.9MB | HDD WDC WD5000BEVT-2 Size 500GB (21%used) | GLX Renderer Gallium 0.4 on NV96 | GLX Version Yes | Client Shell | Infobash v3.45
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
CarnophageOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 01.04.2012, 17:16



Joined: 2010-09-12
Posts: 59

Status: Offline
@slam:
Would You be so kind to waste a minute to check if Your lxdm includes the following patch: https://bugs.archlinux.org/task/29220

At least in the sources found here: http://lab.aptosid.com/svn/lxde/lxdm/ it's not included (no idea if they are they same as used to build package in Your repo).
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slamOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 03.04.2012, 18:21
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
I will rebuild LXDM this weekend including this patch: http://apt.klaumikli.de/testing/lxdm_0. ... 86.changes
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
CarnophageOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 09.04.2012, 15:03



Joined: 2010-09-12
Posts: 59

Status: Offline
Any luck with the packaging?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slamOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 17.04.2012, 09:12
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Upgraded packages are available in my repo now, bug is fixed: http://w3you.com/debian/pool/main/l/lxdm/
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
CarnophageOffline
Post subject: RE: lxdm-binary uses 100% cpu  PostPosted: 17.04.2012, 16:51



Joined: 2010-09-12
Posts: 59

Status: Offline
Thanks a lot.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio