Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
pumrelOffline
Post subject: cifs mount error  PostPosted: 02.06.2012, 11:16



Joined: 2010-09-14
Posts: 117
Location: Czech Republic
Status: Offline
I have this line in /etc/fstab
      Code:
//192.168.2.118/Volume_1   /media/ULOZISTE   cifs      credentials=/etc/cifs_pwd,nls=utf8,nounix,noserverino,users,auto   0   0



When I try to mount it from the console I get this:
      Code:
root@desktop-aptosid:/home/petr# mount --verbose /media/ULOZISTE/
mount.cifs kernel mount options: ip=192.168.2.118,unc=\\192.168.2.118\Volume_1,noexec,nosuid,nodev,credentials=/etc/cifs_pwd,nls=utf8,nounix,noserverino,ver=1,user=petr,pass=********
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


It's not very useful.
I don't understand what I am doing wrong. It used to work. Maybe some changes in a package?

_________________
Petr
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slhOffline
Post subject: RE: cifs mount error  PostPosted: 02.06.2012, 23:34



Joined: 2010-08-25
Posts: 737

Status: Offline
Please try mounting by hand, to pinpoint the issue a bit more - a very simple test succeeds for me:
      Code:
# mount -t cifs -o username=<user> //<server>/<share> /mnt/
add one option after another, until you find the one mount.cifs chokes on.

Also make sure to have cifs-utils >= 2:5.4-2 installed.
 
 View user's profile Send private message  
Reply with quote Back to top
pumrelOffline
Post subject:   PostPosted: 13.06.2012, 18:02



Joined: 2010-09-14
Posts: 117
Location: Czech Republic
Status: Offline
Ok, so this is really strange. Even with no argument it shows me the error

      Code:
root@desktop-aptosid:/home/petr# mount -t cifs -o username=petr //192.168.2.118/Volume_1 /media/ULOZISTE/
Password:
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

      Code:
root@desktop-aptosid:/home/petr# apt-cache policy cifs-utils
cifs-utils:
  Instalovaná verze: 2:5.5-1
  Kandidát:          2:5.5-1
  Tabulka verzí:
 *** 2:5.5-1 0
        500 http://ftp.cz.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2:5.4-2 0
        500 http://ftp.cz.debian.org/debian/ wheezy/main amd64 Packages
     2:4.5-2+squeeze1 0
        500 http://ftp.cz.debian.org/debian/ squeeze/main amd64 Packages
root@desktop-aptosid:/home/petr#
[/code]

_________________
Petr
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 13.06.2012, 19:00



Joined: 2010-08-25
Posts: 737

Status: Offline
      Code:
# mount -t cifs -o username=<remote_username> //<server_name>/<share_name /mnt
works for me, with cifs-utils 2:5.5-1.
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 14.06.2012, 05:56



Joined: 2010-09-13
Posts: 497
Location: Pößneck / Thüringen
Status: Offline
Taken from the manpage mount.cifs, the option is user=<remote_username> not username=<remote_username> and works flawly eith the recent cifs-utils.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 14.06.2012, 15:42



Joined: 2010-08-25
Posts: 737

Status: Offline
MOUNT.CIFS(8)
      Code:
Note
               The cifs vfs accepts the parameter user=, or for users familiar with smbfs it
               accepts the longer form of the parameter username=. Similarly the longer smbfs
               style parameter names may be accepted as synonyms for the shorter cifs
               parameters pass=,dom= and cred=.
q.e.d.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio