Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [solved] multi-arch problems  PostPosted: 12.08.2012, 15:31



Joined: 2010-09-12
Posts: 312

Status: Offline
Dear all,

I am having problems DUing my system:

      Code:

root@debian[/home/finotti]# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqt4-core : Depends: libqt4-dbus (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
               Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
               Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
               Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-dbus : Depends: qdbus (= 4:4.8.2-2)
               Breaks: libqt4-dbus:i386 (!= 4:4.8.2-2) but 4:4.8.2-2+b1 is installed
 libqt4-dbus:i386 : Breaks: libqt4-dbus (!= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-declarative : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
                      Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-designer : Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
                   Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-help : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
               Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-network : Breaks: libqt4-network:i386 (!= 4:4.8.2-2) but 4:4.8.2-2+b1 is installed
 libqt4-network:i386 : Breaks: libqt4-network (!= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-opengl : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-qt3support : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
                     Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
                     Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-script : Depends: libqt4-dbus (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
                 Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-scripttools : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-sql : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-sql-mysql : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-sql-sqlite : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-svg : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-test : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-xml : Breaks: libqt4-xml:i386 (!= 4:4.8.2-2) but 4:4.8.2-2+b1 is installed
 libqt4-xml:i386 : Breaks: libqt4-xml (!= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqt4-xmlpatterns : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
                      Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqtcore4 : Breaks: libqtcore4:i386 (!= 4:4.8.2-2) but 4:4.8.2-2+b1 is installed
 libqtcore4:i386 : Breaks: libqtcore4 (!= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqtgui4 : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
             Breaks: libqtgui4:i386 (!= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
 libqtgui4:i386 : Depends: libqtcore4:i386 (= 4:4.8.2-2) but 4:4.8.2-2+b1 is installed
                  Breaks: libqtgui4 (!= 4:4.8.2-2) but 4:4.8.2-2+b1 is installed
 qdbus : Depends: libqt4-dbus (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
         Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
         Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2-2 is installed
E: Unmet dependencies. Try using -f.


      Code:

root@debian[/home/finotti]# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqt4-dbus libqt4-network libqt4-xml libqtcore4 libqtgui4:i386
Suggested packages:
  qt4-qtconfig:i386
The following packages will be upgraded:
  libqt4-dbus libqt4-network libqt4-xml libqtcore4 libqtgui4:i386
5 upgraded, 0 newly installed, 0 to remove and 21 not upgraded.
21 not fully installed or removed.
Need to get 0 B/9,750 kB of archives.
After this operation, 178 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 490442 files and directories currently installed.)
Preparing to replace libqt4-network:amd64 4:4.8.2-2 (using .../libqt4-network_4%3a4.8.2-2+b1_amd64.deb) ...
Unpacking replacement libqt4-network:amd64 ...
dpkg: error processing /var/cache/apt/archives/libqt4-network_4%3a4.8.2-2+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqt4-network/changelog.Debian.gz', which is different from other instances of package libqt4-network:amd64
Preparing to replace libqt4-dbus:amd64 4:4.8.2-2 (using .../libqt4-dbus_4%3a4.8.2-2+b1_amd64.deb) ...
Unpacking replacement libqt4-dbus:amd64 ...
dpkg: error processing /var/cache/apt/archives/libqt4-dbus_4%3a4.8.2-2+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqt4-dbus/changelog.Debian.gz', which is different from other instances of package libqt4-dbus:amd64
Preparing to replace libqt4-xml:amd64 4:4.8.2-2 (using .../libqt4-xml_4%3a4.8.2-2+b1_amd64.deb) ...
Unpacking replacement libqt4-xml:amd64 ...
dpkg: error processing /var/cache/apt/archives/libqt4-xml_4%3a4.8.2-2+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqt4-xml/changelog.Debian.gz', which is different from other instances of package libqt4-xml:amd64
Preparing to replace libqtgui4:i386 4:4.8.2-2 (using .../libqtgui4_4%3a4.8.2-2+b1_i386.deb) ...
Unpacking replacement libqtgui4:i386 ...
dpkg: error processing /var/cache/apt/archives/libqtgui4_4%3a4.8.2-2+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqtgui4/changelog.Debian.gz', which is different from other instances of package libqtgui4:i386
Preparing to replace libqtcore4:amd64 4:4.8.2-2 (using .../libqtcore4_4%3a4.8.2-2+b1_amd64.deb) ...
Unpacking replacement libqtcore4:amd64 ...
dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.2-2+b1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqtcore4/changelog.Debian.gz', which is different from other instances of package libqtcore4:amd64
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-network_4%3a4.8.2-2+b1_amd64.deb
 /var/cache/apt/archives/libqt4-dbus_4%3a4.8.2-2+b1_amd64.deb
 /var/cache/apt/archives/libqt4-xml_4%3a4.8.2-2+b1_amd64.deb
 /var/cache/apt/archives/libqtgui4_4%3a4.8.2-2+b1_i386.deb
 /var/cache/apt/archives/libqtcore4_4%3a4.8.2-2+b1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


      Code:

root@debian[/home/finotti]# dpkg --configure -a
dpkg: error processing libqtgui4:amd64 (--configure):
 package libqtgui4:amd64 4:4.8.2-2+b1 cannot be configured because libqtgui4:i386 is at a different version (4:4.8.2-2)
dpkg: dependency problems prevent configuration of libqt4-sql-sqlite:amd64:
 libqt4-sql-sqlite:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-sql-sqlite:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:amd64:
 libqt4-sql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-sql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:amd64:
 libqt4-declarative:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2-2.
 libqt4-declarative:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-declarative:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-declarative:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:amd64:
 libqt4-svg:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-svg:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-svg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqtcore4:i386 (--configure):
 package libqtcore4:i386 4:4.8.2-2+b1 cannot be configured because libqtcore4:amd64 is at a different version (4:4.8.2-2)
dpkg: error processing libqt4-network:i386 (--configure):
 package libqt4-network:i386 4:4.8.2-2+b1 cannot be configured because libqt4-network:amd64 is at a different version (4:4.8.2-2)
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:amd64:
 libqt4-sql-mysql:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-mysql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-sql-mysql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-script:amd64:
 libqt4-script:amd64 depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2-2.
 libqt4-script:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-script:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqt4-dbus:i386 (--configure):
 package libqt4-dbus:i386 4:4.8.2-2+b1 cannot be configured because libqt4-dbus:amd64 is at a different version (4:4.8.2-2)
dpkg: dependency problems prevent configuration of libqt4-opengl:amd64:
 libqt4-opengl:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-opengl:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-opengl:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-designer:amd64:
 libqt4-designer:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-designer:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2-2.
 libqt4-designer:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-designer:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-designer:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:amd64:
 libqt4-help:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2-2.
 libqt4-help:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-help:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-help:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-help:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:amd64:
 libqt4-scripttools:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-scripttools:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-scripttools:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-scripttools:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qdbus:
 qdbus depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2-2.
 qdbus depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2-2.
 qdbus depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing qdbus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-core:
 libqt4-core depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2-2.
 libqt4-core depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2-2.
 libqt4-core depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-core depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2-2.
 libqt4-core depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:amd64:
 libqt4-qt3support:amd64 depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2-2.
 libqt4-qt3support:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2-2.
 libqt4-qt3support:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.
 libqt4-qt3support:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-qt3support:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqt4-xml:i386 (--configure):
 package libqt4-xml:i386 4:4.8.2-2+b1 cannot be configured because libqt4-xml:amd64 is at a different version (4:4.8.2-2)
dpkg: dependency problems prevent configuration of libqt4-test:amd64:
 libqt4-test:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-test:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:amd64:
 libqt4-xmlpatterns:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2-2.
 libqt4-xmlpatterns:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2-2.

dpkg: error processing libqt4-xmlpatterns:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-gui:
 libqt4-gui depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-gui depends on libqt4-opengl (= 4:4.8.2-2+b1); however:
  Package libqt4-opengl:amd64 is not configured yet.
 libqt4-gui depends on libqt4-svg (= 4:4.8.2-2+b1); however:
  Package libqt4-svg:amd64 is not configured yet.
 libqt4-gui depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-gui (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqtgui4:amd64
 libqt4-sql-sqlite:amd64
 libqt4-sql:amd64
 libqt4-declarative:amd64
 libqt4-svg:amd64
 libqtcore4:i386
 libqt4-network:i386
 libqt4-sql-mysql:amd64
 libqt4-script:amd64
 libqt4-dbus:i386
 libqt4-opengl:amd64
 libqt4-designer:amd64
 libqt4-help:amd64
 libqt4-scripttools:amd64
 qdbus
 libqt4-core
 libqt4-qt3support:amd64
 libqt4-xml:i386
 libqt4-test:amd64
 libqt4-xmlpatterns:amd64
 libqt4-gui


Here is some info on the computer:

      Code:

root@debian[/home/finotti]# infobash -v3
Host/Kernel/OS  "debian" running Linux 3.5-1.slh.2-aptosid-amd64 x86_64 [ aptosid 2010-02 Κῆρες - kde-full - (201009132215) ]
CPU Info        2x Intel Core2 Duo E8400 @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2999.853 MHz ]
Videocard       NVIDIA G86 [GeForce 8500 GT]     [  ]
Network cards   NVIDIA MCP55
                NVIDIA MCP55
                NETGEAR WNA WNA1100
Processes 166 | Uptime 16:35 | Memory 1877.7/7991.2MB | HDD WDC WD1500ADFD-0,ST31000528AS,WDC WD1001FALS-0,WDC WD10EALS-00Z Size 3150GB (47%used) | Client Shell | Infobash v3.45


Any help would be greatly appreciated!

Luis


Last edited by finotti on 27.08.2012, 13:16; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: multi-arch problems  PostPosted: 12.08.2012, 15:36



Joined: 2010-08-25
Posts: 731

Status: Offline
Multi-Arch strictly enforces the same version for concurrently installed packages from different architectures, this breaks on BinNMUs. There are several suggestions for fixing these problems (for BinNMUs in particular, the same source version will always be enforced), but right now this is a limitation of m-a.

There is no solution to this, other than waiting until it fixes itself (either if i386 gets the same BinNMU in a subsequent mirror pulse or if a sourceful 'BinNMU' gets done in a couple of days).

This remains to be a serious problem with multi-arch in practice in pre-release wheezy and testing/unstable in general, but might be possible to handle in stable once it gets released (very few changes, ignoring security updates stage in .point upgrades and in a way that allows synchronization prior to stable releases). Therefore the practical BinNMU handling is in need of changing soon.
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: multi-arch problems  PostPosted: 12.08.2012, 20:27
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
In this specific case I wonder through why you have QT packages for i386 installed. Does anything depend on it?
(I presume something does, I am just interested what it is)

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: multi-arch problems  PostPosted: 13.08.2012, 08:46



Joined: 2010-09-12
Posts: 312

Status: Offline
Thanks for the replies. I will wait and see...

      DonKult wrote:
In this specific case I wonder through why you have QT packages for i386 installed. Does anything depend on it?
(I presume something does, I am just interested what it is)


I'm pretty sure it's Skype.

Thanks again,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 24.08.2012, 15:14



Joined: 2010-09-12
Posts: 312

Status: Offline
OK, still no fix for this... Is there a simple way to purge all i386 packages (and things that depend on it)? As it is now, I can't install anything or DU.
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 25.08.2012, 08:58
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
Newer versions for these packages are online for a while now, are you sure you are trying with the latest version(s)? I can't test it right now, but it should work (tm).

Regarding removing all :i386 packages:
      Code:
apt-get remove ^.*$:i386 -o pkgProblemResolver::FixByInstall=0

This has A LOT of output as it selects all packages from i386 and will notify you that these aren't installed. Ignore this. Important is the "usual" output about removes. You will find in there also everything depending on these i386 packages, like wine or skype.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 25.08.2012, 11:06



Joined: 2010-09-12
Posts: 312

Status: Offline
APT still cannot install it:

      Code:

root@debian[/home/finotti]# apdud
Ign http://dl.google.com stable InRelease
Get:1 http://ftp.us.debian.org experimental InRelease [162 kB]                                               
Get:2 http://mirror.yellowfiber.net sid InRelease [23.5 kB]                                                 
Get:3 http://dl.google.com stable Release.gpg [198 B]                                                       
Get:4 http://www.**removed**.org sid InRelease [32.6 kB]                                               
Get:5 http://dl.google.com stable Release                                                                   
Ign http://frickelplatz.de sid InRelease                                                                     
Get:6 http://dl.google.com stable/main amd64 Packages [774 B]                                               
Get:7 http://dl.google.com stable/main i386 Packages [776 B]                                                 
Hit http://www.**removed**.org sid/main amd64 Packages/DiffIndex                                       
Hit http://frickelplatz.de sid Release.gpg                                                                   
Get:8 http://mirror.yellowfiber.net sid/main amd64 Packages [27.7 kB]                                 
Get:9 http://www.**removed**.org sid/non-free amd64 Packages/DiffIndex [1,057 B]                       
Hit http://frickelplatz.de sid Release                                                                       
Get:10 http://ftp.us.debian.org sid InRelease [249 kB]                                                       
Get:11 http://mirror.yellowfiber.net sid/fix.main amd64 Packages [14 B]                                     
Hit http://www.**removed**.org sid/main i386 Packages/DiffIndex                                       
Hit http://frickelplatz.de sid/main amd64 Packages                                                           
Get:12 http://mirror.yellowfiber.net sid/main i386 Packages [27.8 kB]                                       
Get:13 http://www.**removed**.org sid/non-free i386 Packages/DiffIndex [1,195 B]                       
Hit http://frickelplatz.de sid/contrib amd64 Packages                                                       
Hit http://frickelplatz.de sid/non-free amd64 Packages                                                       
Get:14 http://mirror.yellowfiber.net sid/fix.main i386 Packages [14 B]                                       
Hit http://frickelplatz.de sid/main i386 Packages                                                           
Ign http://dl.google.com stable/main Translation-en_US                                                       
Hit http://frickelplatz.de sid/contrib i386 Packages                                                 
Ign http://dl.google.com stable/main Translation-en                                                     
Hit http://frickelplatz.de sid/non-free i386 Packages                                                       
Get:15 http://ftp.us.debian.org testing InRelease [199 kB]                                 
Get:16 http://www.**removed**.org sid/non-free amd64 2012-08-25-0159.49.pdiff [75 B]       
Get:17 http://www.**removed**.org sid/non-free amd64 2012-08-25-0159.49.pdiff [75 B]                   
Get:18 http://www.**removed**.org sid/non-free i386 2012-08-25-0159.49.pdiff [115 B]                   
Get:19 http://www.**removed**.org sid/non-free i386 2012-08-25-0159.49.pdiff [115 B]                   
Get:20 http://ftp.us.debian.org experimental/main amd64 Packages/DiffIndex [7,819 B]                         
Hit http://ftp.us.debian.org experimental/contrib amd64 Packages/DiffIndex                       
Hit http://ftp.us.debian.org experimental/non-free amd64 Packages/DiffIndex                                 
Get:21 http://ftp.us.debian.org experimental/main i386 Packages/DiffIndex [7,819 B]                         
Ign http://mirror.yellowfiber.net sid/fix.main Translation-en_US                                 
Ign http://mirror.yellowfiber.net sid/fix.main Translation-en                                     
Ign http://mirror.yellowfiber.net sid/main Translation-en_US                     
Hit http://ftp.us.debian.org experimental/contrib i386 Packages/DiffIndex                                   
Ign http://mirror.yellowfiber.net sid/main Translation-en                                                   
Hit http://ftp.us.debian.org experimental/non-free i386 Packages/DiffIndex                                   
Hit http://ftp.us.debian.org experimental/contrib Translation-en/DiffIndex                                   
Ign http://www.**removed**.org sid/main Translation-en_US                                             
Hit http://ftp.us.debian.org experimental/main Translation-en/DiffIndex                                     
Ign http://www.**removed**.org sid/main Translation-en                                                 
Hit http://ftp.us.debian.org experimental/non-free Translation-en/DiffIndex                                 
Ign http://www.**removed**.org sid/non-free Translation-en_US                                         
Get:22 http://ftp.us.debian.org sid/main amd64 Packages/DiffIndex [7,876 B]                                 
Ign http://www.**removed**.org sid/non-free Translation-en                                             
Hit http://ftp.us.debian.org sid/contrib amd64 Packages/DiffIndex                                           
Hit http://ftp.us.debian.org sid/non-free amd64 Packages/DiffIndex                                           
Get:23 http://ftp.us.debian.org sid/main i386 Packages/DiffIndex [7,876 B]                                   
Hit http://ftp.us.debian.org sid/contrib i386 Packages/DiffIndex                                             
Ign http://frickelplatz.de sid/contrib Translation-en_US                                                     
Hit http://ftp.us.debian.org sid/non-free i386 Packages/DiffIndex                                           
Ign http://frickelplatz.de sid/contrib Translation-en                                                       
Hit http://ftp.us.debian.org sid/contrib Translation-en/DiffIndex                                           
Ign http://frickelplatz.de sid/main Translation-en_US                                                       
Ign http://frickelplatz.de sid/main Translation-en                                                           
Hit http://ftp.us.debian.org sid/main Translation-en/DiffIndex                                               
Ign http://frickelplatz.de sid/non-free Translation-en_US                                                   
Hit http://ftp.us.debian.org sid/non-free Translation-en/DiffIndex                                           
Ign http://frickelplatz.de sid/non-free Translation-en                                                       
Get:24 http://ftp.us.debian.org testing/main amd64 Packages/DiffIndex [7,876 B]                             
Hit http://ftp.us.debian.org testing/contrib amd64 Packages/DiffIndex                                       
Hit http://ftp.us.debian.org testing/non-free amd64 Packages/DiffIndex                                       
Get:25 http://ftp.us.debian.org testing/main i386 Packages/DiffIndex [7,876 B]                               
Hit http://ftp.us.debian.org testing/contrib i386 Packages/DiffIndex                                         
Hit http://ftp.us.debian.org testing/non-free i386 Packages/DiffIndex                                       
Hit http://ftp.us.debian.org testing/contrib Translation-en/DiffIndex                                       
Hit http://ftp.us.debian.org testing/main Translation-en/DiffIndex                                           
Hit http://ftp.us.debian.org testing/non-free Translation-en/DiffIndex                                       
Get:26 http://ftp.us.debian.org experimental/main amd64 2012-08-25-0811.40.pdiff [488 B]                     
Get:27 http://ftp.us.debian.org experimental/main amd64 2012-08-25-0811.40.pdiff [488 B]                     
Get:28 http://ftp.us.debian.org experimental/main i386 2012-08-25-0211.15.pdiff [852 B]                     
Get:29 http://ftp.us.debian.org experimental/main i386 2012-08-25-0211.15.pdiff [852 B]                     
Get:30 http://ftp.us.debian.org sid/main amd64 2012-08-25-0211.15.pdiff [6,962 B]                           
Get:31 http://ftp.us.debian.org sid/main amd64 2012-08-25-0211.15.pdiff [6,962 B]                           
Get:32 http://ftp.us.debian.org sid/main i386 2012-08-25-0211.15.pdiff [7,151 B]                             
Get:33 http://ftp.us.debian.org testing/main amd64 2012-08-25-0211.15.pdiff [10.1 kB]                       
Get:34 http://ftp.us.debian.org testing/main i386 2012-08-25-0211.15.pdiff [10.3 kB]                         
Get:35 http://ftp.us.debian.org sid/main i386 2012-08-25-0211.15.pdiff [7,151 B]                             
Get:36 http://ftp.us.debian.org experimental/main i386 2012-08-25-0811.40.pdiff [487 B]                     
Get:37 http://ftp.us.debian.org sid/main amd64 2012-08-25-0811.40.pdiff [1,994 B]                           
Get:38 http://ftp.us.debian.org testing/main amd64 2012-08-25-0211.15.pdiff [10.1 kB]                       
Get:39 http://ftp.us.debian.org sid/main i386 2012-08-25-0811.40.pdiff [1,992 B]                             
Get:40 http://ftp.us.debian.org testing/main i386 2012-08-25-0211.15.pdiff [10.3 kB]                         
Get:41 http://ftp.us.debian.org experimental/main i386 2012-08-25-0811.40.pdiff [487 B]                     
Get:42 http://ftp.us.debian.org sid/main amd64 2012-08-25-0811.40.pdiff [1,994 B]                           
Get:43 http://ftp.us.debian.org sid/main i386 2012-08-25-0811.40.pdiff [1,992 B]                             
Fetched 815 kB in 21s (37.1 kB/s)                                                                           
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqt4-core : Depends: libqt4-dbus (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
               Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
               Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
               Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-dbus : Depends: qdbus (= 4:4.8.2+dfsg-1)
               Breaks: libqt4-dbus:i386 (!= 4:4.8.2+dfsg-1) but 4:4.8.2-2+b1 is installed
 libqt4-dbus:i386 : Breaks: libqt4-dbus (!= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-declarative : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
                      Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-designer : Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
                   Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-help : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
               Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-network : Breaks: libqt4-network:i386 (!= 4:4.8.2+dfsg-1) but 4:4.8.2-2+b1 is installed
 libqt4-network:i386 : Breaks: libqt4-network (!= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-opengl : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-qt3support : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
                     Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
                     Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-script : Depends: libqt4-dbus (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
                 Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-scripttools : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-sql : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-sql-mysql : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-sql-sqlite : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-svg : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-test : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-xml : Breaks: libqt4-xml:i386 (!= 4:4.8.2+dfsg-1) but 4:4.8.2-2+b1 is installed
 libqt4-xml:i386 : Breaks: libqt4-xml (!= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqt4-xmlpatterns : Depends: libqt4-network (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
                      Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqtcore4 : Breaks: libqtcore4:i386 (!= 4:4.8.2+dfsg-1) but 4:4.8.2-2+b1 is installed
 libqtcore4:i386 : Breaks: libqtcore4 (!= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqtgui4 : Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
             Breaks: libqtgui4:i386 (!= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
 libqtgui4:i386 : Depends: libqtcore4:i386 (= 4:4.8.2+dfsg-1) but 4:4.8.2-2+b1 is installed
                  Breaks: libqtgui4 (!= 4:4.8.2+dfsg-1) but 4:4.8.2-2+b1 is installed
 qdbus : Depends: libqt4-dbus (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
         Depends: libqt4-xml (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
         Depends: libqtcore4 (= 4:4.8.2-2+b1) but 4:4.8.2+dfsg-1 is installed
E: Unmet dependencies. Try using -f.


      Code:

root@debian[/home/finotti]# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqt4-core libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-gui libqt4-help libqt4-network:i386
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml:i386 libqt4-xmlpatterns libqtcore4:i386 libqtgui4
  qdbus
Suggested packages:
  libqt4-declarative-folderlistmodel libqt4-declarative-gestures libqt4-declarative-particles
  libqt4-declarative-shaders qt4-qmlviewer libqt4-dev libicu48:i386 qt4-qtconfig
The following packages will be upgraded:
  libqt4-core libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-gui libqt4-help libqt4-network:i386
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml:i386 libqt4-xmlpatterns libqtcore4:i386 libqtgui4
  qdbus
21 upgraded, 0 newly installed, 0 to remove and 165 not upgraded.
26 not fully installed or removed.
Need to get 0 B/16.3 MB of archives.
After this operation, 763 kB of additional disk space will be used.
Do you want to continue [Y/n]?
dpkg: error processing libqtcore4:amd64 (--configure):
 package libqtcore4:amd64 4:4.8.2+dfsg-1 cannot be configured because libqtcore4:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqtcore4:i386 (--configure):
 package libqtcore4:i386 4:4.8.2-2+b1 cannot be configured because libqtcore4:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: error processing libqt4-xml:amd64 (--configure):
 package libqt4-xml:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-xml:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-xml:i386 (--configure):
 package libqt4-xml:i386 4:4.8.2-2+b1 cannot be configured because libqt4-xml:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: error processing libqt4-dbus:amd64 (--configure):
 package libqt4-dbus:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-dbus:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-dbus:i386 (--configure):
 package libqt4-dbus:i386 4:4.8.2-2+b1 cannot be configured because libqt4-dbus:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of qdbus:
 qdbus depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 qdbus depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 qdbus depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing qdbus (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqt4-network:amd64 (--configure):
 package libqt4-network:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-network:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-network:i386 (--configure):
 package libqt4-network:i386 4:4.8.2-2+b1 cannot be configured because libqt4-network:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-script:amd64:
 libqt4-script:amd64 depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-script:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-script:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:amd64:
 libqt4-sql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:amd64:
 libqt4-xmlpatterns:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-xmlpatterns:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-xmlpatterns:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqtgui4:amd64 (--configure):
 package libqtgui4:amd64 4:4.8.2-2+b1 cannot be configured because libqtgui4:i386 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-declarative:amd64:
 libqt4-declarative:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-declarative:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqt4-xmlpatterns (= 4:4.8.2-2+b1); however:
  Package libqt4-xmlpatterns:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-declarative:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-declarative:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-designer:amd64:
 libqt4-designer:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-designer:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-designer:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-designer:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-designer:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:amd64:
 libqt4-qt3support:amd64 depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-qt3support:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:amd64:
 libqt4-help:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-help:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-help:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-help:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-help:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:amd64:
 libqt4-test:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-test:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:amd64:
 libqt4-scripttools:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-scripttools:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-scripttools:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-scripttools:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-sqlite:amd64:
 libqt4-sql-sqlite:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-sqlite:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql-sqlite:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:amd64:
 libqt4-sql-mysql:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-mysql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql-mysql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:amd64:
 libqt4-opengl:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-opengl:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-opengl:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-core:
 libqt4-core depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-core depends on libqt4-test (= 4:4.8.2-2+b1); however:
  Package libqt4-test:amd64 is not configured yet.
 libqt4-core depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:amd64:
 libqt4-svg:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-svg:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-svg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-gui:
 libqt4-gui depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-gui depends on libqt4-opengl (= 4:4.8.2-2+b1); however:
  Package libqt4-opengl:amd64 is not configured yet.
 libqt4-gui depends on libqt4-svg (= 4:4.8.2-2+b1); however:
  Package libqt4-svg:amd64 is not configured yet.
 libqt4-gui depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-gui (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqtgui4:i386 (--configure):
 package libqtgui4:i386 4:4.8.2+dfsg-1 cannot be configured because libqtgui4:amd64 is at a different version (4:4.8.2-2+b1)
Errors were encountered while processing:
 libqtcore4:amd64
 libqtcore4:i386
 libqt4-xml:amd64
 libqt4-xml:i386
 libqt4-dbus:amd64
 libqt4-dbus:i386
 qdbus
 libqt4-network:amd64
 libqt4-network:i386
 libqt4-script:amd64
 libqt4-sql:amd64
 libqt4-xmlpatterns:amd64
 libqtgui4:amd64
 libqt4-declarative:amd64
 libqt4-designer:amd64
 libqt4-qt3support:amd64
 libqt4-help:amd64
 libqt4-test:amd64
 libqt4-scripttools:amd64
 libqt4-sql-sqlite:amd64
 libqt4-sql-mysql:amd64
 libqt4-opengl:amd64
 libqt4-core
 libqt4-svg:amd64
 libqt4-gui
 libqtgui4:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@debian[/home/finotti]# dpkg --configure -a
dpkg: error processing libqtgui4:amd64 (--configure):
 package libqtgui4:amd64 4:4.8.2-2+b1 cannot be configured because libqtgui4:i386 is at a different version (4:4.8.2+dfsg-1)
dpkg: error processing libqtgui4:i386 (--configure):
 package libqtgui4:i386 4:4.8.2+dfsg-1 cannot be configured because libqtgui4:amd64 is at a different version (4:4.8.2-2+b1)
dpkg: dependency problems prevent configuration of libqt4-sql-sqlite:amd64:
 libqt4-sql-sqlite:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql-sqlite:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:amd64:
 libqt4-sql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:amd64:
 libqt4-declarative:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-declarative:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-declarative:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-declarative:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:amd64:
 libqt4-svg:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-svg:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-svg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqtcore4:amd64 (--configure):
 package libqtcore4:amd64 4:4.8.2+dfsg-1 cannot be configured because libqtcore4:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqtcore4:i386 (--configure):
 package libqtcore4:i386 4:4.8.2-2+b1 cannot be configured because libqtcore4:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: error processing libqt4-network:amd64 (--configure):
 package libqt4-network:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-network:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-network:i386 (--configure):
 package libqt4-network:i386 4:4.8.2-2+b1 cannot be configured because libqt4-network:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:amd64:
 libqt4-sql-mysql:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-mysql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql-mysql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-script:amd64:
 libqt4-script:amd64 depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-script:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-script:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqt4-dbus:amd64 (--configure):
 package libqt4-dbus:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-dbus:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-dbus:i386 (--configure):
 package libqt4-dbus:i386 4:4.8.2-2+b1 cannot be configured because libqt4-dbus:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-opengl:amd64:
 libqt4-opengl:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-opengl:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-opengl:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-designer:amd64:
 libqt4-designer:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-designer:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-designer:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-designer:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-designer:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:amd64:
 libqt4-help:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-help:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-help:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-help:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-help:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:amd64:
 libqt4-scripttools:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-scripttools:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-scripttools:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-scripttools:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qdbus:
 qdbus depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 qdbus depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 qdbus depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing qdbus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-core:
 libqt4-core depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-core depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:amd64:
 libqt4-qt3support:amd64 depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-qt3support:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqt4-xml:amd64 (--configure):
 package libqt4-xml:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-xml:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-xml:i386 (--configure):
 package libqt4-xml:i386 4:4.8.2-2+b1 cannot be configured because libqt4-xml:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-test:amd64:
 libqt4-test:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-test:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:amd64:
 libqt4-xmlpatterns:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-xmlpatterns:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-xmlpatterns:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-gui:
 libqt4-gui depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-gui depends on libqt4-opengl (= 4:4.8.2-2+b1); however:
  Package libqt4-opengl:amd64 is not configured yet.
 libqt4-gui depends on libqt4-svg (= 4:4.8.2-2+b1); however:
  Package libqt4-svg:amd64 is not configured yet.
 libqt4-gui depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-gui (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqtgui4:amd64
 libqtgui4:i386
 libqt4-sql-sqlite:amd64
 libqt4-sql:amd64
 libqt4-declarative:amd64
 libqt4-svg:amd64
 libqtcore4:amd64
 libqtcore4:i386
 libqt4-network:amd64
 libqt4-network:i386
 libqt4-sql-mysql:amd64
 libqt4-script:amd64
 libqt4-dbus:amd64
 libqt4-dbus:i386
 libqt4-opengl:amd64
 libqt4-designer:amd64
 libqt4-help:amd64
 libqt4-scripttools:amd64
 qdbus
 libqt4-core
 libqt4-qt3support:amd64
 libqt4-xml:amd64
 libqt4-xml:i386
 libqt4-test:amd64
 libqt4-xmlpatterns:amd64
 libqt4-gui


Is there something else wrong here?

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 25.08.2012, 11:57
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
finotti, you have been running several dist-upgrades against 3rd-party repositories which is strongly depreciated - and most likely the reason for your problems. I really suggest a fresh install as those problems are not easy to sort out.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
DonKultOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 25.08.2012, 12:50
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
It is true that you have a LOT of third party repositories which quiet a few aren't even maintained anymore. This can cause a lot of problems similar to this one, e.g. as some of them contain wine packages you can end up with a very "funny" mixture which will not work (usually it just randomly segfaults). The same for this multimedia source you have. Do you really need it? Most people don't understand that MP3 and windows media files can be played without it out-of-the-box…

Anyway, multi-arch is new, so problems - especially the recovery from them - can be problematic for the tools (dpkg/APT). It would be cool if you could upload your /var/lib/dpkg/status file somewhere so I can play a bit with it to maybe be able to fix that for the future.

After that you can try
      Code:
apt-get dist-upgrade -f

Might be that this helps already. Otherwise getting temporary right of the :i386 packages could be an easy option to get out of the mess.

(The mess is that as dpkg says two different versions for the same package in different architectures are "installed" (and half-* and broken and what not is counting here) which is forbidden by multiarch)

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 25.08.2012, 13:38



Joined: 2010-09-12
Posts: 312

Status: Offline
Thanks for the replies.

Slam: I understand what you are saying and why you say it. It was a calculated risk and I might have to pay the price...

DonKult: Thanks for the support! My /var/lib/dpkg/status (before "apt-get dist-upgrade -f") can be found at http://www.math.utk.edu/~finotti/tmp/status.

"apt-get dist-upgrade -f" updated many packages (for the first time in a long time) but still failed to fix it. Here is a second issue (so that it is not as long), FWIW:

      Code:

root@debian[/home/finotti]# apt-get dist-upgrade -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following packages have been kept back:
  intel-microcode
The following packages will be upgraded:
  libqt4-core libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-gui libqt4-help libqt4-network:i386
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml:i386 libqt4-xmlpatterns libqtcore4:i386 libqtgui4
  qdbus
21 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
33 not fully installed or removed.
Need to get 0 B/16.3 MB of archives.
After this operation, 763 kB of additional disk space will be used.
Do you want to continue [Y/n]?
dpkg: error processing libqtcore4:amd64 (--configure):
 package libqtcore4:amd64 4:4.8.2+dfsg-1 cannot be configured because libqtcore4:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqtcore4:i386 (--configure):
 package libqtcore4:i386 4:4.8.2-2+b1 cannot be configured because libqtcore4:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: error processing libqt4-xml:amd64 (--configure):
 package libqt4-xml:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-xml:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-xml:i386 (--configure):
 package libqt4-xml:i386 4:4.8.2-2+b1 cannot be configured because libqt4-xml:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: error processing libqt4-dbus:amd64 (--configure):
 package libqt4-dbus:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-dbus:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-dbus:i386 (--configure):
 package libqt4-dbus:i386 4:4.8.2-2+b1 cannot be configured because libqt4-dbus:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of qdbus:
 qdbus depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 qdbus depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 qdbus depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing qdbus (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqt4-network:amd64 (--configure):
 package libqt4-network:amd64 4:4.8.2+dfsg-1 cannot be configured because libqt4-network:i386 is at a different version (4:4.8.2-2+b1)
dpkg: error processing libqt4-network:i386 (--configure):
 package libqt4-network:i386 4:4.8.2-2+b1 cannot be configured because libqt4-network:amd64 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-script:amd64:
 libqt4-script:amd64 depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-script:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-script:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:amd64:
 libqt4-sql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:amd64:
 libqt4-xmlpatterns:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-xmlpatterns:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-xmlpatterns:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqtgui4:amd64 (--configure):
 package libqtgui4:amd64 4:4.8.2-2+b1 cannot be configured because libqtgui4:i386 is at a different version (4:4.8.2+dfsg-1)
dpkg: dependency problems prevent configuration of libqt4-declarative:amd64:
 libqt4-declarative:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-declarative:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqt4-xmlpatterns (= 4:4.8.2-2+b1); however:
  Package libqt4-xmlpatterns:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-declarative:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-declarative:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-designer:amd64:
 libqt4-designer:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-designer:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-designer:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-designer:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-designer:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:amd64:
 libqt4-qt3support:amd64 depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-qt3support:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-qt3support:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:amd64:
 libqt4-help:amd64 depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-help:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-help:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-help:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-help:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:amd64:
 libqt4-test:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-test:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:amd64:
 libqt4-scripttools:amd64 depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-scripttools:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-scripttools:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-scripttools:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-sqlite:amd64:
 libqt4-sql-sqlite:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-sqlite:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql-sqlite:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:amd64:
 libqt4-sql-mysql:amd64 depends on libqt4-sql (= 4:4.8.2-2+b1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-mysql:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-sql-mysql:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:amd64:
 libqt4-opengl:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-opengl:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-opengl:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-core:
 libqt4-core depends on libqt4-dbus (= 4:4.8.2-2+b1); however:
  Version of libqt4-dbus:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqt4-network (= 4:4.8.2-2+b1); however:
  Version of libqt4-network:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqt4-script (= 4:4.8.2-2+b1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-core depends on libqt4-test (= 4:4.8.2-2+b1); however:
  Package libqt4-test:amd64 is not configured yet.
 libqt4-core depends on libqt4-xml (= 4:4.8.2-2+b1); however:
  Version of libqt4-xml:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-core depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.

dpkg: error processing libqt4-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:amd64:
 libqt4-svg:amd64 depends on libqtcore4 (= 4:4.8.2-2+b1); however:
  Version of libqtcore4:amd64 on system is 4:4.8.2+dfsg-1.
 libqt4-svg:amd64 depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-svg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-gui:
 libqt4-gui depends on libqt4-designer (= 4:4.8.2-2+b1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-gui depends on libqt4-opengl (= 4:4.8.2-2+b1); however:
  Package libqt4-opengl:amd64 is not configured yet.
 libqt4-gui depends on libqt4-svg (= 4:4.8.2-2+b1); however:
  Package libqt4-svg:amd64 is not configured yet.
 libqt4-gui depends on libqtgui4 (= 4:4.8.2-2+b1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libqt4-gui (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libqtgui4:i386 (--configure):
 package libqtgui4:i386 4:4.8.2+dfsg-1 cannot be configured because libqtgui4:amd64 is at a different version (4:4.8.2-2+b1)
dpkg: dependency problems prevent configuration of amarok-utils:
 amarok-utils depends on libqtcore4 (>= 4:4.8.0); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing amarok-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amarok:
 amarok depends on amarok-utils (= 2.6.0-1); however:
  Package amarok-utils is not configured yet.
 amarok depends on libqt4-dbus (>= 4:4.6.1); however:
  Package libqt4-dbus:amd64 is not configured yet.
 amarok depends on libqt4-network (>= 4:4.5.3); however:
  Package libqt4-network:amd64 is not configured yet.
 amarok depends on libqt4-opengl (>= 4:4.5.3); however:
  Package libqt4-opengl:amd64 is not configured yet.
 amarok depends on libqt4-script (>= 4:4.5.3); however:
  Package libqt4-script:amd64 is not configured yet.
 amarok depends on libqt4-sql (>= 4:4.5.3); however:
  Package libqt4-sql:amd64 is not configured yet.
 amarok depends on libqt4-svg (>= 4:4.5.3); however:
  Package libqt4-svg:amd64 is not configured yet.
 amarok depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml:amd64 is not configured yet.
 amarok depends on libqtcore4 (>= 4:4.8.0); however:
  Package libqtcore4:amd64 is not configured yet.
 amarok depends on libqt
dpkg: error processing amarok (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libk3b6:
 libk3b6 depends on libqt4-qt3support (>= 4:4.5.3); however:
  Package libqt4-qt3support:amd64 is not configured yet.
 libk3b6 depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml:amd64 is not configured yet.
 libk3b6 depends on libqtcore4 (>= 4:4.8.0); however:
  Package libqtcore4:amd64 is not configured yet.
 libk3b6 depends on libqtgui4 (>= 4:4.6.1); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libk3b6 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of k3b:
 k3b depends on libk3b6 (= 2.0.2-6); however:
  Package libk3b6 is not configured yet.
 k3b depends on libqt4-qt3support (>= 4:4.5.3); however:
  Package libqt4-qt3support:amd64 is not configured yet.
 k3b depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml:amd64 is not configured yet.
 k3b depends on libqtcore4 (>= 4:4.8.0); however:
  Package libqtcore4:amd64 is not configured yet.
 k3b depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing k3b (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libk3b6-extracodecs:
 libk3b6-extracodecs depends on libk3b6; however:
  Package libk3b6 is not configured yet.
 libk3b6-extracodecs depends on libqtcore4 (>= 4:4.7.0~beta1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libk3b6-extracodecs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-kde:
 libreoffice-kde depends on libqtcore4 (>= 4:4.8); however:
  Package libqtcore4:amd64 is not configured yet.
 libreoffice-kde depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing libreoffice-kde (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of phonon-backend-vlc:
 phonon-backend-vlc depends on libqtcore4 (>= 4:4.7.0~beta1); however:
  Package libqtcore4:amd64 is not configured yet.
 phonon-backend-vlc depends on libqtgui4 (>= 4:4.6.0); however:
  Package libqtgui4:amd64 is not configured yet.

dpkg: error processing phonon-backend-vlc (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqtcore4:amd64
 libqtcore4:i386
 libqt4-xml:amd64
 libqt4-xml:i386
 libqt4-dbus:amd64
 libqt4-dbus:i386
 qdbus
 libqt4-network:amd64
 libqt4-network:i386
 libqt4-script:amd64
 libqt4-sql:amd64
 libqt4-xmlpatterns:amd64
 libqtgui4:amd64
 libqt4-declarative:amd64
 libqt4-designer:amd64
 libqt4-qt3support:amd64
 libqt4-help:amd64
 libqt4-test:amd64
 libqt4-scripttools:amd64
 libqt4-sql-sqlite:amd64
 libqt4-sql-mysql:amd64
 libqt4-opengl:amd64
 libqt4-core
 libqt4-svg:amd64
 libqt4-gui
 libqtgui4:i386
 amarok-utils
 amarok
 libk3b6
 k3b
 libk3b6-extracodecs
 libreoffice-kde
 phonon-backend-vlc
E: Sub-process /usr/bin/dpkg returned an error code (1)


I am going to wait a little hoping for a new aptosid install version. Then I will get rid of i386 and see if it works OK. If not, then I have how to do a new installation...

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 25.08.2012, 21:13
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
Thanks for the status file. There is indeed some strange behavior going on in the recovery. I haven't found a fix yet and I can't really test that in my simulation here, but as far as I can see here is that APT is downloading packages, but isn't installing (aka unpacking) them because these packages are already unpacked (but in a different version) resulting in different versions for the same package (in different architectures) are unpacked which dpkg doesn't like.

But you can try this manually:
      Code:
apt-get clean
apt-get install -f -d
dpkg -i /var/cache/apt/archives/*.deb
dpkg --configure -a

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 26.08.2012, 00:37



Joined: 2010-09-12
Posts: 312

Status: Offline
Thanks, DonKult! That fixed it:

      Code:

root@debian[/home/finotti]# apt-get clean
root@debian[/home/finotti]# apt-get install -f -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqt4-core libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-gui libqt4-help libqt4-network:i386
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml:i386 libqt4-xmlpatterns libqtcore4:i386 libqtgui4
  qdbus
Suggested packages:
  libqt4-declarative-folderlistmodel libqt4-declarative-gestures libqt4-declarative-particles
  libqt4-declarative-shaders qt4-qmlviewer libqt4-dev libicu48:i386 qt4-qtconfig
The following packages will be upgraded:
  libqt4-core libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-gui libqt4-help libqt4-network:i386
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml:i386 libqt4-xmlpatterns libqtcore4:i386 libqtgui4
  qdbus
21 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
33 not fully installed or removed.
Need to get 16.3 MB of archives.
After this operation, 763 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.us.debian.org/debian/ sid/main libqt4-declarative amd64 4:4.8.2+dfsg-1 [1,103 kB]
Get:2 http://ftp.us.debian.org/debian/ sid/main libqt4-xmlpatterns amd64 4:4.8.2+dfsg-1 [1,048 kB]
Get:3 http://ftp.us.debian.org/debian/ sid/main libqt4-qt3support amd64 4:4.8.2+dfsg-1 [1,070 kB]
Get:4 http://ftp.us.debian.org/debian/ sid/main libqt4-help amd64 4:4.8.2+dfsg-1 [237 kB]
Get:5 http://ftp.us.debian.org/debian/ sid/main libqt4-opengl amd64 4:4.8.2+dfsg-1 [335 kB]
Get:6 http://ftp.us.debian.org/debian/ sid/main libqtgui4 amd64 4:4.8.2+dfsg-1 [4,047 kB]
Get:7 http://ftp.us.debian.org/debian/ sid/main libqt4-test amd64 4:4.8.2+dfsg-1 [98.9 kB]                   
Get:8 http://ftp.us.debian.org/debian/ sid/main libqt4-sql-sqlite amd64 4:4.8.2+dfsg-1 [62.1 kB]             
Get:9 http://ftp.us.debian.org/debian/ sid/main libqt4-sql-mysql amd64 4:4.8.2+dfsg-1 [69.0 kB]             
Get:10 http://ftp.us.debian.org/debian/ sid/main libqt4-sql amd64 4:4.8.2+dfsg-1 [136 kB]                   
Get:11 http://ftp.us.debian.org/debian/ sid/main libqt4-scripttools amd64 4:4.8.2+dfsg-1 [255 kB]           
Get:12 http://ftp.us.debian.org/debian/ sid/main libqt4-script amd64 4:4.8.2+dfsg-1 [813 kB]                 
Get:13 http://ftp.us.debian.org/debian/ sid/main libqtcore4 i386 4:4.8.2+dfsg-1 [2,143 kB]                   
Get:14 http://ftp.us.debian.org/debian/ sid/main libqt4-gui amd64 4:4.8.2+dfsg-1 [44.5 kB]                   
Get:15 http://ftp.us.debian.org/debian/ sid/main libqt4-svg amd64 4:4.8.2+dfsg-1 [175 kB]                   
Get:16 http://ftp.us.debian.org/debian/ sid/main libqt4-designer amd64 4:4.8.2+dfsg-1 [3,644 kB]             
Get:17 http://ftp.us.debian.org/debian/ sid/main libqt4-xml i386 4:4.8.2+dfsg-1 [133 kB]                     
Get:18 http://ftp.us.debian.org/debian/ sid/main libqt4-dbus i386 4:4.8.2+dfsg-1 [225 kB]                   
Get:19 http://ftp.us.debian.org/debian/ sid/main libqt4-core amd64 4:4.8.2+dfsg-1 [44.5 kB]                 
Get:20 http://ftp.us.debian.org/debian/ sid/main libqt4-network i386 4:4.8.2+dfsg-1 [592 kB]                 
Get:21 http://ftp.us.debian.org/debian/ sid/main qdbus amd64 4:4.8.2+dfsg-1 [67.6 kB]                       
Fetched 16.3 MB in 19s (841 kB/s)                                                                           
Download complete and in download only mode


      Code:

root@debian[/home/finotti]# dpkg -i /var/cache/apt/archives/*.deb
(Reading database ... 505448 files and directories currently installed.)
Preparing to replace libqt4-core 4:4.8.2-2+b1 (using .../libqt4-core_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-core ...
Preparing to replace libqt4-dbus:i386 4:4.8.2-2+b1 (using .../libqt4-dbus_4%3a4.8.2+dfsg-1_i386.deb) ...
Unpacking replacement libqt4-dbus:i386 ...
Preparing to replace libqt4-declarative:amd64 4:4.8.2-2+b1 (using .../libqt4-declarative_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-declarative:amd64 ...
Preparing to replace libqt4-designer:amd64 4:4.8.2-2+b1 (using .../libqt4-designer_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-designer:amd64 ...
Preparing to replace libqt4-gui 4:4.8.2-2+b1 (using .../libqt4-gui_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-gui ...
Preparing to replace libqt4-help:amd64 4:4.8.2-2+b1 (using .../libqt4-help_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-help:amd64 ...
Preparing to replace libqt4-network:i386 4:4.8.2-2+b1 (using .../libqt4-network_4%3a4.8.2+dfsg-1_i386.deb) ...
Unpacking replacement libqt4-network:i386 ...
Preparing to replace libqt4-opengl:amd64 4:4.8.2-2+b1 (using .../libqt4-opengl_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-opengl:amd64 ...
Preparing to replace libqt4-qt3support:amd64 4:4.8.2-2+b1 (using .../libqt4-qt3support_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-qt3support:amd64 ...
Preparing to replace libqt4-script:amd64 4:4.8.2-2+b1 (using .../libqt4-script_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-script:amd64 ...
Preparing to replace libqt4-scripttools:amd64 4:4.8.2-2+b1 (using .../libqt4-scripttools_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-scripttools:amd64 ...
Preparing to replace libqt4-sql:amd64 4:4.8.2-2+b1 (using .../libqt4-sql_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-sql:amd64 ...
Preparing to replace libqt4-sql-mysql:amd64 4:4.8.2-2+b1 (using .../libqt4-sql-mysql_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-sql-mysql:amd64 ...
Preparing to replace libqt4-sql-sqlite:amd64 4:4.8.2-2+b1 (using .../libqt4-sql-sqlite_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-sql-sqlite:amd64 ...
Preparing to replace libqt4-svg:amd64 4:4.8.2-2+b1 (using .../libqt4-svg_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-svg:amd64 ...
Preparing to replace libqt4-test:amd64 4:4.8.2-2+b1 (using .../libqt4-test_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-test:amd64 ...
Preparing to replace libqt4-xml:i386 4:4.8.2-2+b1 (using .../libqt4-xml_4%3a4.8.2+dfsg-1_i386.deb) ...
Unpacking replacement libqt4-xml:i386 ...
Preparing to replace libqt4-xmlpatterns:amd64 4:4.8.2-2+b1 (using .../libqt4-xmlpatterns_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqt4-xmlpatterns:amd64 ...
Preparing to replace libqtcore4:i386 4:4.8.2-2+b1 (using .../libqtcore4_4%3a4.8.2+dfsg-1_i386.deb) ...
Unpacking replacement libqtcore4:i386 ...
Preparing to replace libqtgui4:amd64 4:4.8.2-2+b1 (using .../libqtgui4_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement libqtgui4:amd64 ...
Preparing to replace qdbus 4:4.8.2-2+b1 (using .../qdbus_4%3a4.8.2+dfsg-1_amd64.deb) ...
Unpacking replacement qdbus ...
dpkg: dependency problems prevent configuration of libqt4-core:
 libqt4-core depends on libqt4-dbus (= 4:4.8.2+dfsg-1); however:
  Package libqt4-dbus:amd64 is not configured yet.
 libqt4-core depends on libqt4-network (= 4:4.8.2+dfsg-1); however:
  Package libqt4-network:amd64 is not configured yet.
 libqt4-core depends on libqt4-xml (= 4:4.8.2+dfsg-1); however:
  Package libqt4-xml:amd64 is not configured yet.
 libqt4-core depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-core (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:amd64:
 libqt4-declarative:amd64 depends on libqt4-network (= 4:4.8.2+dfsg-1); however:
  Package libqt4-network:amd64 is not configured yet.
 libqt4-declarative:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-declarative:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-designer:amd64:
 libqt4-designer:amd64 depends on libqt4-xml (= 4:4.8.2+dfsg-1); however:
  Package libqt4-xml:amd64 is not configured yet.
 libqt4-designer:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-designer:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-gui:
 libqt4-gui depends on libqt4-designer (= 4:4.8.2+dfsg-1); however:
  Package libqt4-designer:amd64 is not configured yet.

dpkg: error processing libqt4-gui (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:amd64:
 libqt4-help:amd64 depends on libqt4-network (= 4:4.8.2+dfsg-1); however:
  Package libqt4-network:amd64 is not configured yet.
 libqt4-help:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-help:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:amd64:
 libqt4-opengl:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-opengl:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:amd64:
 libqt4-qt3support:amd64 depends on libqt4-designer (= 4:4.8.2+dfsg-1); however:
  Package libqt4-designer:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-network (= 4:4.8.2+dfsg-1); however:
  Package libqt4-network:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqt4-xml (= 4:4.8.2+dfsg-1); however:
  Package libqt4-xml:amd64 is not configured yet.
 libqt4-qt3support:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-qt3support:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-script:amd64:
 libqt4-script:amd64 depends on libqt4-dbus (= 4:4.8.2+dfsg-1); however:
  Package libqt4-dbus:amd64 is not configured yet.
 libqt4-script:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-script:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:amd64:
 libqt4-scripttools:amd64 depends on libqt4-script (= 4:4.8.2+dfsg-1); however:
  Package libqt4-script:amd64 is not configured yet.
 libqt4-scripttools:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-scripttools:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:amd64:
 libqt4-sql:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-sql:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-mysql:amd64:
 libqt4-sql-mysql:amd64 depends on libqt4-sql (= 4:4.8.2+dfsg-1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-mysql:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-sql-mysql:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql-sqlite:amd64:
 libqt4-sql-sqlite:amd64 depends on libqt4-sql (= 4:4.8.2+dfsg-1); however:
  Package libqt4-sql:amd64 is not configured yet.
 libqt4-sql-sqlite:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-sql-sqlite:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:amd64:
 libqt4-svg:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-svg:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:amd64:
 libqt4-test:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-test:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:amd64:
 libqt4-xmlpatterns:amd64 depends on libqt4-network (= 4:4.8.2+dfsg-1); however:
  Package libqt4-network:amd64 is not configured yet.
 libqt4-xmlpatterns:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqt4-xmlpatterns:amd64 (--install):
 dependency problems - leaving unconfigured
Setting up libqtcore4:i386 (4:4.8.2+dfsg-1) ...
dpkg: dependency problems prevent configuration of libqtgui4:amd64:
 libqtgui4:amd64 depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing libqtgui4:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qdbus:
 qdbus depends on libqt4-dbus (= 4:4.8.2+dfsg-1); however:
  Package libqt4-dbus:amd64 is not configured yet.
 qdbus depends on libqt4-xml (= 4:4.8.2+dfsg-1); however:
  Package libqt4-xml:amd64 is not configured yet.
 qdbus depends on libqtcore4 (= 4:4.8.2+dfsg-1); however:
  Package libqtcore4:amd64 is not configured yet.

dpkg: error processing qdbus (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-dbus:i386:
 libqt4-dbus:i386 depends on qdbus (= 4:4.8.2+dfsg-1); however:
  Package qdbus is not configured yet.

dpkg: error processing libqt4-dbus:i386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-network:i386:
 libqt4-network:i386 depends on libqt4-dbus (= 4:4.8.2+dfsg-1); however:
  Package libqt4-dbus:i386 is not configured yet.

dpkg: error processing libqt4-network:i386 (--install):
 dependency problems - leaving unconfigured
Setting up libqt4-xml:i386 (4:4.8.2+dfsg-1) ...
Processing triggers for man-db ...
Errors were encountered while processing:
 libqt4-core
 libqt4-declarative:amd64
 libqt4-designer:amd64
 libqt4-gui
 libqt4-help:amd64
 libqt4-opengl:amd64
 libqt4-qt3support:amd64
 libqt4-script:amd64
 libqt4-scripttools:amd64
 libqt4-sql:amd64
 libqt4-sql-mysql:amd64
 libqt4-sql-sqlite:amd64
 libqt4-svg:amd64
 libqt4-test:amd64
 libqt4-xmlpatterns:amd64
 libqtgui4:amd64
 qdbus
 libqt4-dbus:i386
 libqt4-network:i386


      Code:

root@debian[/home/finotti]# dpkg --configure -a
Setting up libqtgui4:i386 (4:4.8.2+dfsg-1) ...
Setting up libqtcore4:amd64 (4:4.8.2+dfsg-1) ...
Setting up amarok-utils (2.6.0-1) ...
Setting up libqt4-xml:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-test:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqtgui4:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-sql:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-svg:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-sql-mysql:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-opengl:amd64 (4:4.8.2+dfsg-1) ...
Setting up libreoffice-kde (1:3.5.4+dfsg-1) ...
Setting up phonon-backend-vlc (0.6.0-1) ...
Setting up libqt4-sql-sqlite:amd64 (4:4.8.2+dfsg-1) ...
Setting up qdbus (4:4.8.2+dfsg-1) ...
Setting up libqt4-dbus:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-dbus:i386 (4:4.8.2+dfsg-1) ...
Setting up libqt4-network:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-network:i386 (4:4.8.2+dfsg-1) ...
Setting up libqt4-script:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-designer:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-help:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-scripttools:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-core (4:4.8.2+dfsg-1) ...
Setting up amarok (2.6.0-1) ...
Setting up libqt4-qt3support:amd64 (4:4.8.2+dfsg-1) ...
Setting up libqt4-xmlpatterns:amd64 (4:4.8.2+dfsg-1) ...
Setting up libk3b6 (2.0.2-6) ...
Setting up libqt4-gui (4:4.8.2+dfsg-1) ...
Setting up libqt4-declarative:amd64 (4:4.8.2+dfsg-1) ...
Setting up libk3b6-extracodecs (2.0.2-6) ...
Setting up k3b (2.0.2-6) ...
Processing triggers for menu ...


      Code:

root@debian[/home/finotti]# apt-get update
[snip]
Fetched 821 kB in 10s (75.4 kB/s)                                                                           
Reading package lists... Done


root@debian[/home/finotti]# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  intel-microcode
The following packages will be upgraded:
  manpages os-prober psutils
3 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 888 kB of archives.
After this operation, 9,216 B of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.us.debian.org/debian/ sid/main manpages all 3.42-1 [784 kB]
Get:2 http://ftp.us.debian.org/debian/ sid/main psutils amd64 1.17.dfsg-1 [75.0 kB]
Get:3 http://ftp.us.debian.org/debian/ sid/main os-prober amd64 1.55 [28.3 kB]
Fetched 888 kB in 1s (612 kB/s)     
(Reading database ... 505448 files and directories currently installed.)
Preparing to replace manpages 3.40-0.1 (using .../manpages_3.42-1_all.deb) ...
Unpacking replacement manpages ...
Preparing to replace psutils 1.17-32 (using .../psutils_1.17.dfsg-1_amd64.deb) ...
Unpacking replacement psutils ...
Preparing to replace os-prober 1.54 (using .../os-prober_1.55_amd64.deb) ...
Unpacking replacement os-prober ...
Processing triggers for man-db ...
Setting up manpages (3.42-1) ...
Setting up psutils (1.17.dfsg-1) ...
Setting up os-prober (1.55) ...


All seems to be working fine now.

Thank you very much DonKult for supporting an "unsupportable" system!
I've been using the infamous French repository for handbrake and
avidemux. I shouldn't DU with those enabled though, at the very
least... I will try to be more careful in the future.

Best,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 26.08.2012, 07:47
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
The problem with the french repo is that it has its own set of versions for some libraries which do "conflict" with packages in debian which depend on these libraries (but in the debian version) resulting in sometimes running, sometimes crashing media players and co (as far as i remember debian follows the "new" ffmpeg while the french will follow the "old", so in future the problems will be even bigger I guess). The other sources aren't that much better from a support point of view…

Regarding handbrake: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=456165
There is some progress there recently again. No upload to debian announced yet, but the packaging seems to be relatively fine (I had built+installed it from the git repo a month ago; worked fine for the few extracts I wanted. Kdenlive is a good video cutter/editor btw).

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
finottiOffline
Post subject: RE: Re: RE: multi-arch problems  PostPosted: 27.08.2012, 13:18



Joined: 2010-09-12
Posts: 312

Status: Offline
Thanks for the info on handbrake and kdenlive, DonKult!
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio