Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
noxOffline
Post subject: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 24.08.2012, 18:45



Joined: 2010-09-14
Posts: 45

Status: Offline
Hi folks,

ever since I've upgraded to the 3.5 kernel I have massive graphical problems, so I'm back to using 3.4 kernel.

Between dist-upgrades a message appears saying something like:
Required firmware files may be missing ... in the new version some of the drivers used on this system may require additional firmware files. (lists a bunch od Radeon...bin files) ... then it says i should include a contrib and non-free section in apt...

but I already have these enabled in source.list, as far as I know...


So I'm using an ATI Radeon X1600, what do I have to do??




Thank you very much
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 25.08.2012, 10:24
Team Member


Joined: 2010-08-26
Posts: 258

Status: Offline
The firmware files for radeons are in the firmware-linux-nonfree package. Strictly speaking these should not be required though they are needed for things like video acceleration and 3d. I've no idea if installing them will help your "massive graphical problems" but I suspect it is worth a try.
 
 View user's profile Send private message  
Reply with quote Back to top
noxOffline
Post subject: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 26.08.2012, 08:06



Joined: 2010-09-14
Posts: 45

Status: Offline
Hi bfree,

I have the firmware-linux-nonfree package already installed, so should I reinstall or can the radeon files be somehow extracted from it? By massive graph. problems I mean almost the same kind of problem I had with libcairo2 a few months ago (tearing, unreadable firefox and chromium toolbars....). I still have libcairo2 on hold, do you think its safe to install it?
 
 View user's profile Send private message  
Reply with quote Back to top
yossarianOffline
Post subject: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 26.08.2012, 12:41



Joined: 2010-09-11
Posts: 35

Status: Offline
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677813
 
 View user's profile Send private message  
Reply with quote Back to top
seasonsOffline
Post subject: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 00:18



Joined: 2010-09-13
Posts: 92

Status: Offline
The warning message and the bug linked in post above only concern very recent RadeonHD (7000-series) cards. The firmware for your card was already in the firmware-linux-nonfree package. It must be a different issue.

How bad are the graphical issues? When you boot the 3.5 kernel, are you able to switch to a terminal and look at dmesg?
 
 View user's profile Send private message  
Reply with quote Back to top
noxOffline
Post subject: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 12:42



Joined: 2010-09-14
Posts: 45

Status: Offline
@seasons

The graphical issues remind me of the problems I've had with libcairo2 (unreadeble, all black and glitchy firefox and chromium toolbars). Currently I still have libcairo2 on hold, so maybe if I just install it, the problem goes away, but it seems much more an radeon problem, because of the missing files message during dist-upgrade.

Anway, the desktop on 3.5 kernel starts at first without problems. The dmesg output is as follows:

http://pastebin.com/tsN943tN


Last edited by nox on 27.08.2012, 12:45; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
noxOffline
Post subject: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 12:42



Joined: 2010-09-14
Posts: 45

Status: Offline
erro
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 13:15



Joined: 2010-09-12
Posts: 326

Status: Offline
      nox wrote:
I still have libcairo2 on hold, do you think its safe to install it?


I don't know if it is related to your problem at all, but libcairo2 is working fine now (at least for me).

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
noxOffline
Post subject: RE: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 13:54



Joined: 2010-09-14
Posts: 45

Status: Offline
Tnx finotti, I've just upgraded to libcairo2, but problem still remains. As I did the system upgrade I also read the non-free-firmware upgrade message again, and indeed the additional files required for my Radeon are the same listed in yossarian's post (Aruba, Tahiti, Pitcairn, Verde ), but how and where do I copy these files to???
 
 View user's profile Send private message  
Reply with quote Back to top
yossarianOffline
Post subject: RE: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 15:07



Joined: 2010-09-11
Posts: 35

Status: Offline
Download required files from:
http://people.freedesktop.org/~agd5f/radeon_ucode/
and save into /lib/firmware.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 15:16



Joined: 2010-08-25
Posts: 766

Status: Offline
No, there is no download required at all.

The firmware images mentioned are for very new graphics cards, which weren't supported before kernel 3.5. If the graphics card was working with older kernels, there is no need for these.
 
 View user's profile Send private message  
Reply with quote Back to top
noxOffline
Post subject: RE: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 15:45



Joined: 2010-09-14
Posts: 45

Status: Offline
slh,
during the kernel upgrade the system itself is asking for those files, so maybe it's worth a try.... Smile

yossarian, I have the folder downloaded,

1.) so you're saying I should put the whole radeon_ucode folder in the /lib/firmware dir, or should I just save the files into the already existing /lib/firmware/radeon directory?


2.)In the latter case, can I just overwrite the existing files with the new ones or do I have to be specific?


3.)Also, as the files were downloaded to my /home partition, do I have to change permissions of the files?


Thanky you!
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 16:03



Joined: 2010-08-25
Posts: 766

Status: Offline
Of course the system is asking, because the radeon module declares the new firmware relations - but the kernel's packaging can not know if those are actually needed for your particular hardware (as radeon.ko supports many different hardware generations).

Those new blobs are not needed for radeon x1300, not at all - and you shouldn't overwrite the packaged files, nor download those blobs by hand in the first place.
 
 View user's profile Send private message  
Reply with quote Back to top
noxOffline
Post subject: RE: Re: RE: ATI Radeon problems since upgrade to 3.5 kernel  PostPosted: 27.08.2012, 17:02



Joined: 2010-09-14
Posts: 45

Status: Offline
slh, ok you're right I've tried it...

Maybe it has something to do with kvm?
When I boot into the 3.5 Kernel a message says "kvm disabled by bios"...?
 
 View user's profile Send private message  
Reply with quote Back to top
stefutzOffline
Post subject:   PostPosted: 18.10.2012, 14:38



Joined: 2010-11-29
Posts: 21

Status: Offline
I have the same problem starting with kernel 3.4.
My video card is Ati Radeon x1250 (shared memory, integrated into mainboard, laptop pc). Putting the files from ucode did not help, only stopped the kernel update message about the missing files.
I am now having kernel 3.3-6 and sticking with it. All others (new) make my system unusable (link to screenshot: http://dl.dropbox.com/u/103396816/Screenshot2.png )
      Code:
$ uname -r
3.3-6.slh.1-aptosid-amd64
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio