Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
LeTuXOffline
15 Post subject: (solved) System unusable after d-u, filesystem writeonly  PostPosted: 09.09.2012, 15:01



Joined: 2011-05-15
Posts: 13
Location: Germany
Status: Offline
after last d-u (the previous being two months old) left my system unusable. The error messages make me believe the file system is write only.

- the boot messages font stays large
- gui (xfce) does not start
- instead of the PCs name, logon prompt gives "unknown"

logon as root or user is possible, but all commands terminate with an error. So I had to restore my hard disk image which I create before every d-u.

This happened twice and no other user seems to have such problem.

Before trying a third time I noticed that d-u wants to install a lot of i386-packages on my 64bit system. Maybe these are the problem?

I deinstalled some 386-compatibility packages and now the list got much shorter but not nil. In any case I wonder why new packages want to get installed when I merely want to update the current ones.

Mabe someone can help me if one of these new package may be the problem and how I can avoid installing them:

      Quote:
Die folgenden NEUEN Pakete werden installiert:
ffmpeg libdbus-1-3:i386 libexpat1:i386 libfontconfig1:i386 libgcrypt11:i386
libgnutls26:i386 libgpg-error0:i386 libjbig0:i386 liblinear1
libp11-kit0:i386 libtasn1-3:i386 libtiff4:i386 libxcomposite1:i386
libxslt1.1:i386 libxxf86vm1:i386 linux-headers-3.5-3.slh.3-aptosid-amd64
linux-image-3.5-3.slh.3-aptosid-amd64 python-six


comment:
ffmpeg should not get installed because I use libav-tools and created a symlink named ffmpeg to avconv

the headers and the image are surely ok, I pasted the complete "new packages" part of the message for better overview.

Below, I quote the full d-u message.

Thanks!
Alexander



      Quote:
Die folgenden Pakete werden ENTFERNT:
linux-headers-2.6-aptosid-amd64
Die folgenden NEUEN Pakete werden installiert:
ffmpeg libdbus-1-3:i386 libexpat1:i386 libfontconfig1:i386 libgcrypt11:i386
libgnutls26:i386 libgpg-error0:i386 libjbig0:i386 liblinear1
libp11-kit0:i386 libtasn1-3:i386 libtiff4:i386 libxcomposite1:i386
libxslt1.1:i386 libxxf86vm1:i386 linux-headers-3.5-3.slh.3-aptosid-amd64
linux-image-3.5-3.slh.3-aptosid-amd64 python-six
Die folgenden Pakete werden aktualisiert (Upgrade):
abiword abiword-common accountsservice acpi-support-base acpid alsa-base apt
apt-utils aptosid-art-wallpaper-imera aptosid-art-xfce-imera
aptosid-art-xsplash-imera aptosid-manual-common aptosid-manual-de
aptosid-manual-en aptosid-scripts asymptote asymptote-doc automake bash bc
binfmt-support binutils br2684ctl brasero brasero-common busybox bzip2
ca-certificates-java chromium chromium-inspector cmake cmake-data
console-setup console-setup-linux consolekit cpp-4.6 cpp-4.7 cron
cups-driver-gutenprint curl dbus dbus-x11 dc debconf debconf-utils debhelper
debianutils desktop-file-utils dictionaries-common distro-defaults dmidecode
dosfstools dpkg dpkg-dev e2fslibs e2fsprogs efibootmgr evince-common
evince-gtk exactimage exo-utils file flashplugin-nonfree flex fll-iso2usb
fontconfig fontconfig-config fonts-opensymbol foomatic-db-gutenprint
foomatic-filters freeglut3 fuse fuse-utils g++-4.6 g++-4.6-multilib g++-4.7
g++-4.7-multilib gcc-4.6 gcc-4.6-base gcc-4.6-multilib gcc-4.7 gcc-4.7-base
gcc-4.7-base:i386 gcc-4.7-multilib gconf-service gconf2 gconf2-common
gir1.2-clutter-1.0 gir1.2-gtk-2.0 gir1.2-gtk-3.0 git git-core git-man
gnome-session-bin gnome-settings-daemon gpsd gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-doc hddtemp htop icedove icedove-l10n-de iceweasel
iceweasel-l10n-de ifupdown ijsgutenprint imagemagick imagemagick-common
initramfs-tools initscripts insserv iptables iputils-ping isc-dhcp-client
isc-dhcp-common iso-codes kernel-remover keyboard-configuration klibc-utils
kmod lastfmsubmitd lesstif2 lib32gcc1 lib32gomp1 lib32itm1 lib32quadmath0
lib32stdc++6 libaa1 libabiword-2.9 libaccountsservice0 libamd2.2.0
libanyevent-perl libaprutil1 libapt-inst1.5 libapt-pkg4.12 libasound2
libasound2-dev libatm1 libav-tools libbfb0 libblas3 libblas3gf
libbrasero-media3-1 libburn4 libbz2-1.0 libbz2-dev libc-bin libc-dev-bin
libc6 libc6:i386 libc6-dev libc6-dev-i386 libc6-i386 libcap-dev libcap2
libcdaudio1 libcdparanoia0 libck-connector0 libclutter-1.0-0 libcolamd2.7.1
libcomerr2 libcurl3 libcurl3-gnutls libcurl3-nss libdb5.1 libdbus-1-3
libdbus-1-dev libdebian-installer-extra4 libdebian-installer4
libdjvulibre-text libdjvulibre21 libdpkg-perl libdvdnav4 libdvdread4
libevdocument3-4 libevview3-3 libexif-dev libexif12 libexo-1-0 libexo-common
libexo-helpers libfftw3-3 libflite1 libfontconfig1 libfontconfig1-dev
libfuse2 libgail-3-0 libgail18 libgc1c2 libgcc1 libgcc1:i386 libgconf-2-4
libgconf2-4 libgdu0 libgfortran3 libgl1-mesa-dev libgl1-mesa-dri
libgl1-mesa-dri-experimental libgl1-mesa-glx libglapi-mesa libglib2.0-cil
libglu1-mesa libglu1-mesa-dev libgomp1 libgpg-error0 libgps20
libgraphicsmagick++3 libgraphicsmagick3 libgssapi-krb5-2 libgssdp-1.0-3
libgstreamer-plugins-bad0.10-0 libgtk-3-0 libgtk-3-bin libgtk-3-common
libgtk-3-dev libgtk2.0-0 libgtk2.0-cil libgtk2.0-common libgtk2.0-dev
libgudev-1.0-0 libgudev-1.0-dev libgupnp-1.0-4 libgutenprint2 libhsqldb-java
libhtml-tree-perl libicu48 libisoburn1 libitm1 libjack-jackd2-0 libjs-jquery
libjson0 libk5crypto3 libkeyutils1 libklibc libkmod2 libkpathsea6 libkrb5-3
libkrb5support0 liblapack3 liblapack3gf liblastfm-dbg liblastfm-dev
liblastfm-fingerprint0 liblastfm0 liblcms1 liblua5.1-0 libmagic1
libmagickcore5 libmagickwand5 libmetacity-private0a libmono-cairo4.0-cil
libmono-compilerservices-symbolwriter4.0-cil libmono-corlib4.0-cil
libmono-data-tds4.0-cil libmono-posix4.0-cil libmono-security4.0-cil
libmono-sharpzip4.84-cil libmono-system-configuration4.0-cil
libmono-system-core4.0-cil libmono-system-data4.0-cil
libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil
libmono-system-runtime-serialization4.0-cil libmono-system-security4.0-cil
libmono-system-transactions4.0-cil libmono-system-xml-linq4.0-cil
libmono-system-xml4.0-cil libmono-system4.0-cil libmozjs10d libmpeg2-4
libmpeg2-4-dev libmpg123-0 libmpg123-0:i386 libmtp-common libmtp9
libmulticobex1 libnautilus-extension1a libnl-3-200 libnl-genl-3-200 libnspr4
libnspr4-0d libnss3 libnss3-1d libobexftp0 libopenexr6 libopenjpeg2
libpackagekit-glib2-14 libpci3 libpcsclite1 libperl5.14 libpng12-0
libpng12-0:i386 libpng12-dev libppl-c4 libppl9 libptexenc1 libpulse-dev
libpulse-mainloop-glib0 libpulse0 libpurple0 libpwl5 libpython2.7
libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-dev-bin
libqt4-help libqt4-network libqt4-qt3support libqt4-script
libqt4-scripttools libqt4-sql libqt4-svg libqt4-test libqt4-xml
libqt4-xmlpatterns libqtcore4 libqtgui4 libquadmath0 libquvi-scripts
libraptor2-0 libreoffice libreoffice-base libreoffice-base-core
libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-filter-mobiledev libreoffice-help-de libreoffice-impress
libreoffice-java-common libreoffice-l10n-de libreoffice-math
libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-writer
librpm3 librpmbuild3 librpmio3 librpmsign1 librrd4 librrds-perl libsane
libsane-common libsasl2-2 libsasl2-modules libservlet2.5-java
libservlet3.0-java libslang2 libslang2-dev libsmbclient libspandsp2
libspectre1 libss2 libssh2-1 libssl-dev libssl1.0.0 libssl1.0.0:i386
libstdc++6 libstdc++6-4.6-dev libstdc++6-4.7-dev libswt-cairo-gtk-3-jni
libswt-gtk-3-java libswt-gtk-3-jni libswt-webkit-gtk-3-jni
libsystemd-daemon0 libsystemd-id128-0 libsystemd-journal0 libsystemd-login0
libtelepathy-glib0 libthai-data libthai0 libthunarx-2-0 libtiff4
libtiff4-dev libtiffxx0c2 libtomcat7-java libtotem-pg-dev libtotem-pg4
libudev0 libumfpack5.4.0 libuniconf4.6 libusb-1.0-0 libvdpau1
libvisual-0.4-0 libvlc5 libvlccore5 libwbclient0 libwine:i386
libwine-bin:i386 libwrap0 libwvstreams4.6-base libwvstreams4.6-extras
libxcb-render-util0 libxml-libxml-perl libxml2 libxml2:i386 libxml2-dev
libxml2-doc libxml2-utils libxslt1.1 libxxf86dga1
linux-headers-3.2.0-3-amd64 linux-headers-3.2.0-3-common
linux-headers-3.2.0-3-common-rt linux-headers-3.2.0-3-rt-amd64
linux-headers-aptosid-amd64 linux-image-aptosid-amd64 linux-libc-dev
linux-source-3.2 liquidsoap liquidsoap-plugin-lastfm
liquidsoap-plugin-xmlplaylist locales logrotate luatex manpages mc mc-data
mdadm mesa-common-dev metacity metacity-common mime-support
module-init-tools mono-4.0-gac mono-gac mono-runtime mousepad mpeg2dec
multiarch-support myspell-en-us nautilus-data net-tools nfs-common nmap
ntfs-3g obexftp openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
openjdk-7-jdk openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib
openssh-client openssh-server openssl orage os-prober pciutils pcscd pdftk
perl perl-base perl-modules pidgin pidgin-data pppconfig
printer-driver-gutenprint psutils python python-apt python-apt-common
python-debian python-libxml2 python-markdown python-minimal python-support
python2.7 python2.7-minimal qdbus qt4-linguist-tools qt4-qmake rpm
rpm-common rpm2cpio rrdtool samba-common sane-utils screen sgml-base
sgml-data smbclient squashfs-tools ssl-cert sudo syslinux syslinux-common
systemd sysv-rc sysvinit sysvinit-utils tesseract-ocr-dev texlive-base
texlive-binaries texlive-common texlive-generic-recommended
texlive-latex-base texlive-pstricks thunar traceroute transmission
transmission-cli transmission-common transmission-gtk ttf-dejavu
ttf-dejavu-core ttf-dejavu-extra tzdata tzdata-java udev udisks
unattended-upgrades uno-libs3 unzip ure usb-modeswitch-data vim vim-common
vim-runtime vlc-data wget whois wine wine-bin:i386 winetricks xbitmaps
xfce4-battery-plugin xfce4-clipman xfce4-clipman-plugin xfce4-cpufreq-plugin
xfce4-cpugraph-plugin xfce4-datetime-plugin xfce4-dict xfce4-diskperf-plugin
xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-mailwatch-plugin xfce4-mixer
xfce4-mount-plugin xfce4-netload-plugin xfce4-notes xfce4-notes-plugin
xfce4-panel xfce4-places-plugin xfce4-quicklauncher-plugin
xfce4-screenshooter xfce4-sensors-plugin xfce4-session
xfce4-smartbookmark-plugin xfce4-systemload-plugin xfce4-timer-plugin
xfce4-verve-plugin xfce4-wavelan-plugin xfce4-weather-plugin
xfce4-xkb-plugin xfwm4 xkb-data xorriso xserver-common xserver-xorg-core
xserver-xorg-input-mouse xserver-xorg-video-cirrus xserver-xorg-video-intel
xserver-xorg-video-mga xserver-xorg-video-nouveau
xserver-xorg-video-openchrome xsltproc xterm xulrunner-10.0 zip
574 aktualisiert, 18 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 863 MB von 876 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 144 MB Plattenplatz zusätzlich benutzt.
 
 View user's profile Send private message  
Reply with quote Back to top
oldieOffline
Post subject: RE: System unusable after d-u, filesystem writeonly  PostPosted: 09.09.2012, 20:24



Joined: 2010-09-12
Posts: 25

Status: Offline
all commands terminate with an error - text ?

please check system time - dd.mm.yy

disk ok ?
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: System unusable after d-u, filesystem writeonly  PostPosted: 09.09.2012, 22:24



Joined: 2010-08-25
Posts: 724

Status: Offline
It's not a generic issue, e.g. I can't reproduce it locally - and it seems to deeply involve multi-arch, which doesn't make it any simpler…

If you have a known-good backup, I'd suggest to start by upgrading packages one by one and see what happens (leave out the libraries, those will be upgraded as needed). Ideally start with leaf packages first.

What is a bit weird, is linux-headers-2.6-aptosid-amd64 getting removed in the upgrade stage, while it's been obsoleted by linux-headers-aptosid-amd64 (and thereby be flagged by deborphan), nothing should really conflict with it; it's also strange that apt isn't complaining about linux-image-2.6-aptosid-amd64 at the same time.
 
 View user's profile Send private message  
Reply with quote Back to top
LeTuXOffline
Post subject: [Solved] System unusable after d-u, filesystem writeonly  PostPosted: 30.09.2012, 15:55



Joined: 2011-05-15
Posts: 13
Location: Germany
Status: Offline
After some trial end error following slh's advice to update the packages sequentially, I noticed errors occurring already during shutdown after an update which would lead to system-unusability. They all sounded like this:

      Quote:
/etc/init.d/networking line 24: /lib/lsb/init-functions: no such file or directory


Indeed this script has disappeared, so for the next try I saved it before d-u and copied it back after d-u before shutdown. Now everything works like charm!

Thanks for your help!
Alexander
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: [Solved] System unusable after d-u, filesystem writeonl  PostPosted: 30.09.2012, 18:51



Joined: 2010-08-25
Posts: 724

Status: Offline
/lib/lsb/init-functions is part of lsb-base, and it should be virtually impossible that it got deinstalled.
 
 View user's profile Send private message  
Reply with quote Back to top
LeTuXOffline
Post subject: RE: [Solved] System unusable after d-u, filesystem writeonl  PostPosted: 03.10.2012, 18:02



Joined: 2011-05-15
Posts: 13
Location: Germany
Status: Offline
No, lsb-base was not removed, and installing lsb did not help, neither.
I really had to save the script and copy it back.

Btw, I falsely accused the i386-packages. I just got suspicious because a lot of them were installed which I haven't asked for. But the problem didn't go away after I successfully avoided them.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio