Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
cliveOffline
Post subject: [SOLVED] sound stopped after last upgrade  PostPosted: 23.10.2012, 15:52



Joined: 2012-03-26
Posts: 14
Location: London
Status: Offline
I upgraded yesterday morning since when sound has stopped working.

dmesg output looks OK
as does lsmod output

The kernel was upgraded to 3.6-3.slh.1-aptosid-686 but the previous kernel now doesn't play sound either (3.6-2.slh.4)

I'm at a bit of a loss as to how to debug this and would be grateful if someone could give me a couple of things to try.

Thanks


Last edited by clive on 25.10.2012, 08:04; edited 1 time in total
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
piperOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 23.10.2012, 18:23
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
How are your settings in kmix ? Anything muted ?



snapshot1.png
 Description:
 Filesize:  49.1 KB
 Viewed:  3102 Time(s)

snapshot1.png



_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
cliveOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 23.10.2012, 19:06



Joined: 2012-03-26
Posts: 14
Location: London
Status: Offline
I'm using XFCE and the alsamixer/sound settings seem to be fine

Thanks for the thought. Is there anywhere else the sound could be muted?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 24.10.2012, 06:06



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
cat /proc/asound/cards

And for checking volume-settings, use alsamixer instead of the graphical tools.
 
 View user's profile Send private message  
Reply with quote Back to top
cliveOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 24.10.2012, 06:31



Joined: 2012-03-26
Posts: 14
Location: London
Status: Offline
:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfebfc000 irq 46


//edit by DonKult: removed double posts so that the thread can continue naturally - and yes, this SMTP error goes on my nerves, too, and is quiet confusing.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 24.10.2012, 10:06



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
Your Card is up and running.
So have you checked the mixer settings with alsamixer?
Do you have maybe pulseaudio installed?

dpkg -l | grep pulseaudio
 
 View user's profile Send private message  
Reply with quote Back to top
cliveOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 24.10.2012, 21:18



Joined: 2012-03-26
Posts: 14
Location: London
Status: Offline
Yes it is, as is aumix:


ii gstreamer0.10-pulseaudio:i386 0.10.31-3 i386 GStreamer plugin for PulseAudio
ii pulseaudio 2.0-6 i386 PulseAudio sound server
ii aumix 2.9.1-2 i386 Simple text-based mixer control program
ii aumix-common 2.9.1-2 all Simple text-based mixer control program (common files)

Should I remove them?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 25.10.2012, 05:23



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Offline
apt-get purge pulseaudio
 
 View user's profile Send private message  
Reply with quote Back to top
cliveOffline
Post subject: RE: Sound stopped after last upgrade  PostPosted: 25.10.2012, 08:03



Joined: 2012-03-26
Posts: 14
Location: London
Status: Offline
SOLVED - Thanks, that did it Smile
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio