Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
azzaOffline
Post subject: Number Lock Light wrong  PostPosted: 16.09.2010, 02:57



Joined: 2010-09-15
Posts: 11

Status: Offline
I want NumLock to be on by default in each new session.

My BIOS is set to turn it on, which it does. The system always respects my preference from KDE System Settings, i.e. NumLock is on for each new session when I ask for it.

However, my problem is that the NumLock keyboard light and the actual NumLock are out of sequence... NumLock light ON = Num Lock OFF, and vice-versa.

During boot:
1st, light comes on during inital start when BIOS turns it on.
2nd, light remains on through grub menu.
3rd, as soon as I see the first line of the boot messages, the light goes out.

How can I get my NumLock light to be on after boot?
 
 View user's profile Send private message  
Reply with quote Back to top
clearyOffline
Post subject: RE: Number Lock Light wrong  PostPosted: 16.09.2010, 03:18



Joined: 2010-08-27
Posts: 34

Status: Offline
It's not a solution, but sounds like it's just being toggled once you boot the OS - so try turning it off in the bios?
 
 View user's profile Send private message  
Reply with quote Back to top
mfdemiccoOffline
Post subject:   PostPosted: 28.09.2010, 22:07



Joined: 2010-09-18
Posts: 8

Status: Offline
I think it's a KDE bug because the same issue occurs for me with Linux Mint KDE, but not with Linux Mint 9 and Linux Mint LMDE, which use Gnome.
 
 View user's profile Send private message  
Reply with quote Back to top
myloOffline
Post subject: Re: RE: Number Lock Light wrong  PostPosted: 29.09.2010, 20:49



Joined: 2010-09-11
Posts: 116
Location: Wiesbaden, Germany
Status: Offline
      cleary wrote:
It's not a solution, but sounds like it's just being toggled once you boot the OS - so try turning it off in the bios?


Dear cleary,

I have the same darkness on the Num Lock LED, while the Num key pad is working correctly.

I toggled the (AMI-) Bios setting "On Boot" from on to off, with no change to the darkness.

So BIOS might be excluded as root cause.

If more info about my config or something else is helpful, tell me what you need!

_________________
Regards
mylo

Linux 3.1-6.slh.1-aptosid-amd64 x86_64[2010-03 Ἀπάτη (201012262151)]
Intel Core2 Duo E6550 @ Cache/Ram 4MB/4GB nVidia G72 7300 nouveau 2*250GB
 
 View user's profile Send private message  
Reply with quote Back to top
azzaOffline
Post subject:   PostPosted: 04.10.2010, 11:39



Joined: 2010-09-15
Posts: 11

Status: Offline
      mfdemicco wrote:
I think it's a KDE bug because the same issue occurs for me with Linux Mint KDE, but not with Linux Mint 9 and Linux Mint LMDE, which use Gnome.

I tend to agree.

It makes no difference what I have the BIOS do, it is always turned off during startup.

Not a fix, but I can turn it on when at the kdm login screen (when I remember). This just turns the light on, and at that stage, has no effect on what the session manager does on login.
 
 View user's profile Send private message  
Reply with quote Back to top
ghstryderOffline
Post subject:   PostPosted: 04.10.2010, 15:09



Joined: 2010-09-12
Posts: 95
Location: Detroit
Status: Offline
      mfdemicco wrote:
I think it's a KDE bug because the same issue occurs for me with Linux Mint KDE, but not with Linux Mint 9 and Linux Mint LMDE, which use Gnome.

Interesting. I have thought it was related to numlockx, but I don't know that for a fact. It might be KDE related. My password is numeric, I like it "on" at the login screen so I can use the numeric keypad. Since the function is correct, I'm just ignoring the light. It will catch up eventually.
 
 View user's profile Send private message  
Reply with quote Back to top
spacepenguinOffline
Post subject:   PostPosted: 04.10.2010, 17:46



Joined: 2010-09-11
Posts: 98
Location: Germany
Status: Offline
Has nothing to do with numlockx as it also happens without installed numlockx.
I use
      Code:
case `tty` in
        /dev/tty[0-9]) setleds -D +num -caps
        ;;
esac

in my ~/.bashrc & .bash_profile to always have numlock on in the virtual terminals. When I switch from wrong LEDed KDE to a virtual console with Ctrl-Alt-Fx the numlock LED turns on as it should be on activated numlock. Switching back to X with Ctrl-F7 the LED turns off again though the state of numlock doesn't change.

I now *have* installed numlockx because my KDE (4.5.1) isn't able anymore to remember that I want to have numlock on (have to turn it on after every login). So using numlockx is a workaround to always have numlock on in KDE but it doesn't change anything concerning the LED.

_________________
Susan | Hardware: SysProfile | 32bit
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
wrenchOffline
Post subject:   PostPosted: 05.10.2010, 12:43



Joined: 2010-10-05
Posts: 7
Location: Hartford, CT USA
Status: Offline
I'm not so sure this is a KDE thing, either. I've had this problem in XFCE for as long as I can remember.
 
 View user's profile Send private message  
Reply with quote Back to top
ghstryderOffline
Post subject:   PostPosted: 06.10.2010, 00:30



Joined: 2010-09-12
Posts: 95
Location: Detroit
Status: Offline
Heh, not numlockx, not KDE, and apparently not XFCE. No wonder there are so many different complaints about it. I don't recall when it started here, maybe 6 months ago. I stopped looking for a solution a while ago, figuring one will come along when it is ready.
 
 View user's profile Send private message  
Reply with quote Back to top
spacepenguinOffline
Post subject:   PostPosted: 07.10.2010, 01:22



Joined: 2010-09-11
Posts: 98
Location: Germany
Status: Offline
Wasn't this an issue with X some (longer) time before?

_________________
Susan | Hardware: SysProfile | 32bit
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio