Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
15 Post subject: (Solved) libvirt to be removed  PostPosted: 23.11.2012, 22:20



Joined: 2010-10-01
Posts: 190

Status: Offline
For a little while now:
      Code:
# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libvirt-bin libvirt0 python-libvirt virt-manager virt-viewer virtinst
The following packages have been kept back:
  icedove
The following packages will be upgraded:
  coreutils cpp-4.6 cups-filters dmsetup exim4 exim4-base exim4-config exim4-daemon-light fonts-opensymbol g++-4.6 gcc-4.6 gcc-4.6-base
  gsettings-desktop-schemas gtk2-engines-qtcurve hdparm iceweasel krb5-multidev libc-bin libc-dev-bin libc6 libc6:i386 libc6-dbg libc6-dev
  libc6-i386 libcupsfilters1 libdevmapper-event1.02.1 libdevmapper1.02.1 **removed** libgegl-0.2-0 libgssapi-krb5-2 libgssapi-krb5-2:i386
  libgssrpc4 libk5crypto3 libk5crypto3:i386 libkadm5clnt-mit8 libkadm5srv-mit8 libkdb5-6 libkrb5-3 libkrb5-3:i386 libkrb5-dev
  libkrb5support0 libkrb5support0:i386 liblvm2app2.2 liblzma5 liblzma5:i386 libmozjs10d libnetcf1 libpci3 libqtwebkit4 libreoffice
  libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge
  libreoffice-filter-mobiledev libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin libreoffice-style-crystal libreoffice-style-oxygen
  libreoffice-writer libruby1.9.1 libsnmp-base libsnmp15 libssh-4 libstdc++6-4.6-dbg libstdc++6-4.6-dev libxenstore3.0 locales lvm2 man-db
  multiarch-support opera pciutils python-uno ruby1.9.1 uno-libs3 ure vim vim-common vim-runtime xulrunner-10.0 xz-utils
91 upgraded, 0 newly installed, 6 to remove and 1 not upgraded.
Need to get 194 MB of archives.
After this operation, 18.9 MB disk space will be freed.
Do you want to continue [Y/n]?


Fixed in version 1:0.2.0-5 (reversion; http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=693744


Last edited by alexk on 20.12.2012, 15:52; edited 1 time in total
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: libvirt to be removed  PostPosted: 24.11.2012, 19:49



Joined: 2010-10-01
Posts: 190

Status: Offline
I'm stumped as to why these packages will be removed. They all depend on libvirt0. Any ideas?

      Code:
$ apt-cache show libvirt0
Package: libvirt0
Source: libvirt
Version: 0.9.12-5
Installed-Size: 3722
Maintainer: Debian Libvirt Maintainers <pkg>
Architecture: amd64
Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6 (>= 2.9), libcap-ng0, libdbus-1-3 (>= 1.1.1), libdevmapper1.02.1 (>= 2:1.02.20), libgcrypt11 (>= 1.4.5), libgnutls26 (>= 2.12.17-0), libnetcf1, libnl1 (>= 1.1), libnuma1 (>= 2.0.8~rc4), libpcap0.8 (>= 0.9.8), libsasl2-2 (>= 2.1.24), libxenstore3.0 (>= 3.2.0), libxml2 (>= 2.7.4), libyajl2 (>= 2.0.4)
Recommends: lvm2
Description-en: library for interfacing with different virtualization systems
 Libvirt is a C toolkit to interact with the virtualization capabilities
 of recent versions of Linux (and other OSes). The library aims at providing
 a long term stable C API for different virtualization mechanisms. It currently
 supports QEMU, KVM, XEN, OpenVZ, LXC, and VirtualBox.
Homepage: http://libvirt.org

      Code:
$ apt-show-versions -u
cpp-4.6/unstable upgradeable from 4.6.3-12 to 4.6.3-13
cups-filters/unstable upgradeable from 1.0.18-2+b2 to 1.0.18-2.1
dmsetup/unstable upgradeable from 2:1.02.74-4 to 2:1.02.74-5
eject/unstable upgradeable from 2.1.5+deb1+cvs20081104-11 to 2.1.5+deb1+cvs20081104-12
exim4/unstable upgradeable from 4.80-5.1 to 4.80-6
exim4-base/unstable upgradeable from 4.80-5.1 to 4.80-6
exim4-config/unstable upgradeable from 4.80-5.1 to 4.80-6
exim4-daemon-light/unstable upgradeable from 4.80-5.1 to 4.80-6
fonts-opensymbol/unstable upgradeable from 2:102.2+LibO3.5.4+dfsg-3 to 2:102.2+LibO3.5.4+dfsg-4
g++-4.6/unstable upgradeable from 4.6.3-12 to 4.6.3-13
gcc-4.6/unstable upgradeable from 4.6.3-12 to 4.6.3-13
gcc-4.6-base/unstable upgradeable from 4.6.3-12 to 4.6.3-13
gimp/unstable upgradeable from 2.8.2-1 to 2.8.2-2
gimp-data/unstable upgradeable from 2.8.2-1 to 2.8.2-2
gsettings-desktop-schemas/unstable upgradeable from 3.4.2-2 to 3.4.2-3
gtk2-engines-qtcurve/unstable upgradeable from 1.8.15-3 to 1.8.15-4
hdparm/unstable upgradeable from 9.42-1 to 9.43-1
icedove/unstable upgradeable from 10.0.10-1 to 10.0.11-1
iceweasel/unstable upgradeable from 10.0.10esr-1 to 10.0.11esr-1
insserv/unstable upgradeable from 1.14.0-4 to 1.14.0-5
krb5-multidev/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libc-bin/unstable upgradeable from 2.13-36 to 2.13-37
libc-dev-bin/unstable upgradeable from 2.13-36 to 2.13-37
libc6/unstable upgradeable from 2.13-36 to 2.13-37
libc6-dbg/unstable upgradeable from 2.13-36 to 2.13-37
libc6-dev/unstable upgradeable from 2.13-36 to 2.13-37
libc6-i386/unstable upgradeable from 2.13-36 to 2.13-37
libcupsfilters1/unstable upgradeable from 1.0.18-2+b2 to 1.0.18-2.1
libdevmapper-event1.02.1/unstable upgradeable from 2:1.02.74-4 to 2:1.02.74-5
libdevmapper1.02.1/unstable upgradeable from 2:1.02.74-4 to 2:1.02.74-5
libgegl-0.2-0/unstable upgradeable from 0.2.0-2 to 0.2.0-2+nmu1
libgimp2.0/unstable upgradeable from 2.8.2-1 to 2.8.2-2
libgssapi-krb5-2/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libgssrpc4/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libk5crypto3/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libkadm5clnt-mit8/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libkadm5srv-mit8/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libkdb5-6/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libkrb5-3/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libkrb5-dev/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libkrb5support0/unstable upgradeable from 1.10.1+dfsg-2 to 1.10.1+dfsg-3
libltdl-dev/unstable upgradeable from 2.4.2-1.1 to 2.4.2-1.2
libltdl7/unstable upgradeable from 2.4.2-1.1 to 2.4.2-1.2
liblvm2app2.2/unstable upgradeable from 2.02.95-4 to 2.02.95-5
liblzma5/unstable upgradeable from 5.1.1alpha+20120614-1 to 5.1.1alpha+20120614-2
libmozjs10d/unstable upgradeable from 10.0.10esr-1 to 10.0.11esr-1
libnetcf1/unstable upgradeable from 0.2.0-4 to 0.2.2-2
libnewt0.52/unstable *manually* upgradeable from 0.52.14-10 to 0.52.14-11
libpci3/unstable upgradeable from 1:3.1.9-5 to 1:3.1.9-6
libqrencode3/unstable upgradeable from 3.3.0-2 to 3.4.1-1
libqt4-dbg/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-dbus/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-declarative/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-designer/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-dev/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-dev-bin/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-help/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-network/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-opengl/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-qt3support/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-script/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-scripttools/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-sql/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-sql-mysql/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-sql-sqlite/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-svg/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-test/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-xml/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqt4-xmlpatterns/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqtcore4/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqtgui4/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
libqtwebkit4/unstable upgradeable from 2.2.1-4+b1 to 2.2.1-5
libreoffice/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-base/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-base-core/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-calc/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-common/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-core/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-draw/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-emailmerge/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-filter-mobiledev/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-help-en-us/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-impress/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-java-common/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-kde/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-math/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-ogltrans/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-pdfimport/unstable upgradeable from 1.0.5+LibO3.5.4+dfsg-3 to 1.0.5+LibO3.5.4+dfsg-4
libreoffice-report-builder-bin/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-style-crystal/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-style-oxygen/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libreoffice-writer/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
libruby1.9.1/unstable upgradeable from 1.9.3.194-3 to 1.9.3.194-4
libsnmp-base/unstable upgradeable from 5.4.3~dfsg-2.5 to 5.4.3~dfsg-2.6
libsnmp15/unstable upgradeable from 5.4.3~dfsg-2.5 to 5.4.3~dfsg-2.6
libssh-4/unstable upgradeable from 0.5.2-1 to 0.5.3-1
libstdc++6-4.6-dbg/unstable upgradeable from 4.6.3-12 to 4.6.3-13
libstdc++6-4.6-dev/unstable upgradeable from 4.6.3-12 to 4.6.3-13
libxenstore3.0/unstable upgradeable from 4.1.3-3 to 4.1.3-4
locales/unstable upgradeable from 2.13-36 to 2.13-37
lvm2/unstable upgradeable from 2.02.95-4 to 2.02.95-5
man-db/unstable upgradeable from 2.6.3-1 to 2.6.3-2
multiarch-support/unstable upgradeable from 2.13-36 to 2.13-37
pciutils/unstable upgradeable from 1:3.1.9-5 to 1:3.1.9-6
python-uno/unstable upgradeable from 1:3.5.4+dfsg-3 to 1:3.5.4+dfsg-4
qdbus/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
qt4-linguist-tools/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
qt4-qmake/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
qt4-qtconfig/unstable upgradeable from 4:4.8.2+dfsg-2 to 4:4.8.2+dfsg-3
ruby1.9.1/unstable upgradeable from 1.9.3.194-3 to 1.9.3.194-4
uno-libs3/unstable upgradeable from 3.5.4+dfsg-3 to 3.5.4+dfsg-4
ure/unstable upgradeable from 3.5.4+dfsg-3 to 3.5.4+dfsg-4
vim/unstable upgradeable from 2:7.3.547-5 to 2:7.3.547-6
vim-common/unstable upgradeable from 2:7.3.547-5 to 2:7.3.547-6
vim-runtime/unstable upgradeable from 2:7.3.547-5 to 2:7.3.547-6
whiptail/unstable *manually* upgradeable from 0.52.14-10 to 0.52.14-11
xulrunner-10.0/unstable upgradeable from 10.0.10esr-1 to 10.0.11esr-1
xz-utils/unstable upgradeable from 5.1.1alpha+20120614-1 to 5.1.1alpha+20120614-2
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: libvirt to be removed  PostPosted: 24.11.2012, 21:10



Joined: 2010-10-01
Posts: 190

Status: Offline
The culprit turns out to be libnetcf1. I have put it on hold for the time being.
      Code:
# apt-get -s install libnetcf1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libvirt-bin libvirt0 python-libvirt virt-manager virt-viewer virtinst
The following packages will be upgraded:
  libnetcf1
1 upgraded, 0 newly installed, 6 to remove and 128 not upgraded.
Remv libvirt-bin [0.9.12-5]
Remv virt-viewer [0.5.4-1]
Remv virt-manager [0.9.4-2]
Remv virtinst [0.600.3-2]
Remv python-libvirt [0.9.12-5]
Remv libvirt0 [0.9.12-5]
Inst libnetcf1 [0.2.0-4] (0.2.2-2 Debian:unstable [amd64])
Conf libnetcf1 (0.2.2-2 Debian:unstable [amd64])
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: libvirt to be removed  PostPosted: 25.11.2012, 01:03



Joined: 2010-10-01
Posts: 190

Status: Offline
      Code:
$ apt-listbugs list libnetcf1
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
serious bugs of libnetcf1 (-> ) <unfixed>
 #693744 - libnetcf1: incompatibility with libvirt-bin
Summary:
 libnetcf1(1 bug)
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
bluewaterOffline
Post subject:   PostPosted: 25.11.2012, 09:36
Team Member


Joined: 2010-08-26
Posts: 58
Location: Hobart, Australia
Status: Offline
I let to go to god on this box, it was not installed on my other 64 k box,, mind you I have not fired up an image with virt for a long time, nor with aqemu

_________________
If all else fails, get the instructions back out of the rubbish bin and read them. http://manual.aptosid.com/
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio