Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
yossarianOffline
Post subject: Add support for newer Ethernet devices.  PostPosted: 09.02.2013, 14:03



Joined: 2010-09-11
Posts: 35

Status: Offline
      Quote:
The alx driver provide support for:
1969:1091 - AR8161 Gigabit Ethernet
1969:1090 - AR8162 Fast Ethernet
1969:1073 - AR8151 v1.0 Gigabit Ethernet
1969:1083 - AR8151 v2.0 Gigabit Ethernet
1969:2062 - AR8152 v2.0 Fast Ethernet
1969:2060 - AR8152 v1.1 Fast Ethernet
1969:1063 - AR8131 Gigabit Ethernet
1969:1062 - AR8132 Fast Ethernet

http://www.linuxfoundation.org/collabor ... orking/alx
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Add support for newer Ethernet devices.  PostPosted: 09.02.2013, 15:27



Joined: 2010-08-25
Posts: 749

Status: Offline
Most of these, namely
      Code:
1969:1062 AR8132 Fast Ethernet
1969:1063 AR8131 Gigabit Ethernet
1969:1073 AR8151 v1.0 Gigabit Ethernet
1969:1083 AR8151 v2.0 Gigabit Ethernet
1969:2060 AR8152 v1.1 Fast Ethernet
1969:2062 AR8152 v2.0 Fast Ethernet
are, or at least should be (I don't have access to either of these devices, so please tell me if they don't work in practice), supported by atl1c already.

Only these two apparently are not, although they should be added to atl1c.
      Code:
1969:1090 - AR8162 Fast Ethernet
1969:1091 - AR8161 Gigabit Ethernet


alx itself has been explicitly rejected by the kernel's netdev maintainer[1] and as such I'm not going to touch it for aptosid, as it has no future in linux. Given that I don't have access to any device supported by atl1c, and in particular not to those that aren't supported by it, I unfortunately can't try to port the missing bits and pieces from alx to atl1c myself either.

If you care about either of those two unsupported devices, please contact Qualcomm Atheros Inc. nic-devel@qualcomm.com and CC netdev@vger.kernel.org.

[1] http://www.gossamer-threads.com/lists/linux/kernel/1498274?do=post_view_threaded#1498274 please read the whole thread for context.
 
 View user's profile Send private message  
Reply with quote Back to top
yossarianOffline
Post subject: RE: Add support for newer Ethernet devices.  PostPosted: 09.02.2013, 16:14



Joined: 2010-09-11
Posts: 35

Status: Offline
Thanks for your explanation and link provided.
      Code:
modinfo atl1c
filename:       /lib/modules/3.7-6.slh.2-aptosid-amd64/kernel/drivers/net/ethernet/atheros/atl1c/atl1c.ko
version:        1.0.1.0-NAPI
license:        GPL
description:    Qualcom Atheros 100/1000M Ethernet Network Driver
author:         Qualcomm Atheros Inc., <nic>
author:         Jie Yang
srcversion:     1A550ECB609B4B690B47528
alias:          pci:v00001969d00001083sv*sd*bc*sc*i*
alias:          pci:v00001969d00001073sv*sd*bc*sc*i*
alias:          pci:v00001969d00002062sv*sd*bc*sc*i*
alias:          pci:v00001969d00002060sv*sd*bc*sc*i*
alias:          pci:v00001969d00001062sv*sd*bc*sc*i*
alias:          pci:v00001969d00001063sv*sd*bc*sc*i*
depends:       
intree:         Y
vermagic:       3.7-6.slh.2-aptosid-amd64 SMP preempt mod_unload modversions

Most of them are already supported.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio