Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
greenpuppyOffline
Post subject: opendns help  PostPosted: 05.10.2010, 08:04



Joined: 2010-10-05
Posts: 6

Status: Offline
I installed aptosid-xfce new.

I want to use opendns, and found this in "Tweaking sidux for speed," which I thought should work:

* Use !OpenDNS?. Once again, !OpenDNS? allows you to safely and quickly surf the internet. You can route your traffic through their DNS servers, which is a round-robin setup that will route your information more efficiently. To do this, all you have to do is:

echo "prepend domain-name-servers 208.67.220.220, 208.67.222.222;" >> /etc/dhcp3/dhclient.conf
dhclient <your-interface>

----
I can't find the dhclient.conf file. The directions at opendns.com are pretty much the same.

What have I overlooked?
 
 View user's profile Send private message  
Reply with quote Back to top
kris99Offline
Post subject:   PostPosted: 05.10.2010, 10:58



Joined: 2010-09-11
Posts: 21

Status: Offline
add the following line to /etc/network/interfaces under the section of the interface you want the OpenDNS servers to solve the server names

      Code:
dns-nameservers 208.67.222.222 208.67.220.220

and run
      Code:
resolvconf -u
 
 View user's profile Send private message  
Reply with quote Back to top
greenpuppyOffline
Post subject:   PostPosted: 05.10.2010, 23:06



Joined: 2010-10-05
Posts: 6

Status: Offline
Thank you, but it didn't work. This is a laptop Latitude D620, if that makes a difference. It's used at home, and it works using Ubuntu and the prepend method shown before.

I'd rather use aptosid.

Anything else I can try?
 
 View user's profile Send private message  
Reply with quote Back to top
HeSaidOffline
Post subject:   PostPosted: 06.10.2010, 00:02
Moderator


Joined: 2010-09-11
Posts: 56
Location: southwest Florida, USA
Status: Offline
I have the openDNS IP addresses in /etc/resolvconf/run/interface/wlan0
The contents of the file:

      Code:
domain box
nameserver 208.67.222.222
nameserver 208.67.220.220
nameserver 8.8.8.8


I do not know if that file is overwritten on boot, but you can see if it works for you.
--
Neal

_________________
Registered Linux User # 159445
aptosid 64-bit Lenovo Thinkpad Edge
aptosid 64-bit HP dv6000 laptop
aptosid 32-bit eeePC 900A
 
 View user's profile Send private message  
Reply with quote Back to top
HeSaidOffline
Post subject:   PostPosted: 06.10.2010, 00:52
Moderator


Joined: 2010-09-11
Posts: 56
Location: southwest Florida, USA
Status: Offline
Moved to software support

_________________
Registered Linux User # 159445
aptosid 64-bit Lenovo Thinkpad Edge
aptosid 64-bit HP dv6000 laptop
aptosid 32-bit eeePC 900A
 
 View user's profile Send private message  
Reply with quote Back to top
natelwinOffline
Post subject:   PostPosted: 06.10.2010, 01:02



Joined: 2010-09-11
Posts: 21
Location: East Tennessee
Status: Offline
Or if you are using a firmware replacement for your router's factory default firmware, you can set it there. This is what I have done in my WRT54GL running DD-WRT. The instructions on exactly how to do this will vary depending upon what firmware replacement and version you are using, of course.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
start2usefrsiduxOffline
Post subject:   PostPosted: 06.10.2010, 03:21



Joined: 2010-09-12
Posts: 26

Status: Offline
Just wanna say that if your goal is speed then OpenDNS doesn't necessarily mean speed. Check where OpenDNS servers are located and see if you are near them. Most of time, Google DNS is faster.

If you are using some GUI software to manage your connection, like gnome-network-manager or wicd, DNS is easy to configure. The instruction on OpenDNS is for Ubuntu.
 
 View user's profile Send private message  
Reply with quote Back to top
greenpuppyOffline
Post subject:   PostPosted: 06.10.2010, 08:16



Joined: 2010-10-05
Posts: 6

Status: Offline
Thanks, all.

For hesaid: that didn't work. So will keep trying.

start2usefrsidux and natelwin: I'm using straight default aptosid install. Ceni works fine so have't changed.

Would wicd or another make it easier to use opendns? I suppose I'd need to uninstall ceni?!

Might try Google is I can get any of them to work!
 
 View user's profile Send private message  
Reply with quote Back to top
monkeynutsOffline
Post subject:   PostPosted: 06.10.2010, 10:53



Joined: 2010-09-20
Posts: 16

Status: Offline
You need to edit /etc/dhcp/dhclient.conf

So it has this line:
      Code:
 prepend domain-name-servers 208.67.222.222,208.67.220.220;
 
 View user's profile Send private message  
Reply with quote Back to top
HeSaidOffline
Post subject:   PostPosted: 06.10.2010, 11:44
Moderator


Joined: 2010-09-11
Posts: 56
Location: southwest Florida, USA
Status: Offline
Have you tried entering the DNS IPs in ceni?
No, you do not have to uninstall ceni to use wicd.
You can apt-get it and it will ask you for users to be allowed access to network settings. wicd daemon will auto run on boot so you need to reboot to set it up. You can add a lot in the config panels.
--
Neal

_________________
Registered Linux User # 159445
aptosid 64-bit Lenovo Thinkpad Edge
aptosid 64-bit HP dv6000 laptop
aptosid 32-bit eeePC 900A
 
 View user's profile Send private message  
Reply with quote Back to top
greenpuppyOffline
Post subject:   PostPosted: 06.10.2010, 12:59



Joined: 2010-10-05
Posts: 6

Status: Offline
For monkeynuts: I don't have a /etc/dhcp/dhclient.conf file.

HeSaid: When I get home, I'll look into editing ceni. Will also see if wicd is any easier or has extra benefits.

Thanks again to everyone.
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: Re: opendns help  PostPosted: 06.10.2010, 13:35
Team Member


Joined: 2010-08-26
Posts: 170

      greenpuppy wrote:
I installed aptosid-xfce new.

I want to use opendns, and found this in "Tweaking sidux for speed," which I thought should work:

* Use !OpenDNS?. Once again, !OpenDNS? allows you to safely and quickly surf the internet. You can route your traffic through their DNS servers, which is a round-robin setup that will route your information more efficiently. To do this, all you have to do is:

echo "prepend domain-name-servers 208.67.220.220, 208.67.222.222;" >> /etc/dhcp3/dhclient.conf
dhclient <your-interface>

----
I can't find the dhclient.conf file. The directions at opendns.com are pretty much the same.

What have I overlooked?


Some say one image says more more than thousand words... well at least if you see/look at it....

Have a look into Configure Network in our fine Manual.

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
titanOffline
Post subject: RE: Re: opendns help  PostPosted: 06.10.2010, 14:22



Joined: 2010-09-11
Posts: 77

Status: Offline
Assuming you are connecting to the net with a router setting DNS is done at the router unless it is running in bridge mode and just acting as a modem. That is certainly the case with the routers I have used Thompson, Cisco, Zyxel, 2wire
 
 View user's profile Send private message  
Reply with quote Back to top
greenpuppyOffline
Post subject: RE: Re: opendns help  PostPosted: 06.10.2010, 22:55



Joined: 2010-10-05
Posts: 6

Status: Offline
HeSaid: I installed wicd and got opendns working! Many thanks for your straight-up, simple help by pointing me to wicd.

I hope x-un-i is not in charge of helping other newish users like me. I had tried (wrongly) to use information from the old sidux site found by searching for opendns.

Thanks again to HeSaid and the others who offered pointers!
 
 View user's profile Send private message  
Reply with quote Back to top
x-un-i
Post subject: RE: Re: opendns help  PostPosted: 07.10.2010, 05:18
Team Member


Joined: 2010-08-26
Posts: 170

you completly overseen the second pic on ceni and there is the solution

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio