Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
giaurOffline
Post subject: 3.8.2.slh4 - 1024x768 console size  PostPosted: 12.03.2013, 17:18



Joined: 2011-01-05
Posts: 34

Status: Offline
Hello,

I've updated from 3.8.2.slh2 to 3.8.2.slh4. After update:
- text console (without X running) is 1024x768 (it should be 1280x800)
- X servers starts with 1024z768 resolution also. It can be changed to correct 1280x800, but kdm is starting at 1024x768

There are no any problems with kernel 3.8.2.slh2. My card is:

      Code:
VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)


Please fix this, because your latest kernel build is not usable - every time I login to kde, I'm forced to change resolution to 1280x800 by hand, it's not acceptable.
 
 View user's profile Send private message  
Reply with quote Back to top
mithatOffline
Post subject:   PostPosted: 13.03.2013, 04:37



Joined: 2011-12-15
Posts: 25

Status: Offline
Confirming same behavior on Xfce with GDM3. Laptop has native 1280x800 resolution. GDM3 starts at 1024x768. After user logs in, display switches to 1280x800 but leaves switching cruft (conky in the wrong palace, open windows in wrong places, corrupted background image.)

      Code:
lspci | grep Display
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

uname --all
Linux sam 3.8-2.slh.4-aptosid-686 #1 SMP PREEMPT Tue Mar 12 01:29:20 UTC 2013 i686 GNU/Linux
 
 View user's profile Send private message  
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 13.03.2013, 17:10



Joined: 2011-01-05
Posts: 34

Status: Offline
3.8.2 slh5 - the same. Are you going to fix this? New update, the same bug, still nothing is fixed...
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject:   PostPosted: 13.03.2013, 18:27



Joined: 2010-09-12
Posts: 325

Status: Offline
      giaur wrote:
3.8.2 slh5 - the same. Are you going to fix this? New update, the same bug, still nothing is fixed...


I think you should ask for your money back...
 
 View user's profile Send private message  
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 13.03.2013, 19:11



Joined: 2011-01-05
Posts: 34

Status: Offline
I'm really not satisfied with your soultion, sorry... any other ideas?
 
 View user's profile Send private message  
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 15.03.2013, 20:48



Joined: 2011-01-05
Posts: 34

Status: Offline
Hello,

I found solution. The simplest thing is avoid to use aptosid kernels, sinse they seems to be broken starting from slh4. Instead of aptosid, I use this kernel:

      Code:
SMP Debian 3.8.2-1~experimental.1 x86_64


This is most recent 3.8.2 and not broken. It can be installed from debian repositories.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject:   PostPosted: 16.03.2013, 02:56
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
I am not seeing this with nvidia (GTS 450, 7900, 6100) or ati (9600), perhaps this is a problem with Intel video cards, I can't test, cause I don't own.

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 16.03.2013, 07:17
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Several laptops and netbooks with Intel video cards over here are ok with latest Aptosid kernels.
Sounds like outdated Xorg config files.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 16.03.2013, 10:01



Joined: 2011-01-05
Posts: 34

Status: Offline
You are definitely wrong. This is not xorg issue - xorg works fine. Problem is text console size, which is always 1024x768.

You probably misunderstanded what's the problem. Imagine this: after kernel boots, all booting messages starting to display on 1024x768 console. I've tried to setup something with grub command line, but without success - no matter what I do, all virtual terminals (Ctrl+Alt+F1-FCool has 1024x768 instead of 1280x800.

When X starting, it reads this size somehow and resolution is automatically set to 1024x768 as well, it can be changed via kde screen settings.

I don't have any xorg.conf, maybe creating xorg.conf and setting 1280x800 there can be temprary workaround, but still problem is not solved.

Problem seems to be related to intel kernel module or intel framebuffer, not X, sorry. And, not all intel cards are affected. But as you can see, I'm not only one who has the same issue.
 
 View user's profile Send private message  
Reply with quote Back to top
slamOffline
Post subject:   PostPosted: 16.03.2013, 15:49
Team Member


Joined: 1970-01-01
Posts: 607
Location: w3
Status: Offline
Please let us see your /etc/default/grub file.
Greetings,
Chris

_________________
an operating system must operate
development is life
my Debian repo
 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number 
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 16.03.2013, 16:52



Joined: 2011-01-05
Posts: 34

Status: Offline
      Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="ro quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1280x800

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


3.8.2 SLH4 and SLH5 (amd64) have this issue, I haven't tested your 3.8.3 build yet.
 
 View user's profile Send private message  
Reply with quote Back to top
manulOffline
Post subject:   PostPosted: 16.03.2013, 17:10



Joined: 2010-09-13
Posts: 96

Status: Offline
giaur,

What if you try adding the grub option in /etc/default/grub

GRUB_GFXPAYLOAD_LINUX=1280x800

(right after the GRUB_GFXMODE) and then save, update-grub and reboot?
 
 View user's profile Send private message  
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 16.03.2013, 18:23



Joined: 2011-01-05
Posts: 34

Status: Offline
This is the result on 3.8.3.slh1:



As you can see, still 1024x768. No X server running.
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject:   PostPosted: 16.03.2013, 22:51



Joined: 2010-09-19
Posts: 168

Status: Offline
I would take "splash" off from GRUB_CMDLINE_LINUX_DEFAULT

If problems are still present, then I'd add GRUB_GFXPAYLOAD_LINUX="keep"
 
 View user's profile Send private message  
Reply with quote Back to top
giaurOffline
Post subject:   PostPosted: 17.03.2013, 11:19



Joined: 2011-01-05
Posts: 34

Status: Offline
It does not change anything.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio