Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Crypto1971Offline
14 Post subject: Wine... no installation possible, wineserver missing  PostPosted: 26.08.2013, 16:00



Joined: 2011-09-18
Posts: 13

Status: Offline
Hi,

I would like to install wine on my 64bit AMD computer.

The apt-sources actually say that wine can be installed from there, also wine64-bin. "This package provides instructions for installing 32-bit wine-unstable on 64-bit
systems."

But that is not there - just a long, long changelog. No hints how to install the whole thing. What am I missing?

I have tried to install from apt-get sources, but I keep getting "wineserver" is not in path for wine. Actually, not wine binary at all is installed, as I can see from the Qt Gui that comes with wine.

So please, please - what is the definite and right way to install wine on a 64bit computer? I have seen some, not sure which is correct.

Does it involve installing 32Bit support?

Does it involve downloading the sources from winehq? Why is that, I mean, winehp claim their .deb packages should work, but I had no success from installing via dpkg -i their winebinaries.

All hints welcome...

Crypto.
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Wine... no installation possible, wineserver missing  PostPosted: 26.08.2013, 19:57
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
You have to enable MultiArch, but the wine binary in wine64-bin is supposed to tell you that as wine currently only supports 32bit (and usually that's what you want anyway).

In short, something like:
      Code:
dpkg --add-architecture i386
apt-get update
apt-get install wine-unstable

should do the trick.

(I mention wine-unstable as it is the slightly fresher version of wine, both are not what wine upstream declares current – the wine-unstable is newer than the unofficial debs you can find on their side though, so don't bother with them)

Works for me at least.

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Crypto1971Offline
22 Post subject: Re: RE: Wine... no installation possible, wineserver missin  PostPosted: 30.09.2013, 16:40



Joined: 2011-09-18
Posts: 13

Status: Offline
      DonKult wrote:
You have to enable MultiArch, but the wine binary in wine64-bin is supposed to tell you that as wine currently only supports 32bit (and usually that's what you want anyway).


Hi DonKult,

I had no success with that. I definitely seem to need the 64bit version of wine-unstable.

I have found deb-packages here:

http://dev.carbon-project.org/debian/wine-unstable/

I have removed the i386 multiarch support from my system.

Then I downloaded all the *.deb packages from that site.

Then did sux -, then attempted to install one package by one. This gave me:

      Code:
root@pucki:/home/lutz/Downloads# dpkg -i libwine-bin-unstable_1.5.5-0.1_amd64.deb
Vormals nicht ausgewähltes Paket libwine-bin-unstable wird gewählt.
(Lese Datenbank ... 127880 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von libwine-bin-unstable (aus libwine-bin-unstable_1.5.5-0.1_amd64.deb) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libwine-bin-unstable:
 libwine-bin-unstable hängt ab von libc6-i386 (>= 2.7); aber:
  Paket libc6-i386 ist nicht installiert.
 libwine-bin-unstable hängt ab von libwine-unstable (= 1.5.5-0.1); aber:
  Paket libwine-unstable ist nicht installiert.

dpkg: Fehler beim Bearbeiten von libwine-bin-unstable (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 libwine-bin-unstable


The thing I do not understand at all is the libc6-i386 thing. I have removed support for i386 from my system, so why does it ask me to install it? Why cannot I step by step install one *.deb package from that site, as it writes?

Crypto.
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Re: RE: Wine... no installation possible, wineserver mi  PostPosted: 30.09.2013, 18:38
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
Clever, ignoring what I said and trying a third party repo that wasn't updated for more than a year and has hence a version even below the version in unstable…

APT exists so that you don't have to fiddle with deb files yourself. If you want to install packages with dpkg by hand, you have to understand what dependencies are, how to resolve them and all the other crazy batshit stuff nobody wants to know, but have to if they want to do it by hand (and for the record: "libc6-i386" is not "libc6:i386"). If there is no reason (and installing wine isn't) you shouldn't try to start with this stuff.

So please step away from whatever mess you are trying to enter, revert whatever you did with this third party repo, as its not gonna work (and note the red warning, so even if you get it working, it will instantly break if it is ever updated…) and just tell us if you have tried the commands I mentioned and what the problems with them was if any.

(MultiArch works here – and my machine was the first machine it ever worked on Wink – so I am pretty sure we will be able to get it working for you, too)

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio