Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
SuperdigiOffline
15 Post subject: [SOLVED] Ragged fonts after XServer upgrade  PostPosted: 07.10.2013, 11:46



Joined: 2011-04-16
Posts: 39

Status: Offline
I do not like aliased fonts so I deactivated it in the systemsettings. I head wonderful clear fonts for years but since the latest XServer upgrade they are ragged. I had this problem in the beginning, dpkg-reconfigure fontconfig-config helped then but now not any more.

Any ideas?


Last edited by Superdigi on 14.11.2013, 11:09; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
krisbeeOffline
Post subject: RE: Ragged fonts after XServer upgrade  PostPosted: 07.10.2013, 16:04



Joined: 2011-04-25
Posts: 49
Location: London
Status: Offline
I haven't done a DU for over a week. Are you referring to the update of the x11-common and xserver-xorg packages? In the past (perhpas not on aptosid) libfreetype6 was the culprit as the bytecode interpreter and subpixel hinting were not always enabled. There were pattern issue, which now do not apply.

Like you, I prefer not to use AA fonts below 12pt. So I have AA enabled in the KDE settings and set an exclude range of 0 to 12pt. Can you use this method to get the fonts you want? Or do they still remain "ragged".

I won't do another DU until there is more feedback on this issue.
 
 View user's profile Send private message  
Reply with quote Back to top
SuperdigiOffline
Post subject: RE: Ragged fonts after XServer upgrade  PostPosted: 08.10.2013, 12:58



Joined: 2011-04-16
Posts: 39

Status: Offline
I am referring to this dist-upgrade: http://www.aptosid.com/index.php?name=P ... amp;t=2676

I would like to have all font sizes not aliased. It worked wonderful until this dist-upgrade.
 
 View user's profile Send private message  
Reply with quote Back to top
broweOffline
Post subject: RE: Ragged fonts after XServer upgrade  PostPosted: 09.10.2013, 02:09



Joined: 2010-09-12
Posts: 155
Location: Canada
Status: Offline
Might be time to have a look around at some of the new fonts that are available.

I'm using Droid Sans and I'm quite happy with it. It's a font designed for computer screens (handheld specifically) but it works very well for desktop too.

Here's a clip from apt-get show fonts-droid:

The Droid family of fonts consists of Droid Sans (Regular and Bold),
Droid Sans Mono (Regular) and Droid Serif (Regular, Bold, Italic and
BoldItalic).
.
Each contains extensive character set coverage including
Western Europe, Eastern/Central Europe, Baltic, Cyrillic, Greek and
Turkish support. The Droid Sans regular font also includes support for
Arabic, Simplified and Traditional Chinese, Hebrew, Japanese, Korean and
Thai.
.
Droid was designed by Ascender's Steve Matteson and hinted to provide
optimal quality for screen text.

      Code:

apt-get install fonts-droid
 
 View user's profile Send private message  
Reply with quote Back to top
bluewaterOffline
Post subject:   PostPosted: 09.10.2013, 11:01
Team Member


Joined: 2010-08-26
Posts: 58
Location: Hobart, Australia
Status: Offline
Superdigi :: A d-u on both 32 and 64 bit boxes is not seeing the problems mentioned as at a d-u at 1030 UTC using ftp.uk.

An earlier d-u may have been missing some packages that have since been upgraded thus nullifying the problem that you have with ragged fonts.

_________________
If all else fails, get the instructions back out of the rubbish bin and read them. http://manual.aptosid.com/
 
 View user's profile Send private message  
Reply with quote Back to top
krisbeeOffline
Post subject:   PostPosted: 10.10.2013, 14:34



Joined: 2011-04-25
Posts: 49
Location: London
Status: Offline
As per bluewater, no font issue after a D-U today. 64bit system with nvidia 313.26 & KDE
 
 View user's profile Send private message  
Reply with quote Back to top
SuperdigiOffline
Post subject:   PostPosted: 15.10.2013, 15:30



Joined: 2011-04-16
Posts: 39

Status: Offline
I think we should not discuss too much the dist-upgrade. What I wanted to say is: Everything was fine until I did a dist-upgrade. Since then the fonts in GTK-Applications like Firefox look ragged.

What do I have to do to get back my sharp and anti-aliased fonts in GTK Applications?
 
 View user's profile Send private message  
Reply with quote Back to top
etorixOffline
Post subject:   PostPosted: 15.10.2013, 18:24
Team Member


Joined: 2010-08-26
Posts: 137

Status: Offline
i found some fonts in browsers did look ragged recently

they have all recovered now, i aint seen it since weeks

are u dist-upgraded to current actual?
 
 View user's profile Send private message  
Reply with quote Back to top
SuperdigiOffline
Post subject: gtk-qt-engine-kde4  PostPosted: 21.10.2013, 19:18



Joined: 2011-04-16
Posts: 39

Status: Offline
I have a clue. Originally I did this to get sharp not aliased fonts in GTK-Applications:

      Quote:
# At first open konsole and type there:
sudo aptitude install gtk-qt-engine-kde4 kwin-style-qtcurve kde-style-qtcurve gtk2-engines-qtcurve
# Configure KDE. Open: K menu - System settings - Appearance. Choose GTK styles and fonts tab, and select there:
KDE4 GTK Styles and fonts

* GTK styles: Use another style: QtCurve
* GTK fonts: Use my KDE fonts in GTK applications

# Click Apply and reboot system.


When I want to install gtk-qt-engine-kde4 I now get

      Code:
E: Paket gtk-qt-engine-kde4 kann nicht gefunden werden.


Does someone know how I can get it to work again?
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: gtk-qt-engine-kde4  PostPosted: 21.10.2013, 21:10
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
The package now is kde-config-gtk-style

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
SuperdigiOffline
Post subject: RE: gtk-qt-engine-kde4  PostPosted: 23.10.2013, 07:04



Joined: 2011-04-16
Posts: 39

Status: Offline
Thanks hubi. But kde-config-gtk-style is already installed and it does not work.
 
 View user's profile Send private message  
Reply with quote Back to top
piperOffline
Post subject: RE: gtk-qt-engine-kde4  PostPosted: 30.10.2013, 12:16
Moderator


Joined: 2010-09-11
Posts: 480
Location: cheektowaga, ny
Status: Offline
      Code:
apt-get remove --purge kde-style-qtcurve kwin-style-qtcurve
and see if the problem still exists

_________________
debian sid | apt-get into it
 
 View user's profile Send private message  
Reply with quote Back to top
SuperdigiOffline
Post subject: Problem solved  PostPosted: 14.11.2013, 11:12



Joined: 2011-04-16
Posts: 39

Status: Offline
It works now. I had to do this:

      Code:
dpkg-reconfigure fontconfig-config

# and then:
#
# - Native
# - Automatic
# - Yes
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio