Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
seagullOffline
Post subject: Kernel 3.13-0.slh.1-aptosid-amd64 fails to load nvidia 304.  PostPosted: 20.01.2014, 09:28



Joined: 2010-09-11
Posts: 42

Status: Offline
      Quote:
[ 261.240] Initializing built-in extension XFree86-DRI
[ 261.240] Initializing built-in extension DRI2
[ 261.240] (II) LoadModule: "glx"
[ 261.241] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[ 261.271] (II) Module glx: vendor="NVIDIA Corporation"
[ 261.271] compiled for 4.0.2, module version = 1.0.0
[ 261.271] Module class: X.Org Server Extension
[ 261.271] (II) NVIDIA GLX Module 304.117 Tue Nov 26 21:45:09 PST 2013
[ 261.271] Loading extension GLX
[ 261.271] (II) LoadModule: "nvidia"
[ 261.272] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 261.273] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 261.273] compiled for 4.0.2, module version = 1.0.0
[ 261.273] Module class: X.Org Video Driver
[ 261.323] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[ 261.323] (EE) NVIDIA: system's kernel log for additional error messages.
[ 261.323] (II) UnloadModule: "nvidia"
[ 261.323] (II) Unloading nvidia
[ 261.323] (EE) Failed to load module "nvidia" (module-specific error, 0)
[ 261.323] (EE) No drivers available.
[ 261.323] (EE)
Fatal server error:
[ 261.323] (EE) no screens found(EE)
[ 261.323] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 261.323] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 261.323] (EE)


      Code:
Host/Kernel/OS  "aptosidbox4" running Linux 3.12-8.slh.1-aptosid-amd64 x86_64 [ aptosid 2012-01 Θάνατος - kde-full - (201212010120) ]
CPU Info        2x AMD Athlon X2 Dual Core BE-2350 clocked at [ 1800.000 MHz ]
Videocard       NVIDIA C68 [GeForce 7050 PV / nForce 630a]  X.Org 1.14.5  [ 1920x1200@60.0hz ]
Processes 161 | Uptime 10min | Memory 1024.5/1944.3MB | HDD Size 628GB (10%used) | GLX Renderer Gallium 0.4 on NV67 | GLX Version Yes | Client Shell | Infobash v3.46
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Kernel 3.13-0.slh.1-aptosid-amd64 fails to load nvidia  PostPosted: 20.01.2014, 10:30
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
304.117 is a bit dated, any reason for staying with it?

I presume you have tried rebuilding the module like the manual says, is there some error displayed in this process?

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
seagullOffline
Post subject: RE: Kernel 3.13-0.slh.1-aptosid-amd64 fails to load nvidia  PostPosted: 20.01.2014, 12:23



Joined: 2010-09-11
Posts: 42

Status: Offline
It's a Gforce7 card so i (have to) use nvidia-legacy-304xx-driver.
 
 View user's profile Send private message  
Reply with quote Back to top
redsidOffline
Post subject:   PostPosted: 20.01.2014, 13:48



Joined: 2011-02-08
Posts: 32
Location: Lake Otsego
Status: Offline
You're going to have to wait awhile. I have an even older nvidia board that can only use the 304 driver. I use sgfxi and h2 put in a patch for the 3.13 kernel with a note that it may not work, and it doesn't. I use towo's kernels but I haven't seen his 3.13 yet so maybe his will overcome the problem. In sgfxi error message it mentions a hei_vnci module as a problem. I have no idea what that is.
I almost forgot to mention I installed the slh 3.13 only to look at the problem. It's gone now.
 
 View user's profile Send private message  
Reply with quote Back to top
sunuOffline
Post subject:   PostPosted: 21.01.2014, 03:03



Joined: 2010-09-11
Posts: 11

Status: Offline
Even the latest 331.38 don't work for me with 3.13-0.slh.2.

Much more important Alt+SysRq+... keystrokes don't work with the new kernel either.
 
 View user's profile Send private message  
Reply with quote Back to top
towoOnline!
Post subject:   PostPosted: 21.01.2014, 07:57



Joined: 2010-09-13
Posts: 500
Location: Pößneck / Thüringen
Status: Online!
On
      Code:
deb http://packages.siduction.org/fixes unstable main contrib non-free
we provide patched drivers, you could try them.
 
 View user's profile Send private message  
Reply with quote Back to top
bluewaterOffline
Post subject:   PostPosted: 21.01.2014, 10:31
Team Member


Joined: 2010-08-26
Posts: 58
Location: Hobart, Australia
Status: Offline
If the latest kernel borks regarding your legacy card, it is a fact of technology life ,, therefore go back to an earlier kernel and wait patiently, bearing in mind it may never happen, ( I too have been a prisoner of support within the kernel and modules in a box that I no longer have)

_________________
If all else fails, get the instructions back out of the rubbish bin and read them. http://manual.aptosid.com/
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio