Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Luis_POffline
Post subject: Issue with init 3  PostPosted: 02.05.2014, 17:47



Joined: 2010-09-11
Posts: 151
Location: Barcelona, Spain
Status: Offline
An old problem arises again: the order init 3 does not cut gdm (more exactly gdm3; now I don't use lightdm).
I've also tried these orders

      Code:
/etc/init.d/gdm3 stop
update-rc.d gdm3 start 05 5 . stop 01 1 2 3 4 6
update-rc.d gdm3 disable 2 3 4
update-rc.d gdm3 remove
update-rc.d gdm3 defaults

without success.

More info:
      Code:

# infobash -v3
Host/Kernel/OS  "aptosidbox1" running Linux 3.14-1.slh.2-aptosid-amd64 x86_64 [ aptosid 2011-03 Πόνος - xfce - (201112312100) ]
CPU Info        2x AMD Athlon II X2 250 1024 KB cache flags( sse3 ht nx lm svm ) clocked at [ 1800.000 MHz ]
Videocard       Advanced Micro Devices, [AMD/ATI] RV730 PRO [Radeon HD 4650]  X.Org 1.15.1  [ 1280x1024@60.0hz ]
Network cards   Realtek RTL-8139/8139C/8139C+
                NVIDIA MCP77
Processes 154 | Uptime 4:25 | Memory 460.3/2006.9MB | HDD Maxtor 6Y080L0,ST3250318AS Size 332GB (14%used) | GLX Renderer Gallium 0.4 on AMD RV730 | GLX Version Yes | Client Shell | Infobash v3.47

# who -r
         `run-level' 3 2014-05-02 19:04                   último=5

This last after "init 3".


Any help will be appreciated.

Luis_P.
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Issue with init 3  PostPosted: 02.05.2014, 22:35



Joined: 2010-08-25
Posts: 747

Status: Offline
The following should work:
      Code:
# dpkg-reconfigure distro-defaults
# update-rc.d -f gdm3
# update-rc.d gdm3 defaults

Hardcoding init sequence numbers has been ignored since lenny, in favour of (only) relying on LSB dependencies instead. Insserv overrides are, for now (until systemd takes over), the weapon of choice to modify dæmon loading.
 
 View user's profile Send private message  
Reply with quote Back to top
Luis_POffline
Post subject:   PostPosted: 03.05.2014, 10:43



Joined: 2010-09-11
Posts: 151
Location: Barcelona, Spain
Status: Offline
Thanks for your quick reply. However an error message appears:
      Code:

# update-rc.d -f gdm3
update-rc.d: error: not enough arguments
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
      -n: not really
      -f: force

The disable|enable API is not stable and might change in the future.

(The others orders went fine)
And, worst of all, Ctrl+Alt+F7 (having done previously init 3) shows again my Xfce wallpaper.Sad

Something else?

Luis_P
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject:   PostPosted: 03.05.2014, 19:12



Joined: 2010-08-25
Posts: 747

Status: Offline
Ooops, I missed the proper keyword - "update-rc.d -f gdm3 remove" - don't forget to run the last command afterwards again.
 
 View user's profile Send private message  
Reply with quote Back to top
Luis_POffline
Post subject:   PostPosted: 04.05.2014, 11:48



Joined: 2010-09-11
Posts: 151
Location: Barcelona, Spain
Status: Offline
I've corrected the missing order, ran "update-rc.d gdm3 defaults", and Ctrl+Alt+F7 after init 3 shows again the wallpaper.
 
 View user's profile Send private message  
Reply with quote Back to top
Luis_POffline
Post subject: Not solved yet  PostPosted: 15.07.2014, 11:53



Joined: 2010-09-11
Posts: 151
Location: Barcelona, Spain
Status: Offline
I push up this thread because it has not been solved and now, doing apt-get -s dist-upgrade, I can see a lot of new X-server packages want to be installed.

All the slh's advices have been followed with no success.

Best regards.

Luis_P
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio