Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: Problems with sound  PostPosted: 10.02.2015, 02:18



Joined: 2010-09-12
Posts: 470

Status: Offline
Dear all,

I've just done a new install. Everything went well with installation, but I cannot quite get sound to work.

Is pulse recommended? It's one thing I haven't tried.

Here is some info:

      Code:

finottim83[~]$ infobash -v3
Host/Kernel/OS  "finottim83" running Linux 3.19.0-0.slh.1-aptosid-amd64 x86_64 UEFI64 [ aptosid 2013-01 Ἑσπερίδες - kde-full - (201305050307) ]
CPU Info        8x Intel Core i7-4790 @ 8192 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 3658.218 MHz ]
Videocard       Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller  tty resolution ( 94x61 )
Network cards   Intel I217-LM
Processes 194 | Uptime 5:54 | Memory 2405.9/31977.9MB | HDD Crucial_CT512M55,WDC WD5000AAKX-0 Size 1012GB (8%used) | Runlevel 5 | Client Shell | Infobash v3.49


      Code:

finottim83[~]$ lspci
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Q85 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)


      Code:

finottim83[~]$ lsmod | grep snd
snd_hda_codec_hdmi     36654  1
snd_hda_codec_realtek    56210  1
snd_hda_codec_generic    51198  1 snd_hda_codec_realtek
snd_hda_intel          21867  4
snd_hda_controller     17819  1 snd_hda_intel
snd_hda_codec          89695  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep               6228  1 snd_hda_codec
snd_pcm                78539  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              18102  1 snd_pcm
snd                    58113  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore               5359  2 snd,snd_hda_codec


I have set up KDE -> Multimedia -> Audio and Video Settings with the correct output (the non HDMI Intel -- I can give more details tomorrow), but clicking on the "Test" button I get no sound from any of the optinos. I've also tried both gstreamer and vlc backends.

I could get sound from audacious by manually configuring its settings (selected ALSA, the correct device and the correct mixer), but could not get any sound from anything else (e.g., iceweasel).

Any suggestions?

Thanks,

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: Re: Problems with sound  PostPosted: 10.02.2015, 03:35



Joined: 2010-08-25
Posts: 949

Status: Offline
      finotti wrote:
I could get sound from audacious by manually configuring its settings (selected ALSA, the correct device and the correct mixer), but could not get any sound from anything else (e.g., iceweasel).

O.k., this proves that the kernel side (and thereby the hardware specific aspect) of it is fine - so the problem is likely to be found higher up in the software stack, perhaps in your mixer configuration or its integration with higher level audio stacks. Usually the best course of action is to avoid pulseaudio and to keep KDE's management consoles alone, by configuring alsa underneath its feet (alsamixer). This tends to be the easiest way to make the configuration global to your whole system (hardware, users and software).

If you're using pulseaudio or other high-level audio stacks, you'll have to deal with their respective configuration methods.

Reading your other post, it could (although not very likely) also be a permission problem (polkit) inherited duing the dist-upgrade, so try the following as well (this is safe/ recommended either way):
      Code:
# apt-get update
# apt-get dist-upgrade
# apt-get install --purge systemd-sysv libpam-systemd
# apt-get remove --purge systemd-shim
# reboot
Also make sure that your user is member of the "audio" group (running "groups" as your user should show that).

Post scriptum: desktop environments (KDE, GNOME, to a lesser extent also the smaller ones) try to be smart about providing configuration aids for hardware (bootloader- or display-manager-) settings, like audio or screen settings - these usually don't work too well, because they're rarely properly adapted to the running distribution or even OS (they've been written by the desktop environment upstream developers, with a wide range of distributions and UN*X-like operating systems, sometimes even windows, in mind). Additionally, due to their nature, they can only apply their settings when the corresponding user is logged in - leaving an unconfigured state for the other users of the system or states when no user is logged in (display-manager when it comes to X, non-PAM sessions, etc.).
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: Re: Problems with sound  PostPosted: 10.02.2015, 14:34



Joined: 2010-09-12
Posts: 470

Status: Offline
Thanks, slh for the quick and helpful reply (as usual).

      slh wrote:
[snip] Usually the best course of action is to avoid pulseaudio and to keep KDE's management consoles alone, by configuring alsa underneath its feet (alsamixer). This tends to be the easiest way to make the configuration global to your whole system (hardware, users and software).


I did not mentioned, but I had already checked. The mixer showed the volumes (for the non-HDMI card) at good levels.


      slh wrote:

Reading your other post, it could (although not very likely) also be a permission problem (polkit) inherited duing the dist-upgrade, so try the following as well (this is safe/ recommended either way):
      Code:
# apt-get update
# apt-get dist-upgrade
# apt-get install --purge systemd-sysv libpam-systemd
# apt-get remove --purge systemd-shim
# reboot
Also make sure that your user is member of the "audio" group (running "groups" as your user should show that).


I had checked a couple of those before (as I remembered you've mentioned to make sure systemd-sysv was installed and syestemd-shim was not in a previous discussion of new installs) and, indeed, the commands above did not install or remove anything.

I decided to install alsaplayer-alsa and see if that would work. I got the following error message:

      Code:

ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory


I googled around a bit and found this: http://forums.gentoo.org/viewtopic-p-7590240.html

I followed the instructions at the very last post and created a '/etc/modprobe.d/alsa.conf' file (there was none) with

      Code:

options snd-hda-intel id=PHC index=1


After rebooting, it seems to work. (I will mark this solved.)

Thanks for the help!

Luis
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio