Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
snvvOffline
Post subject: Many packages to be removed  PostPosted: 02.06.2015, 11:07



Joined: 2010-09-13
Posts: 331

Status: Offline
with last DU the following packages will be removed

libkpeople3 libktpcommoninternalsprivate7 libktploggerprivate7 libktpmodelsprivate7 libktpwidgetsprivate7 libqt4-core libqt4-gui

I am especially concerned with last two : libqt4-core libqt4-gui

If I put libqt4-core on hold then the packages to be removed are much more.

The complete listing is as follows:
      Code:
Calculating upgrade... Done
The following packages will be REMOVED:
  libkpeople3 libktpcommoninternalsprivate7 libktploggerprivate7 libktpmodelsprivate7 libktpwidgetsprivate7 libqt4-core libqt4-gui
The following NEW packages will be installed:
  libapparmor1 libjim0.76 libjs-prototype libjs-scriptaculous libkpeople-data libkpeople4 libkpeoplewidgets4 libktpcommoninternalsprivate8
  libktploggerprivate8 libktpmodelsprivate8 libktpotrprivate8 libktpwidgetsprivate8 libqtgstreamer-1.0-0 libqtgstreamerui-1.0-0 qtgstreamer-declarative
The following packages will be upgraded:
  adwaita-icon-theme binutils bsdutils ca-certificates cpp-4.9 dconf-gsettings-backend dconf-service debianutils distro-defaults dosfstools dpkg dpkg-dev
  feh g++-4.9 gcc-4.9 gcc-4.9-base gcc-5-base gcj-4.9-jre-headless gcj-4.9-jre-lib gdisk gfortran-4.9 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0
  gir1.2-glib-2.0 gnupg gnupg-agent gnupg2 gpgv gvfs gvfs-backends gvfs-common gvfs-daemons gvfs-libs iceweasel kde-config-telepathy-accounts kde-telepathy
  kde-telepathy-auth-handler kde-telepathy-call-ui kde-telepathy-contact-list kde-telepathy-declarative kde-telepathy-desktop-applets
  kde-telepathy-filetransfer-handler kde-telepathy-integration-module kde-telepathy-kpeople kde-telepathy-minimal kde-telepathy-send-file
  kde-telepathy-text-ui libasan1 libatomic1 libav-tools libavcodec56 libavdevice55 libavfilter5 libavformat56 libavresample2 libavutil54 libblkid1
  libcilkrts5 libdconf1 libdebian-installer-extra4 libdebian-installer4 libdpkg-perl libfdisk1 libgcc-4.9-dev libgcc1 libgcj15 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libgfortran-4.9-dev libgfortran3 libgirepository-1.0-1 libgoa-1.0-0b libgoa-1.0-common libgomp1 libgudev-1.0-0 libgwengui-cpp0
  libgwengui-qt4-0 libgwenhywfar-data libgwenhywfar60 libitm1 libkolab0 libkolabxml1 libmodplug1 libmount1 libnspr4 libnspr4-0d libnss3 libnss3-1d
  libopenjp2-7 libopenjpeg5 libpam-systemd libpcre3 libpython2.7 libpython2.7-minimal libpython2.7-stdlib libqt4-dbus libqt4-declarative libqt4-designer
  libqt4-dev libqt4-dev-bin libqt4-help libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-sqlite
  libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libquadmath0 libraw10 libreadline5 libsane libsane-common libsbc1
  libsmartcols1 libstdc++-4.9-dev libstdc++6 libswscale3 libsystemd0 libterm-readkey-perl libubsan0 libudev1 libupower-glib3 libuuid1 libwayland-client0
  libwayland-cursor0 libwayland-server0 libzvbi-common libzvbi0 linux-libc-dev mount ntfs-3g plasma-runner-telepathy-contact python-imaging python-pil
  python-pip python-pkg-resources python-requests python-setuptools python2.7 python2.7-minimal python3-pip python3-pkg-resources python3-requests
  python3-setuptools qdbus qt4-linguist-tools qt4-qmake qt4-qtconfig qtcore4-l10n r-cran-gtools r-cran-rcurl r-cran-rsymphony r-cran-xml sane-utils systemd
  udev upower usb-modeswitch util-linux
167 upgraded, 15 newly installed, 7 to remove and 0 not upgraded.
Need to get 0 B/182 MB of archives.
After this operation, 9,320 kB of additional disk space will be used.
Do you want to continue? [Y/n]
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Many packages to be removed  PostPosted: 02.06.2015, 16:11



Joined: 2010-08-25
Posts: 949

Status: Offline
That's the normal churn of library transitions, all to be expected and fine.
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject: Re: RE: Many packages to be removed  PostPosted: 13.06.2015, 21:12



Joined: 2010-09-14
Posts: 194
Location: Costa Teguise
Status: Offline
      slh wrote:
That's the normal churn of library transitions, all to be expected and fine.

As a softwaredeveloper I rely quite badly on tortoisehg. i can do without graphical interface most of the time. But I am at a state of transition which could produce some problems without these tools.
So, I am worrying for a couple of weeks about this:
      Code:
Calculating upgrade... Done
The following packages will be REMOVED:
  librpmsign1 tortoisehg xserver-xorg-video-modesetting

ATM I just wonder if it would be save and possible to d-u and reinstall toroisehg?
Thanks in advance
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Re: RE: Many packages to be removed  PostPosted: 13.06.2015, 22:33



Joined: 2010-08-25
Posts: 949

Status: Offline
xserver-xorg-video-modesetting is fine/ expected, librpmsign1 part of a normal library transition - tortoisehg is installable normally on unstable at the moment.
 
 View user's profile Send private message  
Reply with quote Back to top
hyOffline
Post subject: RE: Re: RE: Many packages to be removed  PostPosted: 14.06.2015, 08:45



Joined: 2010-09-14
Posts: 194
Location: Costa Teguise
Status: Offline
As of today, the message that tortoisehg will be removed vanished.
 
 View user's profile Send private message  
Reply with quote Back to top
joschOffline
Post subject: Many packages to be removed  PostPosted: 21.06.2015, 21:25



Joined: 2011-02-05
Posts: 8

Status: Offline
sorry to ask the same question once again. In my case it is a lot of core kde-software to be removed and I am really uncertain what to do. Of course I don't want to crash may installation when I do the next d-u. Is there anyone who can give me some advise ? Josch

Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
abiword afflib-dbg afflib-tools aimage akonadiconsole akregator apt-file apt-spy aptosid-art-kde aptosid-art-kde-imera aptosid-art-kde-nemesis
aptosid-art-ksplash-geras aptosid-art-ksplash-imera aptosid-art-ksplash-nemesis aptosid-settings-kde ardour audacious audacious-plugins autopsy
blogilo braindump brasero browser-plugin-gnash calligra calligra-libs calligraauthor calligraflow calligraplan calligrasheets calligrastage
calligrawords cantata cantor-backend-octave cantor-backend-r cantor-backend-scilab clamassassin clamav clamtk cmake curl digikam
digikam-private-libs dolphin feh ffmpeg ffmpegthumbs flashplugin-nonfree gimp gir1.2-rb-3.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 git gnash
gnash-common gnome-video-effects gosmore grilo-plugins-0.2 gstreamer0.10-plugins-bad gstreamer1.0-plugins-bad idjc kaddressbook kaffeine kajongg
kalarm karbon kde-baseapps kde-plasma-desktop kde-plasma-netbook kde-workspace kde-workspace-bin kdeartwork kdebase-apps kdebase-workspace
kdebase-workspace-bin kdenetwork kdepim kdepim-kresources kdepim-runtime kdesdk kdesdk-dolphin-plugins kdeutils kdewebdev kexi
kexi-calligrasheets-driver kexi-mysql-driver kexi-postgresql-driver kexi-sybase-driver kexi-xbase-driver kgpg kile kile-l10n kipi-plugins kjots
kleopatra klinkstatus kmail knode knotes konsolekalendar kontact konversation kopete korganizer krfb krita krusader kscreensaver
kscreensaver-xsavers ktorrent libabiword-2.9 libabiword-3.0 libafflib-dev libafflib0 libarchive12 libaubio4 libavdevice-ffmpeg56 libavdevice56
libavfilter-ffmpeg5 libavfilter5 libavformat-ffmpeg56 libavformat55 libbaloowidgets4 libbrasero-media3-1 libcalendarsupport4 libcmis-0.2-0
libcmis-0.3-3 libcmis-0.4-4 libcmis-0.5-5 libcryptui0a libcups2:i386 libcurl3 libcurl3-nss libeventviews4 libfarstream-0.1-0 libgdata19
libgegl-0.2-0 libgmime-2.6-0 libgmime2.6-cil libgnutls-deb0-28:i386 libgnutls28 libgrilo-0.2-1 libhogweed2:i386 libincidenceeditorsng4
libkactivities-bin libkactivities-models1 libkdepim4 libkdepimdbusinterfaces4 libkfilemetadata4 libkolab0 libkolabxml0 libkolabxml1 libkopete4
libkpeople4 libksieveui4 libktpcommoninternalsprivate8 libktpmodelsprivate8 libktpwidgetsprivate8 libldap-2.4-2:i386 liblrdf0 libmailcommon4
libmailimporter4 libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4 libmetacity-private2 libnepomukcore4 libnepomukwidgets4
libnepomukwidgets4abi1 libnettle4:i386 libnoteshared4 liboauth0 liboctave2 libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-features2d2.4
libopencv-gpu2.4 libopencv-highgui2.4 libopencv-legacy2.4 libopencv-objdetect2.4 libopencv-ocl2.4 libopencv-stitching2.4 libopencv-superres2.4
libopencv-ts2.4 libopencv-videostab2.4 libpimcommon4 libpurple0 libqmmp-misc libquvi0 libquvi7 libraptor1 librasqal2 libreoffice-base-core
libreoffice-calc libreoffice-core libreoffice-draw libreoffice-help-de libreoffice-help-en-us libreoffice-impress libreoffice-kde
libreoffice-math libreoffice-writer librhythmbox-core4 librhythmbox-core5 librhythmbox-core7 librhythmbox-core8 librhythmbox-core9 libslv2-9
libtelepathy-farstream2 libtemplateparser4 libtotem-plparser17 libtotem-plparser18 libtotem0 libtsk-dev libtsk10 libtsk3-3 libtsk3-3-dbg
libwine:i386 libwine-bin:i386 libxine2-ffmpeg libxine2-plugins mythes-de mythes-en-us ncmpcpp nepomuk-core-runtime octave pidgin
plasma-dataengines-workspace plasma-desktop plasma-netbook plasma-runners-addons plasma-widgets-workspace python-aptdaemon-gtk
python-aptdaemon.gtkwidgets python-cupshelpers python-kde4 python-pycurl r-base-core rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugins
rosegarden scilab-cli scilab-full-bin scilab-minimal-bin seahorse seahorse-daemon sleuthkit smb4k sound-juicer streamtuner system-config-printer
system-config-printer-udev totem totem-plugins transcode virtualbox-4.3 vlc vlc-nox vlc-plugin-jack vorbis-tools weechat-curses wine32:i386
xjadeo yakuake
Die folgenden NEUEN Pakete werden installiert:
gir1.2-vte-2.91 gstreamer1.0-clutter-3.0 libcamel-1.2-52 libclutter-gst-3.0-0 libebackend-1.2-10 libebook-1.2-16 libebook-contacts-1.2-1
libecal-1.2-18 libedata-book-1.2-25 libedataserver-1.2-20 libgom-1.0-0 libgom-1.0-common libgtop-2.0-10 libhogweed4 libhogweed4:i386
libmetacity-private3 libnettle6 libnettle6:i386 libplist3 libqca2-plugins libqt5concurrent5 libqt5declarative5 libqt5quickwidgets5
libqt5scripttools5 libqt5sql5-sqlite libqt5xmlpatterns5 libwps-0.4-4 mplayer2 qml-module-qtquick-controls qml-module-qtquick-layouts
qml-module-qtquick-window2 qml-module-qtquick2 ruby-molinillo **removed**
Die folgenden Pakete sind zurückgehalten worden:
libavformat56 libcurl3-gnutls libglib2.0-0 libglib2.0-bin libgnutls-deb0-28 libgnutls-openssl27 libgpgme11 libifd-cyberjack6 transmission-common
transmission-gtk wget
Die folgenden Pakete werden aktualisiert (Upgrade):
abiword-common accountsservice ant apt-listchanges aptdaemon aptdaemon-data bundler calligra-data calligraflow-data calligrastage-data
calligrawords-data ceni clamav-base clamav-freshclam cpp-4.8 cpp-4.9 cups cups-bsd cups-client cups-common cups-core-drivers cups-daemon
cups-filters cups-filters-core-drivers cups-ppdc cups-server-common dbconfig-common deb-multimedia-keyring distro-defaults docbook-xml ekiga
elinks elinks-data evince evince-common evolution-common evolution-data-server-common ewf-tools fil-plugins file-roller five-or-more
folks-common fonts-opensymbol fuse g++-4.8 g++-4.9 gcalctool gcc-4.8 gcc-4.8-base gcc-4.8-base:i386 gcc-4.9 gcc-4.9-base gcc-4.9-base:i386
gcc-5-base gcc-5-base:i386 gedit gedit-common geoip-database geoip-database-extra gir1.2-clutter-1.0 gir1.2-gnomebluetooth-1.0 gir1.2-gtk-2.0
gir1.2-gtk-3.0 gir1.2-gtksource-3.0 gir1.2-packagekitglib-1.0 gir1.2-panelapplet-4.0 gir1.2-upowerglib-1.0 gjs glchess glines
gnome-accessibility-themes gnome-calculator gnome-chess gnome-control-center-data gnome-klotski gnome-mahjongg gnome-mines gnome-nettool
gnome-settings-daemon gnome-sudoku gnome-system-monitor gnome-tetravex gnome-themes-standard gnome-themes-standard-data gnomine gnotravex
gnotski gnuchess gnupg-agent gnupg2 gpgsm groovy2 grub-common grub-pc grub-pc-bin grub2-common gstreamer1.0-clutter gtali gtk2-engines-pixbuf
gvfs gvfs-backends gvfs-bin gvfs-daemons gvfs-libs iagno iamerican ienglish-common ifupdown inkscape iso-codes ispell jarwrapper jmapviewer
kexec-tools kexi-data krita-data libaccountsservice0 libafterimage0 libarchive13 libasan0 libasan1 libatk-wrapper-java libatk-wrapper-java-jni
libatomic1 libaudit-common libaudit1 libaudit1:i386 libavcodec-ffmpeg56 libavcodec56 libavresample-ffmpeg2 libavresample2 libavutil-ffmpeg54
libavutil54 libbfio-dev libbfio1 libboost-date-time1.54.0 libboost-program-options1.54.0 libboost-python1.54.0 libboost-signals1.54.0
libboost-system1.54.0 libboost-thread1.54.0 libcap2 libcap2:i386 libcap2-bin libcilkrts5 libclamav6 libclutter-1.0-0 libclutter-gst-2.0-0
libcups2 libcupscgi1 libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libdatrie1 libdatrie1:i386 libdbusmenu-qt2 libdebconfclient0
libdebian-installer-extra4 libdebian-installer4 libdmapsharing-3.0-2 libegl1-mesa libegl1-mesa:i386 libegl1-mesa-dev libegl1-mesa-drivers
libevdocument3-4 libevview3-3 libewf-dbg libewf-dev libewf2 libfolks-telepathy25 libfolks25 libfontembed1 libfreehand-0.1-1 libfuse2 libgail-3-0
libgail18 libgbm1 libgbm1:i386 libgcc-4.8-dev libgcc-4.9-dev libgcc1 libgcc1:i386 libgcj15 libgee-0.8-2 libgfortran3 libgjs0e libgksu2-0
libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles1-mesa
libgles2-mesa libglib2.0-data libglib2.0-doc libgnome-bluetooth13 libgoa-1.0-0b libgoa-1.0-common libgomp1 libgpg-error0 libgpg-error0:i386
libgpod4 libgstreamer-plugins-bad1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkmm-3.0-1
libgtksourceview-3.0-1 libgtksourceview-3.0-common libgtop2-common libgudev-1.0-0 libhtml-parser-perl libhtml-tree-perl libhwloc5 libibus-1.0-5
libimobiledevice4 libinput10 libio-socket-inet6-perl libio-socket-ssl-perl libitm1 libjsoncpp0 libldap-2.4-2 liblocale-gettext-perl liblsan0
liblz4-1 libmodplug1 libmtp-common libmtp-runtime libmtp9 libmysqlclient18 libnb-org-openide-util-java libnb-org-openide-util-lookup-java
libnss3 libnss3:i386 libnss3-1d libnss3-1d:i386 libobjc-4.9-dev libobjc4 libpackagekit-glib2-18 libpam-systemd libpanel-applet-4-0 libpcre3
libpcre3:i386 libpcrecpp0 libperl4-corelibs-perl libpostproc-ffmpeg53 libpostproc53 libpq5 libpython2.7 libpython2.7-minimal libpython2.7-stdlib
libpython3.4 libpython3.4-minimal libpython3.4-stdlib libqca2 libqca2-plugin-gnupg libqca2-plugin-ossl libqdbm14 libqscintilla2-11 libquadmath0
libreoffice-common libreoffice-l10n-de libreoffice-style-galaxy libruby libsbc1 libseccomp2 libselinux1 libselinux1:i386 libsemanage1 libslang2
libslang2:i386 libsonic0 libssl-dev libssl1.0.0 libssl1.0.0:i386 libstdc++-4.8-dev libstdc++-4.9-dev libstdc++6 libstdc++6:i386
libswresample-ffmpeg1 libswresample1 libswscale-ffmpeg3 libswscale3 libsystemd0 libsystemd0:i386 libterm-readkey-perl libtext-glob-perl
libthai-data libthai0 libthai0:i386 libtsan0 libubsan0 libudev1 libudev1:i386 libupower-glib3 libusbmuxd2 libustr-1.0-1 libutempter0
libvncclient1 libvncserver1 libwavpack1 libwayland-client0 libwayland-client0:i386 libwayland-cursor0 libwayland-dev libwayland-egl1-mesa
libwayland-server0 libwayland-server0:i386 libwine libwireshark-data libwireshark5 libwiretap4 libwsutil4 libwww-perl libx265-59 libxatracker2
libxml++2.6-2 libxml-libxml-perl linux-libc-dev mahjongg maxima mesa-common-dev metacity metacity-common musescore musescore-common
mutter-common mysql-client mysql-client-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5 notification-daemon openssl p7zip
p7zip-full pinentry-gtk2 python-apt python-apt-common python-aptdaemon python-aptdaemon.gtk3widgets python-enum34 python-imaging python-pil
python-qt4 python-qt4-dbus python-qt4-sql python-reportlab python-reportlab-accel python-simplejson python-sip python2.7 python2.7-minimal
python3-apt python3-aptdaemon python3.4 python3.4-doc python3.4-minimal qemu-utils rkhunter ruby ruby-atomic ruby-cairo ruby-json
ruby-mime-types ruby-minitest ruby-mysql ruby-nokogiri ruby-sqlite3 ruby-text-format ruby-unf-ext ruby-zoom rubygems-integration scdaemon screen
seabios sqlitebrowser sysstat systemd systemd-gui systemd-sysv systemd-ui tali tor tor-geoipdb torsocks totem-common udev unattended-upgrades
uno-libs3 upower ure usbmuxd vim vim-common vim-runtime wavpack whois wine64 wireshark wireshark-common xfig xfsprogs youtube-dl zynaddsubfx
413 aktualisiert, 34 neu installiert, 265 zu entfernen und 11 nicht aktualisiert.
Es müssen 459 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 1.084 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Many packages to be removed  PostPosted: 22.06.2015, 08:19



Joined: 2010-09-12
Posts: 470

Status: Offline
Definitely do not proceed. But I do not have that problem. (Just DUed and no KDE package was removed.) Are you on AMD64?

Also, please use the 'code' tags for the APT output. It makes it much easier to read.
 
 View user's profile Send private message  
Reply with quote Back to top
joschOffline
Post subject: RE: Many packages to be removed  PostPosted: 22.06.2015, 09:43



Joined: 2011-02-05
Posts: 8

Status: Offline
Thanks for your advice: I didn't proceed so far. I'm on AMD64. And you are right it was a little bit silly not to use the code tags.
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: Many packages to be removed  PostPosted: 22.06.2015, 10:59



Joined: 2010-09-12
Posts: 470

Status: Offline
It's odd that those packages are to be removed in your system, but not mine. Maybe you can run:
      Code:

apt-get -o Debug::pkgProblemResolver=yes dist-upgrade

(answer NO) to see what is going on. Have you DUed recently?
 
 View user's profile Send private message  
Reply with quote Back to top
snvvOffline
Post subject:   PostPosted: 25.06.2015, 08:40



Joined: 2010-09-13
Posts: 331

Status: Offline
Recent DU

      Quote:
Calculating upgrade... Done
The following packages will be REMOVED:
libarchive12 libgnutls28-dev libhogweed2 librtmp-dev
The following NEW packages will be installed:
libaqbanking35-plugins libdouble-conversion1 libfakekey0 libgtop-2.0-10 libjavascriptcoregtk-4.0-18 liborcus-0.10-0 libpcre16-3 libqca2-plugins libseccomp2 libwebkit2gtk-4.0-37
libwps-0.4-4 linux-headers-4.1.0-0.slh.1-aptosid-amd64 linux-image-4.1.0-0.slh.1-aptosid-amd64
The following packages have been kept back:
chromium libgnutls-deb0-28 libgnutls-openssl27 libgnutlsxx28 libudev1 udev wget
The following packages will be upgraded:
...

241 upgraded, 13 newly installed, 4 to remove and 7 not upgraded.
Need to get 0 B/396 MB of archives.
After this operation, 351 MB of additional disk space will be used.
Do you want to continue? [Y/n]


What I do now?
Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 25.06.2015, 13:29



Joined: 2010-09-13
Posts: 516
Location: Pößneck / Thüringen
Status: Offline
Let them go.

_________________
      Code:

System:    Host: Defiant Kernel: 4.9.1-towo.1-siduction-amd64 x86_64 (64 bit) Desktop: Cinnamon 3.2.7
           Distro: siduction 13.2.0 December - xfce - (201312310323)
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio