Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
kenyeeOffline
Post subject: kdebase and kde-workspace no longer needed as packages?  PostPosted: 08.08.2015, 22:14



Joined: 2010-09-29
Posts: 98

Status: Offline
Weird that it wants to take out MySql and MythTV as well.
Is it safe to upgrade?


The following packages will be REMOVED:
akonadi-backend-mysql digikam digikam-private-libs gs-cjk-resource
kde-plasma-desktop kde-workspace kde-workspace-bin kdebase kdebase-workspace
kdebase-workspace-bin kdepim-runtime kdeutils kgpg konversation kopete krfb
libasprintf0c2 libcalendarsupport4 libept1.4.12 libffado1 libglibmm-2.4-1c2a
libincidenceeditorsng4 libkadm5srv-mit8 libkdb5-7 libkdepim4
libkdepimdbusinterfaces4 libkolab0 libkolabxml1 libkopete4 libkpeople4
libktpcommoninternalsprivate8 libktpmodelsprivate8 libktpwidgetsprivate8
libmailcommon4 libmailimporter4 libmessagecomposer4 libmessagecore4
libmessageviewer4 libpimcommon4 libproxy1 libqpdf13 libsigc++-2.0-0c2a
libsigc++-2.0-0c2a:i386 libtemplateparser4 libusb++-0.1-4c2 libxapian22
mysql-admin mysql-client mysql-client-5.5 mysql-server mysql-server-5.5
mysql-server-core-5.5 mythtv mythtv-database plasma-dataengines-workspace
plasma-desktop plasma-widgets-workspace xpdf-common
The following NEW packages will be installed:
akonadi-backend-sqlite cpp-5 g++-5 gcc-5 gdb-minimal kde-cli-tools
kde-cli-tools-data konsole-kpart konsole4-kpart ksysguard-data kwin-common
kwin-data kwin-x11 libapt-inst1.7 libapt-pkg4.16 libasan2 libasprintf0v5
libavcodec-ffmpeg56 libavformat-ffmpeg56 libavutil-ffmpeg54 libcc1-0
libdbusmenu-qt5-2 libdouble-conversion1 libgcc-5-dev libglibmm-2.4-1v5
libicu55 libinput10 libjs-inherits libkdb5-8 libkdecorations2-5
libkdecorations2private5 libkf5activities5 libkf5archive5 libkf5attica5
libkf5auth-data libkf5auth5 libkf5bluezqt-data libkf5bluezqt5
libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5
libkf5completion-data libkf5completion5 libkf5config-data libkf5configcore5
libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-data
libkf5dbusaddons5 libkf5declarative-data libkf5declarative5
libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5
libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data
libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5
libkf5kcmutils-data libkf5kcmutils5 libkf5kdelibs4support-data
libkf5kdelibs4support5 libkf5khtml-data libkf5khtml5 libkf5kiocore5
libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5 libkf5newstuff-data
libkf5newstuff5 libkf5notifications-data libkf5notifications5
libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data
libkf5package5 libkf5parts-data libkf5parts5 libkf5plasma5
libkf5plasmaquick5 libkf5plotting5 libkf5pty-data libkf5pty5
libkf5quickaddons5 libkf5screen6 libkf5service-bin libkf5service-data
libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data
libkf5sonnetcore5 libkf5sonnetui5 libkf5su-data libkf5su5 libkf5sysguard-bin
libkf5sysguard-data libkf5textwidgets-data libkf5textwidgets5
libkf5wallet-data libkf5wallet5 libkf5waylandclient5 libkf5waylandserver5
libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
libkf5windowsystem5 libkf5xmlgui-data libkf5xmlgui5 libksgrd7
libksignalplotter7 libkwalletbackend5-5 libkwin4-effect-builtins1
libkwineffects6 libkwinglutils6 libkwinxrenderutils6 liblilv-0-0 libmovit2
libmpx0 libmusicbrainz5cc2 libpcre16-3 libphonon4qt5-4 libpolkit-qt5-1-1
libprocesscore7 libprocessui7 libprocps4 libproxy1v5 libqpdf13v5
libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5multimedia5
libqt5multimediaquick-p5 libqt5network5 libqt5opengl5 libqt5printsupport5
libqt5qml5 libqt5quick5 libqt5script5 libqt5sql5 libqt5sql5-sqlite
libqt5svg5 libqt5webkit5 libqt5widgets5 libqt5x11extras5 libqt5xml5
libsdl-image1.2 libserd-0-0 libsigc++-2.0-0v5 libsord-0-0 libsratom-0-0
libstdc++-5-dev libsuil-0-0 libswresample-ffmpeg1 libswscale-ffmpeg3
libtrio2 libusb++-0.1-4v5 libx264-148 libxapian22v5 libxcb-cursor0
libxcb-icccm4 libxcb-xkb1 libxkbcommon-x11-0 mariadb-client
mariadb-client-10.0 mariadb-client-core-10.0 mariadb-common pinentry-gnome3
plasma-framework polkit-kde-agent-1 poppler-data python3-apt python3-chardet
python3-debian python3-pkg-resources python3-six qml-module-org-kde-bluezqt
qml-module-org-kde-draganddrop qml-module-org-kde-kcoreaddons
qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons
qml-module-org-kde-solid qml-module-qtgraphicaleffects
qml-module-qtmultimedia qml-module-qtquick-controls
qml-module-qtquick-layouts qml-module-qtquick-window2 qml-module-qtquick2
qtdeclarative5-kf5declarative qtdeclarative5-kf5solid
The following packages have been kept back:
gstreamer0.10-plugins-good k3b ktorrent libk3b6 libtagc0 vlc-nox
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 08.08.2015, 22:24



Joined: 2010-08-25
Posts: 949

Status: Offline
It depends on which packages, besides the library churn, you care about - but the general answer to this is a firm 'no' for now.
 
 View user's profile Send private message  
Reply with quote Back to top
kenyeeOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 09.08.2015, 00:55



Joined: 2010-09-29
Posts: 98

Status: Offline
Thanks slh...thought so too Smile
Just wondering if anyone else hit this and survived the d-u Wink
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 12.08.2015, 03:17



Joined: 2010-10-01
Posts: 288

Status: Offline
I let kdeworkspace go a few weeks ago to resolve a dependency issue. This allowed me to dist-upgrade until I was stopped by the gcc5 transition like everyone else apparently.
      Code:
$ zgrep workspace /var/log/apt/term.log.1.gz
Removing kde-workspace (4:4.11.13-2) ...
Removing kde-workspace-bin (4:4.11.13-2) ...
Removing kde-workspace-data (4:4.11.13-2) ...
Selecting previously unselected package libkworkspace5-5.
Preparing to unpack .../libkworkspace5-5_4%3a5.3.2-4_amd64.deb ...
Unpacking libkworkspace5-5 (4:5.3.2-4) ...
Selecting previously unselected package plasma-workspace.
Preparing to unpack .../plasma-workspace_4%3a5.3.2-4_amd64.deb ...
Unpacking plasma-workspace (4:5.3.2-4) ...
Setting up libkworkspace5-5 (4:5.3.2-4) ...
Setting up plasma-workspace (4:5.3.2-4) ...
Removing kde-workspace-kgreet-plugins (4:4.11.13-2) ...
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
slhOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 22.08.2015, 20:19



Joined: 2010-08-25
Posts: 949

Status: Offline
It's a bit early to officially call it "green lights", but I'd venture to call it "yellow lights with shades of green" (or Grünpfeil in the german StVO).

While it strongly depends on which packages you have installed - and which of those you care about, many regular systems should be upgradable with some handholding for apt (as the dependency cycles still aren't quite well).
      Code:
# apt update
# apt-get dist-upgrade libstreamanalyzer0v5+ libstreams0v5+ libstreams0- kdeutils+ kdeadmin+ konversation+

Even with that assistance, you'll need to be very careful and cross-check what apt wants to remove - don't expect to be able to reinstall whatever bites the dust anytime soon. So if apt wants to remove any non-library packages (you care about), give it some more time!

MythTV probably needs some more time, before you can upgrade that.
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 25.08.2015, 03:15



Joined: 2010-10-01
Posts: 288

Status: Offline
No go here:
      Code:
# apt-get dist-upgrade libstreamanalyzer0v5+ libstreams0v5+ libstreams0- kdeutils+ kdeadmin+ konversation+
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... konversation is already the newest version.
kdeadmin is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdeadmin : Depends: ksystemlog (>= 4:4.11.3) but it is not going to be installed
            Depends: kuser (>= 4:4.11.3) but it is not going to be installed
 kdeutils : Depends: ark (>= 4:4.11.3) but it is not going to be installed
            Depends: filelight (>= 4:4.11.3) but it is not going to be installed
            Depends: kcharselect (>= 4:4.11.3) but it is not going to be installed
            Depends: kdf (>= 4:4.11.3) but it is not going to be installed
            Depends: kgpg (>= 4:4.11.3) but it is not going to be installed
            Depends: kremotecontrol (>= 4:4.11.3) but it is not going to be installed
            Depends: ktimer (>= 4:4.11.3) but it is not going to be installed
            Depends: kwalletmanager (>= 4:4.11.3) but it is not going to be installed
            Depends: plasma-scriptengine-superkaramba (>= 4:4.11.3) but it is not going to be installed
            Depends: sweeper (>= 4:4.11.3) but it is not going to be installed
 konversation : Depends: kde-runtime (> 4:4.10) but it is not going to be installed
                Depends: kdepim-runtime but it is not going to be installed
                Depends: libkde3support4 (>= 4:4.4.3) but it is not going to be installed
                Depends: libkparts4 (>= 4:4.4.3) but it is not going to be installed
                Depends: libnepomukutils4 (>= 4:4.5.85) but it is not going to be installed
 libstreamanalyzer0v5 : Depends: libclucene-core1v5 (>= 2.3.3.4) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
slhOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 25.08.2015, 23:38



Joined: 2010-08-25
Posts: 949

Status: Offline
It depends on your installed packages (sometimes giving apt some more guidance to resolve the dependencies can help, sometimes it doesn't and only time will sort it out) - and changes from day to day.
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 30.08.2015, 19:06



Joined: 2010-10-01
Posts: 288

Status: Offline
I let 75 packages go today and things looks good. I can do without digikam and I was able to get wine32 back.

      Code:
Start-Date: 2015-08-30  11:30:09
Commandline: apt-get dist-upgrade
...
Remove: libktoblzcheck1c2a:amd64 (1.48-2), libept1.4.12:amd64 (1.0.12.1), libboost-date-time1.55.0:amd64 (1.
55.0+dfsg-4), libxapian22:amd64 (1.2.21-1), libmediainfo0:amd64 (0.7.70-1), libclamav6:amd64 (0.98.7+dfsg-2),
liborcus-0.10-0:amd64 (0.9.2-1), libreoffice-style-crystal:amd64 (4.4.4-1), calligra-libs:amd64 (2.8.5+dfsg-1.
2), clamtk:amd64 (5.19-1), krita:amd64 (2.8.5+dfsg-1.2), showfoto:amd64 (4.4.0-1.1+b2), libcwidget3:amd64 (0.
5.17-2), bluedevil:amd64 (5.3.2-1), libcmis-0.5-5:amd64 (0.5.0-2), libstrigihtmlgui0:amd64 (0.7.8-1.2+b3),
libllvm3.5:amd64 (3.5.2-1), libllvm3.5:i386 (3.5.2-1), libgl1-mesa-dri:i386 (10.6.3-1), libwxbase3.0-0:amd64 (
3.0.2+dfsg-1), gimagereader:amd64 (3.1-1), libglibmm-2.4-1c2a:amd64 (2.44.0-1), libtag1c2a:amd64 (1.9.1-2.1),
libebml4:amd64 (1.3.1-3), libilmbase6:amd64 (1.0.1-6.1), libkolabxml1:amd64 (1.1.0-3), digikam-private-libs:
amd64 (4.4.0-1.1+b2), libsigc++-2.0-0c2a:amd64 (2.4.1-1), libsigc++-2.0-0c2a:i386 (2.4.1-1), libprotobuf9:
amd64 (2.6.1-1), libid3-3.8.3c2a:amd64 (3.8.3-16), libconfig++9:amd64 (1.4.9-2), wine32:i386 (1.6.2-22),
libproxy1:amd64 (0.4.11-4+b2), libkdecorations2private5:amd64 (5.3.2-1), libclucene-core1:amd64 (2.3.3.4-4),
libaqbanking34-plugins:amd64 (5.4.3beta-2+b1), libqpdf13:amd64 (5.1.3-1), digikam:amd64 (4.4.0-1.1+b2),
libclucene-contribs1:amd64 (2.3.3.4-4), blender:amd64 (2.74+dfsg0-4+b1), kipi-plugins:amd64 (4.4.0-1.1+b2),
libkdecorations2-5:amd64 (5.3.2-1), clamav-freshclam:amd64 (0.98.7+dfsg-2), backintime-kde:amd64 (1.0.36-1),
googleearth:amd64 (6.0.3.2197+1.1.0-1), libopenimageio1.5:amd64 (1.5.17~dfsg0-1), libkf5bluezqt5:amd64 (5.3.1-
1), packagesearch:amd64 (2.7.4), libtag1-vanilla:amd64 (1.9.1-2.1), gstreamer1.0-plugins-bad:amd64 (1.4.5-
2+b1), libgltf-0.0-0:amd64 (0.0.2-3), libvamp-hostsdk3:amd64 (2.6~repack0-1), libstreams0:amd64 (0.7.8-1.2+b3)
, libffado-dev:amd64 (2.2.1-2), clamav:amd64 (0.98.7+dfsg-2), libopenexr6:amd64 (1.6.1-8), gnucash:amd64 (2.6.
7-2), libwxgtk3.0-0:amd64 (3.0.2+dfsg-1), libpcrecpp0:amd64 (8.35-7), libflac++6:amd64 (1.3.1-2), libasprintf0
c2:amd64 (0.19.4-1), libstreamanalyzer0:amd64 (0.7.8-1.2+b3), adept:amd64 (3.0~beta7.2+qa2), libffado2:amd64 (
2.2.1-2), libmatroska6:amd64 (1.4.2-2), libsidplayfp3:amd64 (1.7.2-1), libprojectm2:amd64 (2.1.0+dfsg-1+b1),
libjsoncpp0:amd64 (0.10.2-4), libsidplay1:amd64 (1.36.59-7), libkolab0:amd64 (0.6.0-1), libqalculate5:amd64 (
0.9.7-9), libzen0:amd64 (0.4.29-1), pitivi:amd64 (0.94-2), strigi-client:amd64 (0.7.8-1.2+b3)
End-Date: 2015-08-30  11:55:16
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
kenyeeOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 12.09.2015, 12:59



Joined: 2010-09-29
Posts: 98

Status: Offline
even with
      Code:
apt-get dist-upgrade libstreamanalyzer0v5+ libstreams0v5+ libstreams0- kdeutils+ kdeadmin+ konversation+


I still get a lot of unmet dependencies:

      Code:
The following packages have unmet dependencies:
 kdeadmin : Depends: ksystemlog (>= 4:4.11.3) but it is not going to be installed
            Depends: kuser (>= 4:4.11.3) but it is not going to be installed
 kdeutils : Depends: kdf (>= 4:4.11.3) but it is not going to be installed
            Depends: kgpg (>= 4:4.11.3) but it is not going to be installed
            Depends: kremotecontrol (>= 4:4.11.3) but it is not going to be installed
            Depends: sweeper (>= 4:4.11.3) but it is not going to be installed


This is a slower upgrade than I remember...even the previous huge KDE major version bump seemed to resolve faster. I think this is because it coincided w/ GCC 5.x Razz
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: kdebase and kde-workspace no longer needed as packages?  PostPosted: 12.09.2015, 19:37



Joined: 2010-08-25
Posts: 949

Status: Offline
Those should be installable, you probably just have to help apt a bit more. Add the missing dependencies (with trailing +) to the end of the line - at some point the conflict should become obvious.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio