Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alien-aptosidOffline
Post subject: iceweasel not able to invoke dolphin for download folder  PostPosted: 11.10.2010, 19:47



Joined: 2010-10-03
Posts: 24

Status: Offline
After download is complete if we right click and select option : open containing folder :

Iceweasel gives us a launch application /choose application dialog from and i cant seem to get firefox to use dolphin. Same case while trying to open any other file
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: RE: iceweasel not able to invoke dolphin for download folder  PostPosted: 11.10.2010, 21:42
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
Moved to "software". This behaviour cannot be influenced by the installer, so it's not a release bug.

Maybe someone can check how iceweasel works opening a folder from the download manager (it's not a KDE application), I really don't have a clue.

I just tested a gif image, and it was opened by easytag. That's not the desired file manager Wink

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Sir_AimOffline
Post subject: RE: iceweasel not able to invoke dolphin for download folder  PostPosted: 12.10.2010, 10:19



Joined: 2010-09-11
Posts: 2

Status: Offline
In Iceweasel you find those setting under Edit->Preferences->Applications. Should be the same location for Firefox

Edit: It's Content Type 'file'.
Set it to /usr/bin/dolphin and it should work.
 
 View user's profile Send private message  
Reply with quote Back to top
alien-aptosidOffline
Post subject: dont see "file" under content type.  PostPosted: 12.10.2010, 19:30



Joined: 2010-10-03
Posts: 24

Status: Offline
i guess iam doing something very stupid. I dont see "file" under content type. Please check screenshot.



iceweasel.jpg.tar.gz
 Description:

Download
 Filename:  iceweasel.jpg.tar.gz
 Filesize:  52.99 KB
 Downloaded:  478 Time(s)

 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: Re: dont see "file" under content type.  PostPosted: 12.10.2010, 22:01
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
      alien-aptosid wrote:
I dont see "file" under content type.

Me neither. It really starts to be an interesting question, because the option is there ... but where to set it properly?

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
schnaps1Offline
Post subject: RE: Re: dont see "file" under content type.  PostPosted: 15.10.2010, 10:01



Joined: 2010-09-13
Posts: 2
Location: Graz (AT)
Status: Offline
Does Iceweasel recognize the correct filetype?

At the bottomline of the 'launch/choose application dialog' you see a checkbox to save your selection for 'xxx-links'. What's the 'xxx' in your case?

You'll get more content type entries under Edit->Preferences->Applications after you downloaded/opened them for the first time. They are saved under 'mimeTypes.rdf' in your .mozilla directory.

Manuel
 
 View user's profile Send private message  
Reply with quote Back to top
Sir_AimOffline
Post subject:   PostPosted: 15.10.2010, 21:06



Joined: 2010-09-11
Posts: 2

Status: Offline
well, my application list is much larger...

my ./mozilla/firefox/mimeTypes.rdf contains

      Code:
  <RDF:Description RDF:about="urn:scheme:file"
                   NC:value="file">
    <NC:handlerProp RDF:resource="urn:scheme:handler:file"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:scheme:handler:file"
                   NC:alwaysAsk="false">
    <NC:possibleApplication RDF:resource="urn:handler:local:/usr/bin/konqueror"/>
    <NC:possibleApplication RDF:resource="urn:handler:local:/usr/bin/dolphin"/>
    <NC:externalApplication RDF:resource="urn:scheme:externalApplication:file"/>
  </RDF:Description>


for the file part...

if i remember right i did a right click on a downloaded file and chose ' open containing folder' -> then choose application -> and entered the path... ie: /usr/bin/dolphin -> that's it.
 
 View user's profile Send private message  
Reply with quote Back to top
alien-aptosidOffline
Post subject: thanks  PostPosted: 16.10.2010, 04:44



Joined: 2010-10-03
Posts: 24

Status: Offline
thanks guys.. followed your instruction. it is having all the file associations i need now ..
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio