Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
15 Post subject: HPLIP doesn't detect the system tray  PostPosted: 01.02.2016, 03:32



Joined: 2010-10-01
Posts: 288

Status: Offline
Every time I boot into Plasma 5, for months now, HPLIP Status Service reports the message "No system tray detected on this system. Unable to start, exiting." although it does start and puts itself into the system tray. I have read this is a timing issue but I've been unable to get this message to stop displaying. Is there a workaround or a fix?


Last edited by alexk on 01.02.2016, 04:13; edited 1 time in total
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
slhOffline
Post subject: RE: HPLIP doesn  PostPosted: 01.02.2016, 03:56



Joined: 2010-08-25
Posts: 949

Status: Offline
Try installing plasma-systray-legacy.
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: HPLIP doesn  PostPosted: 01.02.2016, 04:12



Joined: 2010-10-01
Posts: 288

Status: Offline
Actually, HPLIP Status Service puts itself into the system tray until one clicks on OK in the error message, then it's gone from the system tray, although it's configured to "Always show" in the system tray under HP Device Manager settings. However, running "hp-systray" from Alt-F2 run box brings it back and if the plasma5 session is then saved before exiting, it restarts automatically upon logging back in and no more delayed error message appears to display.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: HPLIP doesn  PostPosted: 01.02.2016, 04:19



Joined: 2010-10-01
Posts: 288

Status: Offline
Thanks, slh, we cross-posted. It appears plasma-systray-legacy is not required here.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: HPLIP doesn  PostPosted: 06.03.2016, 22:29



Joined: 2010-10-01
Posts: 288

Status: Offline
Further experience has showed that plasma-systray-legacy is indeed required to solve this issue. Thanks, slh.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio