Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
alexkOffline
Post subject: drm:intel_opregion_init [i9] *ERROR* No ACPI video bus found  PostPosted: 19.02.2016, 03:15



Joined: 2010-10-01
Posts: 288

Status: Offline
I've been getting this error upon boot:
      Code:
[   15.174431] [drm] Memory usable by graphics device = 2048M
[   15.174434] [drm] Replacing VGA console driver
[   15.175674] Console: switching to colour dummy device 80x25
[   15.181796] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   15.181797] [drm] Driver supports precise vblank timestamp query.
[   15.181842] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[   15.185064] [drm:intel_opregion_init [i915]] *ERROR* No ACPI video bus found
[   15.185089] [drm] Initialized i915 1.6.0 20151010 for 0000:00:02.0 on minor 0

I haven't noticed any ill effects, however.
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: drm:intel_opregion_init [i9] *ERROR* No ACPI video bus f  PostPosted: 09.03.2016, 03:24



Joined: 2010-10-01
Posts: 288

Status: Offline
I'm also getting other drm errors:
      Code:
Mar  8 17:19:58 MSAK1 kernel: [80707.733961] [drm:ironlake_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Mar  8 17:19:58 MSAK1 kernel: [80707.733990] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
Mar  8 17:19:58 MSAK1 kernel: [80707.734004] [drm:cpt_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

      Code:
$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.4.0-4.slh.1-aptosid-amd64 root=UUID=54d2e561-1007-44ae-9eee-6d54ce1ebd8f ro quiet irqpoll
$ infobash -v3
Host/Kernel/OS  "MSAK1" running Linux 4.4.0-4.slh.1-aptosid-amd64 x86_64 [ sidux 2009-02 Αιθήρ - kde-full - (200907141427) ]
CPU Info        4x Intel Core i5-2500K @ 6144 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 2778.445 MHz ]
Videocard       Intel 2nd Generation Core Processor Family Integrated Graphics Controller  X.Org 1.18.1  [ 1920x1080@60.00hz ]
Network cards   Intel 82579V Gigabit
                Atheros AR9271 802.11n
Processes 306 | Uptime 3days | Memory 4342.9/15961.1MB | HDD  Size 320GB (57%used) | Client Shell | Infobash v3.50
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
slhOffline
Post subject: RE: drm:intel_opregion_init [i9] *ERROR* No ACPI video bus f  PostPosted: 09.03.2016, 05:46



Joined: 2010-08-25
Posts: 949

Status: Offline
These error messages are highly device specific (so basically not debuggable by anyone without the exact same hardware) and would need git-bisecting the (upstream-) kernel between the last known-good (without error message) kernel and a known-bad (with the error message) kernel, while keeping in mind that this might just as well be a long-standing issue that just got attributed a visible warning message recently...

In other words, if you want to tackle this, you'd need to debug this closely with upstream (the intel driver is under active development and changes frequently and significantly) and start with a git bisect (typically you'll need around 15-18 intermediate/ individual kernel builds between known-good and known-bad versions, which one depends on your findings and can't be estimated before). While it is worth debugging this, and I do so for bugs I can reproduce on machines I personally use regularly, it is a significant effort - and if the warnings have no visible ill-effects...
 
 View user's profile Send private message  
Reply with quote Back to top
alexkOffline
Post subject: RE: drm:intel_opregion_init [i9] *ERROR* No ACPI video bus f  PostPosted: 09.03.2016, 21:19



Joined: 2010-10-01
Posts: 288

Status: Offline
I may file this under "If it ain't broke, don't fix it". Smile
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: drm:intel_opregion_init [i9] *ERROR* No ACPI video bus f  PostPosted: 12.03.2016, 18:30



Joined: 2010-10-01
Posts: 288

Status: Offline
However, I have been getting some occasional screen flickering for quite a while now, with a 5-month old Acer H236HL monitor and the flickering sometimes seems to coincide with the drm errors. The flickering is bad, making the computer difficult to use and I sometimes seem to "fix" it by changing the screen resolution in Plasma System Settings and then changging it back. Turning the monitor off and then back on doesn't always stop the flickering. Might this be related to the drm errors?
      Code:
Mar 12 13:16:54 MSAK1 kernel: [  744.355293] [drm:ironlake_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Mar 12 13:16:54 MSAK1 kernel: [  744.355322] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
Mar 12 13:16:54 MSAK1 kernel: [  744.355335] [drm:cpt_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
alexkOffline
Post subject: RE: drm:intel_opregion_init [i9] *ERROR* No ACPI video bus f  PostPosted: 13.03.2016, 16:13



Joined: 2010-10-01
Posts: 288

Status: Offline
I no longer seem to be getting the FIFO underrun errors, maybe due to installing the missing xserver-xorg-video-* packages. I'm still getting the "No ACPI video bus found" error.
      Code:
Mar 13 11:01:39 MSAK1 kernel: [ 4773.014662] [drm:intel_opregion_init [i915]] *ERROR* No ACPI video bus found
 
 View user's profile Send private message Yahoo Messenger  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio