Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: [Solved] APT stuck  PostPosted: 16.05.2016, 13:11



Joined: 2010-09-12
Posts: 470

Status: Offline
Dear all,

As stated in a different post, I'm stuck after a failed attempt to DU with a broken texlive update.

Here are some attempts of "apt -f install", "apt -f full-upgrade" and "dpkg --configure -a":

      Code:

finottim83(scrn)[/home/finotti]$ apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 context : Depends: texlive-binaries (>= 2014.20140512.33982) but it is not installed
 dvipng : Depends: texlive-base-bin
 feynmf : Depends: texlive-font-utils but it is not installed
          Depends: texlive-extra-utils but it is not installed
 fragmaster : Depends: texlive-base-bin
              Depends: texlive-extra-utils but it is not installed
              Depends: texlive-font-utils but it is not installed
 latex-cjk-common : Depends: texlive-font-utils (>= 2007.dfsg.2-1) but it is not installed
 tex4ht : Depends: texlive-base-bin
 tex4ht-common : Depends: texlive-base-bin
 texlive-base : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-fonts-recommended-doc : Depends: texlive-base (>= 2016) but 2015.20160320-1 is installed
 texlive-formats-extra : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-games : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-humanities : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-latex-base : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-latex-extra : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-latex-recommended : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-luatex : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-math-extra : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-metapost : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-music : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-omega : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-pictures : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-pstricks : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-science : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 texlive-xetex : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not installed
 tipa : Depends: texlive-base-bin
E: Unmet dependencies. Try using -f.

finottim83(scrn)[/home/finotti]$ apt -f full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  gstreamer1.0-plugins-ugly libsidplay1v5 texlive-binaries texlive-extra-utils texlive-font-utils
The following packages will be upgraded:
  hyphen-de kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libav-tools libevdev2 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4
  libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4
  libkparts4 libkprintutils4 libkpty4 libkrosscore4 libktexteditor4 libkunitconversion4 libkutils4 libnepomuk4 libnepomukquery4a
  libnepomukutils4 liborcus-0.11-0 libplasma3 libpng16-16 libqtermwidget5-0 librest-0.7-0 libsolid4 libthreadweaver4 libva-drm1
  libva-glx1 libva-wayland1 libva-x11-1 libva1 libxatracker2 mythes-en-us openvpn pepperflashplugin-nonfree python-pip
  python-pip-whl python-ptyprocess python-rgain python3-pip python3-ptyprocess qtermwidget5-data texlive-base
  texlive-fonts-extra-doc texlive-fonts-recommended texlive-formats-extra texlive-games texlive-generic-extra
  texlive-generic-recommended texlive-humanities texlive-humanities-doc texlive-lang-english texlive-lang-european
  texlive-lang-french texlive-lang-portuguese texlive-lang-spanish texlive-latex-base texlive-latex-base-doc texlive-latex-extra
  texlive-latex-extra-doc texlive-latex-recommended texlive-latex-recommended-doc texlive-luatex texlive-math-extra
  texlive-metapost texlive-metapost-doc texlive-music texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra
  texlive-pstricks texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc
  texlive-xetex x11-xkb-utils
98 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,246 MB of archives.
After this operation, 116 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 548804 files and directories currently installed.)
Preparing to unpack .../texlive-fonts-extra-doc_2016.20160512-1_all.deb ...
Unpacking texlive-fonts-extra-doc (2016.20160512-1) over (2015.20160320-1) ...
dpkg: error processing archive /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb (--unpack):
 trying to overwrite '/usr/share/doc/texlive-doc/latex/mweights/README', which is also in package texlive-latex-extra-doc 2015.20160320-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

finottim83(scrn)[/home/finotti]$ apt -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  texlive-base texlive-binaries texlive-extra-utils texlive-font-utils texlive-fonts-extra-doc texlive-fonts-recommended
  texlive-formats-extra texlive-games texlive-generic-extra texlive-generic-recommended texlive-humanities
  texlive-humanities-doc texlive-lang-english texlive-lang-european texlive-lang-french texlive-lang-portuguese
  texlive-lang-spanish texlive-latex-base texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc
  texlive-latex-recommended texlive-latex-recommended-doc texlive-luatex texlive-math-extra texlive-metapost
  texlive-metapost-doc texlive-music texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra texlive-pstricks
  texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc texlive-xetex
Suggested packages:
  perl-tk xindy python-pygments libspreadsheet-parseexcel-perl dot2tex libtcltk-ruby
Recommended packages:
  wish libyaml-tiny-perl libfile-homedir-perl tk
The following NEW packages will be installed:
  texlive-binaries texlive-extra-utils texlive-font-utils
The following packages will be upgraded:
  texlive-base texlive-fonts-extra-doc texlive-fonts-recommended texlive-formats-extra texlive-games texlive-generic-extra
  texlive-generic-recommended texlive-humanities texlive-humanities-doc texlive-lang-english texlive-lang-european
  texlive-lang-french texlive-lang-portuguese texlive-lang-spanish texlive-latex-base texlive-latex-base-doc texlive-latex-extra
  texlive-latex-extra-doc texlive-latex-recommended texlive-latex-recommended-doc texlive-luatex texlive-math-extra
  texlive-metapost texlive-metapost-doc texlive-music texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra
  texlive-pstricks texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc
  texlive-xetex
36 upgraded, 3 newly installed, 0 to remove and 62 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,222 MB of archives.
After this operation, 115 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 548804 files and directories currently installed.)
Preparing to unpack .../texlive-fonts-extra-doc_2016.20160512-1_all.deb ...
Unpacking texlive-fonts-extra-doc (2016.20160512-1) over (2015.20160320-1) ...
dpkg: error processing archive /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb (--unpack):
 trying to overwrite '/usr/share/doc/texlive-doc/latex/mweights/README', which is also in package texlive-latex-extra-doc 2015.20160320-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

finottim83(scrn)[/home/finotti]$ dpkg --configure -a
dpkg: dependency problems prevent configuration of texlive-fonts-recommended-doc:
 texlive-fonts-recommended-doc depends on texlive-base (>= 2016); however:
  Version of texlive-base on system is 2015.20160320-1.

dpkg: error processing package texlive-fonts-recommended-doc (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 texlive-fonts-recommended-doc

finottim83(scrn)[/home/finotti]$ apt remove texlive-fonts-recommended-doc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 context : Depends: texlive-binaries (>= 2014.20140512.33982) but it is not going to be installed
 dvipng : Depends: texlive-base-bin
 feynmf : Depends: texlive-font-utils but it is not going to be installed
          Depends: texlive-extra-utils but it is not going to be installed
 fragmaster : Depends: texlive-base-bin
              Depends: texlive-extra-utils but it is not going to be installed
              Depends: texlive-font-utils but it is not going to be installed
 latex-cjk-common : Depends: texlive-font-utils (>= 2007.dfsg.2-1) but it is not going to be installed
 tex4ht : Depends: texlive-base-bin
 tex4ht-common : Depends: texlive-base-bin
 texlive-base : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-formats-extra : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-games : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-humanities : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-latex-base : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-latex-extra : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-latex-recommended : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-luatex : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-math-extra : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-metapost : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-music : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-omega : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-pictures : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-pstricks : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-science : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 texlive-xetex : Depends: texlive-binaries (>= 2015.20160222.37495-1) but it is not going to be installed
 tipa : Depends: texlive-base-bin
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

finottim83(scrn)[/home/finotti]$ apt -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  texlive-base texlive-binaries texlive-extra-utils texlive-font-utils texlive-fonts-extra-doc texlive-fonts-recommended
  texlive-formats-extra texlive-games texlive-generic-extra texlive-generic-recommended texlive-humanities
  texlive-humanities-doc texlive-lang-english texlive-lang-european texlive-lang-french texlive-lang-portuguese
  texlive-lang-spanish texlive-latex-base texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc
  texlive-latex-recommended texlive-latex-recommended-doc texlive-luatex texlive-math-extra texlive-metapost
  texlive-metapost-doc texlive-music texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra texlive-pstricks
  texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc texlive-xetex
Suggested packages:
  perl-tk xindy python-pygments libspreadsheet-parseexcel-perl dot2tex libtcltk-ruby
Recommended packages:
  wish libyaml-tiny-perl libfile-homedir-perl tk
The following NEW packages will be installed:
  texlive-binaries texlive-extra-utils texlive-font-utils
The following packages will be upgraded:
  texlive-base texlive-fonts-extra-doc texlive-fonts-recommended texlive-formats-extra texlive-games texlive-generic-extra
  texlive-generic-recommended texlive-humanities texlive-humanities-doc texlive-lang-english texlive-lang-european
  texlive-lang-french texlive-lang-portuguese texlive-lang-spanish texlive-latex-base texlive-latex-base-doc texlive-latex-extra
  texlive-latex-extra-doc texlive-latex-recommended texlive-latex-recommended-doc texlive-luatex texlive-math-extra
  texlive-metapost texlive-metapost-doc texlive-music texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra
  texlive-pstricks texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc
  texlive-xetex
36 upgraded, 3 newly installed, 0 to remove and 62 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,222 MB of archives.
After this operation, 115 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 548804 files and directories currently installed.)
Preparing to unpack .../texlive-fonts-extra-doc_2016.20160512-1_all.deb ...
Unpacking texlive-fonts-extra-doc (2016.20160512-1) over (2015.20160320-1) ...
dpkg: error processing archive /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb (--unpack):
 trying to overwrite '/usr/share/doc/texlive-doc/latex/mweights/README', which is also in package texlive-latex-extra-doc 2015.20160320-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/texlive-fonts-extra-doc_2016.20160512-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


LaTeX is essential for my work, and although I can compile my files remotely, I'd really appreciate some help. (And of course, I can't DU at all either...)

Best to all,

Luis


Last edited by finotti on 16.05.2016, 21:43; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
finottiOffline
Post subject: RE: APT stuck  PostPosted: 16.05.2016, 21:43



Joined: 2010-09-12
Posts: 470

Status: Offline
OK, I had to appeal to aptitude (I know it is not recommended, but I was a bit desperate), which downgraded some packages and allowed me to remove texlive-fonts-extra-doc. After that I could reinstall it (and other things that were removed).

It seems that all is working now. I am not sure if aptitude "broke" anything, but I guess I will find out eventually...

(BTW, I configures aptitude to not remove "unused" packages...)
 
 View user's profile Send private message  
Reply with quote Back to top
LatOffline
Post subject: RE: APT stuck  PostPosted: 21.05.2016, 15:42



Joined: 2010-09-19
Posts: 204

Status: Offline
I fixed this with:
      Code:
apt-get install texlive-latex-base/testing texlive-extra-utils/testing texlive-font-utils/testing texlive-fonts-recommended/testing texlive-latex-recommended/testing texlive-pictures/testing texlive-latex-extra/testing texlive-binaries/testing


(I should have used apt-get install -t testing, instead, huh?)
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio