Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
finottiOffline
Post subject: XWindows Problems  PostPosted: 05.05.2017, 14:15



Joined: 2010-09-12
Posts: 467

Status: Offline
Dear all,

I was having problems with GTK applications (mostly Emacs and Ardour) producing some glitches, like parts of the screen flickering and not being displayed properly.

After some Googling, I found a suggestion to change AccelMethod from "sna" to "uxa" in /etc/X11/xorg.conf.d/20-intel.conf. It worked, it even fixed a problem that, despite my Xorg and xrandr, configurations, Plasma would switch the primary and secondary displays.

BUT: now when the monitors turn off (the computer does NOT suspend, only the screens turn off), I cannot turn them on again until I switch to and a back from a virtual terminal (Ctrl+Alt-F1 then Ctrl+Alt-F7). Then, all is back to normal.

Any ideas on how to fix this?

Here is some info on the system:

      Code:

$ cat /etc/X11/xorg.conf.d/10-monitor.conf
Section "Monitor"
    Identifier  "HDMI3"
    Option      "Primary"       "true"
EndSection

Section "Monitor"
    Identifier  "HDMI1"
    Option      "RightOf"        "HDMI3"
EndSection


$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
  Identifier  "Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics"
  Driver      "intel"
  Option "DRI" "3"
  Option      "AccelMethod" "uxa"
  #Option      "AccelMethod" "sna"
  #Option      "TearFree" "true"
  Option      "Monitor-HDMI1" "HDMI1"
  Option      "Monitor-HDMI3" "HDMI3"
EndSection


      Code:

$ inxi -v3 -G                                                                                   
System:    Host: debian Kernel: 4.10.0-11.slh.1-aptosid-amd64 x86_64 (64 bit gcc: 6.3.0)                                           
           Desktop: KDE Plasma 5.8.6 Distro: aptosid 2013-01 Ἑσπερίδες - kde-full - (201305050307)                                 
Machine:   Device: desktop System: ASUS product: All Series                                                                         
           Mobo: ASUSTeK model: Z87-PRO v: Rev 1.xx UEFI: American Megatrends v: 2103 date: 08/18/2014                             
CPU:       Quad core Intel Core i7-4771 (-HT-MCP-) cache: 8192 KB                                                                   
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27982                                                       
           clock speeds: max: 3900 MHz 1: 3500 MHz 2: 3526 MHz 3: 3641 MHz 4: 3569 MHz 5: 3602 MHz 6: 3528 MHz                     
           7: 3513 MHz 8: 3717 MHz                                                                                                 
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0                       
           Display Server: X.Org 1.19.3 driver: intel Resolution: 1920x1080@60.00hz, 1280x1024@60.02hz                             
           GLX Renderer: Mesa DRI Intel Haswell Desktop GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes                         
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0                             
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: e0:3f:49:a3:4c:a6                                                   
Drives:    HDD Total Size: 9257.9GB (52.4% used)                                                                                   
           ID-1: model: WDC_WD10EALS                                                                                               
           ID-2: model: WDC_WD20EARX
           ID-3: model: Samsung_SSD_840
           ID-4: model: WDC_WD20EARX
           ID-5: model: WDC_WD40EZRX
Info:      Processes: 337 Uptime: 16:11 Memory: 8614.1/15925.6MB Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.111) inxi: 2.3.5
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio