Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ganymedOffline
Post subject: Howto start ssh-Server when booting  PostPosted: 13.10.2010, 17:11



Joined: 2010-09-12
Posts: 19

Status: Offline
Hiya,

tried a login on my PC#2 today using ssh and received a "Connection refused". Sort of irritated I was wondering if ssh was running at all on the remote machine, so I did a
      Code:
ls /etc/rc5.d
and the response included a K01ssh.

Why was the connection refused then, I asked myself, and did a
      Code:
/etc/init.d/ssh restart

Then I tried to login via ssh again and this time it worked. Funny enough that this behaviour is reproducable, so I need to know how to start the server (not only the client as it seems) at boot time.

Btw,
      Code:
~$ apt-cache policy openssh-server
openssh-server:
  Installiert: 1:5.5p1-5
  Kandidat:    1:5.5p1-5
  Versionstabelle:
 *** 1:5.5p1-5 0
        500 http://ftp.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status


Thanks for any sort of advice!


Last edited by ganymed on 14.10.2010, 17:24; edited 2 times in total
 
 View user's profile Send private message  
Reply with quote Back to top
bfreeOffline
Post subject: RE: Howto start ssh-Server when booting  PostPosted: 13.10.2010, 17:21
Team Member


Joined: 2010-08-26
Posts: 254

Status: Offline
K01ssh means it will stop ssh in that runlevel. During the install you were asked if you wanted to start the ssh server and you presumably didn't tick the box to say you would want it. To change that decision now you can run (as root):
      Code:
update-rc.d ssh enable
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: Howto start ssh-Server when booting  PostPosted: 13.10.2010, 19:18
Team Member


Joined: 2010-09-02
Posts: 482

Status: Offline
But please take actions to protect your ssh if you have it activated all the time:
http://manual.aptosid.com/en/ssh-en.htm#ssh

Special hint: PubkeyAuthentication is wonderful Smile

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
devilOffline
Post subject: RE: Howto start ssh-Server when booting  PostPosted: 13.10.2010, 21:19



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
      Quote:

Special hint: PubkeyAuthentication is wonderful

+1

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
ganymedOffline
Post subject:   PostPosted: 13.10.2010, 21:33



Joined: 2010-09-12
Posts: 19

Status: Offline
Geeeeeeeeeeeez, that went fast....anyway, many thanks for all that.
Seems to be operating fine now. Only using ssh on the local network with a changed port number, root access being denied and using 'pubkey' authentication.

Cheerio, folks!
 
 View user's profile Send private message  
Reply with quote Back to top
ganymedOffline
Post subject: Feeling happy too early  PostPosted: 14.10.2010, 17:40



Joined: 2010-09-12
Posts: 19

Status: Offline
Hi again,

still having to cope with the fact that the ssh-server isn't started at boot time....
I tried to run the command update-rc.d ssh enable, but that didn't change anything. Meanwhile I have noticed there are other users on the www, who also claim the stuff isn't working expectedly.

Shouldn't there be a start script for that service in one of the run levels, for example? All I can find is stop scripts K01ssh in /etc/rcXd (X=2-5).
Now I regularly have got to do a /etc/init.d/ssh restart before I can start working. Sad

Thanks again for any sort of help
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio