Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
KalianahOffline
15 Post subject: grub broken right after installation?  PostPosted: 15.10.2010, 11:28



Joined: 2010-10-14
Posts: 8

Status: Offline
Hey,

I installed aptosid on my pc. after reboot i get the message,
welcome to grub2
error: out of disk
entering rescue mode

tried to reinstall grub without success.
same problem with grub rescue mode, when i set the
prefix to /boot i also get the message out of disk!

Does anybody have an idea??

Pc information:
grafik: ati radeon 4850
cpu: core2duo e6750 2,66 GHZ
mainboard: gigabyte p35 ds3l
ide harddrive with win xp
sata harddrive with non working aptosid Smile


Last edited by Kalianah on 07.11.2010, 10:48; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 15.10.2010, 12:05



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
First thing to try, in BIOS try setting the SATA mode to "IDE" or "Legacy" or "Compatibility" (not AHCI). If the installation goes correctly, then afterward you can go back and reset SATA mode to AHCI and it should work right.

If that doesn't help, then I'd set a new partition table on the hard drive and make the partition(s) again, and reinstall. (Back up any/all data first).
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 15.10.2010, 12:31



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
Show us:

fdisk -l
/boot/grub/grubcfg
/etc/default/grub
 
 View user's profile Send private message  
Reply with quote Back to top
devilOffline
Post subject:   PostPosted: 15.10.2010, 14:10



Joined: 2010-08-26
Posts: 491
Location: Berlin
Status: Offline
and maybe df -h

greetz
devil
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
Post subject:   PostPosted: 15.10.2010, 19:30



Joined: 2010-10-14
Posts: 8

Status: Offline
@dibl: Bios setting for SATA mode is not AHCI, because of troubles with xp...
and i'd installed aptosid twice!! first time with grub on mbr. didn't work well either Sad

@towo:
fdisk -l
      Code:

Disk /dev/sda: 320.1 GB, 320071851520 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x5762454f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       34967   280872396    7  HPFS/NTFS
/dev/sda2           34968       38913    31696245    f  W95 Ext'd (LBA)
/dev/sda5           34968       38913    31696213+   7  HPFS/NTFS

Disk /dev/sdb: 500.1 GB, 500106780160 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6b9db2df

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        7435    59721606   83  Linux
/dev/sdb2            7436       20197   102510765    7  HPFS/NTFS
/dev/sdb3           20198       59477   315516600   83  Linux
/dev/sdb4           59478       60801    10635030    5  Extended
/dev/sdb5           59478       59755     2233003+  82  Linux swap / Solaris
/dev/sdb6           59756       60801     8401963+  83  Linux


grub.cfg
      Code:

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  load_video
  insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(hd1,msdos1)'search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
set locale_dir=($root)/boot/grub/locale
set lang=de
insmod gettext
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Debian GNU/Linux, with Linux 2.6.35-4.slh.9-aptosid-686' --class debian --class gnu-linux --class gnu --class os {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
        search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
        echo    'Loading Linux 2.6.35-4.slh.9-aptosid-686 ...'
        linux   /boot/vmlinuz-2.6.35-4.slh.9-aptosid-686 root=UUID=858d124d-18e2-4f87-99eb-cc21d15f0753 ro vga=791 quiet
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initrd.img-2.6.35-4.slh.9-aptosid-686
}
menuentry 'Debian GNU/Linux, with Linux 2.6.35-4.slh.9-aptosid-686 (recovery mode)' --class debian --class gnu-linux --class gnu --class os {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
        search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
        echo    'Loading Linux 2.6.35-4.slh.9-aptosid-686 ...'
        linux   /boot/vmlinuz-2.6.35-4.slh.9-aptosid-686 root=UUID=858d124d-18e2-4f87-99eb-cc21d15f0753 ro single vga=791
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initrd.img-2.6.35-4.slh.9-aptosid-686
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
        search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
        linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
        search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
        linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
menuentry "Memory test (memtest86+, experimental multiboot)" {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
        search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
        multiboot       /boot/memtest86+_multiboot.bin
}
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {
        insmod part_msdos
        insmod ext2
        set root='(hd1,msdos1)'
        search --no-floppy --fs-uuid --set 858d124d-18e2-4f87-99eb-cc21d15f0753
        multiboot       /boot/memtest86+_multiboot.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sdb1)" {
        insmod part_msdos
        insmod ntfs
        set root='(hd0,msdos5)'
        search --no-floppy --fs-uuid --set 9804ffd104ffb07c
        drivemap -s (hd0) ${root}
        chainloader +1
}
### END /etc/grub.d/30_os-prober ###
### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###


/etc/default/grub
      Code:

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""


@devil:
df -h
      Code:

Dateisystem           Size  Used Avail Use% Eingehängt auf
tmpfs                1013M  8,0K 1013M   1% /lib/init/rw
udev                 1007M  216K 1007M   1% /dev
tmpfs                1013M  4,0K 1013M   1% /dev/shm
rootfs                1,8G   18M  1,8G   1% /
/dev/sr0              592M  592M     0 100% /fll/sr0
/dev/loop0            573M  573M     0 100% /fll/aptosid
aufs                  1,8G   18M  1,8G   1% /fll/aufs
aufs                  1,8G   18M  1,8G   1% /bin
aufs                  1,8G   18M  1,8G   1% /boot
aufs                  1,8G   18M  1,8G   1% /etc
aufs                  1,8G   18M  1,8G   1% /home
aufs                  1,8G   18M  1,8G   1% /lib
aufs                  1,8G   18M  1,8G   1% /mnt
aufs                  1,8G   18M  1,8G   1% /opt
aufs                  1,8G   18M  1,8G   1% /root
aufs                  1,8G   18M  1,8G   1% /sbin
aufs                  1,8G   18M  1,8G   1% /selinux
aufs                  1,8G   18M  1,8G   1% /srv
aufs                  1,8G   18M  1,8G   1% /usr
aufs                  1,8G   18M  1,8G   1% /var
/dev/sdb1              57G  1,8G   52G   4% /mnt/aptosid
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
Post subject:   PostPosted: 15.10.2010, 19:36



Joined: 2010-10-14
Posts: 8

Status: Offline
@towo
sry, the /etc/default/grub is the one of the live cd ...
here is the one from the system:
      Code:

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.modeset=0"
GRUB_CMDLINE_LINUX="vga=791"
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 15.10.2010, 19:38



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
Which disk is your boot-device in the bios?
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
Post subject:   PostPosted: 15.10.2010, 19:51



Joined: 2010-10-14
Posts: 8

Status: Offline
actually i want sdb to be the only boot-device, but when i want to use windows i had to switch to sda first. Smile
 
 View user's profile Send private message  
Reply with quote Back to top
towoOffline
Post subject:   PostPosted: 15.10.2010, 20:17



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
If you boot from sdb, then in grub.cfg it must be
      Code:
set root='(hd0,msdos1)'

But don't edit grub.cfg, you have to edit the right files in /etc/grub.
Why you havn't installed grub to mbr of sda?
Then the config is right and you shold able to boot win and linux.
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
Post subject:   PostPosted: 15.10.2010, 21:30



Joined: 2010-10-14
Posts: 8

Status: Offline
but hd0 is sda?
first time i'd installed grub to mbr -> after reboot i got the message 'error: no such device on "uuid of my rootpartition"'.
So i wasn't able to start linux or windows -> so i installed grub to my linux partition.
That's what i meant with changing to sda as boot-device... i don't want to, but it's the only possibility to have a running system!
If grub will ever works fine, then i don't need to switch again.
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
Post subject:   PostPosted: 17.10.2010, 10:23



Joined: 2010-10-14
Posts: 8

Status: Offline
I installed aptosid again. after reboot same as ever.
But something during the installation is odd!
xparted says that the sata disk is sda, there i installed root and grub.
when i mount sda1 with live cd, it shows me my windows ide disk, which supposed
to be sdb2!
And when i mount sdb1 i have my linux partition.
In grub rescue when i set prefix to (hd0,msdos1) = sda1? i get the error "out of disk" and when i set the prefix to (hd1,msdos1) = sdb1? i get the error "unknown filesystem"

Can anybody help, please??
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
Post subject:   PostPosted: 17.10.2010, 10:59



Joined: 2010-10-14
Posts: 8

Status: Offline
when i set root = (hd0,msdos1) i can see my rootpartition with ls (hd0,msdos1)/
 
 View user's profile Send private message  
Reply with quote Back to top
KalianahOffline
15 Post subject:   PostPosted: 07.11.2010, 10:46



Joined: 2010-10-14
Posts: 8

Status: Offline
Changed Bios settings for onboard serial port, onboard parallel port, parallel port mode and disabled floppy drive. I don't know what setting caused the problem and i can't reproduce it by changing it back to before.
 
 View user's profile Send private message  
Reply with quote Back to top
diblOffline
Post subject:   PostPosted: 07.11.2010, 19:58



Joined: 2010-09-12
Posts: 302
Location: Dayton, Ohio, USA
Status: Offline
      Kalianah wrote:


xparted says that the sata disk is sda, there i installed root and grub.

it shows me my windows ide disk, which supposed to be sdb2!




Grub and Linux installers do not always agree on the /dev/sdx ID of hard disk drives, when you mix IDE and SATA drives. Before I retired my last IDE drive, I had the same problem on an Intel D975XBX motherboard.

The easiest workaround I found was to pull the power connector off the IDE drive while I installed Linux on a SATA drive. Afterwards, you can reconnect the IDE drive, fix /etc/fstab (always use UUID numbers, not "/dev/sdx"), and Grub doesn't care, unless you want to boot an OS off the IDE drive. In that case, run update-grub and the OS prober should find the other OS and put it on the boot menu for you.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio